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Planen von Berichten mit Abonnements

Mithilfe von Abonnementberichten können Sie wiederkehrende E-Mails planen, die Ihre bevorzugten Arbeitsblätter oder Diagramme enthalten. Sie können die gewünschten Filter festlegen und erhalten einen Bericht mit den neuesten Daten zu festgelegten Zeiten in Ihrem Posteingang. Beispielsweise können Sie über Nacht eingegangene Bestellungen jeden Morgen per E-Mail erhalten. Sie können Abonnements, die Ihnen gehören, jederzeit bearbeiten.

Per E-Mail zugestellter Abonnementbericht

Eine Abonnementberichts-E-Mail mit Bild- und PDF-Anhang.

Abonnements folgen denselben Zugriffsregeln wie Apps, Daten und Bereichen. Besitzer und Empfänger sind je nach Abschnittszugriff, Berechtigungen und Benutzerberechtigungen (Professional und Analyzer) eingeschränkt. Empfänger erhalten nur Daten, auf die sie Zugriff haben.

Eine Abonnementbericht-E-Mail enthält:

  • Eine PDF- oder PowerPoint-Datei der abonnierten Visualisierung oder Arbeitsblätter als Anhang. Die Bildauflösung beträgt 300 DPI.

  • Ein Bild der Visualisierung. Wenn Sie Arbeitsblätter abonnieren, ist kein Bild vorhanden.

  • Ein Link zur App, über den Sie die den ursprünglichen Analysepunkt einsehen können. Wenn das Abonnement mehr als ein Arbeitsblatt enthält, wird das erste Arbeitsblatt in der Liste geöffnet.

  • Ein Link zur Verwaltungsseite für Abonnements.

Verwendung

Abonnements werden basierend auf einem von Ihnen festgelegten Zeitplan generiert. Sie sollten ein Abonnement erstellen, wenn:

  • Sie regelmäßige Updates zu einem Diagramm oder bis zu 10 Arbeitsblättern möchten.

  • Sie nicht etwas so mathematisch Komplexes wie einen Alarm einrichten müssen.

  • Sie einen Export von bis zu 10 Arbeitsblättern oder eines Diagramms nach einem Zeitplan erstellen möchten.

  • Ihre Empfänger Zugriff auf Qlik Cloud haben.

  • Ihre Empfänger Arbeitsblätter oder Diagramme zu PowerPoint-Dateien hinzufügen möchten.

Andere Möglichkeiten zum Teilen von Dateneinblicken

Wenn Sie Benachrichtigungen erhalten möchten, wenn für Ihre Daten bestimmte Bedingungen erfüllt sind, finden Sie weiter Informationen unter Überwachen von Daten mit Alarmen. Alarme werden gestützt auf Datenladevorgänge bewertet und basierend auf Datenausnahmen gesendet. Alarme können auch nach einem Zeitplan ausgelöst werden. In diesem Fall müssen Sie aber dennoch eine Bedingung oder ein Ziel erstellen, um den Alarm zu speichern. Sie können Qlik-Benutzer zu einem Alarm hinzufügen.

Wenn Sie anpassbare Berichte basierend auf einer ganzen App erstellen und an Empfänger außerhalb Ihrer Qlik Cloud-Umgebung senden möchten, finden Sie weitere Informationen unter Berichterstellung über Qlik Cloud Analytics mit Qlik Application Automation.

Voraussetzungen

Für Abonnements gelten die folgenden Voraussetzungen:

Informationshinweis Für Arbeitsblätter, die als Abonnements oder Automatisierungen im PowerPoint-Format ausgegeben werden, wird das Hochformat nicht unterstützt. Arbeitsblätter im Hochformat werden in Querformat konvertiert. Sie können aber das Hochformat verwenden, wenn Sie die Qlik Reporting Service API nutzen. Weitere Informationen zum Verwenden der API bei der Berichtserstellung finden Sie in der Dokumentation zum Entwickler-Portal.
Informationshinweis Falls die App gelöscht wird, sind etwaige, damit verbundene Abonnements nach wie vor vorhanden. Sie werden jedoch nicht mehr generiert.

In Abonnements gespeicherte App-Einstellungen

Wenn Sie ein Abonnement erstellen, werden die folgenden Einstellungen gespeichert:

  • Auswahlen

  • Visualisierungseigenschaften: Layout, Farben, Legende, Beschriftungen u. a. Weitere Informationen zur Anwendung dieser Eigenschaften finden Sie unter Visuelle Untersuchung.

  • JavaScript-Optionen: Sprachen, Formatvorlagen, Variablen oder Gerätetypen

    Der Gerätetyp kann „auto“, „touch“ oder „desktop“ sein. Der Wert hängt von der Einstellung des Berührungsbildschirmmodus in Ihrer Qlik Sense App ab. Wenn der Berührungsbildschirmmodus aktiviert ist, ist der Gerätetyp „touch“. Andernfalls ist er „auto“ oder „desktop“.

Diese Optionen werden bei jeder Berichtsgenerierung angewendet. Beispiel: Sie erstellen ein Abonnement in einer App, die Theme1 verwendet. Die App wird später zu Theme2 geändert. Im Abonnementbericht wird nach wie vor Theme1 verwendet.

Erstellen eines Abonnements

Sie können ein Abonnement basierend auf einer Visualisierung oder einem Arbeitsblatt erstellen. Wenn Sie ein Abonnement erstellen, werden Sie zum Besitzer. Wenn Sie der Besitzer eines Abonnements sind, können Sie ihm Empfänger hinzufügen. Weitere Informationen finden Sie unter Freigeben eines Abonnements. Wenn Sie ein Abonnement basierend auf einem Arbeitsblatt erstellen, können Sie dem Abonnement bis zu 10 Arbeitsblätter hinzufügen.

  1. Öffnen Sie das Arbeitsblatt im Analysemodus. Gehen Sie folgendermaßen vor:

    • Klicken Sie mit der rechten Maustaste auf eine Visualisierung und wählen Sie Abonnieren aus.

    • Klicken Sie in der oberen Leiste auf Navigation und wählen Sie Arbeitsblatt abonnieren aus.

  2. Titel

    Geben Sie einen Titel für das Abonnement ein. Dies wird als Betreff für die E-Mail verwendet.

  3. Beschreibung

    Dieses Feld ist optional. Diese wird im Hauptteil der E-Mail angezeigt. Dieser Abschnitt kann zur Unterschied zwischen ähnlich aussehenden Abonnements verwendet werden.

    Hier ein Beispiel: Wöchentliche Umsätze - Ostküste und Wöchentliche Umsätze - Westküste.

  4. Format

    Wählen Sie zwischen PDF oder Microsoft PowerPoint. Wenn Ihre Berichte als PowerPoint-Dateien verteilt werden, können sie von Ihren Empfängern bearbeitet werden.

  5. Arbeitsblätter

    Wenn Sie ein Abonnement basierend auf einem Arbeitsblatt erstellt haben, können Sie dem Abonnement weitere Arbeitsblätter hinzufügen. Die maximale Anzahl Arbeitsblätter ist 10.

    Sie können die Arbeitsblätter sortieren, um die Reihenfolge zu ändern, in der sie in der E-Mail angezeigt werden.

  6. E-Mail senden

    Wählen Sie, wie oft das Abonnement einen Bericht generiert. Die Uhrzeit, die Sie festlegen, ist die Startzeit der Berichtsgenerierung, nicht die Zeit, um die der Bericht empfangen wird.

    • Täglich: Wählen Sie, um welche Uhrzeit der Bericht täglich generiert wird.

    • Wöchentlich: Wählen Sie, an welchen Tagen der Woche der Bericht gesendet wird. Sie können so viele Tage wie gewünscht auswählen.

    • Monatlich: Wählen Sie, an welchen Tagen des Monats der Bericht gesendet wird. Sie können so viele Tage wie gewünscht auswählen.

  7. Uhrzeit

    Wählen Sie die Uhrzeit, zu der das Abonnement einen Bericht sendet.

    Dies ist die Uhrzeit, um die der Bericht zur Generierung der Warteschlange hinzugefügt wird. Es ist nicht die Uhrzeit, um die Sie den Bericht erhalten. Weitere Informationen zu Berichtsgenerierungszeiten finden Sie unter Berichts-E-Mails treffen nicht zur geplanten Zeit ein.

  8. Aktivieren Sie Benutzer zum Abonnement hinzufügen, um Empfänger zum Abonnement hinzuzufügen.

  9. Klicken Sie auf Abonnieren.

WarnhinweisEin Benutzer kann Zugriff auf die Sichtbarkeit aller anderen Benutzer im gleichen Mandanten erhalten. Diese Sichtbarkeit kann unter anderem Benutzernamen, E-Mail-Adressen und den Antragsteller des Benutzers (eine eindeutige Zeichenfolge zur Identifizierung des Benutzers, die vom konfigurierten Identitätsanbieter an Qlik Cloud bereitgestellt wird) betreffen.

Freigeben eines Abonnements

Sie können Empfänger zu einem Abonnement hinzufügen, wenn:

  • Sie das Abonnement besitzen.

  • Die Arbeitsblätter öffentlich sind.

  • Der Empfänger hat Zugriff auf die App. Wenn er keinen Zugriff hat, wird er dem Abonnement hinzugefügt, erhält aber keine Berichte. Nachdem sie die Berechtigung zum Zugriff auf die App erhalten haben, können Sie das Abonnement bearbeiten und sie hinzufügen.

Empfänger erhalten keine Benachrichtigung, wenn sie zu einem Abonnement hinzugefügt oder daraus entfernt wurden.

Verwalten Ihrer Abonnements

Klicken Sie im linken Fenster im Hub auf Abonnements, um eine Liste der Abonnements anzuzeigen, die Sie besitzen. Daneben werden die Abonnements angezeigt, denen Sie als Empfänger hinzugefügt wurden. Alternativ können Sie im Benutzerprofilmenü oben rechts in der Anwendung auf Abonnements klicken.

Abschnitt Abonnements des Cloud-Hubs

Spezielle Seite für Abonnements, die über den Cloud-Hub aufgerufen werden kann.

Sie können die Abonnements auf der Seite Abonnements filtern und sortieren. Sie können Ihre Liste nach Besitzern (beliebig, Sie oder andere) verfeinern oder nach Abonnements eines bestimmten Benutzers suchen. Die Abonnements in der Liste können nach der Uhrzeit, zu der sie das letzte Mal gesendet wurden, der Uhrzeit, zu der sie das nächste Mal gesendet werden sollen, oder alphabetisch nach Name sortiert werden.

Klicken Sie auf ein Abonnement, um weitere Details anzuzeigen. Das Menü Aktion rechts neben jedem Abonnement hat verschiedene Aktionen.

Wenn Sie ein Abonnement erhalten, dieses aber nicht besitzen, haben Sie die folgenden Möglichkeiten:

  • Details: Zeigen Sie Abonnementdetails wie Letztes Senden, Geplant und Erstellt an. Sie können auch eine Liste aller im Abonnement enthaltenen Arbeitsblätter anzeigen und sie in der App öffnen.

  • In App anzeigen: Öffnen Sie das Arbeitsblatt oder Diagramm in der App. Wenn das Abonnement mehr als ein Arbeitsblatt enthält, wird das erste Arbeitsblatt in der Liste geöffnet.

  • Abonnement stornieren: Entfernt Sie aus einem Abonnement.

Wenn Sie der Eigentümer des Abonnements sind, haben Sie die folgenden Möglichkeiten:

  • Details: Zeigen Sie Abonnementdetails wie Letztes Senden, Geplant und Erstellt an. Besitzer können auch diesen Abschnitt verwenden, um das Abonnement zu bearbeiten, zu senden, zu aktivieren/deaktivieren oder zu löschen.
  • Empfänger: Zeigt und bearbeitet die Liste der Empfänger.

  • Bearbeiten: Ändert Abonnementdetails oder den Zeitplan.

  • Jetzt senden: Senden Sie den Bericht sofort.

  • In App anzeigen: Öffnen Sie das Arbeitsblatt oder Diagramm in der App. Wenn das Abonnement mehr als ein Arbeitsblatt enthält, wird das erste Arbeitsblatt in der Liste geöffnet.

  • Aktivieren/Deaktivieren: Aktivieren und deaktivieren Sie die geplanten E-Mails. Sie können nach wie vor einen Bericht über Jetzt senden senden.

  • Löschen: Löschen Sie das Abonnement. Dieser Vorgang kann nicht rückgängig gemacht werden.

Anzeige von Zeitzonen für Alarme und Abonnements mit wiederkehrenden Zeitplänen

Im Hub entspricht die angezeigte Zeit bzw. Zeitzone in der Regel der Zeitzone, die Sie in den Profileinstellungen festgelegt haben. Eine Ausnahme ist das wiederkehrende Zeitintervall für Alarme und Abonnements.

Wenn Sie auf der Seite Details einen Alarm oder ein Abonnement anzeigen, sehen Sie die nächste geplante Ausführungszeit unter Geplant. Die Zeit unter Geplant entspricht Ihrer Zeitzone. Wenn Sie den Mauszeiger über Info halten, wird eine Quickinfo angezeigt, die angibt, wie oft das Abonnement oder der Alarm gesendet wird.

Diese Abbildung zeigt, wie es aussieht, wenn der Ersteller und der Empfänger in der gleichen Zeitzone leben:

  • Die nächste geplante Ausführungszeit ist: 3. April 2023 um 2:15 PM.

  • Die dunkelgraue Quickinfo zeigt, wie oft das Abonnement gesendet wird: Wöchentlich montags und mittwochs um 2:15 PM.

Eine Abonnementdetailseite, so wie sie einem Empfänger in der gleichen Zeitzone wie der Ersteller angezeigt wird.

Eine Abonnementdetailseite zeigt eine Quickinfo mit dem Abonnementzeitplan.

Die Quickinfo zeigt jedoch Warnung, wenn der Alarm oder das Abonnement in einer anderen Zeitzone als derjenigen des Empfängers erstellt wurde. In diesem Fall wird der Zeitplan in der Zeitzone angezeigt, in der der Alarm oder das Abonnement erstellt wurden.

Beispiel: Ein Benutzer in Toronto, Kanada (GMT-4), erstellt ein Abonnement. Er fügt einen Empfänger hinzu, der in Stockholm, Schweden (GMT+2) wohnt. Der Zeitunterschied zwischen ihnen beträgt 6 Stunden. Der schwedische Empfänger schaut auf der Detailseite nach, wie oft er dieses Abonnement erhalten wird. Unter Geplant wird die Uhrzeit in der korrekten Zeitzone angezeigt: Stockholm, Schweden. Wenn der Empfänger aber den Mauszeiger über Info hält, zeigt die Quickinfo den ganzen Abonnementzeitplan in der kanadischen Zeitzone an:

  • Die nächste geplante Ausführungszeit ist der 13. März 2023, 3:30 PM.

  • Die dunkelgraue Quickinfo zeigt den Abonnementzeitplan, aber in der kanadischen Zeitzone: Warnung Erstellt in (GMT -4:00) Amerika/Toronto: Wöchentlich Montag, Mittwoch, Freitag 9:30 AM.

Der Zeitplan eines in Kanada erstellten Abonnements, wie es von einem Empfänger in Schweden angezeigt wird.

Der Unterschied zwischen der geplanten Zeitzone und der Zeit, um die der Benutzer eine Abonnement-E-Mail erhält.

Beschränkungen

  • Sie können nur maximal 100 Abonnements erstellen.

  • Sie können bis zu 10 Arbeitsblätter einschließen.

  • Ein Abonnement kann bis zu 100 Empfänger haben.

  • Falls ein Abonnement drei Mal nicht generiert werden kann, wird es deaktiviert.

  • Wenn der Export für ein oder mehrere Arbeitsblätter im Abonnement fehlschlägt, wird der Bericht nicht generiert. Mögliche Ursachen:

    • Der Empfänger hat keinen Zugriff auf alle Arbeitsblätter im Abonnement.

    • Ein Arbeitsblatt wurde gelöscht.

  • Sie können folgende Elemente nicht abonnieren:

  • Diese Funktion ist eine Form der Berichtserstellung in Qlik Cloud Analytics. Über alle Formen der Berichtserstellung hinweg kann ein Mandant maximal 30,000 Anfragen im Zsuammenhang mit Berichten stellen.

  • Wenn Sie in Ihrer App eine benutzerdefinierte Schriftart verwenden, wird davon ausgegangen, dass Sie über die erforderliche Lizenz zum Verwenden dieser Schriftart in der Ausgabe über Qlik Sense verfügen. Um zu gewährleisten, dass Ihre Schriftarten lizenziert sind, sollten Sie die zahlreichen Open-Source-Schriftarten verwenden, die in Qlik Sense zum Designen von App-Inhalten verfügbar sind.

    Wenn Sie über die erforderlichen Lizenzen für eine Schriftart verfügen, die in den Qlik Sense Standardformatvorlagen nicht verfügbar ist, finden Sie in Erstellen von Formatvorlagen mit benutzerdefinierten Schriftarten weitere Informationen darüber, wie Sie die Schriftart zu einer benutzerdefinierten Formatvorlage hinzufügen.

  • Wenn Zeichen, die in der ausgewählten Schriftart nicht unterstützt werden, im App-Inhalt verwendet werden, werden diese Zeichen in der Ausgabe in einer unterstützten Schriftart gerendert. Wenn eine benutzerdefinierte Schriftart verwendet wird, kann abweichendes Verhalten festgestellt werden.

  • Wenn Sie eine benutzerdefinierte Formatvorlage in der App zum Definieren der Schriftart verwenden (indem Sie z. B. eine Schriftartdatei direkt zur Formatvorlage hinzufügen), stimmen die gerenderten Schriftarten in verschiedenen Ausgaben möglicherweise nicht mit den in der App verwendeten Schriftarten überein.

  • Auf Diagrammobjekte in der App angewendete Schatten werden im generierten Abonnementbericht nicht angezeigt.

Beachten Sie die folgenden Limits für das Abonnieren von App-Inhalten. Diese Limits werden geprüft, wenn Sie auf Abonnieren klicken. Wenn die Limits überschritten werden, wird eine Fehlermeldung angezeigt. Wenn dieses Problem eintritt, wenden Sie sich an einen Benutzer mit der Berechtigung Kann bearbeiten in der App.

Die spezifischen Einschränkungen werden unten aufgelistet:

  • Maximale Anzahl Felder in den Auswahlen: 125

  • Maximale Anzahl der Feldwerte in den Auswahlen: 150.000 Feldwerte insgesamt in einem oder mehreren Feldern

  • Maximale Anzahl alternativer Zustände: 125

    Verwenden von alternativen Zuständen für vergleichende Analysen

  • Maximale Anzahl Patches: 100

    Patches sind Eigenschaften oder Formate, die in der App angewendet werden. Beispiel: Hinzufügen einer Sortierung zu einer Tabellenspalte.

  • Maximale Anzahl Variablen: 1.100

    Verwenden von Variablen in Formeln

  • Maximale Anzahl Arbeitsblätter im Abonnement: 10

  • Maximale Bildgröße: 4.000 x 4.000 Pixel

  • Minimale Bildgröße: 5 x 5 Pixel für Diagramme und 20 x 20 Pixel für Arbeitsblätter

Fehlerbehebung

Berichts-E-Mails treffen nicht zur geplanten Zeit ein

Für ein Berichtsabonnement ist eine bestimmte Startzeit festgelegt, aber der Bericht trifft erst Stunden später in Ihrem E-Mail-Posteingang ein.

Mögliche Ursache  

Die im Abonnement festgelegte Zeit ist die Uhrzeit, zu der die Berichtsgenerierung startet, nicht die Uhrzeit des Eintreffens in Ihrem Posteingang. Wie lange die Berichtsgenerierung dauert, hängt von mehreren Faktoren ab. Die wichtigsten sind:

  • Anzahl der aktiven Qlik Cloud Benutzer

  • Anzahl der aktiven oder in der Warteschlange stehenden Prozesse: Alarme, Datenladevorgänge, Abonnements

Vorgeschlagene Aktion  

Legen Sie für Ihr Abonnement die Ausführung außerhalb der Spitzenzeiten fest. Wenn Sie und Ihre Empfänger um 9 Uhr mit der Arbeit beginnen, könnten Sie die Abonnementausführung auf 6 Uhr festlegen.

Weitere Informationen

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