Создание сводных таблиц (Pivot) | Qlik Cloud Справка
Перейти к основному содержимому Перейти к дополнительному содержимому

Создание сводных таблиц (Pivot)

Last updated: 01.09.2026

Сводная таблица (Pivot) в Visualization bundle представляет измерения и меры в виде строк и столбцов в таблице. В сводной таблице можно одновременно анализировать данные по нескольким мерам и в нескольких измерениях. Для получения дополнительной информации см. Visualization bundle.

  1. На панели ресурсов откройте Диаграммы.
  2. В разделе Визуализация перетащите Сводная таблица на лист.
  3. Добавьте строковое измерение. Выполните одно из следующих действий:

    1. Нажмите Добавить измерение и выберите поле или основное измерение.

    2. На панели свойств разверните Данные и нажмите Добавить пользовательское выражение, чтобы вставить пользовательское выражение в качестве измерения строки.

  4. При желании, добавьте больше измерений строк на панели свойств:

    • В Данные > Измерения > Строки, нажмите Добавление данных и выберите поле или основное измерение.

    • В Данные > Измерения > Строки, нажмите Открытие редактора выражения, чтобы вставить пользовательское выражение в качестве измерения строки.

    Примечание к подсказке Сводная таблица детализирует строки в порядке их добавления. Можно щелкнуть и перетащить измерения, чтобы изменить их порядок.
  5. Добавьте одно или несколько измерений столбцов по мере необходимости:

    • В Данные > Измерения > Столбцы, нажмите Добавление данных и выберите поле или основное измерение.

    • В Данные > Измерения > Столбцы, нажмите Открытие редактора выражения, чтобы вставить пользовательское выражение в качестве измерения столбца.

  6. Добавьте одну или несколько мер:

    • В Данные > Меры нажмите Добавление данных и выберите агрегацию поля или основную меру.

    • В Данные > Меры нажмите Открытие редактора выражения, чтобы вставить пользовательское выражение в качестве меры.

  7. При желании, вы можете определить фильтры для применения к данным диаграммы. Это делается в Данные > Фильтры на панели свойств.

    Для получения дополнительной информации о фильтрах см. Применение фильтров к визуализации.

  8. При необходимости дополнительно управляйте данными сводной таблицы на вкладке Данные панели свойств. Можно выполнить следующие действия.

    • Установите флажок рядом с любым элементом. Нажмите Инструменты или щелкните правой кнопкой мыши по элементу, чтобы выполнить следующие действия:

      • Переместить наверх
      • Переместить в самый низ
      • Скрыть
      • Показать
      • Вырезать
      • Копировать
      • Дублировать
      • Вставить
      • Удалить

      Вы можете применить изменения к нескольким элементам, выбрав их, а затем щелкнув правой кнопкой мыши по одному из выбранных элементов.

      Примечание к информацииДействия по скрытию и отображению недоступны, когда выбраны как видимые, так и альтернативные столбцы.
    • Щелкните Скрыть: или Показать на элементах, чтобы скрыть или показать их — то есть добавить или удалить их из альтернативных столбцов. Скрытые столбцы можно добавить при использовании исследования диаграмм.

    • Нажмите Перетаскиваемый столбец рядом с элементами и перетащите их, чтобы изменить порядок или переместить их между измерениями строк и столбцов.

После определения данных вы можете настроить внешний вид и другие параметры в других разделах панели свойств.

Сведение данных на панели свойств

На панели свойств можно добавлять измерения и меры в сводную таблицу, а также сводить строки или столбцы.

Данные

На панели Данные вы можете добавить Измерения, Меры и Фильтры. Можно перемещать элементы между строками и столбцами. Можно также изменить порядок элементов в строках или столбцах. При использовании нескольких мер они группируются, и создается элемент Значения.

Панель свойств, раздел «Данные».

Сортировка

На панели сортировки в расширенных свойствах можно изменить внутренний порядок измерений и мер.

Панель свойств, подпанель сортировки.

Примечание к информацииПри сортировке сводных таблиц значения NULL всегда отображаются первыми.

Сортировка по первой мере

Если есть несколько мер, создается группа мер. Параметр Сортировать по первой мере позволяет отсортировать значения измерения по числовому значению первой меры. Этот порядок сортировки повлияет на все измерения, и его приоритет выше приоритета любого другого порядка сортировки, определенного для измерений.

Например, есть две меры: Quantity и Sales. На панели свойств в разделе Данные> Меры мера Quantity стоит первой в списке. Если применять параметр Сортировать по первой мере в порядке убывания, таблица будет отсортирована, начиная с измерения с самым высоким значением Quantity.

Если параметр Сортировка по первой мере выключен, таблица использует порядок сортировки, настроенный для измерений.

Сводная таблица в режиме изменения. Параметр «Сортировать по первой мере» был включен.

Объект сводной таблицы с сортировкой по первой мере.

Ограничения:

  • Этот параметр поддерживается, только если вычисляются подытоги. Для вычисления подытогов можно выполнить одно из следующих действий.
    • На панели свойств перейдите в раздел Данные и щелкните измерение. В разделе Поле, включите Показать итоги.
    • На панели свойств перейдите в раздел Вид > Представление. Включите параметр Увеличить отступ строк.
  • Этот параметр не поддерживается для вычисляемых измерений.
  • Этот параметр поддерживается, только если все измерения находятся в разделе «Строка», а все меры — в разделе «Столбец».

Сортировка измерений

Когда параметр Сортировка по первой мере выключен, таблицу можно сортировать по значениям измерений. Каждое измерение можно сортировать с использованием параметра Авто или Пользовательская. При использовании сортировки Авто значения полей сортируются по алфавиту и по численным значениям в порядке возрастания. При использовании сортировки Пользовательская можно выключать или выключать каждый из следующих параметров:

  • Сортировка по выражению: выполняется сортировка по пользовательскому выражению. Параметр Сортировка по выражению переопределяет параметры Сортировка по численным значениям и Сортировка по алфавиту. Этот параметр следует использовать только с первым (крайним) измерением в таблице.

  • Сортировка по численным значениям: выполняется сортировка значений полей, которые начинаются с числа.

  • Сортировка по алфавиту: выполняется сортировка значений полей, которые начинаются с буквы.

Для всех трех вариантов сортировки доступны параметры По возрастанию и По убыванию.

Сортировка в поиске

Пользователь может щелкнуть имя измерения в таблице, чтобы развернуть список. В списке пользователь может выполнить поиск и выбрать отдельные значения измерения. Параметр Сортировка в поиске управляет порядком сортировки значений в списке измерений.

Для порядка сортировки списка предлагаются следующие параметры:

  • Авто: используется порядок сортировки по умолчанию. Числа сортируются по численным значениям в порядке возрастания. Текст сортируется в алфавитном порядке в порядке возрастания.

  • Наследовать из измерения: используется порядок сортировки, определенный для отдельного измерения.

Форматирование столбцов измерений и мер

Можно форматировать столбцы изменений и мер, используя дополнительные параметры. Можно выполнить следующие действия.

  • Ограничение отображаемых измерений

  • Форматирование представления измерения

  • Форматирование представления меры

  • Форматирование числовых значений мер

  • Создание условных столбцов

  • Установка цвета фона для ячеек с помощью выражений

  • Установка цвета текста с помощью выражений

  • Настройка ширины столбца

Ограничение отображаемых измерений

Ограничьте число отображаемых значений для измерений. При установке ограничения отображаются только измерения, значение меры которых отвечает критерию ограничения.

  1. В поле Данные выберите измерение и разверните свойства.

  2. В разделе Поле > Ограничение, выберите одно из следующих ограничений:

    • Без ограничений: значение по умолчанию.

    • Фиксированное число: выберите, чтобы отобразить верхнее или нижнее значение. Задайте число значений. Вы также можете использовать выражение, чтобы задать число. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

    • Точное значение: используйте операторы и задайте точное значение ограничения. Вы также можете использовать выражение, чтобы задать число. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

    • Относительное значение: используйте операторы и задайте относительное значение ограничения в процентном выражении. Вы также можете использовать выражение, чтобы задать число. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

Форматирование представления измерения

Можно форматировать столбцы измерений для отображения значений, ссылок или изображений, используя параметры в разделе Представление на панели свойств. Можно выбрать следующие представления: 

  • Текст: значения измерения отображаются в виде текста. Это значение по умолчанию.
  • Ссылка: значения отображаются в виде активных ссылок. Используется значение измерения или URL-ссылка, либо можно добавить другие URL-ссылки на отображаемые значения измерений.

  • Изображение: значения, содержащие абсолютный URL-адрес изображения, будут показаны как изображения.

Форматирование ссылок

Примечание к информации

Символ ; не поддерживается как разделитель параметров запроса в URL-адресе.

  1. В поле Данные выберите измерение и разверните свойства.

  2. В разделе Представление > Отображение выберите Ссылка.

  3. В поле Параметр ссылки выберите один из следующих параметров:

    • Добавить метку: измерение содержит URL-адрес назначения либо в выражении измерения, либо в таблице данных. Ссылки отображаются и упорядочиваются по выражению URL-адреса назначения.

      В поле Метка ссылки введите описательную текстовую метку для целевого URL-адреса. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

    • Добавить URL-адрес: значения измерения становятся активными текстовыми ссылками, которые служат метками для URL-адреса.

      Под URL ссылки введите выражение целевого URL. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

Форматирование изображений

Примечание к предупреждению

Изображения в сводных таблицах доступны только с серверов и доменов, внесенных в безопасный список. Администраторы делают эти ресурсы доступными в Администрирование путем добавления политики безопасности содержимого Content-Security-Policies (CSP) для каждого сервера или домена. CSP помогает предотвратить межсайтовые скриптовые атаки, контролируя, какие ресурсы браузер может запрашивать с сервера.

Примечание к информации

Символ ; не поддерживается как разделитель параметров запроса в URL-адресе.

  1. В поле Данные выберите измерение и разверните свойства.

  2. В разделе Представление > Отображение выберите Изображение.

  3. В поле Параметр изображения выберите один из следующих вариантов.

    • Добавить метку: измерение содержит абсолютный URL-адрес изображения либо в выражении измерения, либо в таблице данных. Ссылки отображаются и упорядочиваются по выражению URL-адреса.

      В поле Метка изображения введите описательную текстовую метку для изображения, которая отображается в качестве альтернативного текста при наведении курсора на изображение. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

    • Добавить URL: значения измерений становятся метками для альтернативного текста, который отображается при наведении указателя мыши на изображение.

      Под URL изображения, введите выражение для целевого URL. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

  4. В поле Изменение размера выберите один из следующих вариантов определения размера:

    • Всегда подходит

    • Подогнать по ширине

    • Подогнать по высоте

    • Растянуть по размеру

    • Исходный размер

  5. В поле Позиция выберите позицию изображения в ячейке.

Форматирование представления меры

Можно форматировать столбцы мер, используя параметры в разделе Представление на панели свойств. Можно выбрать следующие представления:

  • Текст: значения измерения отображаются в виде текста. Это значение по умолчанию.

  • Изображение: значения меры представлены в виде изображений.

  • Индикатор: в ячейках мер отображаются настраиваемые символы. В зависимости от предпочтений рядом с этими индикаторами могут отображаться или не отображаться текстовые представления для каждого значения.

Форматирование изображений

Примечание к предупреждению

Изображения в сводных таблицах доступны только с серверов и доменов, внесенных в безопасный список. Администраторы делают эти ресурсы доступными в Администрирование путем добавления политики безопасности содержимого Content-Security-Policies (CSP) для каждого сервера или домена. CSP помогает предотвратить межсайтовые скриптовые атаки, контролируя, какие ресурсы браузер может запрашивать с сервера.

Примечание к информации

Символ ; не поддерживается как разделитель параметров запроса в URL-адресе.

  1. В области Данные выберите меру и разверните свойства.

  2. В разделе Представление > Отображение выберите Изображение.

  3. В поле Параметр изображения выберите один из следующих вариантов.

    • Добавить метку: мера содержит абсолютный URL-адрес изображения либо в выражении меры, либо в таблице данных. Ссылки отображаются и упорядочиваются по выражению URL-адреса.

      В поле Метка изображения введите описательную текстовую метку для изображения, которая отображается в качестве альтернативного текста при наведении курсора на изображение. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

    • Добавить URL: значения мер становятся метками для альтернативного текста, который отображается при наведении курсора на изображение.

      Под URL изображения, введите выражение для целевого URL. Щелкните элемент Открытие редактора выражения, чтобы открыть редактор выражения.

  4. В поле Изменение размера выберите один из следующих вариантов определения размера:

    • Всегда подходит

    • Подогнать по ширине

    • Подогнать по высоте

    • Растянуть по размеру

    • Исходный размер

  5. В поле Позиция выберите позицию изображения в ячейке.

Добавление индикатора тренда к мере

В столбец меры можно добавить индикатор тренда. Индикатор будет отображаться в виде символа рядом из измеряемым значением. Пользователь может задать диапазоны, для которых будут выводиться разные символы индикатора, а также цвет индикатора.

  1. На панели свойств разверните список Данные и щелкните меру.

    Откроется окно «Свойства меры».

  2. В разделе Представление установите для параметра Представление значение Индикатор.

  3. Под кнопкой Добавить предел щелкните прямоугольник, содержащий цвет и символ. Можно настроить цвет и символ для индикатора.

    Если добавлен один или несколько пределов, можно настроить цвет и символ для каждого диапазона, щелкнув диапазон в этом прямоугольнике.

  4. Настройте дополнительные свойства для индикаторов, которые подробно описаны в разделах ниже.

Для диапазонов, в которых будут использоваться индикаторы, необходимо задать предельные значения (кнопка Добавить предел). Предельное значение можно задать тремя способами.

  • При помощи ползунка.
  • Указав значение в текстовом поле.
  • При помощи выражения, возвращающего предельное значение.

После задания предельных значений можно выбрать цвет и символ индикаторов, используемых в разных диапазонах.

Можно изменить стиль отображения индикатора.

  • Чтобы вывести одновременно значения индикатора и меры, выберите Показать значения.

  • Чтобы цвет значения совпадал с цветом индикатора, нажмите Применить цвет к значению.

    Примечание к информацииКогда этот параметр включен, цвет индикатора переопределяет текущий цвет значения ячейки, если он задан в других свойствах диаграммы.
  • Индикатор может выводиться справа или слева от значения (кнопка Положение индикатора.

  • Если установлен один или несколько пределов, включите Градиент, чтобы окрасить индикаторы с использованием градиентов между цветами.

Форматирование числовых значений мер

Настроить формат числовых значений мер можно в области Формат чисел на панели свойств.

Если вы хотите изменить формат числа на уровне приложения, а не только для одной меры, лучше сделать это в региональных настройках в операторах SET в начале скрипта в редакторе загрузки данных.

  1. В области Данные выберите меру и разверните свойства.

  2. В разделе Поле > Форматирование чисел выберите формат:

    • Авто: Qlik Sense автоматически задает формат чисел на основе исходных данных.

      В качестве числовых аббревиатур используются международные единицы СИ, такие как: k (тысяча), M (миллион) и G (миллиард).

    • Число: по умолчанию формат задан как Простой. Формат можно выбрать из вариантов в списке. Выберите вариант Пользовательский и введите образец в поле Образец формата.

      • # ##0 описывает число как целое с разделителем тысяч. В этом примере « » используется в качестве разделителя тысяч.
      • ###0 описывает число как целое без разделителя тысяч.
      • 0000 описывает число как целое не менее чем с четырьмя разрядами. Например, число 123 будет отображаться как 0123.
      • 0.000 описывает число с тремя десятичными знаками. В этом примере «.» используется в качестве десятичного разделителя.

      Если к образцу формата добавить знак процента (%), значения меры автоматически умножатся на 100.

    • Деньги: По умолчанию, образец формата, используемый для денег, определяется предпочтительными региональными настройками в вашем профиле. Используйте поле Образец формата, чтобы изменить образец.
    • Дата: по умолчанию формат задан как Простой. Формат можно выбрать из вариантов в списке. Выберите вариант Пользовательский и введите образец в поле Образец формата.
    • Длительность: По умолчанию, Образец формата, используемый для длительности, устанавливается предпочтительными региональными настройками в вашем профиле. Длительность можно форматировать как дни или комбинацию дней, часов, минут, секунд и долей секунд. Используйте Образец формата для изменения образца формата.
    • Пользовательский: По умолчанию, Образец формата, используемый для пользовательского, определяется предпочтительными региональными настройками в вашем профиле. Используйте Образец формата для изменения образца формата.

Создание условных столбцов

Столбцы могут быть условными и отображаться только при соблюдении определенных условий.

  1. В области Данные выберите измерение или меру и разверните свойства.

  2. В разделе Представление > Показывать столбец, если, нажмите Открытие редактора выражения, чтобы открыть редактор выражения.

  3. Введите выражение, чтобы определить условия для отображения столбца.

  4. Щелкните Применить.

Пример

Предположим, есть Сводная таблица или объект Pivot, который содержит следующее:

  • Измерения: Product Type и Product Name.

  • Меры: Sum(Sales) и Count (distinct InvoiceNumber).

  • Элементы в разделе Столбцы ― это Значения (по умолчанию) и поле Quarter.

В вашем приложении может быть большое количество данных за несколько лет, поэтому вы не хотите слишком загромождать визуализацию. В то же время требуется обеспечить детализированный и интерактивный анализ.

Для столбца Квартал можно добавить следующее выражение для Показать столбец, если:

GetSelectedCount(Year)=1

Благодаря этому выражению, если пользователь выбирает один год в приложении, сводная таблица разбивает каждую меру по кварталам. Если нет, то отображаются общие значения меры.

Можно использовать переменные, чтобы получить интерактивный анализ. Предположим, что создана переменная vUserInteraction с пустым определением. Затем на листе создаются две диаграммы типа Кнопка, настроенные с помощью действия Задать значение переменной:

  • Показать больше сведений: нажмите эту кнопку, чтобы задать для vUserInteraction значение ='Yes'.

  • Показать меньше сведений: нажмите эту кнопку, чтобы задать для vUserInteraction значение ='No'.

В сводную таблицу можно добавить несколько дополнительных мер на диаграмму, например Count(Quantity) и Sum(Cost). Затем настройте для каждого столбца меры следующее значение для Показать столбец, если:

'$(Reference)'='Yes'

Это позволяет диаграмме адаптироваться к тому, нужна ли пользователю дополнительная информация или нет. Если пользователь нажимает кнопку Показать больше сведений, в таблицу будут добавлены дополнительные меры. Если нет или если пользователь нажимает кнопку Показать меньше сведений, дополнительные меры убираются.

  • Показать больше сведений: нажмите эту кнопку, чтобы задать для vUserInteraction значение ='Yes'.

  • Показать меньше сведений: нажмите эту кнопку, чтобы задать для vUserInteraction значение ='No'.

В сводную таблицу можно добавить несколько дополнительных мер на диаграмму, например Count(Quantity) и Sum(Cost). Затем настройте для каждого столбца меры следующее значение для Показать столбец, если:

'$(Reference)'='Yes'

Это позволяет диаграмме адаптироваться к тому, нужна ли пользователю дополнительная информация или нет. Если пользователь нажимает кнопку Показать больше сведений, в таблицу будут добавлены дополнительные меры. Если нет или если пользователь нажимает кнопку Показать меньше сведений, дополнительные меры убираются.

Установка цвета фона с помощью выражений

Вы можете использовать выражения для определения цвета фона как ячеек заголовка, так и ячеек содержимого каждого элемента. Например, можно настроить изменение цвета фона ячеек столбца в зависимости от значений в столбце ячейки.

Для получения дополнительной информации о применении цветов с помощью выражений, см. Раскрашивание по выражению.

  1. В области Данные выберите элемент и откройте раздел Представление в свойствах.

  2. Чтобы задать цвет фона ячейки заголовка элемента, в разделе Заголовок, в разделе Выражение цвета фона, введите выражение. Щелкните элемент Открыть редактор выражения, чтобы открыть редактор выражения.

  3. Чтобы задать цвет фона ячеек содержимого элемента, в разделе Содержимое, в разделе Выражение цвета фона, введите выражение. Щелкните элемент Открыть редактор выражения, чтобы открыть редактор выражения.

Установка цвета текста с помощью выражений

Можно определить цвет текста для столбца, используя выражения. Например, можно настроить изменение цвета текста в ячейках столбца в зависимости от значений в столбце ячейки. Если цвет фона ячейки определен, но цвет текста не определен, цвет текста по умолчанию будет выбран таким образом, чтобы он наилучшим образом контрастировал с фоном.

Вы можете изменить цвет текста как в заголовке элемента, так и в ячейках содержимого.

Для получения дополнительной информации о применении цветов с помощью выражений, см. Раскрашивание по выражению.

  1. В области Данные выберите элемент и откройте раздел Представление в свойствах.

  2. Чтобы задать цвет текста ячейки заголовка, в разделе Заголовок, в разделе Выражение для цвета текста, введите выражение. Щелкните элемент Открыть редактор выражения, чтобы открыть редактор выражения.

  3. Чтобы задать цвет текста ячейки содержимого, в разделе Содержимое, в разделе Выражение для цвета текста, введите выражение. Щелкните элемент Открыть редактор выражения, чтобы открыть редактор выражения.

Настройка ширины столбца

По умолчанию ширина столбца задается автоматически. Можно вручную задать ширину столбца по:

  • Содержимое

  • Пиксели

  • Процентное значение

Также можно настроить размер столбцов вручную, перетаскивая границы заголовка.

  1. В области Данные выберите измерение или меру и разверните свойства.

  2. В разделе Представление > Ширина столбца выберите способ установки ширины столбцов:

    • По содержимому: размер столбцов определяется по ширине их содержимого.

    • Пиксели: ширина столбца устанавливается в пикселях.

    • Процентное значение: ширина столбца устанавливается в процентах.

    • Авто: ширина столбца устанавливается автоматически с помощью Qlik Sense.

Изменение способа представления данных

Существует несколько вариантов настройки представления данных в сводной таблице. Эти параметры доступны на панели свойств в разделе ВидПредставление.

Полностью развернутая

Когда флажок установлен, в сводной таблице все значения отображаются в развернутом виде, а не в свернутом. Этот параметр отображается, когда добавлено больше одного измерения.

Увеличить отступ строк

Этот параметр также отображается, когда добавлено больше одного измерения.

Когда эта настройка включена, измерения вкладываются друг в друга, их можно развернуть. Когда разворачивается строка измерения верхнего уровня, вложенные измерения отображаются с отступом в начале каждой строки.

Если эта настройка выключена, измерения после первого измерения отображаются в отдельных столбцах таблицы и отображаются, если разворачивается строка измерения верхнего уровня.

Пользовательская настройка стиля

В области Вид на панели свойств доступен ряд параметров для настройки стилей.

Щелкните ПалитраСтиль в области Вид > Представление для дополнительной настройки стиля диаграммы. Панель стиля содержит несколько разделов на вкладках Общие и Диаграмма.

Чтобы сбросить стили, щелкните Сброс рядом с каждым разделом. Щелкните Сброс Сбросить все, чтобы сбросить стили для всех доступных вкладок на панели стиля.

Настройка текста

Можно настроить текст для заголовка, подзаголовка и сноски на вкладке Вид > Общие. Чтобы скрыть эти элементы, выключите параметр Показать заголовки.

Видимость различных меток на диаграмме зависит от настроек конкретной диаграммы и от параметров отображения меток. Их можно задать на панели свойств.

Можно настроить стиль текста, который отображается на диаграмме.

  1. На панели свойств разверните раздел Вид.

  2. Выберите ВидПредставление и щелкните ПалитраСтиль.

  3. На вкладке Общие настройте шрифт, стиль начертания, размер шрифта и цвет для следующих элементов:

    • Заголовок

    • Подзаголовок

    • Сноска

  4. На вкладке Диаграмма настройте стиль — например, шрифт, стиль начертания, размер шрифта и цвет — для следующих текстовых элементов:

    • Заголовок: Оформляет текст заголовков для всех измерений.
    • Значения измерения: Оформить текстовые значения измерения.
    • Значения мер: настройте стиль текста для значений мер.
    • Метки мер: настройте стиль текста для заголовков мер.
    • Итоговые значения: настройте стиль текста для итогов.
    • Нулевые значения: настройте стиль текста для нулевых значений.

Настройка фона

Можно настроить фон диаграммы. Также можно применить цвет к отдельным измерениям или мер с использованием выражения.

  1. На панели свойств разверните раздел Вид.

  2. Выберите ВидПредставление и щелкните ПалитраСтиль.

  3. На вкладке Общие панели стиля выберите цвет фона (основной цвет или выражение). Также можно выбрать фоновое изображение из библиотеки медиафайлов или указать URL-адрес изображения.

    Примечание к информации

    Чтобы добавить фоновое изображение из URL-адреса, источник URL-адреса необходимо добавить в список разрешенных в политике безопасности содержимого клиента. Источник должен быть добавлен со следующей Директивой: img-src. Это действие выполняет администратор клиента.

    Для получения дополнительной информации см. раздел Создание записи CSP.

    При использовании цвета фона настройте непрозрачность фона с помощью ползунка.

    При использовании фонового изображения можно настроить размер и расположение изображения.

  4. На вкладке Диаграмма настройте цвет шрифта для следующих элементов:

    • Заголовок
    • Значения измерений
    • Значения мер
    • Метки мер
    • Итоговые значения
    • Пустые значения

Настройка сетки

Можно настроить сетку сводной таблицы.

  1. На панели свойств разверните раздел Вид.

  2. Выберите ВидПредставление и щелкните ПалитраСтиль.

  3. На вкладке Диаграмма настройте сетку для следующих элементов:

    • Высота строки: задайте высоту строки в линиях.

    • Граница: задайте цвет границ ячейки.

    • Разделитель: задайте цвет разделителя, который разграничивает измерения и меры, а также заголовок и строки.

    • Фон: задайте цвет пустой области, которая создается, когда имеются измерения в столбце.

Настройка значений null

Можно изменить представление нулевых значений в сводной таблицы.

  1. Щелкните ВидПредставление на панели свойств.

  2. В области Текст для нулевого значения введите текст, которым требуется заменять нулевые значения.

Полное разворачивание сводной таблицы

Можно настроить сводную таблицу так, чтобы она всегда отображалась в полностью развернутом виде.

  1. Щелкните ВидПредставление на панели свойств.

  2. Установите флажок Полностью развернутая.

Пользовательская настройка границы и тени

Можно настроить границу и тень диаграммы.

  1. На панели свойств разверните раздел Вид.

  2. Выберите ВидПредставление и щелкните ПалитраСтиль.

  3. На вкладке Общие панели стилей в области Граница настройте значение параметра Контур, чтобы сделать линию вокруг диаграммы более широкой или узкой.

  4. Выберите цвет границы.

  5. Настройте параметр Радиус закругления, чтобы управлять скруглением рамки.

  6. В области Тень на вкладке Общие выберите размер и цвет тени. Выберите Нет, чтобы убрать тень.

Настройка итоговых значений

Вы можете включить отображение числовых итоговых значений измерений в сводной таблице. Необходимо учитывать следующее.

  • Если в меню Внешний вид > Представление включен параметр Увеличить отступ строк, можно показать итоговые значения для любого измерения, кроме автоматически созданного измерения Значения.

  • Если в меню Внешний вид > Представление выключен параметр Увеличить отступ строк, можно показать итоговые значения для первого измерения Строка и любого измерения Столбец, кроме автоматически созданного измерения Значения.

  1. На панели свойств разверните раздел Данные.

  2. Нажмите на измерение, чтобы развернуть его свойства.

  3. Установите для параметра Показать итоги значение Включено.

Работа с исследованием диаграмм

Исследование диаграмм позволяет пользователям без доступа к редактированию листа изменять сводный объект на лету во время анализа. Пользователи могут добавлять, удалять и изменять порядок данных, эффективно создавая свои собственные таблицы, если это необходимо для пользовательского анализа.

Подготовка к активации исследования диаграммы

Подготовьте Сводный объект для исследования диаграммы путем добавления всех ресурсов данных, которые понадобятся пользователям. Это делается в разделе Data на панели свойств.

  1. Настройте Сводный объект, как вы обычно это делаете, задав ему расположение по умолчанию в разделе Данные в свойствах.

    Создание сводных таблиц

  2. Добавьте дополнительные элементы строки, столбца и меры, к которым вы хотите предоставить доступ пользователям, но которые не будут отображаться в таблице по умолчанию.

  3. Скрыть эти дополнительные элементы из представления по умолчанию, наведя курсор на элемент на панели свойств и нажав Скрыть:.

    Скрытие ресурса данных из представления по умолчанию объекта Сводная таблица. Его можно будет использовать в исследовании диаграмм.

    Объект сводной таблицы с сортировкой по первой мере.
    Примечание к подсказкеВы можете снова показывать скрытые элементы по умолчанию, нажав Показать на них в панели свойств.

Активация исследования диаграммы

После того как вы подготовили данные на диаграмме для изучения диаграммы, вы можете активировать ее для пользователей.

  1. На панели свойств разверните Внешний вид > Исследование диаграммы.

  2. Установите переключатель Включить исследование диаграммы.

  3. В разделе Параметры видимости выберите один из указанных ниже вариантов.

    • Авто: панель «Исследование диаграммы» отображается, когда пользователи открывают лист.

    • Свернуто: панель «Исследование диаграммы» включена, но не отображается, когда пользователи открывают лист. Пользователи могут открыть ее в меню наведения, щелкнув Дополнительно, а затем Элементы управления Исследование диаграммы.

Использование исследования диаграммы во время анализа

При анализе диаграммы потребители могут добавлять, удалять и изменять порядок ресурсов данных на лету. Это позволяет проводить динамический, гибкий анализ, который может помочь раскрыть дополнительные выводы из данных. Пользователи также могут делиться, загружать и добавлять в закладки измененное состояние таблицы.

Примечание к информацииДля сводных объектов с активированным исследованием диаграммы, исследование диаграммы либо видно по умолчанию, либо его можно открыть в меню Дополнительно в разделе Элементы управления Исследование диаграммы.

Исследование диаграммы используется в режиме анализа. Добавляйте или удаляйте строки, значения и столбцы из объекта сводной таблицы, пересортировывайте данные, изменяйте ширину столбцов и применяйте выделения. Нельзя изменить размер или макет всей диаграммы на листе в режиме исследования диаграммы.

Примечание к подсказке

Доступны следующие действия в заголовке панели:

  • Снять выделение со всех: Удалить все выбранные в данный момент элементы.

  • Сброс: Сбросить все несохраненные изменения, внесенные вами во время анализа в текущей сессии, включая добавленные или удаленные элементы, сортировку и многое другое.

  • Тщательное исследование: Закрыть панель.

Если вы настраиваете сводный объект, используя режим исследования диаграммы, другие пользователи не смогут увидеть ваши изменения, если вы не сохраните их как общедоступную закладку. Это означает, что несколько пользователей могут одновременно вносить изменения в одну и ту же диаграмму. Ваши изменения будут видны вам до завершения сессии. После этого диаграмма вернется в состояние по умолчанию, установленное создателем. Если вы хотите сохранить свой макет, создайте закладку. Для получения дополнительной информации см. Создание закладок.

Панель исследования диаграммы не отображается в результирующей диаграмме, загруженной или предоставленной для совместного использования.

Исследование диаграммы Сводного объекта. На этом изображении диаграмма находится в состоянии по умолчанию — данные не были добавлены, удалены или переупорядочены.

Сводный объект в конфигурации по умолчанию с развернутым исследованием диаграммы.

Исследование диаграммы того же Сводного объекта, что и выше, но с измененными элементами строк измерения (некоторые добавлены, некоторые удалены). Также добавлены три новые меры. Фактически, новая таблица была построена на лету.

Сводный объект с развернутым исследованием диаграммы и изменениями, добавленными на лету в его конфигурацию и данные.

Выбор активных полей из циклических измерений в сводных таблицах

Если в сводной таблице используется циклическое измерение, пользователи могут выбирать активные поля из такого измерения.

  1. Щелкните Меню в столбце циклического измерения.

  2. Щелкните Цикл <Имя измерения> и выберите поле из циклического измерения.

Развертывание и свертывание измерений во время анализа

В зависимости от настроек в сводной таблице могут быть доступны функции, позволяющие разворачивать и сворачивать элементы во время анализа. В стандартном случае все измерения выводятся в развернутом виде.

Чтобы развернуть измерение, нажмите Плюс. Чтобы свернуть развернутое измерение, нажмите Минус.

Развернуть или свернуть измерение также можно через контекстное меню диаграммы, выбрав Дополнительно.

  1. Щелкните правой кнопкой мыши по диаграмме или откройте меню параметров, выбрав Дополнительно в меню, отображающемся при наведении мыши.

  2. Нажмите Развернуть / свернуть.

  3. Используйте доступные опции:

    • Плюс Развернуть все: развернуть все измерения.

    • Минус Свернуть все: свернуть все измерения.

    • Плюс Развернуть <имя измерения>: развернуть данное измерение.

    • Минус Свернуть <имя измерения>: свернуть данное измерение.

Подробнее

Помогла ли вам эта страница?

Если вы обнаружили какую-либо проблему на этой странице или с ее содержанием — будь то опечатка, пропущенный шаг или техническая ошибка, сообщите нам об этом!