Menü Datei
Letzte Aktualisierung: 07.10.2026
Das Dropdown-Menü Datei finden Sie auf der Menüleiste. Es enthält folgende Befehle:
- Neu: Öffnet ein neues QlikView-Fenster und ermöglicht das Erstellen einer neuen QlikView-Datei.
- Öffnen...: Öffnet ein neues QlikView-Fenster und ermöglicht das Öffnen einer QlikView-Datei oder einer Tabellendatei. Beim Öffnen von Tabellendateien gelangen Sie automatisch in den Dateiassistenten. Dasselbe erreichen Sie mit der Tastenkombination Strg+O.
-
Auf Server öffnen...: Öffnet einen Dialog, in dem eine Verbindung zu einem QlikView Server hergestellt und nach einem Dokument gesucht werden kann, um es im Client-Modus zu öffnen.
Dasselbe erreichen Sie mit der Tastenkombination Strg+Umschalt+O.InformationshinweisWenn Sie ein QlikView Server-Dokument im Client-Modus öffnen, haben Sie nur eine eingeschränkte Funktionalität zur Verfügung. Je nach Client-Variante und Server-Einstellungen können Sie gegebenenfalls Veränderungen am Layout vornehmen. Objekte können nicht hinzugefügt oder gelöscht werden. Möglicherweise können nicht alle Eigenschaftsdialoge aufgerufen werden. Ferner sind eventuell auch das Ändern von Makros, der Skriptzugriff, das Laden von Daten oder das Speichern von Dokumenten nicht möglich. - Dokument aktualisieren: Dieser Befehl ist nur bei Dokumenten verfügbar, die auf QlikView Server geöffnet sind, und wenn eine neuere Version des Dokuments auf dem Server verfügbar ist. Durch den Befehl wird das Dokument aktualisiert, ohne dass Sie die Sitzung beenden müssen. Sogar das momentane Layout und der Auswahlstatus bleiben erhalten.
- URL öffnen...: Öffnet das Dialogfeld URL \n öffnen. Dort können Sie die URL einer beliebigen Internetseite eingeben. Die Seite wird in einem eigenen Fenster innerhalb von QlikView angezeigt Dieser Befehl kann beispielsweise für den QlikView Publisher AccessPoint benutzt werden oder für QlikView Server-Dokumente, die mit dem AJAX-Client geöffnet werden. Geöffnete Webseiten sind genau wie geöffnete QlikView-Dokumente über das Menü Fenster zugänglich.
- FTP öffnen...: Öffnet ein neues QlikView-Fenster, ermöglicht das Öffnen einer QlikView-Datei oder Tabellendatei von einem FTP-Server. Beim Öffnen von Tabellendateien gelangen Sie automatisch in den Dateiassistenten.
- Schließen: Schließt die aktive QlikView-Datei.
- Favoriten: Dieses Kaskadenmenü steuert eine Liste benutzerdefinierter Favoritendokumente, die unabhängig von der Liste Zuletzt verwendete Dokumente (siehe unten) verwaltet wird.
- Speichern: Speichert die aktuelle Konfiguration in einer QlikView- Datei. Daten, Skript und Layout werden gespeichert. Dasselbe erreichen Sie mit der Tastenkombination STRG+S. Zum Freigeben eines QlikView-Dokuments über die AJAX-Clients darf der Dateiname kein Hash-Zeichen (#) enthalten.
- Speichern unter...: Speichert die aktuelle Konfiguration in einer neuen QlikView- Datei unter einem neuen Namen. Dasselbe erreichen Sie mit der Tastenkombination F12. Zum Freigeben eines QlikView-Dokuments über die AJAX-Clients darf der Dateiname kein Hash-Zeichen (#) enthalten.
- Link speichern...: Speichert einen Link zu einem auf einem QlikView Server geöffneten Dokument als Textdatei auf dem lokalen Computer. Diese Datei erhält die Erweiterung qvw, enthält aber nicht das QlikView-Dokument, d. h. keine Daten und Layoutinformationen. Beim Öffnen der Linkdatei stellt QlikView eine Verbindung zum QlikView Server her und öffnet das Dokument. Dieser Befehl ist für lokal gespeicherte Dokumente nicht verfügbar.
- Als E-Mail-Anhang senden...: Nur verfügbar, wenn Sie mit einem lokalen Dokument arbeiten. Erstellt eine E-Mail mit einer Kopie des aktuellen QlikView-Dokuments als Anhang. Der E-Mail-Empfänger kann das QlikView-Dokument öffnen, vorausgesetzt, er hat Zugriff auf QlikView und Zugriffsrechte für das Dokument (sofern Abschnittszugriffssicherheit verwendet wird). Dieser Befehl funktioniert nur, wenn ein Mail-Client auf dem Computer konfiguriert ist.
- E-Mail mit Lesezeichen als Link...: Nur verfügbar bei der Arbeit mit einem QlikView Server-Dokument. Er verschickt eine E-Mail mit einem Hyperlink zu dem aktiven Server-Dokument. Dabei wird der aktuelle Auswahlstatus und das Layout in einem temporären Lesezeichen gespeichert und im Hyperlink codiert. Wenn der Empfänger auf den Link klickt, öffnet sich das Server-Dokument und das Lesezeichen wird aufgerufen, vorausgesetzt der Empfänger hat die nötigen Zugriffsrechte für das Dokument und die darin enthaltenen Daten. Dieser Befehl funktioniert nur, wenn ein Mail-Client installiert ist Darüber hinaus muss der QlikView Server Server-Lesezeichen zulassen.
- Drucken...: Öffnet das Standarddialogfeld Drucken und ermöglicht das Drucken des aktuellen Arbeitsblattobjekts. Dieser Befehl ist für Listboxen nicht verfügbar. Dasselbe erreichen Sie mit der Tastenkombination STRG+P.
- Als PDF drucken...: Führt in den Dialog Drucken, wobei der Drucker Microsoft-Druckausgabe in PDF vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist. Dasselbe erreichen Sie mit der Tastenkombination Strg+Umschalt+P.
- Mögliche drucken...: Öffnet das standardmäßige Dialogfenster Drucken und ermöglicht das Drucken der möglichen (ausgewählten und optionalen) Werte der aktuellen Listbox. Von dort aus können Sie die wählbaren bzw. ausgewählten Werte der Listbox drucken.
- Mögliche als PDF drucken...: Dieser Befehl muss verwendet werden, wenn Listenfelder und Multiboxen als PDF gedruckt werden.
- Arbeitsblatt drucken...: Öffnet das Dialogfeld Drucken und ermöglicht das Drucken eines Bildes des aktuellen Arbeitsblatts.
- Druckvorschau...: Zeigt eine Vorschau der druckbaren Arbeitsblattobjekte.
- Quellcodeverwaltung
Informationshinweis Diese Funktionalität ist veraltet. Siehe die letzte Version der Dokumentation vor dem Supportende: Menü „Datei“
- Exportieren:
- Inhalt exportieren...: Diese Alternative ist nur verfügbar, wenn ein exportierbares Arbeitsblattobjekt aktiv ist. Es wird der Exportvorgang ausgeführt, der im Objekt-Menü des aktiven Objekts zu finden ist.
- Arbeitsblatt-Bild exportieren...: Öffnet ein Dialogfeld zum Speichern eines Bilds des aktuellen Arbeitsblatts in einer Datei.
- Dokumentlayout exportieren: Öffnet einen Dialog zum Speichern des Dokumentlayouts als XML-Datei. Die Daten des Dokuments werden nicht mitgespeichert.
- Skript bearbeiten...: Öffnet das Dialogfeld Skript bearbeiten. Dort können Sie Skripte ändern, anhand derer Datenbankverbindungen hergestellt und Datenbanken geöffnet werden.
- Neu laden: Führt das aktuelle Ladeskript aus und lädt Daten in das aktive QlikView-Dokument neu. Dieser Befehl sollte ausgeführt werden, wenn die Datenquelle seit der letzten Ausführung des Skripts aktualisiert wurde. Dasselbe erreichen Sie mit der Tastenkombination STRG+R.
- Teilladen: Führt das aktuelle Ladeskript einschließlich aller Skriptbefehle wie Drop table aus und lädt Daten in das aktive QlikView-Dokument neu. Es werden jedoch nur die Tabellen erneut geladen, deren "load"- und "select"-Befehle den Zusatz Ersetzen oder Hinzufügen tragen. Datentabellen, die von dieser Art „load“- oder „select“-Befehl nicht betroffen sind, werden von der partiellen Ausführung des Skripts nicht berührt. Dasselbe erreichen Sie mit der Tastenkombination STRG+UMSCHALT+R.
- Daten reduzieren: Öffnet ein Menü mit den folgenden zwei Befehlen:
- Mögliche Werte beibehalten: Reduziert die QlikView-Datenbank durch Entfernen aller Werte mit dem Status Ausgeschlossen.
- Alle Werte entfernen: Erstellt eine Vorlage, indem alle Werte aus der QlikView-Datenbank entfernt werden, die Datenbankstruktur und das Layout jedoch beibehalten werden.
- Tabellenstruktur...: Führt in den Dialog Tabellenstruktur, wo die internen Tabellen, Felder und Verknüpfungen in einer grafischen Übersicht dargestellt sind. Dasselbe erreichen Sie mit der Tastenkombination STRG+T.
- Liste der zuletzt verwendeten Dokumente: Eine Auflistung der zuletzt verwendeten QlikView-Dokumente. Die Anzahl der gelisteten Dateinamen können Sie im Dialogfeld Benutzereinstellungen, Allgemein ändern. Vorbesetzt wird 8. Die Auswahl einer dieser Optionen entspricht dem Befehl Öffnen.
- Beenden: Schließt die geöffneten Dokumente und beendet QlikView.
Verbindung zum Server herstellen