檔案功能表 | QlikView 說明
跳到主要內容

檔案功能表

上次更新:2026/10/7

檔案功能表是螢幕頂端的下拉式功能表,包含下列命令:

  • 新增:開啟新的 QlikView 視窗,並可建立新的 QlikView 檔案。
  • 開啟...:開啟新的 QlikView 視窗,並允許開啟 QlikView 檔案或表格檔案。開啟表格檔案將自動開啟檔案精靈。利用下列鍵盤快速鍵即可叫用此命令: Ctrl+O。
  • 在伺服器中開啟...:開啟對話方塊,可在其中連線至 QlikView Server 並瀏覽文件以在用戶端模式下開啟。
    利用下列鍵盤快速鍵即可叫用此命令: Ctrl+Shift+O。

    資訊備註相較於開啟本機文件,QlikView Server 的用戶端開啟文件時,可對文件進行的動作會受到限制。用戶端無法新增或刪除工作表物件,端視文件是否支援共同作業而定。無法新增或刪除工作表。此外,並非所有屬性對話方塊都可供存取、並非所有巨集都可以變更、並非所有指令碼都可供存取、並非所有資料都可重新載入,或者並非所有文件都可儲存。
  • 重新整理文件:此命令僅適用於在 QlikView Server 上開啟的文件,且伺服器上有該文件的較新版本可供使用時。叫用重新整理時,會將存取權授予最新的資料,同時維持工作階段,包括選項和版面配置狀態。
  • 開啟 URL...:開啟 開啟 \n URL 對話方塊。在此對話方塊中,輸入任何網頁的有效 URL。網頁將在 QlikView 內的個別視窗中開啟。例如,此功能可用於 QlikView Publisher Accesspoint 或透過 AJAX 用戶端顯示 QlikView Server 文件的頁面。透過視窗功能表可以存取開啟的網頁,就像標準的 QlikView 文件視窗一樣。
  • 開啟 FTP...:開啟新的 QlikView 視窗,允許從 FTP 伺服器開啟 QlikView 檔案或表格檔案。開啟表格檔案將自動開啟檔案精靈。
  • 關閉:關閉作用中的 QlikView 檔案。
  • 我的最愛:此階層式功能表控制使用者自訂的我的最愛文件清單,其與 最近的文件 清單分開獨立管理(請參閱下文)。
  • 儲存:將目前的組態儲存至 QlikView 檔案中。資料、指令碼及版面配置都會儲存。利用下列鍵盤快速鍵即可叫用此命令: Ctrl+S。如果您想要使用 AJAX 用戶端來共用 QlikView 文件,檔案名稱不可包含井字號 (#) 字元。
  • 另存新檔...:以新名稱將目前的組態儲存至新的 QlikView 檔案中。利用下列鍵盤快速鍵即可叫用此命令: F12。如果您想要使用 AJAX 用戶端來共用 QlikView 文件,檔案名稱不可包含井字號 (#) 字元。
  • 儲存連結...:將在 QlikView Server 上開啟之文件的連結儲存為本機電腦上的文字檔。此檔案將會有副檔名 qvw,但是不會包含任何資料或版面配置。開啟這類連結文件時,QlikView 將嘗試重新連線到伺服器,並且在 QlikView Server 上開啟該文件。此命令不適用於本機文件。
  • 以附件寄送...:僅在處理本機文件時可用。建立附有目前 QlikView 文件複本的郵件。郵件收件人將能夠開啟 QlikView 文件,前提是他們具備 QlikView 存取權限以及該文件的存取權限 (若使用區段存取安全性)。若要讓此命令生效,必須在電腦上設定郵件用戶端。
  • 以連結形式郵寄書籤...:僅在處理 QlikView Server 文件時可用。建立一封郵件,內含目前伺服器文件的 URL 連結。將會建立暫存的伺服器書籤 (包含版面配置狀態) 並以 URL 編碼。只要郵件收件者擁有文件及其資料的存取權,該收件者即可使用該 URL 連結來開啟伺服器文件,並查看您所瀏覽的內容。必須在電腦上設定郵件用戶端,此命令才會發生作用。必須將 QlikView Server 設為允許伺服器書籤。
  • 列印...:開啟標準 列印 對話方塊,可列印目前的工作表物件。此命令不適用於列表框。利用下列鍵盤快速鍵即可叫用此命令: Ctrl+P。
  • 列印為 PDF...: 開啟已預先選取 Microsoft Print to PDF 印表機的列印對話方塊。按列印按鈕之後,將會提示您輸入 PDF 輸出檔案的檔案名稱。此命令僅在您的系統中有可用的 PDF 印表機時才可供使用。 利用下列鍵盤快速鍵即可叫用此命令: Ctrl+Shift+P。
  • 列印可能值...:開啟標準 列印 對話方塊,可列印目前列表框的可能(已選取和選用)值。此命令僅適用於列表框。
  • 列印可能值為 PDF...:將清單方塊和多重方塊列印為 PDF 時,必須使用此命令。
  • 列印工作表...:開啟 列印 對話方塊,可列印目前工作表的影像。
  • 列印預覽...:顯示可列印工作表物件的預覽。
  • 原始檔控制
    資訊備註這項功能已淘汰。請參閱終止支援前的最後一個說明文件版本:檔案功能表
  • 匯出:
    • 匯出內容...:此替代選項僅在可匯出的工作表物件為作用中時才可用。它會執行在工作表物件的物件功能表中出現的匯出操作。
    • 匯出工作表 影像...:開啟對話方塊,以將目前工作表的影像儲存至檔案。
    • 匯出文件版面配置:開啟對話方塊以將文件版面配置儲存為 XML 檔案。文件的資料不會儲存在 XML 檔案中。
  • 編輯指令碼...:開啟 編輯指令碼 對話方塊。可以在處此寫入並執行可開啟並連線到資料庫的指令碼。
  • 重新載入:執行目前的載入指令碼,並將資料重新載入至作用中的 QlikView 文件。如果上次重新載入之後變更了資料庫,就需要完成此動作。利用下列鍵盤快速鍵即可叫用此命令: Ctrl+R。
  • 部分重新載入:執行目前的載入指令碼,包括所有指令碼命令,例如 Drop table,並將資料重新載入至作用中的 QlikView 文件。然而,只有 load 及 select 陳述式前方加上 Replace 或 Add 前置詞的表格,才會重新載入。不受這類 load 或 select 陳述式影響的資料表也將不受部份重新載入的影響。利用下列鍵盤快速鍵即可叫用此命令: Ctrl+Shift+R。
  • 縮減資料:開啟包含下列兩個指令的選單:
    • 保留可能值:透過移除所有已排除值來縮減 QlikView 資料庫。
    • 移除所有值:透過從 QlikView 資料庫中移除所有值, 但保留資料庫結構與版面配置來建立範本。
  • 表格檢視器...:開啟「表格檢視器」對話方塊,您可以在其中透過表格、欄位和關聯的圖形檢視來檢視已載入資料的結構。利用下列鍵盤快速鍵即可叫用此命令: Ctrl+T。
  • 最近的文件清單:最近使用的 QlikView 文件清單。顯示的文件數可以在設定:使用者喜好設定對話方塊中設定。預設數目為 8。選取其中一個項目相當於開啟命令。
  • 結束:關閉開啟的文件並結束 QlikView。

此頁面是否對您有幫助?

若您發現此頁面或其內容有任何問題——錯字、遺漏步驟或技術錯誤——請告知我們!

加入分析現代化計畫

Remove banner from view

透過分析現代化程式進行現代化而不犧牲寶貴的 QlikView 應用程式。 按一下這裡 取得更多資訊或聯繫: ampquestions@qlik.com