Arkiv-meny
Senast uppdaterad: 2026-10-07
Arkiv-menyn hittar man överst i fönstret. Den innehåller följande kommandon:
- Ny: Öppnar ett nytt QlikView-fönster och gör det möjligt att skapa en ny QlikView-fil.
- Öppna...: Öppnar ett nytt QlikView-fönster och gör det möjligt att öppna en QlikView-fil eller en tabellfil. När man öppnar en tabellfil öppnas Filguiden automatiskt. Motsvaras av kortkommandot: Ctrl+O.
-
Öppna på server...: Öppnar en dialogruta där det är möjligt att ansluta till en QlikView Server och bläddra efter ett dokument att öppna i klientläge.
Motsvaras av kortkommandot: Ctrl+Skift+O.Anteckning om informationNär man öppnar dokument som klient till QlikView Server har man inte samma rättigheter som när man öppnar lokala dokument. Som klient kan man kanske inte lägga till eller ta bort arkobjekt, beroende på om dokumentet tillåter samverkan. Man kan inte lägga till eller ta bort ark. Det är inte heller möjligt att komma åt alla egenskapsdialoger, ändra makron, nå skriptet, ladda data eller spara dokumentet. - Uppdatera dokument: Detta kommando är endast tillgängligt för dokument som öppnats på QlikView Server och när det finns en nyare version av dokumentet tillgänglig på servern. När man begär en uppdatering får man tillgång till de senaste uppgifterna samtidigt som den pågående sessionens val och layoutstatus bibehålls.
- Öppna URL...: Öppnar dialogrutan Öppna URL. Här anger man en giltig URL-adress till en valfri webbsida. Webbsidan kommer att öppnas i ett separat fönster inuti QlikView. Denna funktion kan exempelvis användas för QlikView Publisher Accesspoint eller sidor som visar QlikView Server-dokument via AJAX-klienter. Webbsidor som har öppnats kan man nå på samma sätt som QlikViews standarddokument - via Windows-menyn.
- Öppna FTP...: Öppnar ett nytt QlikView-fönster, gör det möjligt att öppna en QlikView-fil eller tabellfil från en FTP-server. När man öppnar en tabellfil öppnas Filguiden automatiskt.
- Stäng: Stänger den aktiva QlikView-filen.
- Favoriter: Denna kaskadmeny styr en lista över användardefinierade favoritdokument, som hanteras oberoende av listan Senaste dokument (se nedan).
- Spara: Sparar den aktuella konfigurationen i en QlikView- fil. Data, skript och layout sparas. Motsvaras av kortkommandot: Ctrl+S. Om du vill dela ett QlikView-dokument med hjälp av AJAX-klienter får filnamnet inte innehålla tecknet brädgård (#).
- Spara som...: Sparar den aktuella konfigurationen i en ny QlikView-\nfil under ett nytt namn. Motsvaras av kortkommandot: F12. Om du vill dela ett QlikView-dokument med hjälp av AJAX-klienter får filnamnet inte innehålla tecknet brädgård (#).
- Spara länk...: Sparar en länk till ett dokument som öppnats på en QlikView Server som en textfil på den lokala datorn. Filen kommer att ha filtillägget .qvw men innehåller varken data eller layout. När man öppnar ett sådant länkat dokument kommer QlikView att försöka att koppla upp och öppna dokumentet på QlikView Server. Detta kommando är inte tillgängligt för lokala dokument.
- E-posta som bilaga...: Endast tillgängligt när du arbetar med ett lokalt dokument. Skapar ett e-postmeddelande med en bifogad kopia av det aktuella QlikView-dokumentet. E-postmottagaren kommer att kunna öppna QlikView-dokumentet förutsatt att de har åtkomst till QlikView och behörighet till dokumentet (om säkerhet för delavsnittsåtkomst används). För att detta kommando ska fungera måste en e-postklient vara konfigurerad på datorn.
- Skicka e-post med bokmärke som länk...: Endast tillgängligt när du arbetar med ett QlikView Server-dokument. Skapar ett e-postmeddelande med en länk till det aktuella serverdokumentet. Ett tillfälligt serverbokmärke (med information om layout-status) skapas och kodas i URL:en. E-postmottagaren kan använda URL-länken för att öppna serverdokumentet och se det du ser – under förutsättning att mottagaren har behörighet för dokumentet och dess information. En e-postklient måste konfigureras på datorn för att detta kommando ska fungera. QlikView Server måste vara konfigurerad så att serverbokmärken är tillåtna.
- Skriv ut...: Öppnar standarddialogrutan Skriv ut och gör det möjligt att skriva ut det aktuella arkobjektet. Kommandot är inte tillgängligt för listboxar. Motsvaras av kortkommandot: Ctrl+P.
- Skriv ut som PDF...: Öppnar dialogen Skriv ut med skrivaren Microsoft Skriv ut till PDF förvald. När du klickar på Skriv ut ombeds du ge pdf-filen ett namn. Detta kommando är endast tillgängligt om en PDF-skrivare finns installerad. Motsvaras av kortkommandot: Ctrl+Skift+P.
- Skriv ut möjliga...: Öppnar standarddialogrutan Skriv ut och gör det möjligt att skriva ut de möjliga (valda och valbara) värdena för den aktuella listboxen. Kommandot är endast tillgängligt för listboxar.
- Skriv ut möjliga som PDF...: Detta kommando måste användas vid utskrift av listrutor och multirutor som PDF.
- Skriv ut ark...: Öppnar dialogrutan Skriv ut och gör det möjligt att skriva ut en bild av det aktuella arket.
- Förhandsgranska...: Visar en förhandsgranskning av utskrivbara arkobjekt.
- Källkodskontroll
Anteckning om information Den här funktionen har fasats ut. Se den sista versionen av dokumentationen innan supporten upphörde: Arkiv-menyn
- Exportera:
- Exportera innehåll...: Detta alternativ är endast tillgängligt när ett exporterbart arkobjekt är aktivt. Då exporteras innehållet på det sätt som beskrivs på arkobjektets Objekt-meny.
- Exportera arkbild...: Öppnar en dialogruta för att spara en bild av det aktuella arket till fil.
- Exportera dokumentlayout: Öppnar en dialogruta för att spara dokumentlayouten som en XML-fil. Inga data från dokumentet sparas i XML-filen.
- Redigera skript...: Öppnar dialogrutan Redigera skript. Här kan man skriva och exekvera skript som öppnar och läser databaser.
- Ladda om: Kör det aktuella laddningsskriptet och laddar om data till det aktiva QlikView-dokumentet. Ändringar i databasen som inträffat sedan föregående exekvering laddas på så sätt in i dokumentet. Motsvaras av kortkommandot: Ctrl+R.
- Partiell laddning: Kör det aktuella laddningsskriptet, inklusive alla skriptkommandon, såsom Drop table, och laddar om data till det aktiva QlikView-dokumentet. Enbart de tabeller vars load- och select-satser föregås av prefixet Replace eller Add laddas dock igen. Datatabeller som inte påverkas av denna typ av load- eller select-satser kommer heller inte att påverkas av den partiella laddningen. Motsvaras av kortkommandot: Ctrl+Skift+R.
- Reducera data: Öppnar en meny som innehåller följande två kommandon:
- Behåll möjliga värden: Minskar QlikView-databasen genom att ta bort alla uteslutna värden.
- Ta bort alla värden: Skapar en mall genom att ta bort alla värden från QlikView-databasen, men behålla databasstrukturen och layouten.
- Tabellvy...: Öppnar dialogen Tabellvy där strukturen av den laddade informationen visas grafiskt i tabeller, fält och associationer. Motsvaras av kortkommandot: Ctrl+T.
- Lista över senaste dokument: En lista över de senast använda QlikView-dokumenten. Antalet dokument som visas kan ställas in i dialogrutan Inställningar: Användarinställningar. Standard är 8. Välj ett av dem för att öppna det.
- Avsluta: Stänger de öppna dokumenten och avslutar QlikView.