| 2026.5.20 |
Standart |
8 Eylül 2026 |
Çözülen sorunlar
-
Kısmi Tam Yük istatistiklerinin birleştirilmesi
-
Databricks Lakehouse (Delta) / Databricks (Cloud Storage) – ODBC test Bağlantı, tüm hazırlık ortamlarında proxy (Kullanıcı Adı/Parola) nedeniyle başarısız oluyor
-
Databricks Lakehouse (Delta) Birimi - Dizin silme işlemi "CLOUD_FILE_NOT_FOUND" hatası nedeniyle başarısız oldu
-
Uygulama modu için, yalnızca tam yük görevi DDL'yi etkinleştirmelidir
-
SAP Uygulama hedefi, Snowflake veri formatına yüklenirken verilerde özel karakter oluşturma
-
Tam Yük S3 hedefi, Kaynak SAP çıkarıcısı ile aynı JSON veya farklı JSON dosyalarında çoğaltılmış kayıtlar hazırlıyor
-
Tablo askıya alındığında ilgili hata mesajı eksik
-
OData hedef SAP ODP işi tamamlandı ancak Tam yükleme tamamlanmıyor
-
SQL Server 2012 desteği (Always-Encrypted kontrolünü atla)
-
MySQL/MemSQL hedefleri için LOCAL INFILE'ı yalnızca yükleme moduna kısıtla (LFI düzeltmesi)
-
SAPDB kaynağı – Başka bir tabloya LOAD TABLE komutu geldiğinde, bir tabloda hatalı veri (eksik veri, yinelenenler) oluşabilir.
-
Databricks delta'da veri tipi uzunluğunu değiştirme desteği
-
BigQuery Akışı - Karakterler birleştirilirken STRING veri tipi alanlarından null değerler kesildi
-
PostgreSQL LOB araması, birincil anahtar TIMESTAMPTZ içeriyorsa başarısız olur
-
SQL Server Ertelenmiş Oluşturucu'daki DBCC çağrısı kurtarılabilir bir hata döndürdüğünde, olası zaman aşımı nedeniyle bir kez yeniden bağlanıp tekrar denemeliyiz.
-
HANA Kaynağı, hedefteki DECIMAL veri tipinde Ölçek değerlerinin düşürülmesi veri uyuşmazlığına neden oluyor
-
2025.11 sürümündeki SAP ODP Kaynağı, Tablo seçim deseni için INCLUDE seçeneği kullanıldıysa. Tam yükün tamamlanması daha uzun saatler sürüyor.
-
SQL Server Always Encrypted: Bozuk CSV dosyası nedeniyle tablo, herhangi bir görevde herhangi bir hedefe askıya alınır
-
SAP HANA kayıt noktasına geri alma desteği
-
Azure Active Directory Hizmet Sorumlusu kimlik doğrulaması ile çalışırken Belirteç Süresi Doldu sorunu nedeniyle görev başarısız oluyor
-
Varlık çalıştırılamadı. Hata mesajı, logda eksik tabloyu göstermelidir.
-
Redshift - sütun uzunluğu desteklenmiyor
-
Tetikleyiciler yanlış bırakılıyor
-
Oracle'ın sıkıştırılmış satırlardaki Güncelleme işlemleri, After Image'a birincil anahtar sütun değeri dahil etmeyebilir ve bu da hedefte NULL değerin kullanılmasına neden olabilir.
-
İniş görevi - aynı tablonun kaldırılması ve eklenmesi, hedef veritabanından manuel olarak bırakılırsa _ct tablosunu oluşturmaz
-
S3 Parquet dosyalarındaki datatime sütun değeri için UTC göstergesi ekleme
-
LOB arama hatasından sonra hedef ayırma/yeniden ekleme işleminde eksik kayıtlar
-
DB2 Z/os yeşil durumda ama hiçbir değişiklik ilerlemiyor.
-
DataBricks Delta karakter dizilerindeki ikili sıfırı boşlukla değiştirir
-
alternateBackupFolderTransportCommand büyük/küçük harf duyarlılığını korumuyor
-
SAP HANA Tam Kayıt Modu - QTREP/TRAN_LOG dolarsa tetikleyiciler başarısız olabilir
-
Databricks Lakehouse (Delta) için SAP VBRP Tablosunda Paralel Yükleme Kullanılamıyor
-
Databricks (Bulut Depolama) karakter dizilerindeki ikili sıfırı boşlukla değiştirir
-
SAPDB - tabloların yeni bir oluşumunda bazı olaylar için birincil anahtarda NULL değerler bulunuyor
-
SAP ve arka uç tablolarındaki sütunların sırası farklı olduğunda LOB aramasında çökme
-
csv dosyasını parquet dosyasına dönüştürürken hata
-
Oracle Standby kullanılarak, Çevrimiçi yineleme günlüğü sırası atlandı ve veri kaybına yol açtı
-
SAPDB - Gerekli meta veriler henüz okunmadığında LOB araması sırasında görev çökmesi
-
Oracle, yineleme henüz hazırlanmamışken çevrimiçi yineleme günlüğünden okuyor.
-
Oracle 26ai + TDE şifrelemesi - Şifrelenmiş CDC değişikliklerinin yanlış REDO günlüğü ayrıştırması
-
Kanada bölgesi desteği ekle
-
https proxy Bağlantı desteği
-
Yönetilen ağ geçidi kullanılırken, tanılama paketi yalnızca son günlüğü içerir
-
SQL Server (MS-CDC) kaynağı – Bir sütun yeniden adlandırma dönüşümü yapılandırıldığında geometri sütunları için geçersiz değişiklik sorgusu oluşturuldu
-
Stitch kaynağı – Tam yük başlatıldığında veya sona erdiğinde değişiklik izleme tablosu dosyaları kapatılmadı
-
Teradata kaynak ve hedef – Sürücü kurulumu belgeleri güncellendi
-
Güvenlik – netty-codec-http 4.1.136 sürümüne güncellendi.Son
-
Güvenlik – lz4-java 1.11.1 sürümüne güncellendi
-
Güvenlik – jackson-core 2.18.8 sürümüne güncellendi
-
Güvenlik – jetty-security 12.1.10 sürümüne güncellendi
-
Güvenlik – SAP ODP ve Salesforce kaynak uç noktalarında Log4j güncellendi
-
fullLoadPartial için hata mesajı desteği
-
Snowflake hedef görevi, "Nesne '<>."attrep_status"' mevcut değil veya yetkilendirilmemiş." şeklinde birçok hata gösterdi.
|
Sonraki sürüm yayınlandığında belirlenir. |
| 2025.11.66 |
Standart |
30 Haziran 2026 |
Uyarı notu1 Temmuz 2026 tarihinden itibaren, Veri Hareketi ağ geçidi kullanan ve SaaS uygulama bağlayıcıları ile yeni görevler oluşturmak isteyen müşteriler, Data Movement 2025.11.66 (bu sürüm) veya sonraki bir sürüme yükseltmelidir.
Çözülen sorunlar
-
Databricks ve Snowflake üzerindeki attrep_history Kontrol Tablosu'nda sözdizimi sorunu
Veri Hareketi ağ geçidi 2025.11.40 sürümüne yükseltildikten sonra, attrep_history Kontrol Tablosuna yapılan INSERT işlemleri bir sözdizimi hatasına neden oldu.
-
Oracle kaynağı
Tablo seçimi get_table_list, sıkıştırma etkinleştirilmiş Oracle Autonomous Database ortamlarında tablo meta verileri alınırken Oracle hata kodu '1406' ile başarısız oldu.
-
Replicate varlık arızası
Eksik bir tablo nedeniyle bir yerleştirme görevi çalıştırılamadığında, eksik tablo adını günlükte görüntülemek için hata mesajları geliştirildi.
-
Ana görev - Değişiklik izleme tablosu
Bir veri kümesini bir yerleştirme görevinde kaldırma ve yeniden ekleme, hedef veritabanından manuel olarak bırakıldıysa artık değişiklik izleme tablosunu oluşturmuyordu.
-
SQL Server kaynağı - Always Encrypted uyumluluğu
Always-Encrypted doğrulama kontrolü atlanarak SQL Server 2012 için (dahili bir özellik kullanılarak) destek eklendi; bu kontroller SQL Server'ın 2016 öncesi sürümlerinde desteklenmemektedir.
-
SQL Server Her Zaman Şifrelenmiş
Her Zaman Şifreli sütunlar kullanılırken, bozuk CSV dosyası işleme nedeniyle tabloların herhangi bir görevde herhangi bir hedefe askıya alınma durumuna girmesi sorunu düzeltildi.
-
Güvenlik
CVE-2025-14819 güvenlik açığını gidermek için libcurl kitaplığı güncellendi.
-
Veritabanı Adı'nda tire içeren kayıtlı veri
Veritabanı adları kısa çizgi içerdiğinde, kayıtlı verinin görev hazırlığının başarısız olmasına neden olan bir sorun düzeltildi.
-
Snowflake hedefi - COPY INTO zaman aşımı
Büyük veri kümeleri Snowflake'e yüklenirken "COPY INTO" adımı sırasında oluşan zaman aşımı hataları giderildi.
|
1 Mart 2027 |
| 2025.11.40 |
Standart |
29 Nisan 2026 |
Databricks sürücüsü yeniden markalama
Databricks ile uyum sağlamak için, Databricks bağlayıcısıyla çalışmaya yönelik sürücü yeniden markalandı.
Uyarı notuGörevlerin başarısız olmasını önlemek için, Databricks bağlayıcısıyla çalışan müşterilerin sürücülerini yükseltmeleri gerekir. Bunu sürücü kurulum yardımcı programını kullanarak otomatik olarak (önerilen) veya manuel olarak yapabilirsiniz. Talimatlar için Sürücü kurulumu bölümüne bakın. Sürücüyü manuel olarak kurmayı seçerseniz odbcinst.ini dosyasını talimatlara göre düzenlediğinizden emin olun.
Yeni Snowflake ve Google BigQuery sürücü sürümleri için destek
Bu sürüm, aşağıdaki sürücü sürümleri için destek sunar:
Databricks VARIANT veri türü için destek
Bu sürümden itibaren, aşağıdaki veri türleri Databricks yerel VARIANT veri türüyle eşlenecektir:
-
STRING
-
WSTRING
-
NCLOB
-
CLOB
Bilgi notuDatabricks Runtime 15.4 veya üzeri gerektirir
Çözülen sorunlar
-
IBM DB2 for iSeries kaynağı:
Bir görevi sürdürdükten sonra, ikili ondalık sütunlar içeren bir tablodan değişiklikleri yakalamak görevin çökmesine neden oluyordu.
-
PostgreSQL kaynağı
- CDC sorunu
Durdurulmadan önceki dakika boyunca hiçbir değişiklik yakalamamış bir görevi sürdürdükten sonra, hiçbir değişiklik yakalanmazdı.
-
SSH bağlayıcı - Bağlantı testi sorunu
SSH bağlayıcısında Bağlantıyı Sına'ya tıklamak, SSH ile ilgili sorunlar olduğunda SSH bağlantısıyla ilgili hataları döndürmezdi.
-
Snowflake hedefi - Snowpipe akış sorunu
Snowpipe Streaming yükleme yöntemi olarak kullanıldığında, çok büyük tabloların yüklenmesi aşırı miktarda bellek tüketir, bu da sonunda görevin çökmesine ve yükleme ile çökme döngüsüne girmesine neden olur.
-
Microsoft SQL Server (log tabanlı) kaynak - Belirsiz hata
Gerekli günlükleri içermeyen bir Alternatif yedekleme klasörü belirtildiğinde, görev, bir uyarı yayınlayıp devam etmek yerine belirsiz bir mesajla dururdu.
-
Güvenlik
org.apache.logging.log4j:log4j-core bileşeni, yüklü sürümlerdeki bilinen güvenlik açıkları nedeniyle 2.25.3 sürümüne yükseltildi.
-
SAP ODP kaynağı - filtreleme sorunu
SAP ODP filtresi, yalnızca CDC modunda çalışan bir çıkarıcıda tanımlandığında SAP'ye iletilmezdi.
-
SAP ODATA kaynağı - filtreleme sorunu
Tek bir sütunda birden fazla filtreleme aralığı tanımlamak, tam yükün başarısız olmasına neden olurdu.
|
30 Aralık 2026 |
| 2025.11.23 |
Standart |
11 Mart 2026 |
Genişletilmiş Paralel Yükleme desteği
Paralel Yükleme özelliği artık Databricks hedefini desteklemektedir.
Veri kümesi segmentlerini paralel olarak çoğaltma
DDL History kontrol tablosu: Yeni desteklenen hedefler
attrep_ddl_history (DDL History) kontrol tablosu, hedef çoğaltma sırasında kaynakta meydana gelen DDL değişikliklerinin bir hikayesini içerir.
Aşağıdaki hedef uç noktaları artık desteklenmektedir:
- Google BigQuery
- Google Cloud Alloy DB for PostgreSQL
- Google Cloud SQL for PostgreSQL
- PostgreSQL (şirket içinde)
DDL geçmişi
“[header]__change_mask” başlık sütununda iyileştirme
Parquet biçimiyle Değişiklik Tabloları kullanılırken, [header]__change_mask başlık sütunu, baytları ters sırada depolama little endian kuralına uymak için artık sıfırları sola (sağa yerine) doldurur.
Etkilenen hedef uç noktalar:
-
Amazon S3
-
Google Cloud Storage
Değişiklik Tabloları
Yeni desteklenen veri kaynağı ve hedef sürümleri
-
Kafka hedefi: 4.0.x
-
IBM z/OS kaynağı: 3.2
Yeni desteklenen sürücü sürümleri
- Microsoft ODBC Sürücüsü 18.5
- MySQL 8.4
Microsoft Azure Database for MySQL ve Microsoft Azure Database for PostgreSQL için kullanım ömrü sonu
Microsoft tarafından resmi olarak kullanımdan kaldırılan Microsoft Azure Database for MySQL ve Microsoft Azure Database for PostgreSQL desteği sonlandırılmıştır.
Kullanım ömrü sonu veri kaynağı ve hedef sürümleri
-
Databricks hedefi: 10.4 LTS ve 11.3 LTS
-
MariaDB kaynak ve hedef: 10.5
-
PostgreSQL kaynak ve hedef: 13.x
-
MySQL kaynak ve hedef: 8.1
Kullanım ömrü sonu sürücü sürümleri
Çözülen sorunlar
-
SAP (Uygulama) kaynağı
Kendi kendine işlenen olaylar oluşturan bir arka uç işlemiyle SAP (Uygulama) kaynağı kullanacak şekilde yapılandırılmış görevler, bir tabloyu yeniden yükledikten sonra bazen çöküyordu.
-
Microsoft Azure SQL Veritabanı hedefi
Homojen çoğaltmada, “İşlemsel uygulama” modunda veya bire bir moda geçen “Toplu İş Optimize Edilmiş Uygulama” modunda çalışırken, hedefteki bir DATETIME sütunu birincil anahtarın parçası olduğunda “0 satır etkilendi” hatası oluşuyordu.
-
Oracle kaynağı
Bir tablo uzun ham bir sütun içerdiğinde ve maksimum LOB boyutu 64K'den büyük veya eşit olduğunda Oracle Görevi Tam Yüklemede çöküyor.
-
SAP Extractor kaynağı - CDC iptali nedeniyle boşaltma döngüsü
Bir tablo yeniden yüklemesi sırasında, uzun süren SAP CDC işleri bazen iptal edilir. Bu durum, boşaltmanın hiçbir zaman tamamlanmadığı kurtarılabilir bir hata durumuna yol açacaktır.
-
Güvenlik
Aşağıdaki bileşenler, bilinen güvenlik açıkları nedeniyle yükseltildi:
-
SAP ODP
Bir tablo için filtre tanımlandığında CDC sırasında aşağıdaki hata oluşuyordu:
Invalid value for parameter "I_DIMNAME"
-
SAP çıkarıcısı
Tablolardan biri Yükleniyor durumundayken görev durdurulup yeniden başlatılırsa Delta çalışmayı durduruyordu.
-
SaaS uygulama kaynağı (Workday Raporları)
-
Tam Yükleme sırasında, S3 hazırlık klasörüne bağlanırken görev bazen şu hatayla başarısız oluyordu:
Unable to execute HTTP request: Connect to s3.amazonaws.com:443
İlk bağlantı başarısız olduğunda S3 klasörüne bağlanmak için çoklu yeniden deneme mekanizması uygulanarak sorun çözüldü.
-
Şema zaten mevcut olsa bile CREATE SCHEMA ayrıcalığı gerekli olacaktır.
-
Microsoft SQL Server hedefi
Görev ayarlarında LOB boyutu sınırsız olarak ayarlandığında, LOB sütunlarında bazen veri kaybı meydana geliyor ve CDC sırasında yanlış veri çoğaltma oluşuyordu.
-
PostgreSQL hedef
CSV dosyasının Net Changes tablosuna yüklenememesi, tek tek uygulama yerine kurtarılabilir bir hata döndürürdü (sonsuz bir döngüyle sonuçlanırdı).
-
MySQL'den MySQL'e çoğaltma
Kaynak ve hedefin şeması aynı MySQL örneğinde olduğunda ve çoğaltma bir kontrol tablosu içerdiğinde, görev bazen "Process crashed with signal 11" hatasıyla çöküyordu.
-
PostgreSQL kaynak
CDC sırasında, görev bazen aynı WAL girişlerini tekrar tekrar okuyordu, bu da hiçbir verinin yakalanamamasına neden oluyordu.
-
Microsoft SQL Server kaynağı
-
Şifreli bloklar içeren bir işlem günlüğü sıkıştırması açılırken bir hata oluşurdu. Bu gibi durumlarda günlüğün sıkıştırılmış halde bırakılmasıyla sorun çözüldü.
-
Mevcut dosyalar için gereksiz bir doğrulama kontrolü nedeniyle, alternatif bir yedekleme klasörü kullanılırken gereksiz hatalar gösteriliyordu.
-
DBCC Lookup çağrısından sonra görev bazen çöküyordu.
|
29 Ekim 2026 |
| 2025.5.41 |
Düzeltme |
15 Şubat 2026 |
Monitörde CDC durumunun görüntülenmemesi sorunu düzeltildi. |
11 Eylül 2026 |
| 2025.5.40 |
Standart |
10 Şubat 2026 |
Kafka hedef bağlayıcısı desteği
Veri Hareketi ağ geçidi'in yeni sürümü, Kafka hedef bağlayıcısı için destek sunar. Verilerinizi desteklenen herhangi bir kaynaktan doğrudan şirket içi Kafka veya Amazon MSK'ya zahmetsizce çoğaltın, uygulamalarınızı çevik ve bilgili tutan güvenilir, hataya dayanıklı aktarımlar sağlayın. İster sistemler arasında veri tutarlılığını koruyor ister analitiği besliyor olun, bu bağlayıcı minimum kurulumla düşük gecikmeli çoğaltma sunar.
Daha fazla bilgi için bk. Kafka Hedef
Çözülen sorunlar
-
MySQL kaynağından MySQL hedefine çoğaltma görevi hatası
Bir veri kümesini bir MySQL şemasından aynı MySQL sunucu örneğinde çalışan farklı bir MySQL şemasına çoğaltırken ve çoğaltmaya bir Kontrol tablosu dahil edildiğinde, CDC aşağıdaki hatayla başarısız olurdu:
Process crashed with signal 11
-
SAP Extractor bağlayıcısı: Bir görev sürdürülürken tablo askıya alındı
Bir tablo hala tam yük durumundayken bir görevi sürdürmek, çıkarma işinin başarısız olmasına ve tablonun askıya alınmasına neden oldu.
|
11 Eylül 2026 |
| 2025.5.32 |
Düzeltme |
13 Ocak 2026 |
Çözülen sorunlar
-
PostgreSQL hedefi - Yanlış hata davranışı
CSV dosyasının Qlik Net Changes tablosuna yüklenememesi, tek tek uygulama yerine kurtarılabilir bir hata döndürürdü (sonsuz bir döngüyle sonuçlanırdı).
-
SaaS uygulaması Lite bağlayıcıları
Tam Yükleme sırasında, bağlantının Amazon tarafından etkin bir şekilde reddedilmesi nedeniyle görevler bazen aşağıdaki hatayla başarısız olurdu:
Unable to execute HTTP request: Connect to s3.amazonaws.com:443
Hata oluşmadan önce maksimum üç yeniden deneme ile bir yeniden deneme mekanizması uygulanarak sorun çözüldü.
-
Microsoft SQL Server kaynağı - Günlük sıkıştırma açma hatası
Şifreli bloklar içeren bir işlem günlüğü sıkıştırması açılırken bir hata oluşurdu. Bu gibi durumlarda günlüğün sıkıştırılmış halde bırakılmasıyla sorun çözüldü.
-
Netsuite Suite Analytics kaynağı - CDC devam ettirme hatası
Kaynakta bir değişiklik yaptıktan sonra bir CDC görevine devam edildiğinde, görev bazen aşağıdaki hatayla başarısız oluyordu:
Cannot change column title from type VARCHAR(8000) to VARCHAR(3) because reducing the byte-length of a varchar is not supported.
-
Microsoft SQL Server kaynak - Yanlış hatalar
Mevcut dosyalar için gereksiz bir doğrulama kontrolü nedeniyle, alternatif bir yedekleme klasörü kullanılırken gereksiz hatalar gösteriliyordu.
|
10 Ağustos 2026 |
| 2025.5.22 |
Standart |
25 Kasım 2025 |
Databricks birincil anahtar desteği
Bu sürümden itibaren, veri görevi hedef Databricks Delta tablolarında RELY anahtar sözcüğünü kullanarak bir birincil anahtar oluşturacaktır. Databricks birincil anahtar kısıtlamalarını uygulamazsa da RELY anahtar sözcüğüne sahip birincil anahtarların çoğaltma içermediği varsayılır ve bu nedenle Databricks tarafından sorgu optimizasyonu için kullanılabilir.
Gereksinimler:
Veri türü geliştirmeleri
-
IBM DB2 for iSeries kaynağı: Aşağıdaki veri türleri için destek eklenmiştir: BINARY-DECIMAL ve ZONED-DECIMAL
-
Databricks hedefi: Önceki sürümlerde BYTES, STRING ile eşlenmişti. Bu sürümden itibaren, VARCHAR (Bayt Cinsinden Uzunluk) ile eşlenecektir.
-
Google Cloud BigQuery hedefi: JSON alt türü artık Google Cloud BigQuery hedefi tarafından desteklenmektedir.
PostgreSQL tabanlı kaynak: Bölümlenmiş tablolar artık varsayılan olarak destekleniyor
PostgreSQL tabanlı veri kaynaklarından bölümlerin ve alt bölümlerin (ve alt-alt bölümlerin) çoğaltılması (Tam Yükleme ve CDC) artık varsayılan olarak destekleniyor.
Google Cloud BigQuery hedefi: Veri kesme hatası işleme desteği
Google Cloud BigQuery hedefi artık veri kesme hatası işlemeyi destekliyor. Bir veri kesme hatası oluşursa kaydı istisnalar kontrol tablosuna kaydetmeyi (varsayılan), kaydı yok saymayı, tabloyu askıya almayı veya görevi durdurmayı seçebilirsiniz.
Yeni desteklenen sürümler
Aşağıdaki kaynak ve hedef uç noktası sürümleri artık desteklenmektedir:
-
MariaDB (şirket içi) ve Amazon RDS for MariaDB: 11.4
-
MySQL (şirket içi), MySQL Percona, Google Cloud SQL for MySQL, Amazon RDS for MySQL ve Microsoft Azure Database for MySQL - Flexible Server: 8.4
-
PostgreSQL (şirket içi), Google Cloud SQL for PostgreSQL, Amazon RDS for PostgreSQL ve Microsoft Azure Database for PostgreSQL - Flexible Server: 17.x
Yeni desteklenen sürücü sürümleri
IBM Data Server Client 11.5.9 artık aşağıdaki DB2 kaynakları için desteklenmektedir:
-
IBM DB2 for LUW
-
IBM DB2 for z/OS
Kullanım ömrü sonu kaynak ve sürücü sürümleri
-
Kullanım ömrü sonu kaynakları ve hedefleri: Microsoft tarafından resmi olarak kullanımdan kaldırılan Microsoft Azure Database for MySQL ve Microsoft Azure Database for PostgreSQL desteği sonlandırılmıştır.
-
Kullanım ömrü sonu kaynak sürümleri: Kullanım ömrü sonu olan IBM DB2 for iSeries 7.2 desteği sonlandırılmıştır.
-
Kullanım ömrü sonu sürücü sürümleri: IBM Data Server Client 11.5.6 desteği sonlandırılmıştır.
Çözülen sorunlar
-
HSTS desteği
HSTS, Qlik Data Gateway - Veri Hareketi makinesinde etkinleştirilmedi.
-
Veri Hareketi ağ geçidi yükleme hatası
Veri Hareketi ağ geçidi'in Redhat Sürüm 9.7 üzerine kurulumu, "OPENSSL_3.4.0 bulunamadı" hatasıyla başarısız olurdu.
-
PostgreSQL 15.7 Kaynak - CDC sırasında veri yakalanmadı
CDC sırasında, görev aynı WAL girişlerini okumaya ve aynı klasör konumunu işlemeye devam ederdi.
-
SAP ODP - CDC hatası
Bir CDC görevi değişiklikler sırasında durduktan sonra (örneğin bir bağlantı sorunu nedeniyle), görevi sürdürmek bazen satır uzunluğu hatalarına neden olurdu.
-
Eksik kaynak bağlantı günlükleri
Önizleme veya Lite bağlayıcı kullanan bir görev çalıştırıldıktan sonra kaynak bağlantı günlükleri kullanılamaz olurdu.
-
İzleme - Eksik bilgi
Bir Tam Yükleme ve CDC görevinin CDC aşamasında bir tablo askıya alındığında İzleme sekmesi bir hata mesajı göstermezdi.
|
10 Ağustos 2026 |
| 2024.11.95 |
Standart |
4 Kasım 2025 |
Databricks platformunda bilgi birikimi ambarları oluşturma desteği
Daha önce bilgi birikimi ambarları yalnızca Snowflake üzerinde destekleniyordu. Artık bilgi birikimi ambarlarını ve dosya tabanlı bilgi birikimi ambarlarını Databricks üzerinde de oluşturabilir ve çalıştırabilirsiniz.
Çözülen sorunlar:
Görevler, hazırlık sırasında şu hatayla aralıklı olarak başarısız oluyordu:
The request was canceled due to the configured HttpClient.Timeout of 300 seconds elapsing.
|
25 Mayıs 2026 |
| 2024.11.90 |
Standart |
21 Ekim 2025 |
Çözülen sorunlar:
metadataschema Dahili özelliği özel karakterlerle tanımlandığında, görev CDC sırasında başarısız oluyordu.
|
4 Mayıs 2026 |
| 2024.11.84 |
Düzeltme |
16 Eylül 2025 |
Çözülen sorunlar:
-
EU-Central-1 bölgesinde üretim uyarıları
EU-Central-1 bölgesindeki müşteriler Veri Hareketi ağ geçidi kullandıklarında sık sık üretim uyarılarıyla karşılaşacaklardır.
-
Jira veri kaynağı: Sıkışmış tablo
Jira'dan veri çoğaltılırken, USERS tablosu ilk çalıştırmada Kuyruğa Alındı durumunda takılı kalıyordu, diğer tablolar yüklemeyi başarıyla tamamlarken.
-
İzleme sorunu
Görev izleyicisinde CDC izlemesi eksikti.
-
Oracle'dan Oracle'a çoğaltma hatası
Oracle lie Oracle arasındaki çoğaltma görevleri, dize uzunluğunun yanlış hesaplanması nedeniyle bazen başarısız olabiliyordu.
-
Güvenlik
Java sunucu bileşeni (sqlite-jdbc), önceki sürümlerdeki bilinen bir güvenlik açığı nedeniyle 3.47.0 sürümüne güncellendi.
-
Bir görev başlatılırken hata
Bir görev daha önce hiç başlatılmadan, ilk kez devam modunda başlatıldığında bazen "Veritabanı için lisans yok" hatası oluşuyordu.
-
Yeni veri kümeleriyle Salesforce bağlayıcısı sorunu
Salesforce veri kaynağına sahip bir açılış görevine yeni veri kümeleri eklemek, görevin "'Tablo mevcut değil'" hatasıyla başarısız olmasına neden olur.
|
21 Nisan 2026 |
| 2024.11.78 |
Standart |
3 Eylül 2025 |
Uyarı notu
Snowflake hedefi kullanan müşteriler, Veri Hareketi ağ geçidi yükseltmesi tamamlandıktan sonra Snowflake sürücülerini yükseltmelidir. Aksi takdirde görevler başarısız olacaktır.
Talimatlar için, bkz. Sürücü kurulumu
Çözülen sorunlar:
-
Depolama görevleri bağlantı hatası
Depolama görevleri, ağ geçidinin yeniden başlatılmasını gerektiren bir bağlantı hatasıyla başarısız oluyordu.
-
DB2 sürücüsü yükleme hatası
/tmp klasörüne erişim kısıtlandığında DB2 sürücüsü yüklemesi başarısız oluyordu.
-
Aşırı Qlik Cloud bağlantısı süresi
Veri Hareketi ağ geçidi sürümünü 2024.11.65'e yükselttikten sonra Qlik Cloud bağlantısı kurmak aşırı zaman alıyordu. Sorun, iki dakikalık zaman aşımına sahip bir iptal belirteci eklenerek çözüldü.
-
Yükseltmeden sonra hizmet çöktü
Veri Hareketi ağ geçidi 2024.11.67 sürümüne yükselttikten sonra, /tmp klasöründeki erişim kısıtlamaları nedeniyle external-data-provider hizmeti (Lite bağlayıcıları tarafından kullanılır) çöktü.
-
Güvenlik düzeltmeleri
Aşağıdaki bileşenler, bilinen güvenlik açıkları nedeniyle daha yeni sürümlerle değiştirildi:
-
SQLite 3.49.1
-
Java Çalışma Zamanı Ortamı 17.0.15
-
org.bouncycastle:bcpkix-fips 2.0.7 (bcpkix-fips-2.0.7.jar)
-
org.bouncycastle:bc-fips 2.0.0 (bc-fips-2.0.0.jar)
-
Bilgi martları - Dosya Paylaşımı (SMB)
SMB'ye bağlanma aşağıdaki hatayla başarısız olurdu:
SmbConnection' object has no attribute 'docs_path'
-
Hazırlama hatası
Bir görevi ikinci kez hazırlarken ve ilk hazırlamadan sonra bir DDL oluştuğunda, hazırlama işlemi bazen aşağıdaki hata ile başarısız oluyordu (alıntı):
Could not find match between landing metadata with gateway task metadata for the following tables: <name>
-
Verileri önizleme sorunu
Microsoft SQL Server hedefi kullanılırken önizleme verileri seçeneği çalışmıyordu.
Geliştirmeler:
-
Qlik Cloud Government DoD için destek eklendi
Bu sürüm, Qlik Cloud Government DoD ile Veri Hareketi ağ geçidi kullanımına destek ekler.
|
21 Nisan 2026 |
| 2024.11.70 |
Standart |
12 Ağustos 2025 |
Geliştirmeler:
-
Tablo hata işleme politikasının ne zaman tetikleneceğini kontrol etme
Çoğaltma ve yerleştirme görevleri için tablo hata işleme ayarlarına yeni bir Tablo hatası döndürmeden önceki yeniden deneme sayısı ayarı eklendi. Daha önce, bir tablo hatası oluştuğunda, tablo askıya alınır veya görev durdurulurdu (seçilen hata işleme eylemine göre). Bu durum bazen SaaS uygulaması bakım zaman aralığı sırasında tabloların askıya alınmasına neden oluyordu. Bu yeni seçenekle, tablo hata işleme politikası tetiklenmeden önce tablonun kaç kez yeniden denenmesi gerektiğini belirlemek artık mümkün. Bu seçenek, SaaS uygulamanız periyodik bakımdan geçiyorsa özellikle kullanışlıdır, çünkü varsayılan yeniden deneme sayısını (3) geçersiz kılarak bakımın tablo hata işleme politikasını tetiklemeden tamamlanmasını sağlayabilirsiniz.
Tablo hatası işleme
Bilgi notuBu seçenek, yalnızca Lite veya Standard SaaS uygulama bağlayıcısı ile yapılandırılmış görevler için gösterilecektir.
-
Önizleme verileri artık sütun veri türlerini içeriyor
Bir SQL dönüşümünü önizlerken, sonuçlar artık sütun veri türlerini içerecektir.
Verileri önizleme
|
3 Mart 2026 |
| 2024.11.67 |
Standart |
29 Temmuz 2025 |
Geliştirmeler:
-
Çoğaltma günlük dosyalarının devri ve temizlenmesi
Ağ geçidi makinesindeki çoğaltma günlük dosyaları için bir devir ve temizleme politikası uygulanmıştır. Devir politikası günlük dosyalarının çok büyük olmasını önlerken (bu da performansı ve analizi etkiler), temizleme politikası da bunların birikmesini ve aşırı disk alanı tüketmesini önler.
Çözülen sorunlar:
-
Yeniden yüklemeden sonra hatalı tablo durumu
Askıya alınmış bir tablo yeniden yüklenirken, monitörde gösterilen tablo durumu bazen yanlış olabiliyordu.
-
Hazırlama işleminin zaman aşımına uğraması
Bir veri kümesi ekledikten sonra bir yerleştirme görevi hazırlarken, varlıkların kataloglanması aşamasında bazen zaman aşımı meydana geliyordu. Bu, Hazırlama işleminin başarısız olmasına neden oluyordu.
|
12 Şubat 2026 |
| 2024.11.65 |
Düzeltme |
22 Temmuz 2025 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
Yeni bir tablo eklerken hazırlama hatası
Bir çoğaltma görevine yeni bir tablo eklerken ve Hazırla'ya tıklarken bazen aşağıdaki hata oluşuyordu:
Prepare data task failed: Object reference not set to an instance of an object.
-
Çözülen güvenlik açıkları
Aşağıdaki Veri Hareketi ağ geçidi kurulum dosyaları bilinen güvenlik açıkları olmayan sürümlere güncellendi:
-
java
-
jetty-io-<version>.jar
-
jetty-http-<version>.jar
-
spring-expression-<version>.jar
-
spring-core-<version>.jar
-
spring-context-<version>.jar
|
29 Ocak 2026 |
| 2024.11.61 |
Düzeltme |
15 Temmuz 2025 |
Python 3.12 yüklü bir makineye ai-local-agent (vektör veritabanı ve LLM bağlantısı için gereklidir) yüklenemiyordu. Bu düzeltme sorunu çözmektedir. |
29 Ocak 2026 |
| 2024.11.59 |
Düzeltme |
1 Temmuz 2025 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
IBM DB2 for LUW bağlantı hatası
Veri Hareketi ağ geçidi 2024.11.54 sürümüne yükselttikten sonra veritabanına bağlanılamıyordu.
-
Hazırlama hatası
Görev bir SaaS uygulama kaynağı ve bir Google BigQuery hedefi ile yapılandırıldığında veri görevi hazırlanamıyordu.
-
Java tabanlı kaynaklara sahip görevler yükseltme sonrasında başarısız oluyor
Java tabanlı veri kaynaklarına sahip görevler Veri Hareketi ağ geçidi 2024.11.54 sürümüne yükseltildikten sonra başarısız oluyordu.
-
Snowflake hedefi: CDC sırasında görevler bazen "tek tek" moduna geçiyordu
CDC sırasında, kaynak tablodaki bir STRING sütunu 65536 baytı aştığında veriler hedef STRING sütununda kesiliyordu. Görev daha sonra "tek tek" uygulama moduna geçiyordu.
-
Güvenlik
java_file_factory.jar ve arep-google-cloud.jar dosyaları bilinen güvenlik açıkları olmayan sürümlere yükseltildi.
|
29 Ocak 2026 |
| 2024.11.54 |
Düzeltme |
17 Haziran 2025 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
Görev ayarlarını yok sayarak tam yük
Tam yük sırasında görev, Hedef tablo zaten mevcutsa: Yoksay ile yapılandırılmış olsa bile, görev hedef tabloları bırakır ve yeniden oluşturur
-
Hatalı kayıt sayısı
Çoğaltma modu tam yük olarak ayarlanmış mevcut bir çoğaltma görevini durdurup hazırladıktan ve değişiklikleri uyguladıktan sonra, CDC işlenen kayıt sayısı artarak yanlış bir sayıma neden oluyordu.
-
JIRA kaynak bağlayıcısı
Mevcut bir göreve yeni bir veri kümesi eklendiğinde görev aşağıdaki hatayla başarısız oluyordu:
Could not find a match between landing metadata and gateway task metadata for the following tables: <name>
-
Test bağlantısı başarısız oldu
SAP ve SQL tabanlı kaynaklara test bağlantısı başarısız oluyordu.
-
Yükselt
Ağ geçidini yükselttikten sonra, görevler bazen beklendiği gibi devam etmiyordu.
|
29 Ocak 2026 |
| 2024.11.45 |
Standart |
20 Mayıs 2025 |
Snowpipe Akışı desteği
Önceden, Snowflake'e veri yüklemek için kullanılabilen tek yöntem Toplu yükleme idi. Artık müşteriler, verilerini Snowflake'e aktarmak veya çoğaltmak için Toplu yükleme'yi ya da Snowpipe Akışı'nı kullanabilir.
Snowpipe Akışı'nın Toplu yükleme'ye göre avantajları şunlardır:
- Daha az maliyetli: Snowpipe Akışı, Snowflake deposunu kullanmadığından, işletim maliyetleri önemli ölçüde daha ucuz olmalıdır, ancak bu sizin özel kullanım durumunuza bağlı olacaktır.
- Daha az gecikme süresi: Veriler doğrudan hedef tablolara aktarıldığından (hazırlama yerine), veri kaynağından hedefe çoğaltma daha hızlı olmalıdır.
Çözülen sorunlar
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
Microsoft Fabric: Bağlantı sorunu
Microsoft Fabric bağlayıcısını kullanarak veritabanlarına göz atarken aşağıdaki hata oluşuyordu (alıntı):
Create connection failed'' with error 'java.lang.NoSuchMethodError
Sorun, sürücü kurulumu yardımcı programıyla yüklenen 12.9.0-preview.jar JDBC sürücüsüyle bir uyumsuzluktan kaynaklanıyordu. Yardımcı program artık uyumlu bir sürücü yüklemek üzere güncellenmiştir.
-
Java sunucusu yeniden başlatma hatası
Veri Hareketi ağ geçidi yükseltmesini yaptıktan veya Veri Hareketi ağ geçidi hizmetini yeniden başlattıktan sonra Java sunucusu (SAP ODP gibi Java tabanlı bağlayıcılar için gereklidir) başlatılamıyordu.
-
Güvenliği sertleştirme
-
Uçtan uca şifreleme, Qlik Cloud Yönetim etkinlik merkezinden müşteri tarafından barındırılan günlükleri döndüren günlük kaydı komutu yükleri için karşılıklı olarak zorlanmıyordu.
-
Veri Hareketi ağ geçidi tarafından kullanılan SQLite sürümü, 3.42.0 (CVE-2023-7104) sürümündeki bir güvenlik açığı nedeniyle yükseltildi.
-
Veri Hareketi ağ geçidi tarafından kullanılan com.h2database dosyası, h2-2.1.212 (CVE-2022-45868) sürümündeki bir güvenlik açığı nedeniyle yükseltildi.
|
29 Ocak 2026 |
| 2024.11.34 |
Düzeltme |
1 Nisan 2025 |
Bu yama, bir IBM DB2 for iSeries veri kaynağından veri taşırken karşılaşılan aşağıdaki sorunu çözer:
ISeries Access ODBC Driver 07.01.026 veya sonraki bir sürümü kullanıldığında görev, CDC sırasında "Ayrıştırma hatası" vererek başarısız oluyordu.
|
20 Kasım 2025 |
| 2024.11.30 |
Standart
|
18 Mart 2025 |
Databricks hedefi için OAuth desteği
Müşteriler artık Databricks'in hesap kimlik doğrulaması için önerdiği yöntem olan OAuth kimlik doğrulamasını kullanarak Databricks hedefine bağlanabilirler. Kişisel Erişim Belirteci kimlik doğrulaması şimdilik geriye dönük uyumluluk için kullanılabilir durumda kalacaktır, ancak OAuth'tan daha az güvenli olduğu düşünülmektedir.
Çözülen sorunlar
|
20 Kasım 2025 |
|
2024.11.24
|
Düzeltme
|
11 Mart 2025 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
SAP ODP kaynağı: Meta veri oluşturma hatası
Meta veri oluşturma, adlarında nokta bulunan tablolar için tamamlanamazdı (örn. Amortisman Alanı).
-
Görev kurtarma
Görevler, çevresel bir sorun nedeniyle tam yük sırasında başarısız olursa yalnızca bir kez kurtarılır. Artık Ayarlar > Hata işleme > Çevresel hatalar > Maksimum yeniden deneme sayısı bölümünde yapılandırılan sayıda kurtarılacaktır.
|
18 Eylül 2025 |
| 2024.11.14 |
Standart |
25 Şubat 2025 |
Geliştirmeler
PostgreSQL yük devretme sertifikası
Yük devretmeden sonra ikincil bir veritabanı ile çalışmak aşağıdaki veri kaynakları ile onaylanmıştır (hepsine PostgreSQL kaynak bağlayıcısı kullanılarak erişilebilir):
- Google Cloud SQL for PostgreSQL
- Amazon RDS for PostgreSQL
- PostgreSQL (şirket içinde)
Ayrıca bkz: Yük devretmeyi ayarlama
MySQL performans iyileştirmesi
Önceki sürümlerde, sınırlı LOB boyutu ile yapılandırılmış bir görevde MySQL tabanlı bir kaynak uç noktası kullanıldığında Veri Hareketi ağ geçidi, LOB sütunlarını okumak için kaynak aramayı kullanıyordu. Şimdi Veri Hareketi ağ geçidi, LOB sütunlarını doğrudan binlog'dan okuyacak ve böylece performansı artıracaktır.
Bilgi notuBu iyileştirme JSON veri türü için geçerli değildir.
Veri türü eşlemesindeki değişiklikler
Amazon Redshift ve Snowflake hedefi için LOB sütunlarına eşlemeler değiştirildi.
Amazon Redshift hedefi
- BLOB artık VARBYTE(16777216) ile eşlenmiştir
- NCLOB artık NVARCHAR(65535) ile eşlenmiştir
- CLOB artık NVARCHAR(65535) ile eşlenmiştir
Snowflake hedefi
- BLOB artık BINARY (8388608) ile eşlenmiştir
- NCLOB artık NVARCHAR(16777216) ile eşlenmiştir
- CLOB artık VARCHAR(16777216) ile eşlenmiştir
Yeni desteklenen veri türleri
DDL Geçmiş kontrol tablosu için genişletilmiş hedef desteği
Önceki Veri Hareketi ağ geçidi sürümlerinde DDL Geçmişi kontrol tablosu yalnızca Databricks ve Microsoft Fabric hedefleriyle destekleniyordu. Bu sürüm aşağıdaki ek hedef bağlayıcıları için destek sunar:
- Amazon Redshift
- Amazon S3
- Google Cloud Storage
- Snowflake
Ayrıca bakınız: DDL geçmişi
PostgreSQL için Google Cloud SQL ile süper kullanıcı olmayan bir kullanıcı kullanma desteği
Bu sürümden itibaren, PostgreSQL için Google Cloud SQL'den çoğaltma yaparken artık süper kullanıcı olmayan bir hesap belirtmek mümkündür
Ayrıca bkz: Süper kullanıcı rolü olmadan bir hesabı kullanma
Yeni onaylanan platformlar ve sürücü sürümleri
-
Databricks hedefi
15.4 LTS
-
Oracle kaynağı ve hedefi
23ai
Bilgi notu
- Oracle 23ai kaynağı ve hedefi yalnızca Oracle Standard Edition ile onaylanmıştır.
- Oracle 23ai kaynağı yalnızca TDE şifrelemesi ile desteklenir.
-
Databricks sürücü güncellemesi
Verileri Databricks'e taşırken artık Simba Spark ODBC Driver 2.8.2 veya sonraki sürümü gereklidir. Müşteriler ya sürücü yükleme yardımcı programını çalıştırmalı ya da sürücüyü manuel olarak yüklemelidir.
Ayrıca bkz.: Sürücü kurulumu
Destek sonu
Aşağıdaki veritabanı sürümleri için destek kesilmiştir:
- PostgreSQL 12.x
- z/OS için IBM DB2: z/OS 2.4
- Databricks 9.1
Çözülen sorunlar
-
SAP HANA (Veritabanı) bağlayıcısı: __CT tablosu oluşturulamıyor
Çoğaltma modu Değişiklikleri Sakla olarak ayarlandığında ve tablo bir .INCLUDE sütunu içerdiğinde görev, hedefte __CT tablosunu oluşturmada başarısız oluyordu.
-
Göl yerleştirme görevi: Yanıltıcı hata
Azure Data Lake Storage parola anahtarının süresi dolduğunda görev başarısız olur ve "Veritabanı için lisans yok" hatası gösterilir.
-
Amazon S3 hedef bağlayıcısı: Eski dosyalar silinmiyor
Yeni bir görev çalıştırıldığında eski dosyalar silinmez. Bu, görevin yinelenen kayıtlar veya eşleşmeyen kayıtlar nedeniyle başarısız olmasına neden olabilir.
-
SAP HANA (Veritabanı) kaynağı: Kullanıcı tanımlı bir tablo nedeniyle bağlantı hatası
Çoğaltma için kullanıcı tanımlı bir tablo seçerken "özellik desteklenmiyor: kullanıcı tanımlı tür seçilemiyor" hatası oluşuyordu. Sorun, kullanıcı tanımlı tabloların (desteklenmeyen) tablo seçiciden hariç tutulmasıyla giderildi.
-
Microsoft Fabric hedef bağlayıcısı: Kurtarma hatası
CDC sırasında oluşan bir bağlantı hatasından kurtulduktan sonra bazen "Dönüştürme başarısız oldu" hatası oluşabiliyordu.
-
Databricks hedef bağlayıcısı: LOB desteği olmadan çalışırken CDC hatası
LOB desteği devre dışı bırakıldığında, CDC değişikliği __ct tablosuna eklemeye çalışırken "yeterli veri sütunu yok" hatası veriyordu. Bu hata, yerleştirme görevleri için kullanılabilen tek mod olan "Değişiklikleri Sakla" modunda çalışırken ortaya çıkıyordu.
-
MySQL kaynağından Snowflake hedefine: CDC hatası
CDC sırasında, mediumtext veri türüne sahip bir "NOT NULL" sütunu çoğaltılırken görev bazen aşağıdaki hatayla başarısız oluyordu:
A NOT NULL constraint violation occurred on LOB column from MySQL source
-
Microsoft Fabric hedef bağlayıcısı: Kesme hatası
Bir VARCHAR sütunu eklenirken aşağıdaki kesme hatası oluşuyordu:
String or binary data would be truncated while reading column of type 'VARCHAR'
Sorun, Microsoft Fabric'te VARCHAR sütunu çarpılarak çözüldü.
|
18 Eylül 2025 |
| 2024.5.54 |
Standart |
21 Ocak 2025 |
Yeni özellikler
Snowflake hedef bağlayıcısına, ek ODBC ve JDBC bağlantı özellikleri belirtme desteği eklendi.
Daha fazla bilgi için bkz. Ek bağlantı özellikleri.
Çözülen sorunlar
|
25 Ağustos 2025
|
|
2024.5.41
|
Düzeltme
|
19 Aralık 2024 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
Amazon S3, Google Cloud Storage ve Qlik Cloud hedefleri: Boş dize değerlerini alıntılama
Boş dizeler artık CSV dosyasında NULL değerlerden ayırt edilmeleri için tırnak içine alınacaktır.
-
Databricks hedefi: Veri uyuşmazlığı
Belirli senaryolarda kaynak ve hedef veriler arasında bir uyumsuzluk meydana gelebilir.
-
Databricks hedefi: LOB desteğinin devre dışı bırakılmasından kaynaklanan CDC hatası
Yerleştirme görevinde LOB desteğinin devre dışı bırakılması CDC'nin aşağıdaki başarısız olarak şu hatayı vermesine neden olur (alıntı):
Cannot write to '<name>__ct', not enough data columns
-
Microsoft Fabric hedefi: CDC hatasıyla sonuçlanan bağlantı hatası
Bir bağlantı hatasından kurtulduktan sonra değişiklikleri hedefe uygulamak bazen başarısız olarak "Dönüştürme başarısız oldu" hatası veriyordu.
|
21 Temmuz 2025
|
|
2024.5.35
|
Düzeltme
|
10 Aralık 2024 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
-
Microsoft Fabric hedefi: Veri türü dönüştürme sorunu
Bir depolama görevi sırasında, NVARCHAR(3500) veri türü, VARCHAR(8000) (izin verilen maksimum değer) yerine yanlışlıkla VARCHAR(10500) türüne dönüştürülerek bir hataya neden oluyordu.
-
LUW için IBM DB2 kaynağı: Kod sayfası 941 ile GRAPHIC veri türü desteği (Japonca)
Kaynak tablo, 941 (Japonca) kod sayfasına sahip bir GRAFİK veri türü içerdiğinde aşağıdaki hata meydana oluşuyordu (alıntı):
Unexpected CCSID '941' in column 'PNTNM'
|
21 Temmuz 2025
|
|
2024.5.32
|
Düzeltme
|
26 Kasım 2024 |
Workday Raporları kaynak bağlayıcısında kullanıcı adı ve parolayı güncelledikten ve ardından görevi yeniden yükledikten sonra, kimlik bilgileri doğru olsa bile "Geçersiz kullanıcı adı veya parola" hatası oluşuyordu. Bu sorun çözüldü.
|
21 Temmuz 2025
|
| 2024.5.31 |
Düzeltme
|
19 Kasım 2024 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
Güvenlik
Veri Hareketi ağ geçidi ile birlikte gelen Oracle Java Standard Edition 17.0.8 sürümünde bilinen birçok güvenlik açığı bulunmaktadır. Bu düzeltme 17.0.8'i 17.0.12 ile değiştirerek sorunları çözmektedir.
Salesforce kaynağı
CDC sırasında, her değişiklik için ilişkili _ct tablosuna (yalnızca bir değil) birden fazla INSERT işlemi eklenecektir. Bu, _ct tablosundaki kayıt sayısını önemli ölçüde artıracaktır.
|
21 Temmuz 2025
|
| 2024.5.28 |
Standart
|
12 Kasım 2024 |
Yakında yayınlanacak olan Şema Değişimi özelliği için gerekli işlevselliği sağlar. |
21 Temmuz 2025
|
| 2024.5.27 |
Düzeltme
|
5 Kasım 2024 |
Bu düzeltme aşağıdaki sorunları çözmektedir:
Snowflake JDBC Sürücüsü güvenlik açığı
14 Ağustos 2024 tarihinde Snowflake, bazıları önceki sürümleriyle kullanılan Snowflake JDBC sürücüleri >= 3.2.6 & <= 3.19.1 hakkında bir güvenlik uyarısıVeri Hareketi ağ geçidi yayınladı. Güvenlik açığı, şu anda sürücü yükleme yardımcı programıyla birlikte yüklenen sürüm olan Snowflake JDBC Driver 3.20'de düzeltilmiştir. Mevcut müşteriler, Sürücü kurulumu bölümünde açıklanan Sürücüyü güncelleme prosedürünü izleyerek ilk fırsatta sürücülerini yükseltmelidir.
Oracle kaynağı
- Redo olayı 11.22 kullanılırken, INSERT işlemlerinden önce sıkıştırılmamış bir sıkıştırılmış sayfada birden fazla INSERT işlenirken eksik INSERT işlemleri oluşuyordu.
- Nadiren, yineleme günlüğü kaydındaki DELETE olaylarının yanlış ayrıştırılması "Yineleme Günlüğü DELETE olayı bilinmeyen bir yapı içeriyor" uyarısı ve ardından çeşitli sorunlar oluşturuyordu.
SAP Extractor kaynağı
YAML dosyasındaki talimatlar, SAP Java Connector'ın doğru sürümünü yansıtacak şekilde güncellendi.
Snowflake hedefi
Snowflake hedefine bir proxy aracılığıyla bağlanmak için Veri Hareketi ağ geçidi kullanıldığında bağlantı başarısız oluyor ve aşağıdaki hatayı veriyordu:
500 Failed to connect to Data Movement Gateway
|
12 Mayıs 2025
|
| 2024.5.22 |
Düzeltme
|
15 Ekim 2024 |
Bu düzeltme, Tam Yük + CDC çoğaltma görevinde, CDC görevi için Veri görevi şu şekilde güncellendi: alanında, CDC zaman damgaları yerine Tam Yük zaman damgasını gösterilmesine neden olan bir sorunu çözmektedir. |
12 Mayıs 2025
|
| 2024.5.16 |
Düzeltme
|
8 Ekim 2024 |
Çözülen sorunlar
-
Oracle Kaynağı
- Redo olayı 11.22 kullanılırken birden fazla INSERT işleminde bazen eksik INSERT'ler oluşabiliyordu.
-
Oracle 19g'yi Temmuz 2024 düzeltmesine yükselttikten sonra, UPDATE işlemleri bazen yakalanamıyor ve aşağıdaki uyarı gösteriliyordu:
A compressed row cannot be parsed
-
Snowflake Hedefi
Görev ayarları, kontrol tablosu şemasını oluşturacak şekilde yapılandırıldığında, görev aşağıdaki hatayla başarısız oluyordu:
Failed to delete directory
-
Planlanan CDC
Bir görev periyodik olarak çalışacak şekilde zamanlandığında bazen başarısız oluyor ve aşağıdaki hatayı veriyordu:
The task stopped abnormally
-
Takılı kalmış dönüşüm ve depolama görevleri
Dönüşüm ve depolama görevleri bazen aşırı uzun süre Kuyruğa alındı durumunda kalabiliyordu.
-
Meta veri yöneticisi
Değişiklikleri Sakla çoğaltması ile use_manipulation_pk_for_apply özellik bayrağı kullanıldığında görevler başarısız oluyordu.
-
SaaS uygulama kaynaklarında sorunlara yol açan uzun süreli zaman aşımı
Dosyaları indirmek için belirteci kaybetmek gibi uzun süreli zaman aşımlarından kaynaklanan sorunları önlemek için S3 zaman aşımı 6 saate çıkarıldı.
|
12 Mayıs 2025
|
| 2024.5.14 |
Standart
|
11 Eylül 2024 |
Geliştirmeler
-
Snowflake hedef bağlayıcısına Anahtar Çifti kimlik doğrulaması eklendi
Anahtar/çift, hizmet hesaplarınızla Snowflake'e bağlanmak için kullanıcıdan/paroladan daha sağlam bir kimlik doğrulama yöntemi sağlar. Bu yaklaşım, veri yükleme (çoğaltma veya yerleştirme görevleri) ve dönüşümler gibi iş yükleri için önerilir.
-
Paralel olarak birden fazla tablodan meta veri alma desteği
Önceki sürümlerde, mevcut bir veri kümesindeki veya yeni eklenen bir veri kümesindeki meta verileri yenilemek bazen başarısız oluyor ve bir hata veriyordu. Bu geliştirme, meta verilerin birden fazla tablodan herhangi bir sorun olmadan paralel olarak alınabilmesini sağlar.
Çözülen sorunlar
-
DECIMAL veri türü Google BigQuery'de STRING ile yanlış eşlendi
Bir kaynak tablo DECIMAL veri türüne sahip örneğin, DECIMAL (38, 20) gibi bir sütun içerdiğinde, Google BigQuery'de depolama görevini hazırlamak başarısız oluyor ve aşağıdaki hata veriliyordu (alıntı):
Column <n> in <table name> has incompatible types: STRING, BIGNUMERIC at [93:1]
Sorun, Google BigQuery'de kaynak DECIMAL veri türü DECIMAL ile eşlenerek çözüldü.
-
Şema kuralı hatası
Bir veri görevinde mevcut bir şema kuralında değişiklik yaptıktan sonra aşağıdaki hata meydana gelir:
QRI SQL error not implemented
-
SAP aktarımından eksik /QTQVC/QRI tablosu
Bir SAP Uygulama kaynağına bağlanan bir yerleştirme görevi hazırlanırken, görev başarıyla tamamlanır, ancak repsrv.log günlük dosyasında aşağıdaki hata rapor edilir:
Invalid object name 'hk1./QTQVC/QRI'
|
12 Mayıs 2025
|
| 2024.5.7 |
Standart
|
6 Ağustos 2024 |
Geliştirmeler
-
Tüm tabloları kullanımdan kaldırıp yeniden oluşturmaya ihtiyaç duymadan çoğaltma ve göl yerleştirme görevlerinde meta veri değişiklikleri desteği
Daha önce bir meta veri değişikliği gerçekleştiğinde meta veri değişikliği tüm tabloları etkilemese bile tüm tablolar kullanımdan kaldırılıp yeniden oluşturuluyordu. Artık yalnızca etkilenen tablolar kullanımdan kaldırılacak ve yeniden oluşturulacak, bu sayede performans artırılacak.
-
Çoğaltma görevlerinde yeni tabloları otomatik yükleme desteği
Desen ekle ile eşleşen çoğaltma veri görevi sırasında kaynak veritabanında oluşturulan tablolar artık CDC (Değişiklik verisi yakalama) sırasında otomatik olarak yakalanacak.
-
Microsoft SQL Server (MS-CDC) kaynak geliştirmeleri
-
Zaman damgasını ve işlem kimliğini koruma
Daha önce Microsoft SQL Server'dan (MS-CDC) birde fazla işlem okurken Qlik Talend Data Integration yalnızca ilk işleme ait zaman damgasını ve işlem kimliğini koruyordu. Hedefte bu, kayıtlar tek bir işlemin parçasıymış gibi bir görünüm veriyordu. Artık Qlik Talend Data Integration, her bir kayıt için orijinal işlem kimliğini ve zaman damgasını koruyacak. Bu, Değişiklik tablolarında İşlem Kimliği ve Zaman Damgası başlık sütunlarından faydalanmak isteyen müşteriler için faydalıdır.
-
İşlem kimliği bayt sırası
Daha önce işlem kimliğindeki baytlar ters sırayla kodlanıyordu. Bu sürümden itibaren baytlar doğru sırada kodlanacak. Mevcut davranışı korumayı tercih eden Bilgi Müşterileri bunu dahili parametreler kullanarak yapabilir. Ayrıntılar için lütfen Qlik Destek ekibiyle iletişime geçin.
-
MySQL ile SHA-2 çıkarılabilir kimlik doğrulamasını önbelleğe alma desteği
Qlik Talend Data Integration artık şirket içinde veya bulutta MySQL kaynakları ya da hedefleri ile çalışırken SHA-2 çıkarılabilir kimlik doğrulamasını (caching_sha2_password) önbelleğe almayı destekliyor. Önceki sürümlerde yalnızca Yerel Çıkarılabilir Kimlik Doğrulaması (mysql_native_password) destekleniyordu.
-
Amazon Redshift veri türü eşlemesindeki değişiklikler
BYTES ve BLOB veri türleri artık VARCHAR yerine Amazon Redshift'te VARBYTE ile eşlenecektir.
Yeni onaylanan platformlar, uç noktaları ve sürümler
-
Veri kaynakları
-
PostgreSQL 16.x
- MySQL 8.1
- z/OS için IBM DB2 3.1
-
Hedef platformlar
- PostgreSQL 16.x
- MySQL 8.1
- Databricks 14.3 LTS
-
Sürücüler
- SQL Server ODBC Sürücüsü 18.3
Destek sonu
Aşağıdaki veritabanı sürümleri için destek kesilmiştir:
- Oracle 19.x sürümünden eski tüm Oracle sürümleri ve sürücüleri
- Microsoft SQL Server 2014
- MySQL 5.7
- PostgreSQL 11
- LUW için IBM DB2 10.5
- z/OS: z/OS 2.3 için IBM DB2
Çözülen sorunlar
-
SAP (Uygulama) kaynağı
Yakalanan küme belgesi değişikliği, yakalanan tüm tablolarındaki satırların hepsini sildiğinde eksik DELETE işlemi ve gereksiz onay mesajları ile karşılaşılır.
-
Güvenlik açıkları
Java için Microsoft Kimlik Doğrulama Kitaplığı (MSAL4J) ve Bouncy Castle, bilinen güvenlik açıkları olmayan sürümlere güncellendi.
-
Snowflake hedefi
- Snowflake dahili depolamasını kullanırken görev bazen başarısız olur.
- Hedef şema adı Japon Katakana olduğunda görev başarısız oluyordu.
-
Oracle kaynağı
Bir görevi Oracle kaynağıyla sürdürürken görev, uygun bir hatayla başarısız olmak yerine silinen bir Arşivlenen Yineleme Günlüğünü beklemeye devam ediyordu.
|
11 Mart 2025
|
| 2023.11.23 |
Standart
|
26 Haziran 2024 |
Geliştirmeler
Çözülen sorunlar
-
Veri kümesini yeniden adlandır kuralında (tablo adını şema adıyla birleştiren) bir değişiklik yapıldıktan ve yerleştirme görevine bir Görünüm eklendikten sonra, Hazırla işlemi aşağıdaki hatayla başarısız oluyordu:
QRI SQL error not implemented.
- java_file_factory bileşenini bilinen güvenlik açığı olmayan bir sürüme güncelledik.
- org.postgresql:postgresql bilinen herhangi bir güvenlik açığı içermeyen bir sürüme güncellendi.
- SQL Server'a veri taşırken dizin adları 128 karakteri aştığında Hazırla işlemi başarısız oluyordu. Sorun, daha kısa dizin adları oluşturma mantığı değiştirilerek çözüldü.
-
SQL Server'dan veri taşırken tablo tanımlarındaki eksik bir sütun adı, repsrv.log dosyasında aşağıdaki mesajla sonsuz bir bildirim döngüsüne neden olacaktır:
mssql_resolve_sqlserver_table_column_attributes(...) failed to find column
|
6 Şubat 2025
|
| 2023.11.11 |
Standart
|
21 Mayıs 2024 |
Geliştirmeler
-
Paralel meta veri alımı
Birden fazla tablo için eş zamanlı olarak meta veri alma desteği eklendi.
-
İyileştirilen izleme performansı
Yerleştirme ve çoğaltma görevleri için izleme bilgileri (60 saniyede bir yerine) artık 10 saniyede bir güncellenerek görevlerin mevcut durumlarıyla ilgili daha hassas bir gösterge sağlatacak.
-
Yeni bölge desteği
Japonya artık Qlik Cloud kiracı bölgesi olarak desteklenmektedir.
Çözülen sorunlar
- Veri ağ geçidi ile Qlik Cloud arasındaki yeniden deneme aralığı sürekli olarak artıyor, ancak hiçbir zaman sıfırlanmıyordu (hizmet yeniden başlatılmadığı sürece).
- Bir SaaS uygulaması kaynağından veri taşırken tablolar bazen yeniden yükleme sırasında hata durumuna giriyordu.
-
MySQL kaynağı içeren görevler bazen CDC sırasında aşağıdaki hatayı vererek başarısız oluyordu:
Read next binary log event failed; mariadb_rpl_fetch error 0
Error reading binary log.
- Daha önce CDC denetim olayları yalnızca yerleştirme görevleri için günlüğe kaydediliyordu. Artık çoğaltma görevleri için de kaydedilecekler.
- SQL Server'dan (MS-CDC) veri taşırken çok sayıda tablo içeren görevlerin başlaması bazen birkaç saat sürüyordu.
-
Kaynak tablosunda CLOB sütunları olduğunda ve "LOB boyutunu sınırlama" değeri 10240'ı aştığında Snowflake'e çoğaltma işlemi aşağıdaki hatayı vererek başarısız oluyordu:
Invalid character length: 0
|
26 Aralık 2024 |
| 2023.11.4 |
Standart
|
12 Mart 2024 |
Veri Hareketi ağ geçidi uygulamasını Red Hat 9.x üzerine yükleme desteği
Müşteriler artık Veri Hareketi ağ geçidi uygulamasını Red Hat 9.x veya karşılık gelen ve uyumlu Linux dağıtımına yükleyebilir.
Veri Hareketi ağ geçidi ayarlama
Veri Hareketi ağ geçidi hizmet komutlarındaki değişiklikler
Veri Hareketi ağ geçidi hizmetinin durumunu durdurma, başlatma ve kontrol etme komutları değişti.
Veri Hareketi ağ geçidi hizmet komutları
Amazon Redshift veri türü eşlemesindeki değişiklikler
- Amazon Redshift'te VARCHAR(1) ile eşlenen BOOLEAN veri türü artık BOOLEAN ile eşlenecektir.
- Amazon Redshift'te VARCHAR(1) ile eşlenen BYTES ve BLOB veri türleri artık VARBINARY (uzunluk) ile eşlenecektir.
Yeni desteklenen veritabanları, veritabanı sürümleri ve sürücü sürümleri
Bu bölümde, yeni desteklenen veritabanları, veritabanı sürümleri ve sürücü sürümleri listelenmektedir.
-
Yeni desteklenen veri kaynağı sürümleri ve yayımları
Aşağıdaki veri kaynağı sürümleri artık desteklenmektedir:
- Azure Database for MySQL - Flexible Server (MySQL kaynak bağlayıcısı üzerinden desteklenir)
- MariaDB 10.4 - 10.11 (önceki 10.4 ve 10.5)
-
Yeni desteklenen hedef veri platformları ve yayımları
Aşağıdaki veri hedefi sürümleri artık desteklenmektedir:
- Azure Database for MySQL - Flexible Server (MySQL hedef bağlayıcısı üzerinden desteklenir)
- Databricks: Databricks 13.3 LTS ve Serverless SQL Warehouse
-
Yeni desteklenen SAP HANA sürücü sürümü
SAP HANA kaynağı olan ve Veri Hareketi ağ geçidi uygulamasını Red Hat Linux 9.x üzerine yüklemek isteyen müşteriler, SAP HANA ODBC 64 bit Sürücü Sürümü 2.0.19 veya daha yeni sürümlerini yüklemelidir.
Destek sonu veritabanı sürümleri
Bu bölümde destek sonu veritabanı sürümleri hakkında bilgi verilmektedir.
Çözülen sorunlar
- Sunucu şifresi sağlamadan Veri Hareketi ağ geçidi yüklemek, kiracı ve proxy URL'lerinin bir komutta yapılandırılmasına izin vermeyecektir.
- Bir Salesforce (SaaS uygulaması) veri kaynağından veri taşımak, çok sayıda gereksiz uyarı oluşturarak veri yükleme performansını olumsuz etkileyecektir.
- Bir SaaS uygulaması veri kaynağı için değişiklikler alınırken tablolardan birine ilişkin değişiklikleri alma sırasında bir hata oluşursa ilgili tablo askıya alınıp işlem veri hattından kaldırılırdı. Artık bir hatayla karşılaşıldığında görev, tabloyu askıya almadan önce değişiklikleri almayı üç kez deneyecektir.
|
21 Kasım 2024 |
| 2023.5.16 |
Standart
|
9 Ocak 2024 |
Çoğaltma projeleri için yeni veri gölü hedefleri
Amazon S3'e ek olarak Qlik Cloud Data Integrarion'daki Replication projesinde desteklenen hedefleri genişletmeye devam ediyoruz. Artık Parquet, JSON veya CSV dosya formatlarında veri gölü teslimi için Azure Data Lake Storage (ADLS) ve Google Cloud Storage'ı (GCS) seçebilirsiniz.
Çözülen sorunlar:
|
12 Eylül 2024
|
| 2023.5.15 |
Standart
|
12 Aralık 2023 |
Veri işlem hattı hedefi olarak Microsoft Fabric desteği
Microsoft Fabric, veri işlem hattı projelerinde hedef olarak kullanılabilen veri depolarının sürekli uzayan listesine katılmıştır.
Çözülen sorunlar:
Sürücü yükleme yardımcı programındkai Snowflake sürücü sürümü güncellendi.
|
9 Temmuz 2024
|
| 2023.5.10 |
Standart
|
31 Ekim 2023 |
Özel Bağlantılar için Genişletilmiş Destek
A private connection cVeri trafiğinizin güvenli ve uyumlu kalmasını sağlamak için özel bir bağlantı kullanılabilir.an be used to ensure your data traffic remains secure and compliant. Gelen güvenlik duvarı bağlantı noktalarını, proxy cihazlarını veya yönlendirme tablolarını açmaya gerek kalmadan VPC'nizin (Sanal Özel Bulut) hem ağ yönetimini hem de güvenliğini basitleştirir. Qlik Cloud Veri Entegrasyonu; Snowflake, Microsoft SQL Server ve Amazon S3 veri hattı hedeflerine özel bağlantıları zaten desteklemektedir. Bu sürümle birlikte müşteriler, verileri Databricks, Microsoft Azure Synapse, Google BigQuery ve Amazon Redshift'e taşırken özel bağlantıları da kullanabilecek.
PostgreSQL tabanlı veri kaynakları
- PostgreSQL veri kaynağı için AWS Aurora Cloud - Süper kullanıcı olmayan rol desteği: PostgreSQL bağlayıcısında belirtilen kullanıcının, PostgreSQL için AWS Aurora Cloud veri kaynağından veri taşımak için artık süper kullanıcı rolüne sahip olması gerekmiyor. Bu, özellikle ayrıcalıklı olmayan kullanıcılara süper kullanıcı erişimi vermelerini engelleyen kurumsal güvenlik politikalarına sahip kuruluşlar için kullanışlıdır.
Microsoft Azure SQL (MS-CDC) veri kaynağı: Coğrafi çoğaltma desteği
Microsoft Azure SQL (MS-CDC) veri kaynağından veri taşıyan müşteriler artık bir Coğrafi Çoğaltma veritabanı kullanabilir.
Oracle veri kaynağı: HSM (Donanım Güvenlik Modülü) desteği
Qlik Cloud Veri Entegrasyonu artık CDC sırasında Oracle şifrelenmiş tablo alanlarından ve şifrelenmiş sütunlardan veri okumayı desteklemektedir.
Yeni bölge desteği
Qlik Cloud Veri Entegrasyonu artık Almanya ve Birleşik Krallık bölgelerindeki kiracıları destekliyor.
Yeni desteklenen sürümler ve üçüncü taraf yazılımlar
Bu bölümde yeni desteklenen veritabanı ve sürücü sürümleri listelenmektedir.
Microsoft SQL Server sürücüsü - Zorunlu yükseltme
Verileri Microsoft SQL Server'a veya Microsoft SQL Server'dan taşıyan müşterilerin SQL Server ODBC sürücü sürümlerini 18.x veya daha yeni bir sürüme yükseltmeleri gerekir. SQL Server ODBC Driver 17.x'i kullanmaya devam etmek veri hatalarına neden olabilir. Sürücünün yükseltilmesi, sürücü yükleme yardımcı programı kullanılarak ya da manuel olarak yapılabilir. Talimatlar için Sürücü kurulumu bölümüne bakın.
Destek sonu veritabanı sürümleri
Bu bölümde destek sonu veritabanı sürümleri hakkında bilgi verilmektedir.
|
12 Haziran 2024
|
|
2022.11.74
|
Standart
|
15 Ağustos 2023
|
Çoğaltma desteği
Hızlı inovasyon ve benimseme sağlayan bulut öncelikli bir yaklaşım benimsiyoruz. Ancak bu, yalnızca bulutta çalıştığımız sonucunu doğurmaz. As part of our continued commitment to improving the long-term value for our customers, we are pleased to announce the release of a new use case for Replication when creating data projects. Yeni Çoğaltma kullanım durumu, Veri Ambarı modernizasyonu gibi tüm veri entegrasyonu ihtiyaçlarınız için veri işlem hatları oluşturmaya yönelik mevcut yeteneğe ektir.
Çoğaltma projesi, desteklenen veri kaynaklarından desteklenen bir hedefe gerçek zamanlı veri çoğaltmayı destekler.
Bu son sürümden başlayarak, verilerin gerçek zamanlı olarak çoğaltılmasını destekleyen ilk hedef Microsoft SQL Server'dır. Şirket içi Microsoft SQL Server desteğine ek olarak, aşağıdaki bulut sağlayıcıları da desteklenmektedir:
- Şirket içinde
- Amazon RDS
- Google Cloud
- Microsoft Azure (Microsoft Azure Yönetilen Örneği ve Microsoft Azure Veritabanı)
Microsoft Azure Synapse Analytics hedefi - Gerekli sürücü yükseltmesi
Verileri Microsoft Azure Synapse Analytics'e taşıyan müşterilerin SQL Server ODBC sürücü sürümlerini 18.x veya daha yeni bir sürüme yükseltmeleri gerekir. SQL Server ODBC Driver 17.x'i kullanmaya devam etmek veri hatalarına neden olabilir. Sürücünün yükseltilmesi, sürücü yükleme yardımcı programı kullanılarak ya da manuel olarak yapılabilir. Talimatlar için Sürücü kurulumu bölümüne bakın.
SaaS uygulama kaynakları için yeni "Kaynaktan veri yükle" seçeneği
Müşterilerin Tam Yükleme sırasında önbelleğe alınan verileri kullanmak yerine verilerini doğrudan kaynaktan okumalarına olanak tanıyan yeni bir Kaynaktan dosya yükle seçeneği sunuldu.
Kullanım durumları da dahil olmak üzere bu seçenek hakkında daha fazla bilgi için bk. Yerleştirme ayarları.
CA sertifikaları güncellendi
Veri Hareketi ağ geçidi 2022.11.74, Qlik Cloud kiracısının kimlik doğrulaması için gerekli olan güncellenmiş CA sertifikalarını içerir. Güncellenen CA sertifikaları İrlanda ve Frankfurt bölgeleri için de destek sağlamaktadır. Bu nedenle, İrlanda veya Frankfurt'ta Qlik Cloud kiracısı olan ve Qlik Cloud Veri Entegrasyonu'nu kullanmak isteyen müşteriler bu sürüme yükseltmelidir.
Çözülen sorun
Oracle kaynağından veri alan görevler, geniş bir tablo kullanılmayan veya desteklenmeyen sütunlar ya da çoğaltılmayan LOB sütunları içerdiğinde bazen başarısız oluyordu.
|
31 Nisan 2024
|
|
2022.11.70
|
Standart
|
28 Haziran 2023
|
SAP istemcileri için sürücü yükleme yardımcı programı geliştirildi
Önceki sürümlerde, müşterilerin SAP istemcilerini yüklerken "source arep_login.sh" komutunu çalıştırması gerekiyordu. Bu sürümden itibaren artık bu komutu çalıştırmaya gerek kalmıyor.
CA sertifikaları güncellendi
Bu sürüm, Qlik Cloud kiracısının kimlik doğrulaması için gerekli olan güncellenmiş CA sertifikalarını içerir.
Çözülen sorunlar
|
15 Şubat 2024 |
|
2022.11.63
|
Standart
|
2 Mayıs 2023
|
Sürücü yükleme yardımcı programı
Bu sürüm, sürücüleri manuel olarak yükleme ve yapılandırma gereksinimini ortadan kaldıran bir sürücü yükleme yardımcı programı sunar. Yeni yardımcı program, kullanıcı hatası olasılığını büyük oranda azaltırken yükleme işlemini kısaltır. Yardımcı program çalıştırıldığında, gerekli sürücü otomatik olarak indirilir (mümkünse) ve yüklenir. Sürücü indirilemezse (ör. DB2 sürücüleri oturum açmayı gerektirir), yapmanız gereken tek şey sürücüyü yüklemek, Veri Hareketi ağ geçidi makinesindeki özel bir klasöre kopyalamak ve yardımcı programı çalıştırmaktır.
Bir PostgreSQL sürücüsünü yüklemek üzere sürücü yükleme yardımcı programını kullanmaya ilişkin bir örnek için bkz. Ön koşullar
Snowflake bulut veri platformu
Snowflake bağlayıcısı artık 4 bit emoji karakterlerini destekliyor.
Azure Database for PostgreSQL - Flexible Server
PostgreSQL bağlayıcısı artık Azure Database for PostgreSQL - Flexible Server'dan verileri taşımayı destekleyebiliyor.
Veri kaynağı olarak PostgreSQL için Cloud SQL desteği
PostgreSQL bağlayıcısı artık PostgreSQL için Cloud SQL'den veri taşıyabilir.
Yeni desteklenen veri kaynağı sürümleri
Bu sürüm, aşağıdaki yeni veri kaynağı sürümleri için destek sunar:
- PostgreSQL 14
- DB2 (IBM DB2 for z/OS için) 12.1
- IBM DB2 for z/OS 2.5
Yeni desteklenen bulut veri platformu sürümleri
Databricks 11.3 LTS
Aşağıdaki veri kaynağı sürümleri için destek kaldırıldı
Aşağıdaki veri kaynağı sürümleri artık desteklenmiyor:
- DB2 (IBM DB2 for z/OS için) 11
- PostgreSQL 9.6
- Microsoft SQL Server 2012
- MariaDB 10.2
Çözülen sorunlar
Bu sürüm, aşağıdaki sorunları çözer:
- Oracle veri kaynağı: Bir görevi durdurup devam ettirirken, görev bazen "Bağlamda klasör konumu ayarlanamadı" hatasıyla başarısız oluyordu.
- SAP Uygulaması kaynağı: Değişiklikler, yerleştirme görevi sırasında yakalanamıyordu.
|
28 Aralık 2023
|
|
2022.5.13
|
Standart
|
19 Ekim 2022
|
İlk yayınlanma
|
2 Kasım 2023
|