升级和卸载数据移动网关 | Qlik Cloud帮助
跳到主要内容 跳到补充内容

升级和卸载数据移动网关

上次更新日期:2026/9/30

本主题介绍如何升级或卸载您的 数据移动网关 安装。它还提供了一个表,列出了每个 数据移动网关 版本中引入的更改。

升级程序

要验证您当前的版本,请转到 管理 > 数据网关 并检查与您的 数据移动网关 对应的版本列。

如果有可用的新版本,则将在版本号后面添加 !。您可以将鼠标悬停在 信息 上方以获取更多信息。

信息注释版本有时会以补丁形式发布。这个!仅当有新的标准版本可用时才会显示(与补丁版本相反)。要了解某个版本是补丁版本还是标准版本,请参阅下面 版本历史表中的数据移动网关类型列。

如果不支持已安装的网关版本,则状态将为停用,并且需要升级才能激活网关。

每当有新版本的 数据移动网关 rpm 可用时,您都应该从 Administration 下载并升级现有安装。

为此:

  1. 单击网关上的 更多,然后单击升级,下载新版本。

    确认客户协议,然后继续下载 RPM。

  2. 打开 shell 提示符并将工作目录更改为包含 RPM 文件的目录:
  3. 然后运行以下命令:

    语法:

    rpm -U <rpm name>

    示例:

    sudo rpm -U qlik-data-gateway-data-movement.rpm

  4. 启动 数据移动网关 服务:

    sudo systemctl start repagent

  5. 可选择确认服务已启动:

    sudo systemctl status repagent

    状态应如下所示:

    Active: active (running) since <timestamp> ago

数据移动网关版本历史记录

版本

类型

发布日期

重大变化

支持日期结束

2026.5.20 标准 2026年9月8日

已解决的问题

  • 聚合部分满载的统计数据

  • Databricks Lakehouse (Delta) / Databricks (云存储) – ODBC 测试连接通过代理(用户名/密码)在所有预生产环境中失败

  • Databricks Lakehouse (Delta) 卷 - 删除目录失败,由于 "CLOUD_FILE_NOT_FOUND" 错误

  • 对于应用程序模式,仅全量加载任务应启用 DDL

  • SAP 应用程序目标在将数据加载到 Snowflake 数据格式时,会在数据中创建特殊字符

  • 与源 SAP 提取器一起,全量加载 S3 目标正在准备复制记录,这些记录将存在于相同或不同的 JSON 文件中。

  • 表挂起时缺少相关错误消息

  • OData 目标 SAP ODP 作业已完成,但全量加载未完成

  • 支持 SQL Server 2012 (跳过始终加密检查)

  • 将 LOCAL INFILE 限制为仅加载模式,适用于 MySQL/MemSQL 目标 (LFI 修复)

  • SAPDB 源 – 错误数据(缺失数据、重复数据)可能发生在某个表上,当另一个表收到 LOAD TABLE 命令时。

  • 支持 Databricks Delta 中数据类型长度的修改

  • BigQuery 流式传输 - 连接字符时,STRING 数据类型字段中的空值被截断

  • PostgreSQL LOB 查找失败,如果主键包含 TIMESTAMPTZ

  • 当 SQL Server 延迟构造函数中的 DBCC 调用返回可恢复错误时,我们必须重新连接并重试一次,因为可能出现超时。

  • HANA 源,目标 DECIMAL 数据类型丢失小数位数导致数据不匹配

  • SAP ODP 源在 2025.11 版本中,如果表选择模式使用了 INCLUDE 选项。完整加载需要更长时间才能完成。

  • SQL Server 始终加密:由于 CSV 文件损坏,表在任何任务中针对任何目标时进入暂停状态

  • SAP HANA 回滚到保存点支持

  • 任务在使用 Azure Active Directory 服务主体身份验证时,因令牌过期问题而失败

  • 运行资产失败。错误消息应在日志中显示缺失的表。

  • Redshift - 列长度不支持

  • 触发器正在被错误地丢弃

  • Oracle 对压缩行执行更新操作时,可能不会将主键列值包含到 After Image 中,从而导致目标中使用 NULL 值

  • 登陆任务 - 如果从目标数据库手动删除了同一张表,则删除并重新添加该表不会创建 _ct 表

  • 在 S3 Parquet 文件中为日期时间列值追加 UTC 指示符

  • LOB查找错误后,目标分离/重新附加时记录缺失

  • DB2 Z/os 是绿色的,但没有进展

  • Databricks Delta 将字符串中的二进制零替换为空格

  • alternateBackupFolderTransportCommand 未保留大小写

  • SAP HANA 全记录模式 - 如果 QTREP/TRAN_LOG 填满,触发器可能会失败

  • 无法在 Databricks Lakehouse (Delta) 上对 SAP VBRP 表使用并行加载

  • Databricks (云存储) 将字符串中的二进制零替换为空格

  • SAPDB - 针对某些事件,表的新实例的主键中存在 NULL 值

  • 当 SAP 和后端表中的列顺序不同时,LOB 查找崩溃

  • 将 csv 转换为 parquet 文件时出错

  • 使用 Oracle Standby,跳过了在线重做日志序列,导致数据丢失

  • SAPDB - 在所需的元数据尚未读取时,LOB 查找导致任务崩溃

  • Oracle 从在线重做日志读取,但重做尚未准备就绪。

  • Oracle 26ai + TDE 加密 - 加密的 CDC 更改的 REDO 日志解析错误

  • 添加加拿大地区支持

  • 支持 https 代理连接

  • 使用托管网关时,诊断数据包仅包含最新的日志

  • SQL Server (MS-CDC) 源 – 当配置了列重命名转换时,针对几何列生成了无效的更改查询

  • Stitch 源 – 更改跟踪表文件在满负载启动或结束时未关闭

  • Teradata 源和目标 – 驱动程序设置文档已更新

  • 安全性 – netty-codec-http 已更新至 4.1.136。最终

  • 安全性 – lz4-java 更新至 1.11.1

  • 安全性 – 已将 jackson-core 更新至 2.18.8

  • 安全 – 更新了 jetty-security 到 12.1.10

  • 安全 – 更新了 SAP ODP 和 Salesforce 源端点中的 Log4j

  • 支持 fullLoadPartial 的错误消息

  • Snowflake 目标任务显示了许多“对象 '<>."attrep_status"' 不存在或未授权。”错误。

已确定下一个版本的发布时间。
2025.11.66 标准 2026年6月30日
警告注释自 2026 年 7 月 1 日起,使用 数据移动网关 的客户如果希望使用 SaaS 应用程序连接器创建新任务,则必须升级到 Data Movement 2025.11.66(此版本)或更高版本。

已解决的问题

  • 升级到 数据移动网关 2025.11.40 后,对 attrep_history 控制表执行的 INSERT 操作导致了语法错误。

  • 在启用了压缩功能的 Oracle 自治数据库环境中检索表元数据时,表选择 get_table_list 失败,并出现 Oracle 错误代码 '1406'。

  • 改进了错误消息,以便在登陆任务因表缺失而运行失败时,在日志中显示缺失的表名。

  • 在登陆任务中移除并重新添加数据集,如果该数据集已从目标数据库中手动删除,则不再创建变更跟踪表。

  • 添加了对 SQL Server 2012 的支持(通过使用内部属性),方法是跳过 Always-Encrypted 验证检查,该检查在 2016 之前的 SQL Server 版本中不受支持。

  • 修复了一个问题,即在使用Always Encrypted列时,由于损坏的CSV文件处理,表在任何任务到任何目标的过程中都会进入暂停状态。

  • 已更新 libcurl 库以解决 CVE-2025-14819 漏洞。

  • 修复了一个问题,即当数据库名称包含连字符时,注册数据的任务准备会失败。

  • 修复了在将大型数据集加载到 Snowflake 时,在“COPY INTO”步骤期间发生的超时错误。

2027年3月1日
2025.11.40 标准 2026年4月29日

为与 Databricks 保持一致,用于 Databricks 连接器的驱动程序已经重新命名。

警告注释为了防止任务失败,使用 Databricks 连接器的客户必须升级其驱动程序。您可使用驱动程序设置实用程序(推荐)自动执行此操作,也可以手动执行。有关说明,请参阅驱动程序设置。如果您选择手动安装驱动程序,请务必按照说明来编辑 odbcinst.ini 文件。

此版本引入了对以下驱动程序版本的支持:

  • Snowflake:Snowflake ODBC 驱动程序 3.15.0(64 位)

  • Google BigQuery:Simba ODBC 驱动程序版本 3.1.6.1026

从该版本开始,以下数据类型将映射至 Databricks 原生 VARIANT 数据类型:

  • STRING

  • WSTRING

  • NCLOB

  • CLOB

信息注释需要 Databricks Runtime 15.4 或者更高版本

已解决的问题

  • 恢复任务后,从包含二进制十进制列的表中捕获更改会导致任务崩溃。

  • 恢复一个在停止前一分钟内未捕获任何更改的任务后,将不会捕获任何更改。

  • 当 SSH 存在问题时,点击 SSH 连接器中的“测试连接”不会返回与 SSH 连接相关的错误。

  • 当使用 Snowpipe Streaming 作为加载方法时,加载非常大的表会消耗过多的内存,这最终会导致任务崩溃并进入加载和崩溃的循环。

  • 当指定一个备用备份文件夹但其中不包含所需日志时,任务会停止并显示一条不明确的消息,而不是发出警告并继续执行。

  • 由于已安装版本存在已知漏洞,org.apache.logging.log4j:log4j-core 组件已升级到 2.25.3。

  • SAP ODP 过滤器在仅 CDC 模式下运行的提取器上定义时,不会传递给 SAP。

  • 在单个列上定义多个筛选范围将导致满负载失败。

2026年12月30日
2025.11.23 标准 2026 年 3 月 11 日

并行加载功能现在支持 Databricks 目标。

并行复制数据集片段

attrep_ddl_history(DDL 历史)控制表包含在复制到目标期间源上发生的 DDL 更改历史记录。

现在支持以下目标端点:

  • Google BigQuery
  • Google Cloud Alloy DB for PostgreSQL
  • Google Cloud SQL for PostgreSQL
  • PostgreSQL(内部)

DDL 历史

当使用 Parquet 格式的更改表格时,标头列 [header]__change_mask 现在将零填充到左侧(而不是右侧),以符合小端字节序规则,即以反向顺序存储字节。

受影响的目标端点:

  • Amazon S3

  • Google Cloud Storage

更改表格

  • Kafka 目标:4.0.x

  • IBM z/OS 源:3.2

  • Microsoft ODBC 驱动程序 18.5
  • MySQL 8.4

已停止支持 Microsoft Azure Database for MySQL 及 Microsoft Azure Database for PostgreSQL(已由 Microsoft 正式停用)。

  • Databricks 目标:10.4 LTS 和 11.3 LTS

  • MariaDB 源和目标:10.5

  • PostgreSQL 源和目标:13.x

  • MySQL 源和目标: 8.1

  • Microsoft ODBC 驱动程序 18.3

已解决的问题

  • 配置为使用具有生成自提交事件的后端进程的 SAP (应用程序) 源的任务,有时会在重新加载表后崩溃。

  • 在同构复制中,当在“事务性应用”模式或切换到一对一模式的“批优化应用”模式下工作时,如果 DATETIME 列是目标上主键的一部分,则会发生“0 行受影响”错误。

  • 当表包含长原始列且最大 LOB 大小大于或等于 64K 时,Oracle 任务在完全加载中崩溃。

  • 在表重新加载期间,长期运行的 SAP CDC 作业有时会被取消。这将导致卸载从未完成的可恢复错误状态。

  • 由于存在已知漏洞,以下组件已升级:

    • JRE 从 17.0.17 升级到 17.0.18
    • org.eclispe.jetty:jetty-io 从 11.0.25 升级到 11.0.26

    • org.apache.logging.log4j:log4j-core 从 2.23.1 升级到 2.25.3

  • 当为表定义了筛选器时,CDC 期间会发生以下错误:

    Invalid value for parameter "I_DIMNAME"

  • 如果任务在其中一个表处于加载状态时停止并恢复,Delta 将停止工作。

    • 在完全加载期间,连接到 S3 暂存文件夹时,任务有时会因以下错误而失败:

      Unable to execute HTTP request: Connect to s3.amazonaws.com:443

      通过在首次连接不成功时,为连接到 S3 文件夹实施多重重试机制,解决了此问题。

    • 即使架构已存在,也需要 CREATE SCHEMA 权限。

  • 当任务设置中 LOB 大小设置为无限制时,LOB 列有时会发生数据丢失,并且在 CDC 期间会发生不正确的数据复制。

  • 将 CSV 文件加载到净更改表失败时,会返回一个可恢复错误(导致无限循环),而不是切换到逐个应用。

  • 当源和目标的架构位于同一 MySQL 实例中,并且复制包含控制表时,任务有时会因“Process crashed with signal 11”错误而崩溃。

  • 在 CDC 期间,任务有时会反复读取相同的 WAL 条目,导致没有数据被捕获。

    • 当解压缩包含加密块的事务日志时,会发生错误。在此类情况下,通过保持日志压缩状态解决了该问题。

    • 使用备用备份文件夹时,由于对现有文件进行了不必要的验证检查,会显示冗余错误。

    • 任务有时会在调用 DBCC Lookup 后崩溃。

2026 年 10 月 29 日
2025.5.41 补丁 2026 年 2 月 15 日 修复了监视器中未显示 CDC 状态的问题。 2026年9月11日
2025.5.40 标准 2026 年 2 月 10 日

数据移动网关的新版本引入了对Kafka目标连接器的支持。轻松地将数据从任何受支持的源直接复制到本地Kafka或Amazon MSK,确保可靠、容错的传输,使您的应用程序保持敏捷和信息畅通。无论您是维护系统之间的数据一致性还是为分析提供支持,此连接器都能以最少的设置实现低延迟复制。

有关更多信息,请参阅Kafka 目标

  • 当将数据集从一个 MySQL 模式复制到在同一 MySQL 服务器实例上运行的不同 MySQL 模式,并且在复制中包含一个控制表时,CDC 将会因以下错误而失败:

    Process crashed with signal 11

  • 在表仍处于满负载状态时恢复任务导致提取作业失败,并且表被暂停。

2026年9月11日
2025.5.32 补丁 2026年1月13日
  • 将 CSV 文件加载到 Qlik 净更改表失败时,会返回一个可恢复错误(导致无限循环),而不是切换到逐个应用。

  • 在完全加载期间,任务有时会因连接被 Amazon 主动拒绝而失败,并显示以下错误:

    Unable to execute HTTP request: Connect to s3.amazonaws.com:443

    问题已通过实施重试机制解决,该机制在错误发生前最多重试三次。

  • 当解压缩包含加密块的事务日志时,会发生错误。在此类情况下,通过保持日志压缩状态解决了该问题。

  • 在更改源后恢复 CDC 任务时,任务有时会因以下错误而失败:

    Cannot change column title from type VARCHAR(8000) to VARCHAR(3) because reducing the byte-length of a varchar is not supported.

  • 使用备用备份文件夹时,由于对现有文件进行了不必要的验证检查,会显示冗余错误。

2026年8月10日
2025.5.22 标准 2025 年 11 月 25 日

从该版本开始,数据任务将在目标 Databricks Delta 表上创建主键,使用的是 RELY 关键字。尽管 Databricks 不强制执行主键约束,但带有 RELY 关键字的主键被假定没有重复项,因此可以由 Databricks 用于查询优化。

要求:

  • 您必须在连接器设置中选择一个目录

  • Databricks 14.2 或者更高版本

  • IBM DB2 for iSeries 源:已添加对以下数据类型的支持:BINARY-DECIMAL 及 ZONED-DECIMAL

  • Databricks 目标:在以前的版本中,BYTES 映射至 STRING。从该版本开始,它将映射至 VARCHAR(以字节计长度)

  • Google Cloud BigQuery 目标:Google Cloud BigQuery 目标当前支持 JSON 子类型

现已默认支持来自基于 PostgreSQL 的数据源的分区及子分区(以及子子分区)的复制(完全加载和 CDC)。

Google Cloud BigQuery 目标现在支持数据截断错误处理。如果发生数据截断错误,您现在可选择是将记录记录到异常控制表(默认)、忽略该记录、暂停该表还是停止任务。

现在支持以下源和目标端点版本:

  • MariaDB(内部部署)和 Amazon RDS for MariaDB:11.4

  • MySQL(内部部署)、MySQL Percona、Google Cloud SQL for MySQL、Amazon RDS for MySQL 和 Microsoft Azure Database for MySQL - Flexible Server:8.4

  • PostgreSQL(内部部署)、Google Cloud SQL for PostgreSQL、Amazon RDS for PostgreSQL 和 Microsoft Azure Database for PostgreSQL - Flexible Server:17.x

IBM Data Server Client 11.5.9 当前支持以下 DB2 源:

  • IBM DB2 for LUW

  • IBM DB2 for z/OS

  • 终止生命周期的源和目标:已停止支持 Microsoft Azure Database for MySQL 及 Microsoft Azure Database for PostgreSQL(已由 Microsoft 正式停用)。

  • 生命周期终止源版本:已停止支持已经终止生命周期的 IBM DB2 for iSeries 7.2。

  • 生命周期结束的驱动程序版本:对 IBM Data Server Client 11.5.6 的支持已经终止。

已解决的问题

  • HSTS 未在 Qlik 数据网关 - 数据移动 机器上启用。

  • 在 Redhat 9.7 版本上安装 数据移动网关 将失败并显示“OPENSSL_3.4.0 not found”错误。

  • 在 CDC 期间,任务会持续读取相同的 WAL 条目并处理相同的数据流位置。

  • 在 CDC 任务在更改期间停止后(例如,由于连接问题),恢复任务有时会导致行长度错误。

  • 使用预览版或精简版连接器运行任务后,源连接日志将不可用。

  • 当表在完全加载和 CDC 任务的 CDC 阶段暂停时,监控 选项卡不会显示错误消息。

2026年8月10日
2024.11.95 标准 2025 年 11 月 4 日

支持在 Databricks 上创建知识集市

以前,知识集市仅在 Snowflake 上受支持。现在,您也可在 Databricks 上创建和运行知识集市和基于文件的知识集市。

已解决的问题:

任务在准备过程中会间歇性失败,并且出现以下错误:

The request was canceled due to the configured HttpClient.Timeout of 300 seconds elapsing.

2026 年 5 月 25 日
2024.11.90 标准 2025 年 10 月 21 日

已解决的问题:

当使用特殊字符定义元数据架构内部属性时,任务会在 CDC 期间失败。

2026 年 5 月 4 日
2024.11.84 补丁 2025 年 9 月 16 日

已解决的问题:

  • EU-Central-1 地区的客户在使用 数据移动网关 时会经常遇到生产警报。

  • 从 Jira 复制数据时,USERS 表在第一次运行时会卡在排队状态,而其他表则会成功完成加载。

  • 任务监控器中缺少 CDC 监控。

  • Oracle 到 Oracle 的复制任务有时候会因字符串长度计算错误而失败。

  • 由于早期版本存在已知漏洞,Java 服务器组件 (sqlite-jdbc) 已经更新至 3.47.0。

  • 在未启动任务的情况下首次以恢复模式启动任务时,有时会出现“数据库无许可证”错误。

  • 在带 Salesforce 数据源的登陆任务中添加新数据集会导致任务失败,并出现“表不存在”错误。

2026年4月21日
2024.11.78 标准 2025 年 9 月 3 日
警告注释

数据移动网关 升级完成之后,使用 Snowflake 目标机的客户必须升级其 Snowflake 驱动程序。否则,任务会失败。

有关说明,请参阅驱动程序设置

  • 存储任务失败时候会出现连接错误,需要重新启动网关。

  • 当访问 /tmp 文件夹受到限制时,DB2 驱动程序安装会失败。

  • 升级到 数据移动网关 2024.11.65 版后,连接到 Qlik Cloud 会花费过多时间。通过添加一个有两分钟超时的取消令牌,问题得到解决。

  • 升级到 数据移动网关 2024.11.67 后,external-data-provider服务(由 Lite 连接器使用)由于 /tmp 文件夹的访问限制而崩溃。

  • 由于存在已知漏洞,以下组件已被替换成后续版本:

    • SQLite 3.49.1

    • Java 运行时引擎 17.0.15

    • org.bouncycastle:bcpkix-fips 2.0.7 (bcpkix-fips-2.0.7.jar)

    • org.bouncycastle:bc-fips 2.0.0 (bc-fips-2.0.0.jar)

  • 连接 SMB 会因以下错误而失败:

    SmbConnection' object has no attribute 'docs_path'

  • 当第二次准备任务且第一次准备后发生 DDL 时,准备操作有时候会失败,并出现以下错误(摘录):

    Could not find match between landing metadata with gateway task metadata for the following tables: <name>

  • 使用 Microsoft SQL Server 目标机时,预览数据选项无法工作。

  • 此版本增加了对使用 数据移动网关 与 Qlik Cloud Government DoD 配合的支持。

2026年4月21日
2024.11.70 标准 August 12, 2025
  • 复制和登陆任务的表错误处理设置中新增了返回表错误前的重试次数设置。以前,当表格出错时,表格将被暂停或任务将被停止(根据所选错误处理操作)。这有时可能导致表格在 SaaS 应用程序维护窗口期间被暂停。有了这个新选项,现在就可确定在触发表格错误处理策略之前,应该重试表格多少次。如果您的 SaaS 应用程序需要定期维护,该选项尤为有用,因为您可以覆盖默认重试次数 (3),这样就可以在不触发表格错误处理策略的情况下完成维护。

    表格错误处理

    信息注释该选项只显示在配置了精简版或标准版 SaaS 应用程序连接器的任务当中。
  • 预览 SQL 转换时,结果目前将包括列数据类型。

    预览数据

2026 年 3 月 3 日
2024.11.67 标准 2025 年 7 月 29 日
  • 已为网关计算机上的复制日志文件实施了翻转和清除策略。翻转策略将防止日志文件变得过大(影响性能和分析),而清除策略则可防止日志文件累积并占用过多磁盘空间。

  • 重新加载挂起的表时,监视器中显示的表状态有时会不正确。

  • 在添加数据集后准备登陆任务时,有时会在编目资产阶段发生超时。这将导致“准备”操作失败。

2026年2月12日
2024.11.65 补丁 2025 年 7 月 22 日

该补丁解决了以下问题:

  • 在复制任务中添加新表并单击准备时,有时候会出现以下错误:

    Prepare data task failed: Object reference not set to an instance of an object.

  • 以下数据移动网关安装文件已更新到没有已知漏洞的版本:

    • Java

    • jetty-io-<version>.jar

    • jetty-http-<version>.jar

    • spring-expression-<version>.jar

    • spring-core-<version>.jar

    • spring-context-<version>.jar

2026年1月29日
2024.11.61 补丁 2025 年 7 月 15 日 在装有 Python 3.12 的机器上安装 ai-local-agent(矢量数据库和 LLM 连接所需)会失败。该补丁解决了问题。 2026年1月29日
2024.11.59 补丁 2025 年 7 月 1 日

该补丁解决了以下问题:

  • 升级到 数据移动网关 2024.11.54 后,连接数据库会失败。

  • 在任务配置为 SaaS 应用程序源和 Google BigQuery 目标时,准备数据任务会失败。

  • 升级到 数据移动网关 2024.11.54 后,使用基于 Java 的数据源的任务会失败。

  • 在 CDC 期间,当数据源表中的 STRING 列超过 65536 字节时,目标 STRING 列中的数据将会被截断。然后,任务将切换到“逐一”应用模式。

  • java_file_factory.jar 和 arep-google-cloud.jar 文件已升级到不存在已知漏洞的版本。

2026年1月29日
2024.11.54 补丁 2025 年 6 月 17 日

该补丁解决了以下问题:

  • 在满负载期间,任务会丢弃并重新创建目标表,即使任务配置了如果目标表已经存在:忽略

  • 在复制模式设置为满负载并持续更新变动的情况下,停止并准备现有复制任务后,CDC 已处理记录计数会增加,从而导致计数不正确。

  • 在现有任务中添加新数据集时,任务会失败,并出现以下错误消息:

    Could not find a match between landing metadata and gateway task metadata for the following tables: <name>

  • 与 SAP 和基于 SQL 的源的测试连接会失败。

  • 升级网关后,任务有时无法如预期恢复。

2026年1月29日
2024.11.45 标准 2025 年 5 月 20 日

支持 Snowpipe 数据流

之前,批量加载是将数据加载到 Snowflake 的唯一方法。现在,客户可以使用批量加载或 Snowpipe 数据流将数据上载或复制到 Snowflake。

与批量加载相比,Snowpipe 数据流的优势包括 :

  • 成本更低:由于 Snowpipe 数据流不使用 Snowflake 仓库,因此运营成本应大大降低,但这取决于您的具体使用情况。
  • 减少延迟: 由于数据直接流向目标数据表(而不是通过暂存),因此从数据源复制到目标数据表的速度应该更快。

已解决的问题

该补丁解决了以下问题:

  • 使用 Microsoft Fabric 连接器浏览数据库时,会出现以下错误(摘录):

    Create connection failed'' with error 'java.lang.NoSuchMethodError

    该问题是由于与 12.9.0-preview.jar JDBC 驱动程序不兼容造成的,该驱动程序是通过驱动程序设置实用程序安装的。该实用程序现已更新,可安装兼容的驱动程序。

  • 升级数据移动网关或重新启动 数据移动网关 服务后,Java 服务器(基于Java 的连接器(如SAP ODP)需要)将无法启动。

    • 对于从 Qlik Cloud Administration 活动中心返回客户托管日志的日志记录命令有效载荷,端到端加密不会相互执行。

    • 由于 3.42.0 (CVE-2023-7104) 版存在漏洞,数据移动网关 所使用的 SQLite 版本已升级。

    • 由于 h2-2.1.212 版本 (CVE-2022-45868) 存在漏洞,因此升级了 数据移动网关 使用的 com.h2database 文件。

2026年1月29日
2024.11.34 补丁 2025 年 4 月 1 日

此补丁解决了从 IBM DB2 for iSeries 数据源移动数据时出现的以下问题:

使用 iSeries Access ODBC 驱动程序 07.01.026 或更高版本时,任务将在 CDC 期间失败,并出现“解析错误”。

2025 年 11 月 20 日
2024.11.30

标准

2025 年 3 月 18 日

客户现在可以使用 OAuth 身份验证连接到 Databricks 目标,这是 Databricks 推荐的帐户身份验证方法。个人访问令牌身份验证目前仍将保持向后兼容性,但被认为不如 OAuth 安全。

  • 当数据集被定义为并行加载并且随后禁用了满载时,即使从时间戳恢复,任务仍将执行该数据集的满负载。

2025 年 11 月 20 日

2024.11.24

补丁

2025 年 3 月 11 日

该补丁解决了以下问题:

  • 元数据生成将无法完成,对于名称中包含点的表(例如折旧范围).

  • 如果任务在满负载期间因环境问题而失败,则只能恢复一次。现在,它们将按照在设置 > 错误处理 > 环境错误 > 最大重试次数中配置的次数恢复。

2025 年 9 月 18 日
2024.11.14 标准 2025 年 2 月 25 日

增强

PostgreSQL 故障转移证书

在故障转移后使用辅助数据库进行操作,该数据库已通过以下数据源的认证(所有数据源都可以使用 PostgreSQL 源连接器访问):

  • Google Cloud SQL for PostgreSQL
  • Amazon RDS for PostgreSQL
  • PostgreSQL(内部)

另请参阅:设置故障转移

改进 MySQL 性能

在以前的版本中,在配置了有限 LOB 大小的任务中使用基于 MySQL 的源端点时,数据移动网关 会使用源查找来读取 LOB 列。现在,数据移动网关 将直接从 binlog 中读取 LOB 列,从而提高性能。

信息注释这一改进不适用于 JSON 数据类型。

数据类型映射更改

LOB 列映射已针对 Amazon Redshift 和 Snowflake 目标更改。

  • BLOB 现在映射到 VARBYTE(16777216)
  • NCLOB 现在映射到 NVARCHAR(65535)
  • CLOB 现在映射到 NVARCHAR(65535)
  • BLOB 现已映射至 BINARY (8388608)
  • NCLOB 现在映射到 NVARCHAR(16777216)
  • CLOB 现在映射到 VARCHAR(16777216)

新支持的 数据类型

  • 现在支持 BOOLEAN 数据类型(来自 DB2 for LUW 11.5)。

  • 现在支持 BIGNUMERIC 数据类型。

扩展了对 DDL 历史控制表的目标支持

在以前的 数据移动网关 版本中,DDL 历史记录控制表仅支持 Databricks 和 Microsoft Fabric 目标。该版本新增了对以下额外目标连接器的支持:

  • Amazon Redshift
  • Amazon S3
  • Google Cloud Storage
  • Snowflake

另请参见:DDL 历史记录

支持对 Google Cloud SQL for PostgreSQL 使用非超级用户

从该版本开始,在从 Google Cloud SQL for PostgreSQL 复制时,现在可以指定一个非超级用户帐户。

另请参阅:使用无超级用户角色的帐户

新认证的平台和驱动程序版本

  • 15.4 LTS

  • 23ai

    信息注释
    • Oracle 23ai 源和目标仅通过 Oracle Standard Edition 认证。
    • Oracle 23ai 源仅支持 TDE 加密。
  • 将数据移至 Databricks 时,现在需要 Simba Spark ODBC 驱动程序 2.8.2 或更高版本。客户应运行驱动程序安装实用程序或手动安装驱动程序。

    另请参见:驱动程序设置

支持结束

已停止支持以下数据库版本:

  • PostgreSQL 12.x
  • IBM DB2 for z/OS: z/OS 2.4
  • Databricks 9.1

已解决的问题

  • 当复制模式设置为存储更改时,表中包含 .INCLUDE 列,该任务将无法在目标上创建 __CT 表。

  • 任务将失败,当 Azure Data Lake Storage 密钥过期时,将显示“数据库无许可证”错误。

  • 运行新任务时,旧文件不会被删除。这可能会导致任务因记录重复或记录不匹配而失败。

     

  • 在选择用户定义的表进行复制时,会出现“特性不受支持:无法选择用户定义的类型”错误。通过从表选择器中排除用户定义的表(不受支持),该问题得到了解决。

  • 从 CDC 期间发生的连接错误中恢复后,有时会出现“转换失败”错误。

  • 当禁用 LOB 支持时,如果 CDC 尝试将更改插入 __ct 表,会出现 "数据列不够 "的故障。在 "存储更改 "模式下工作时会出现此错误,这是登陆任务的唯一可用模式。

  • 在 CDC 期间,当复制具有 mediumtext 数据类型的“NOT NULL”列时,任务有时会失败,并出现以下错误:

    A NOT NULL constraint violation occurred on LOB column from MySQL source

  • 插入 VARCHAR 列时,会出现以下截断错误:

    String or binary data would be truncated while reading column of type 'VARCHAR'

    该问题可通过在 Microsoft Fabric 中乘以 VARCHAR 列来解决。

2025 年 9 月 18 日
2024.5.54 标准 2025 年 1 月 21 日

Snowflake 目标连接器中添加了对指定其他 ODBC 和 JDBC 连接属性的支持。

有关更多信息,请参阅其他连接属性。

  • 当源上的主键被更改时,目标元数据在重新加载后将不会更新。

  • 创建和运行新任务时,不会从表位置删除以前任务遗留的文件。

  • 尝试使用基于日志的 CDC 连接到 SAP HANA 源将导致以下错误:

    Cannot select user-defined type

2025 年 8 月 25 日

2024.5.41

补丁

2024 年 12 月 19 日

该补丁解决了以下问题:

  • 现在,CSV 文件中将引用空字符串,以将其与 NULL 值区分开来。

  • 在某些情况下,源数据和目标数据之间会出现不匹配。

  • 在登陆任务中禁用 LOB 支持将导致 CDC 故障,并出现以下错误(摘录):

    Cannot write to '<name>__ct', not enough data columns

  • 从连接错误中恢复后对目标应用更改有时会失败,并出现“转换失败”错误。

2025 年 7 月 21 日

2024.5.35

补丁

2024 年 12 月 10 日

该补丁解决了以下问题:

  • 在存储任务期间,数据类型 NVARCHAR(3500) 将被错误地转换为 VARCHAR(10500),而不是 VARCHAR(8000)(允许的最大值),从而导致错误。

  • 当源表包含代码页为 941(日语)的 GRAPHIC 数据类型时,将出现以下错误(摘录):

    Unexpected CCSID '941' in column 'PNTNM'

2025 年 7 月 21 日

2024.5.32

补丁

2024 年 11 月 26 日

在 Workday Reports 源连接器中更新用户名和密码,然后重新加载任务后,即使凭据正确,也会出现“无效用户名或密码”错误。该问题现已解决。

2025 年 7 月 21 日

2024.5.31

补丁

2024 年 11 月 19 日

该补丁解决了以下问题:

数据移动网关 随附的 Oracle Java Standard Edition 17.0.8 有几个已知漏洞。此补丁将 17.0.8 替换为 17.0.12,从而解决了问题。

在 CDC 期间,对于每个更改,将向关联的 _ct 表添加多个 INSERT 操作(而不是只有一个)。这将显著增加 _ct 表中的记录数量。

2025 年 7 月 21 日

2024.5.28

标准

2024 年 11 月 12 日 提供即将发布的架构演进特性所需的功能。

2025 年 7 月 21 日

2024.5.27

补丁

2024 年 11 月 5 日

该补丁解决了以下问题:

2024 年 8 月 14 日,Snowflake 发布了一份关于 Snowflake JDBC 驱动程序 >= 3.2.6 & <= 3.19.1 的安全公告,其中一些驱动程序与以前版本的 数据移动网关 一起使用。该漏洞已在 Snowflake JDBC Driver 3.20 中修补,该版本现在随驱动程序安装实用程序一起安装。现有客户应按照驱动程序设置中描述的程序更新驱动程序,尽早升级其驱动程序。

  • 当使用重做事件 11.22 时,在未在 INSERT 之前压缩的压缩页面上处理多个 INSERT 时,会出现丢失 INSERT 的情况。
  • 在极少数情况下,对重做日志记录中的 DELETE 事件的错误解析会生成“重做日志 DELETE 事件包含未知结构”警告,随后出现各种问题。

YAML 文件中的说明已更新,以反映 SAP Java Connector 的正确版本。

当使用 数据移动网关 通过代理连接到 Snowflake 目标时,连接将失败,并出现以下错误:

500 Failed to connect to Data Movement Gateway

2025 年 5 月 12 日

2024.5.22

补丁

2024 年 10 月 15 日 此修补程序解决了满负载 + CDC 复制任务中的一个问题,具体表现为,CDC 任务的数据任务更新为字段会显示满负载时间戳,而不是 CDC 时间戳。

2025 年 5 月 12 日

2024.5.16

补丁

2024 年 10 月 8 日
    • 使用重做事件 11.22 时,在多个插入操作中有时会出现缺失的插入。
    • 在将 Oracle 19g 升级到 July 2024 修补程序后,更新操作有时不会被捕获,并且会显示以下警告:

      A compressed row cannot be parsed

  • 当任务设置被配置为创建控制表模式时,任务将失败,并出现以下错误:

    Failed to delete directory

  • 当任务计划定期运行时,它有时会失败,并出现以下错误:

    The task stopped abnormally

  • 转换和存储任务有时会长时间处于排队状态。

  • 将 use_manipulation_pk_for_apply 特性标志用于存储更改复制时,任务将失败。

  • 将 S3 超时时间延长至 6 小时,以防止因超时时间过长而导致的问题,例如丢失下载文件的令牌。

2025 年 5 月 12 日

2024.5.14

标准

2024 年 9 月 11 日
  • 密钥/对提供了一种比用户/密码更强大的身份验证方法,用于使用您的服务帐户连接到 Snowflake。建议将此方法用于数据加载(复制或登陆任务)和转换等工作负载。

  • 在以前的版本中,刷新现有数据集或新添加的数据集上的元数据有时会因错误而失败。此增强功能确保可以从多个表中并行检索元数据,而不会出现任何问题。

  • 当源表包含 DECIMAL 数据类型的列时,例如 DECIMAL (38, 20),在 Google BigQuery 上准备存储任务将失败,并出现以下错误(摘录):

    Column <n> in <table name> has incompatible types: STRING, BIGNUMERIC at [93:1]

    通过将源 DECIMAL 数据类型映射到 Google BigQuery 中的 DECIMAL,该问题得到了解决。

  • 在数据任务中更改现有架构规则后,将出现以下错误:

    QRI SQL error not implemented

  • 在准备连接到 SAP 应用程序源的登录任务时,该任务将成功完成,但 repsrv.log 日志文件中会报告以下错误:

    Invalid object name 'hk1./QTQVC/QRI'

2025 年 5 月 12 日

2024.5.7

标准

2024 年 8 月 6 日
  • 以前,当元数据发生更改时,即使元数据更改不会影响所有表,也会删除并重新创建所有表。现在,只有更改的表将被删除并重新创建,从而提高性能。

  • 在复制数据任务期间在源数据库中创建的与包含模式匹配的表格现在将在 CDC(更改数据捕获)期间自动捕获。

    • 以前,从 Microsoft SQL Server (MS-CDC) 读取多个事务时,Qlik Talend Data Integration 只会保留第一个事务的事务 ID 和时间戳。在目标上,这使记录看起来像是单个事务的一部分。现在,Qlik Talend Data Integration 将保留每个单独记录的原始事务 ID 和时间戳。这有利于希望利用更改表中的事务 ID 和时间戳头列的客户。

    • 以前,事务 ID 中的字节以相反的顺序编码。从这个版本开始,字节将以正确的顺序编码。希望保留现有行为的信息客户可以使用内部参数来如此操作。有关详细信息,请联系 Qlik 支持部门。

  • Qlik Talend Data Integration 现在支持在本地或云中使用 MySQL 源或目标时缓存 SHA-2 可插入身份验证 (caching_sha2_password)。在以前的版本中,只支持原生可插入身份验证 (mysql_native_password)。

  • BYTES 和 BLOB 数据类型现在将映射到 Amazon Redshift 上的 VARBYTE,而不是映射到 VARCHAR。

    • PostgreSQL 16.x

    • MySQL 8.1
    • IBM DB2 for z/OS 3.1
    • PostgreSQL 16.x
    • MySQL 8.1
    • Databricks 14.3 LTS
    • SQL Server ODBC Driver 18.3

已停止支持以下数据库版本:

  • 所有早于 Oracle 19.x 的 Oracle 版本和驱动程序
  • Microsoft SQL Server 2014
  • MySQL 5.7
  • PostgreSQL 11
  • IBM DB2 for LUW 10.5
  • IBM DB2 for z/OS:z/OS 2.3
  • 当捕获的集群文档更改删除了其所有捕获表的所有行时,将遇到缺失的 DELETE 操作和不必要的断言消息。

  • 将 Microsoft Authentication Library for Java (MSAL4J) 和 Bouncy Castle 更新为没有已知漏洞的版本。

    • 使用 Snowflake 内部存储时,该任务有时会失败。
    • 当目标模式名称为日语片假名时,该任务将失败。
  • 当使用 Oracle 源恢复任务时,该任务将继续等待已删除的存档重做日志,而不是因相应的错误而失败。

2025 年 3 月 11 日

2023.11.23

标准

2024 年 6 月 26 日
  • 在此版本中,如果 Snowflake 元数据架构(用于暂存文件)不存在,则会创建该架构。

  • 更改重命名数据集规则(将表名与架构名连接起来)并将视图添加到着陆任务后,“准备”操作将失败,并出现以下错误:

    QRI SQL error not implemented.

  • 已将 java_file_factory 组件更新到没有任何已知漏洞的版本。
  • 已将 org.postgresql:postgresql 更新到没有任何已知漏洞的版本。
  • 当移动数据到 SQL Server 时,如果索引名称超过 128 个字符,“准备”操作将失败。通过更改逻辑以创建较短的索引名称,解决了此问题。
  • 从 SQL Server 移动数据时,表定义中缺少列名会导致 repsrv.log 文件中出现无限通知循环,并显示以下消息:

    mssql_resolve_sqlserver_table_column_attributes(...) failed to find column

2025 年 2 月 6 日

2023.11.11

标准

2024 年 5 月 21 日
  • 增加了对同时检索多个表的元数据的支持。

  • 现在,登陆和复制任务的监控信息将每 10 秒更新一次(而不是每 60 秒更新一一次),从而更准确地指示其当前状态。

  • 日本现在作为 Qlik Cloud 租户地区受支持。

  • 数据网关和 Qlik Cloud 之间的重试间隔会不断延长,但永远不会重置(除非重新启动服务)。
  • 当从 SaaS 应用程序源移动数据时,表有时会在重新加载期间进入错误状态。
  • 在 CDC 期间,MySQL 源的任务有时会失败,并出现以下错误:

    Read next binary log event failed; mariadb_rpl_fetch error 0 Error reading binary log.

  • 以前,CD C审核事件只会记录在登陆任务中。现在,它们将被记录以执行复制任务。
  • 从 SQL Server (MS-CDC) 中移动数据时,具有大量表的任务有时需要几个小时才能启动。
  • 当源表包含 CLOB 列并且“限制 LOB 大小”值超过 10240 时,复制到 Snowflake 将失败,并出现以下错误:

    Invalid character length: 0

2024 年 12 月 26 日
2023.11.4

标准

2024 年 3 月 12 日

客户现在可以在 Red Hat 9.x 或任何相应的兼容 Linux 发行版上进行安装 数据移动网关。

设置 数据移动网关

停止、启动和检查 数据移动网关 服务状态的命令已更改。

数据移动网关 服务命令

  • 在 Amazon Redshift 中映射到 VARCHAR(1) 的 BOOLEAN 数据类型现在将映射到 BOOLEAN。
  • 在 Amazon Redshift 中映射到 VARCHAR(1) 的 BYTES 和 BLOB 数据类型现在将映射到 VARBINARY(长度)。

本部分列出了最新支持的数据库、数据库版本和驱动程序版本。

  • 新支持的数据源版本。

    现在支持以下数据源版本:

    • Azure Database for MySQL - Flexible Server(通过 MySQL 源连接器支持)
    • MariaDB 10.4-10.11(之前为 10.4 和 10.5)
  • 新支持的目标数据平台和版本

    现在支持以下数据目标版本:

    • Azure Database for MySQL - Flexible Server(通过 MySQL 目标连接器支持)
    • Databricks:Databricks 13.3 LTS 和 Serverless SQL Warehouse
  • 新支持的 SAP HANA 驱动程序版本

    拥有 SAP HANA 源代码的客户如果要在 Red Hat Linux 9.x 上安装 数据移动网关,则必须安装 SAP HANA ODBC 64 位驱动程序 2.0.19 或更高版本。

本部分提供有关结束支持的数据库版本的信息。

  • 已停止支持以下数据源版本:

    • Oracle 11.x
    • SAP HANA 1.0
  • 在不提供服务器密码的情况下安装 数据移动网关 将不允许在一个命令中配置租户和代理 URL。
  • 从 Salesforce(SaaS应用程序)数据源移动数据会打印大量冗余警告,从而影响数据加载性能。
  • 在检索 SaaS 应用程序数据源的更改时,如果检索其中一个表的更改时发生错误,该表将被挂起并从管道中删除。现在,当遇到错误时,该任务将尝试在挂起表之前检索最多三次更改。
2024 年 11 月 21 日
2023.5.16

标准

2024 年1 月 9 日

我们正在继续扩大n Qlik Cloud Data Integration 中复制项目的支持目标,除了 Amazon S3,您现在可以选择 Azure Data Lake Storage (ADLS) 和 Google Cloud Storage (GCS) 进行数据湖交付,如 Parquet、JSON 或 CSV 文件格式。

  • 当连接所需的文件(如 SSL 客户端证书和密钥库文件)的大小超过 4 KB 时,指向 IBM DB2 for LUW 的连接将失效。

  • 使用驱动程序安装实用程序时,DB2 驱动程序安装会失败。

2024 年 9 月 12 日

2023.5.15

标准

2023 年 12 月 12 日

Microsoft Fabric 加入了不断扩展的数据仓库列表,这些数据仓库可以用作数据管道项目的目标。

更新了驱动程序安装实用程序中的 Snowflake 驱动程序版本。

2024 年 7 月 9 日

2023.5.10

标准

2023 年 10 月 31 日

可以使用专用连接来确保您的数据流量保持安全和合规。它简化了 VPC(虚拟私有云)的网络管理和安全,无需打开入站防火墙端口、代理设备或路由表。Qlik Cloud 数据集成已经支持到 Snowflake、Microsoft SQL Server 和 Amazon S3 数据管道目标的私有连接。有了这个版本,客户在将数据移动到 Databricks、Microsoft Azure Synapse、Google BigQuery 和 Amazon Redshift 时还可以使用私人连接。

  • 所有基于 PostgreSQL 的数据源 - 多范围数据类型支持:现在所有基于 PostgreSQL 的数据源(本地和云)都支持以下多范围数据。

    • INT4MULTIRANGE
    • INT8MULTIRANGE
    • NUMMULTIRANGE
    • TSMULTIRANGE
  • AWS Aurora Cloud for PostgreSQL数据源 - 非超级用户角色支持:在 PostgreSQL 连接器中指定的用户不再需要拥有超级用户角色才能从 AWS AuroraCloud for PostgresSQL 数据源中移动数据。这对于具有公司安全策略的组织尤其有用,因为这些策略阻止他们将超级用户访问权限授予非特权用户。

从 Microsoft Azure SQL (MS-CDC) 数据源移动数据的客户现在可以使用地理副本数据库。

Qlik Cloud 数据集成现在支持在 CDC 期间从 Oracle 加密的表空间和加密的列中读取数据。

Qlik Cloud 数据集成现在支持德国和英国地区的租户。

本节列出了最新支持的数据库和驱动程序版本。

  • 新支持的数据源版本。现在支持以下数据源版本:

    • Microsoft SQL Server 2022
    • Oracle 21c
    • PostgreSQL 15.x
    • DB2 13.1(使用 IBM DB2 for z/OS 时)
    • IBM DB2 for iSeries
  • 最新支持的目标数据平台版本现在支持以下数据目标版本:

    • Databricks(云存储):Databricks 12.2 LTS 和 Databricks SQL Serverless
  • 驱动程序版本。现在支持以下 ODBC 驱动程序版本:

    • IBM Data Server Client 11.5.8 for IBM DB2 for z/OZ 以及 IBM DB2 for LUW
    • Simba ODBC 驱动程序 3.0.0.1001,适用于 Google Cloud BigQuery
    • MySQL ODBC Unicode Driver 64 位 8.0.32

往返于 icrosoft SQL Server 移动数据的客户需要将其 SQL Server ODBC 驱动程序版本升级到 18.x 或更高版本。请注意,继续使用 SQL Server ODBC Driver 17.x 可能会导致数据错误。可以使用驱动程序安装实用程序或手动方式升级驱动程序。有关说明,请参阅驱动程序设置。

本部分提供有关结束支持的数据库版本的信息。

  • 结束支持的数据源版本。已停止支持以下数据源版本:

    • PostgreSQL 10
    • MySQL 5.6
    • MariaDB 10.3
  • 结束支持的目标数据平台版本已停止支持以下数据目标版本:

    • Databricks 9.1 LTS

2024 年 6 月 12 日

2022.11.74

标准

2023 年 8 月 15 日

我们采用云优先的方法,实现快速创新和采用。然而,这并不意味着我们只是云。作为我们持续致力于提高客户长期价值的一部分,我们很高兴地宣布,在创建数据项目时,将发布一个新的复制用例。新的 Replication 用例是对现有能力的补充,可以为您的所有数据集成需求(如数据仓库现代化)创建数据管道。

Replication 项目支持从受支持的数据源到受支持的目标的实时数据复制。

从最新版本开始,第一个支持实时复制数据的目标是 Microsoft SQL Server。除了支持 Microsoft SQL Server 内部部署外,还支持以下云提供者:

  • 内部:
  • Amazon RDS
  • Google Cloud
  • Microsoft Azure(Microsoft Azure 托管实例和 Microsoft Azure 数据库)

将数据移动到 Microsoft Azure Synapse Analytics 的客户需要将其 SQL Server ODBC 驱动程序版本升级到 18.x 或更高版本。请注意,继续使用 SQL Server ODBC Driver 17.x 可能会导致数据错误。可以使用驱动程序安装实用程序或手动方式升级驱动程序。有关说明,请参阅驱动程序设置。

引入了一个新的从源加载数据选项,允许客户在满负载期间直接从源读取数据,而不是使用缓存的数据。

有关此选项(包括使用情况)的详细信息,请参阅登陆设置。

数据移动网关 2022.11.74 包括验证 Qlik Cloud 租户所需的更新的 CA 证书。更新后的 CA 证书还为爱尔兰和法兰克福地区提供支持。因此,在爱尔兰或法兰克福拥有 Qlik Cloud 租户的客户如果想要使用 Qlik Cloud Data Integration ,必须升级到此版本。

当宽型表格包含未使用或不支持的列,或未复制的 LOB 列时,从 Oracle 源获取数据的任务有时会失败。

2024 年 4 月 31 日

2022.11.70

标准

2023 年 6 月 28 日

在以前的版本中,客户在安装 SAP 客户端时需要运行 "source arep_login.sh" 命令。在此版本中,不再需要运行此命令。

该版本包括验证 Qlik Cloud 租户所需的更新的 CA 证书。

  • 当 数据移动网关 上的复制任务失败并自动恢复时,恢复的状态将不会传达给 Qlik Cloud 中的登陆数据资产。

  • 数据移动网关 的端到端加密默认情况下将不会启用,而是由运行时标志控制。
2024 年 2 月 15 日

2022.11.63

标准

2023 年 5 月 2 日

此版本引入了一个驱动程序安装工具,不再需要手动安装和配置驱动程序。新工具缩短了安装过程,同时大大降低了用户出错的可能性。当工具运行时,如果可能,会自动下载并安装所需的驱动程序。如果无法下载驱动程序(例如,DB2 驱动程序需要登录),您所需要做的就是下载驱动程序,将其复制到数据移动网关计算机上的专用文件夹中,然后运行该工具。

有关使用驱动程序安装工具安装 PostgreSQL 驱动程序的示例,请参阅先决条件

Snowflake 连接器现在支持 4 字节表情符号字符。

PostgreSQL 连接器现在可以从 Azure Database for PostgreSQL - Flexible Server 移动数据。

PostgreSQL 连接器现在可以为 PostgreSQL 从 Cloud SQL 中移动数据。

此版本引入了对以下新数据源版本的支持:

  • PostgreSQL 14
  • DB2(适用于 IBM DB2 for z/OS)12.1
  • IBM DB2 for z/OS 2.5

Databricks 11.3 LTS

不再支持以下数据源版本:

  • DB2(适用于 IBM DB2 for z/OS)11
  • PostgreSQL 9.6
  • Microsoft SQL Server 2012
  • MariaDB 10.2

此版本解决了以下问题:

  • Oracle 数据源:在停止和恢复任务时,任务有时会失败,并出现“无法在上下文中设置数据流位置”错误。
  • SAP 应用程序源:在登陆 任务期间不会捕捉到更改。

2023 年 12 月 28 日

2022.5.13

标准

2022 年 10 月 19 日

初始版本

2023年11月2日

卸载 数据移动网关

要卸载 数据移动网关,请运行以下命令:

rpm -e <installation package name>

示例:

rpm -e qlik-data-gateway-data-movement-2023.11-1.x86_64

如果您不知道程序包名称,请运行:

rpm -qa | grep qlik

警告注释卸载 数据移动网关 将导致当前使用数据网关的所有任务失败。

本页面有帮助吗?

如果您发现此页面或其内容有任何问题 – 打字错误、遗漏步骤或技术错误 – 请告诉我们!