Zu Hauptinhalt springen Zu ergänzendem Inhalt springen

Die Logs meiner Pipeline-Tasks werden in Talend Management Console nicht angezeigt

Bei der Planung einer Pipeline-Task auf der Remote Engine Gen2 in Talend Management Console werden die entsprechenden Logs ggf. nicht angezeigt.

Ursache

Die Logs wurden unter Umständen nicht aktiviert.

Fehlerbehebung

Prozedur

  1. Führen Sie folgenden Befehl aus, um die Remote Engine Gen2 anzuhalten:
    remote-engine.bat stop in einem Windows-System
    ./remote-engine.sh stop in einem Unix-System
  2. Öffnen Sie die folgende Datei, um sie zu bearbeiten:

    <engine_directory>/default/.env, wenn Sie die Engine in den Regionen AWS USA, AWS Europa, AWS Asien/Pazifik oder Azure einsetzen.

    <engine_directory>/eap/.env, wenn Sie die Engine im Rahmen eines Early-Adopter-Programms verwenden.

  3. Setzen Sie den Parameter LIVY_JOB_LOG_PERSISTENCE_ENABLE auf true.
  4. Speichern Sie die vorgenommenen Änderungen und starten Sie die Remote Engine Gen2 neu.

Hat diese Seite Ihnen geholfen?

Wenn Sie ein Problem mit dieser Seite oder ihrem Inhalt feststellen, sei es ein Tippfehler, ein ausgelassener Schritt oder ein technischer Fehler, informieren Sie uns bitte!