跳到主要內容 跳至補充內容

支援的來源資料庫版本

下表列出 資料移動閘道 支援哪些來源資料庫版本,也指定需要設定哪些連接器以連線至資料庫。

支援的資料來源
連接器 資料來源 支援的版本 來源類型

MySQL

如需詳細資訊,請參閱MySQL

  • MySQL
  • Amazon Aurora for MySQL
  • Amazon RDS for MySQL
  • Google Cloud SQL for MySQL
  • Percona

5.7, 8.0

關聯式資料庫
  • Microsoft Azure Database for MySQL
8.0 關聯式資料庫
  • MariaDB
10.4 至 10.11 關聯式資料庫
  • Amazon RDS for MariaDB
10.3、10.4 及 10.5 版 關聯式資料庫

PostgreSQL

如需詳細資訊,請參閱 PostgreSQL

  • PostgreSQL
  • Amazon RDS for PostgreSQL
  • Google Cloud SQL for PostgreSQL

10.x、11.x、12.x、13.x、14.x、15.x

關聯式資料庫
  • Amazon Aurora Cloud for PostgreSQL
10.x、11.x、12.x、13.x、14.x、15.x 關聯式資料庫
  • Microsoft Azure Database for PostgreSQL
10.x、11.x、12.x、13.x、14.x、15.x 關聯式資料庫
  • 適用於 PostgreSQL 的 Microsoft Azure 資料庫 - 彈性伺服器
不適用 關聯式資料庫

Oracle

如需詳細資訊,請參閱 Oracle

  • Oracle
  • Oracle Amazon RDS for Oracle
  • Oracle Cloud 上的 Oracle

12.x, 18.x, 19.x, 21c

警告備註如您設定 Oracle 相容性參數,請確定指定 資料移動閘道 支援的版本。例如,若您使用 12.x 版,不可設定更早的版本做為相容性版本。
關聯式資料庫

Microsoft SQL Server (記錄為主)

如需詳細資訊,請參閱 內部部署 Microsoft SQL Server (記錄為主)

Microsoft SQL Server

2014、2016、2017、2019、2022 版

關聯式資料庫

Microsoft SQL Server (Microsoft-CDC 為主)。

如需詳細資訊,請參閱 Microsoft SQL Server (Microsoft CDC 為主)

  • Microsoft Azure SQL 受控執行個體
  • Microsoft Azure SQL 資料庫

2014、2016、2017、2019、2022 版

關聯式資料庫

IBM DB2 for LUW

如需詳細資訊,請參閱 IBM DB2 for LUW

IBM DB2 for LUW

10.5 版、11.1 版及 11.5 版

資訊備註

10.5,Fix Pack 5 受支援。

關聯式資料庫

IBM DB2 for z/OS

如需詳細資訊,請參閱 IBM DB2 for z/OS

IBM DB2 for z/OS

db2

12, 12.1 , 13.1

IBM z/OS:

2.3, 2.4, 2.5

主機

IBM DB2 for iSeries

如需詳細資訊,請參閱 IBM DB2 for iSeries

IBM DB2 for iSeries 7.2 版、7.3 版、7.4 版和 7.5 版 關聯式資料庫

SAP HANA (資料庫)

如需詳細資訊,請參閱 SAP HANA (資料庫)

SAP HANA 2.0 SAP

其他支援的 SAP 連接器

以下 SAP 連接器不受支援:

  • SAP 擷取器

    如需詳細資訊,請參閱 SAP 擷取器

  • SAP (應用程式)

    適用於使用下列任何後端資料庫的 SAP 設定:Oracle、Microsoft SQL Server、LUW 版 IBM DB2、z/OS 版 IBM DB2 和 SAP HANA。如需詳細資訊,請參閱 SAP (應用程式)

此頁面是否對您有幫助?

若您發現此頁面或其內容有任何問題——錯字、遺漏步驟或技術錯誤——請告知我們可以如何改善!