跳到主要内容

文件菜单

在该页面上

文件菜单

文件菜单是一种下拉式菜单,位于屏幕顶部,并且包含以下指令:

  • :打开新的 QlikView 窗口并允许创建新的 QlikView 文件。
  • 打开...:打开新的 QlikView 窗口,并允许打开 QlikView 文件或表格文件。打开表格文件会自动打开文件向导。该命令还可以通过以下键盘快捷方式调用: Ctrl+O。
  • 在服务器上打开...:打开一个对话框,您可在此对话框中连接到 QlikView 服务器,浏览文档并以客户端模式打开。
    该命令还可以通过以下键盘快捷方式调用: Ctrl+Shift+O。

    备注: 在客户端打开 QlikView Server 上的文档时,与打开本地文档不同,在处理文档时您的权限可能会受到限制。您在客户端可能无法添加或删除工作表对象,具体取决于该文档是否支持协作。不能添加或删除工作表。此外,并非所有属性对话框均可存取,并非所有宏均可更改,并非所有脚本均可存取,并非所有数据均可重新加载,或者并非所有文档均可保存。
  • 刷新文档:只有在 QlikView 服务器上打开文档并且该服务器上有一个可用文档的较新版本时才能使用此命令。调用刷新时,可以存取最新数据,同时可以维持包括选择项和布局状态的会话。
  • 打开 URL...:打开打开 URL对话框。在此对话框中,输入有效的 URL 到任意网页。网页会在 QlikView 内以独立窗口打开。此功能可用于 QlikView Publisher 接入点,或用于页面通过 AJAX 客户端显示 QlikView 服务器文档。如同 QlikView 标准文档窗口,已打开的网页可通过 窗口菜单访问。
  • 打开 FTP...:打开新的 QlikView 窗口,允许在 FTP 服务器上打开 QlikView 文件或表格文件。打开表格文件会自动打开文件向导
  • 关闭:关闭在用的 QlikView 文件。
  • 收藏夹:此层叠菜单可控制用户定义的收藏夹文档,独立管理最近使用的文档列表(详见下文)。
  • 保存:保存 QlikView 文件的当前配置。数据、脚本和布局均已保存。该命令还可以通过以下键盘快捷方式调用: Ctrl+S。如果您要使用 AJAX 客户端共享 QlikView 文档,则文件名不得包含井号 (#) 字符。
  • 另存为...:使用新名称保存 QlikView 文件的当前配置。该命令还可以通过以下键盘快捷方式调用: F12. 如果您要使用 AJAX 客户端共享 QlikView 文档,则文件名不得包含井号 (#) 字符。
  • 保存链接...:保存在 QlikView 服务器上打开并作为本地机器上的文本文件的文档链接。文件会拥有 qvw 扩展名,但不包含任何数据或布局。当打开此类链接文档时,QlikView 会尝试重新连接到服务器,并打开 QlikView 服务器上的文档。此指令不可用于本地文档。
  • 作为附件发送...:仅当使用本地文档时可用。创建带当前 qvw 文档副本的电子邮件。如果邮件收件人能访问 QlikView 并有权访问该文档(如果使用区域权限安全性),则将能够打开 qvw 文档。为使此指令生效,必须在电脑上配置邮件客户端。
  • 与书签一起作为链接发送...:仅当使用 QlikView 服务器文档时可用。创建带当前服务期文档 URL 链接的邮件。在 URL 中创建(包括布局状态)和编码临时服务期书签。邮件收件人能够使用 URL 链接打开服务器文档,并查看正在查看的内容,假如他拥有其中文档和数据的访问权限。为使此指令生效,必须在电脑上配置邮件客户端。QlikView 服务器必须配置,以允许使用服务器书签。
  • 打印...:打开标准打印对话框,允许打印当前工作表对象。此指令不可用于列表框。该命令还可以通过以下键盘快捷方式调用: Ctrl+P。
  • 以 PDF 打印...: 打开打印对话框,其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后,程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。 该命令还可以通过以下键盘快捷方式调用: Ctrl+Shift+P.
  • 打印可能值....:打开标准打印对话框,允许打印当前列表框的可能值(选中和可选)。此命令仅可用于列表框。
  • 以 PDF 文件格式打印...:此命令必须在将列表框和多选框打印成 PDF 时使用。
  • 打印工作表...:打开打印对话框,允许打印当前工作表的图片。
  • 打印预览...:显示可打印工作表对象预览。
  • 源代码控制
    • 设置:添加项目或从源控制取得项目时设置要使用哪个 MSSCCI(Microsoft 源代码控制界面)提供程序 dll。
    • 添加项目至源控制:保存已打开的 QlikView 文档,并自动创建一个项目文件夹和项目文件。调用源控制系统以添加项目至源控制。
    • 从源控制获取项目:从源控制检索项目并从项目文件重建 QlikView 文档。QlikView 数据未存储在源控制中。若要以数据填充文档,必须在重建文档中执行重新加载命令。
    • 获得最新版本:检索源控制系统中最新版本的文档,并重建 QlikView 文档。
    • 签入挂起更改:保存 QlikView 文档并针对源控制系统执行签入操作。这包括四项不同的源控制操作,且每项操作均包含单独的对话框:

      • 添加新创建的文件。
      • 撤消需要从源控制中删除的已注销文件。
      • 移除属于源控制部分相应要被移除的工作表或工作表对象的文件。
      • 登记修改的文件。

      如果文档在执行签入挂起更改前并非最新的文档,则此后应重新打开文档,以加载在解决冲突时可能引入的项目更改。

    • 撤销挂起更改:撤消更改。如果源控制系统中并未签出局部修改的文件,则这些文件将在执行撤销签出操作前被签出。此项操作通过删除已添加但未签入的文件将会重建 QlikView 文档,且将储存那些待删除的文件。
  • 导出
    • 导出内容...:此替代项仅在使用可导出工作表对象时可用。然后,它会执行工作表对象的对象菜单内的导出操作。
    • 导出工作表图片...:打开一个对话框,保存当前工作表图片到文件。
    • 导出文档布局:打开对话框,将文档布局保存为 XML 文件。文档中的任何数据都不会保存到 XML 文件中。
  • 编辑脚本...:打开编辑脚本对话框。您可在此写入并执行脚本,以打开和连接到数据库。
  • 重新加载:执行当前加载脚本,重新加载数据到在用的 QlikView 文档。自从上次重新加载完成之后,如果数据库的内容发生更改,则需要完成此操作。该命令还可以通过以下键盘快捷方式调用: Ctrl+R.
  • 部分重新加载:执行当前加载脚本,包括所有脚本指令,例如 Drop table,重新加载数据到活动 QlikView 文档中。但是,仅先前带有 ReplaceAdd 前缀的加载和选择语句的表格会重新加载。未受此类加载或选择语句影响的数据表格不受部分重新加载的影响。该命令还可以通过以下键盘快捷方式调用: Ctrl+Shift+R.
  • 减少数据:打开包含以下两个指令的菜单:
    • 保留可能的值:通过移除所有排除值减少 QlikView 数据库。
    • 移除所有值:移除 QlikView 数据库的所有数值,保留数据库结构和布局,创建模板。
  • 表视图...:打开表格查看器对话框,这里的加载数据结构可在表格,字段以及关联图形中进行研究。该命令还可以通过以下键盘快捷方式调用: Ctrl+T。
  • 最近使用的文档列表:使用最新使用的 QlikView 文档的列表。显示的文档数可在设置:用户首选项对话框中设置。默认数量为 8。选择其中一个值等于打开指令。
  • 退出:关闭打开的文档并退出 QlikView。