メイン コンテンツをスキップする

[ファイル] メニュー

このページ上

[ファイル] メニュー

ファイル メニューは画面上にあるドロップダウン メニューで、以下のコマンドが含まれます。

  • 新規: 新しい QlikView ウィンドウを開き、新しい QlikView ファイル を作成できます。
  • 開く: 新しい QlikView ウィンドウを開き、QlikView ファイル、またはテーブル ファイルを開きます。テーブル ファイルを開く場合、自動的にファイル ウィザードが開きます。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+O。
  • サーバーで開く: このダイアログを開き、QlikView Server に接続してクライアント モードで開くドキュメントを参照できます。
    このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+SHIFT+O

    注: QlikView Server のクライアントとしてドキュメントを開く場合は、ローカル ドキュメントを開く場合に比べて、ドキュメントに対して実行できる操作が制限されます。クライアントは、ドキュメントが共有機能をサポートしているかどうかによって、シート オブジェクトを追加したり削除できないことがあります。シートを追加または削除することはできません。さらに、すべてのプロパティ ダイアログへアクセスできるわけではありません。マクロの変更、スクリプトへのアクセス、データのリロード、またはドキュメントの保存は実行できません。
  • ドキュメントを更新: このコマンドが有効に機能するのは、ドキュメントが QlikView Server で開かれた状態で、より新しいバージョンのドキュメントがサーバーに存在する場合のみです。更新コマンドを呼び出すと、最新のデータにアクセスできますが、選択条件やレイアウトの状態などのユーザーのセッションは保持されます。
  • URL から開く:URL から開くダイアログを開きます。このダイアログで、Web ページへの有効な URL を入力します。Web ページは、QlikView 内の別ウィンドウに開きます。この機能は、たとえば、QlikView Publisher AccessPoint や AJAX クライアントを介して QlikView Server のドキュメントを表示するページに使用できます。開いた Web ページは、標準の QlikView ドキュメント ウィンドウと同様にウィンドウ メニューからアクセスできます。
  • FTP から開く: 新しい QlikView ウィンドウを開き、FTP サーバーから QlikView ファイルもしくはテーブル ファイルを開きます。テーブル ファイルを開く場合、自動的にファイル ウィザードが開きます。
  • 閉じる: アクティブな QlikView ファイル を閉じます。
  • お気に入り: このカスケード メニューを使用すると、最近使用したファイル のリスト (以下参照) とは別に、ユーザーの定義したお気に入りドキュメントのリストを管理できます。
  • 保存: QlikView ファイルの現在の設定を保存します。データ、スクリプト、およびレイアウトが保存されます。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+S。AJAX クライアントを使用している QlikView ドキュメントを共有したい場合、ファイル名にはハッシュ (#) 記号は使用できません。
  • 名前を付けて保存: 新しい QlikView ファイルに新しい名前を付けて現在の設定を保存します。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: F12. AJAX クライアントを使用している QlikView ドキュメントを共有したい場合、ファイル名にはハッシュ (#) 記号は使用できません。
  • サーバー リンクの保存: QlikView Server で開かれているドキュメントへのリンクをローカル マシンにテキスト ファイルとして保存します。ファイルには拡張子 qvw が付きますが、データやレイアウトは含まれません。このようなリンク ドキュメントを開くと、サーバーへの再接続が試みられ、ドキュメントが QlikView Server 上で開かれます。このコマンドはローカル ドキュメントには使用できません。
  • 添付ファイルとして電子メールで送信: ローカル ドキュメントで作業している場合にのみ使用できます。現在の qvw ドキュメントのコピーを添付した電子メールを作成します。メール受信者は、QlikView にアクセスしていて、ドキュメントへのアクセス権がある場合 (セクション アクセス セキュリティが使用されている場合)、qvw ドキュメントを開くことができます。このコマンドが機能するには、コンピュータに電子メール クライアントが設定されている必要があります。
  • ブックマークをリンクとして電子メールで送信: QlikView Server ドキュメントで作業している場合にのみ使用できます。現在のサーバー ドキュメントへの URL リンクを含む電子メールを作成します。レイアウトの状態を含む一時的なサーバー ブックマークが作成され、URL にエンコードされます。メール受信者は、ドキュメントとそのデータへのアクセス権がある場合、URL リンクを使用してサーバー ドキュメントを開き、送信者と同じ内容を確認できます。このコマンドが機能するには、コンピュータに電子メール クライアントが設定されている必要があります。QlikView Server は、サーバー ブックマークを許可する設定になっている必要があります。
  • 印刷: 標準の [印刷] ダイアログ ボックスを表示し、現在のシート オブジェクトを印刷できます。このコマンドはリスト ボックスには使用できません。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+P。
  • PDF として印刷: Microsoft Print to PDF プリンタがあらかじめ選択されている状態で [印刷] ダイアログを開きます。印刷 ボタンをクリックすると、PDF 出力ファイルのファイル名を指定するように要求されます。このコマンドは、PDF プリンタがシステムで使用可能な場合のみ使用できます。 このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+SHIFT+P。
  • 絞込値を印刷: 標準の[印刷] ダイアログが開かれ、現在のリスト ボックスの絞込値 (選択値と連結値) を印刷できます。このコマンドはリスト ボックスにのみ使用できます。
  • 絞込値を PDF として印刷: このコマンドは、リスト ボックスとマルチ ボックスを PDF として印刷する場合に使用します。
  • シートの印刷:[印刷] ダイアログを開き、現在のシートの画像を印刷できます。
  • 印刷プレビュー: 印刷可能なシート オブジェクトのプレビューを表示します。
  • ソース管理:
    • 設定: ソース管理へのプロジェクト追加時、またはソース管理からのプロジェクト取得時に、どの MSSCCI (Microsoft Source Code Control Interface) プロバイダ dll を使用するかを設定します。
    • ソース管理にプロジェクトを追加: 開いている QlikView ドキュメントを保存し、自動的にプロジェクト フォルダとプロジェクト ファイルを作成します。ソース管理にプロジェクトを追加するため、ソース管理システムを呼び出します。
    • ソース管理からプロジェクトを取得: ソース管理からプロジェクトを取得し、プロジェクト ファイルから QlikView ドキュメントをビルドし直します。ソース管理に QlikView データは保存されていません。ドキュメントにデータを読み込むには、ビルドし直したドキュメントで Reload コマンドを実行する必要があります。
    • 最新バージョンの取得: ソース管理から最新バージョンのドキュメントを取得し、QlikView ドキュメントをビルドし直します。
    • 保留中の変更のチェック イン: QlikView ドキュメントを保存し、ソース管理システムへのチェック イン操作を実行します。これには、それぞれのダイアログで行われる 4 つの異なるソース管理操作が含まれます。

      • 新規作成ファイルを追加
      • ソース管理から削除のためにチェック アウトされたファイルを元に戻す
      • ソース管理の一部である削除済みのシートやシート オブジェクトに対応するファイルを削除する
      • 修正したファイルをチェック イン

      保留中の変更のチェック イン操作を行う前のドキュメントが最新でない場合、競合を解消しながら導入されたプロジェクトの変更をロードするためにドキュメントを開き直します。

    • 保留中の変更を元に戻す: 変更を元に戻します。ローカルで変更したファイルがソース管理システムでチェック アウトされていない場合、このファイルはチェック アウトを元に戻す操作を実行する前にチェック アウトされます。この操作は、追加されたけれどもチェック インされていないファイルを削除し、保留中の削除ファイルの参照を復元します。
  • エクスポート:
    • 内容をエクスポート: このオプションは、エクスポート可能なシート オブジェクトがアクティブになっている場合のみ使用できます。その場合、シート オブジェクトの [オブジェクト] メニューにあるエクスポート操作を実行します。
    • シートの画像をエクスポート: 現在のシートのイメージをファイルに保存するためのダイアログを開きます。
    • ドキュメント レイアウトをエクスポート: ドキュメント レイアウトを XML ファイルとして保存するためのダイアログが開きます。保存される XML ファイルには、ドキュメントのデータは含まれません。
  • スクリプトの編集:[ロード スクリプトの編集] ダイアログを開きます。ここでは、データベースを開いて接続するロード スクリプトを入力したり実行することができます。
  • リロード: 現在のロード スクリプトを実行し、データをアクティブな QlikView ドキュメントにリロードします。最後のリロード実行以降にデータベースの内容が変更された場合は、この操作を実行する必要があります。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+R。
  • パーシャル リロード: 例えば drop table など、すべてのスクリプト コマンドを含む現在のロード スクリプトを実行し、データをアクティブな QlikView ドキュメントにリロードします。けれども、ReplaceAdd プレフィックスが付く load や select ステートメントを持つテーブルのみがリロードされます。このタイプの load ステートメントまたは select ステートメントの影響を受けないデータ テーブルは、パーシャル リロードの影響も受けません。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+SHIFT+R。
  • データの縮小: 以下の 2 つのコマンドが含まれるメニューを開きます。
    • 絞込値の維持: 除外されたすべての値を削除することで、QlikView データベースを縮小します。
    • すべての値を削除: QlikView データベースからすべての値を削除し、データベース構造とレイアウトは保持して、テンプレートを作成します。
  • テーブル ビューアー: [テーブル ビューアー] ダイアログが開かれ、このダイアログで、テーブル、項目、関連付けを視覚的に表示してロードされたデータの構造を調べることができます。このコマンドは、次のキーボード ショートカットで呼び出すこともできます: CTRL+T。
  • 最近使用したドキュメントのリスト: 最近使用した QlikView ドキュメントのリスト。表示されるドキュメントの数は、[設定: ユーザー プロパティ] ダイアログで設定できます。既定値は 8 です。リストの中からひとつ選択することは、開くコマンドを使用するのと同じです。
  • 終了: 開いているドキュメントを閉じ、QlikView を終了します。