Przeskocz do zawartości głównej

Przeglądarka tabel

Okno dialogowe Przeglądarka tabel jest otwierane po wybraniu polecenia Przeglądarka tabel z menu Plik lub naciśnięciu klawisza Ctrl T.

The Table Viewer dialog

To okno dialogowe służy do wyświetlania struktury tabeli danych bieżącego dokumentu QlikView. Tabele są wyświetlane jako okna z listą pól, jakie zawierają. Linie konektora między oknami przedstawiają skojarzenia. W miejscach, w których spotykają się co najmniej dwie linie konektora, widoczne są punkty konektora w postaci niewielkich kropek.

Tabele, punkty połączeń oraz wszystkie punkty, w których konektory się zaginają, można przesuwać poprzez przeciąganie i upuszczanie (zob. poniżej). Takie zmiany układu będą zapisywane z dokumentem, chyba że okno dialogowe zostanie zamknięte za pomocą przycisku Anuluj.

Dostępne są dwa widoki, a układy każdego z nich są przechowywane osobno. Te dwa widoki są następujące:

  • Widokiem domyślnym jest Widok tabeli wewnętrznej. Przedstawia on tabele danych w postaci, w jakiej są przechowywane przez program QlikView W tabelach, które mają więcej niż jedno pole wspólne, formowane są złożone klucze syntetyczne. W celu ich łączenia używane są tabele syntetyczne. Ten widok najbardziej ułatwia zrozumienie logiki QlikView i udostępnia bardzo przejrzysty układ, w którym każda para tabel jest połączona maksymalnie jednym konektorem.

    The Internal Table View. Tables are connected at a single point by synthetic keys.
  • Widok tabeli źródłowej przedstawia tabele danych w takiej postaci, w jakiej odczytuje je program QlikView. W tym widoku nie ma pól składni ani tabel syntetycznych Klucze złożone są reprezentowane przez wiele konektorów między tabelami.

    The Source Table View. Tables are connected by multiple connectors.

Umieszczenie wskaźnika myszy nad jednym z pól tabeli spowoduje wyświetlenie podpowiedzi z informacjami na temat zawartości pola:

  • Gęstość informacji to liczba wierszy, które zawierają wartości (tj. inne niż NULL) w tym polu, w porównaniu do łącznej liczby wierszy w tabeli.

  • Stosunek podzbioru to liczba odrębnych wartości tego pola znalezionych w tej tabeli, w porównaniu do łącznej liczby odrębnych wartości tego pola (także w innych tabelach).
  • Komentarze do tabeli są wyświetlane w podpowiedzi.
  • Komentarze do pola są wyświetlane w podpowiedzi.
  • Znaczniki, które zostały dodane w skrypcie albo na stronie Właściwości dokumentu: Tabele, w tym także znaczniki systemowe, które są wyświetlane w podpowiedzi.