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Troubleshooting .NET SDK

This section describes problems that can occur when connecting to the Qlik Sense .NET SDK, as well as suggestion for resolving them.

Troubleshooting connection

Scenario 1

You can not connect to Qlik Sense.

Possible cause  

  • The Qlik Sense installation is improperly.
  • The WebSocket origin white list is not configured.
  • Windows authentication patterns is not configured for Windows.
  • The QMC is not configured with static header.
  • The URI entered during the installation of Qlik Sense does not match the location specified.

  • The credentials entered during the installation of Qlik Sense is not the user making the connection.

Proposed action for Qlik Sense Server

Choose one of the following solutions:

  • Open a browser and navigate to https://server.domain.com. If you do not get the hub on page check your installation.
  • Configure the WebSocket origin white list in the QMC.

    Websocket origin white list is configured

  • Configure Windows authentication patterns by adding Http in the QMC.
  • Configure the static header in the QMC.

    Static header

Proposed action for Qlik Sense Desktop

Verify your Qlik Sense installation by opening a browser and navigate to http://127.0.0.1:4848. The hub should be visualized on page, if not, choose one of the following solutions:

  • Change the location specification to ILocation location = Qlik.Engine.Location.FromUri(new Uri("http://localhost:4848"));

  • Check if the firewall settings are correct for the port numbers.
  • Make sure no IIS (or anything else) is running on default port 80 or 443, since this will conflict with Qlik Sense. In order to run http this has to be enabled in the proxy, through the QMC. Https is the default setting.
  • Check that your local host name or domain wild card is added to the WebSocket origin white list in the remote QMC.

    Websocket origin white list is configured

Open a browser and navigate to http://127.0.0.1:4848. If you still do not get the hub on page reinstall Qlik Sense.

Scenario 2

Exception message contains the following, The remote certificate is invalid according to the validation procedure.

Possible cause  

There is a problem with the website’s security certificate.

Proposed action  

Choose one of the following solutions:

  • Reinstall the Qlik Sense server so that you get a correct certificate.

  • Use a valid certificate.

    Export certificate

  • Install the certificate on your local machine.

  • For testing purpose, set ignore certificate: false to true. Supported from Qlik Sense .NET SDK Version 3.0.

  • Run without encryption by allowing http.

    Set Allow http in the QMC

Scenario 3

Could not connect using non-encrypted authentication. Exception message, Connection failed after 4 attempts. Unable to keep connection open: Failed to ensure open connection: One or more errors occurred.

Possible cause  

Http is not set in the QMC.

Proposed action  

 

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