Skip to main content Skip to complementary content

Troubleshooting mashups built with Qlik Sense Desktop or Qlik Sense Enterprise on Windows

This section describes problems that can occur when creating mashups for Qlik Sense, as well as suggestion for resolving them.

Mashup is empty in Qlik Sense environment

Your mashup is empty when you try to access it in a server environment.

Scenario 1

Possible cause  

The Qlik Sense app does not exist or the app ID is incorrectly referenced in the mashup.

Proposed action  

Add the app to the repository or update the mashup's reference to the app ID.

Scenario 2

Possible cause  

Your environment is set up with a virtual proxy and the prefix has not been added to your mashup files.

Proposed action  

Make sure the host, including the prefix, is included in the three link references in the HTML file. Also, make sure you adjust the HTML configuration in the JavaScript file.

Mashup is empty after copying to Extensions folder

After having copied a mashup to the Extensions folder it do not render, the mashup is empty.

Information noteThis problem can only occur on Qlik Sense Desktop.

Possible cause  

The Qlik associative engine has not been refreshed since copying the mashup to the Extensions folder and therefore, the mashup is not yet available.

Proposed action  

  1. Re-start the Qlik associative engine.
  2. Close Qlik Sense Desktop.
  3. Launch Qlik Sense Desktop again.

Create new button is unavailable

The Create new button in Dev Hub is unavailable and therefore, no new extensions or mashups can be created from Dev Hub.

Possible cause  

You may not have sufficient privileges to create extensions and mashups.

Proposed action  

Add the correct privileges by creating a security rule in Qlik Management Console.

  1. Open Qlik Management Console.
  2. Select Security rules on the QMC start page or from the Start Arrow down drop-down menu to display the overview.

  3. Click Create new Create new in the action bar.

    This opens the Security rule edit page.

  4. In the Identification view, select Extension access rule from the Create from template drop-down list.

  5. In the Basic section, select the Create, Read, Update, and Delete check-boxes as applicable.

    Then, select a user condition that specifies which users the rule will apply to.

  6. In the Identification view, give the security rule a name in the Name text box.
  7. Click Apply in the action bar to create and save the rule, or click Cancel to discard changes.

    Successfully added is displayed at the bottom of the page.

Extension does not work in a mashup on an external web server

An extension used in a mashup hosted on a web server that is different from the one on which Qlik Sense is running.

Possible cause  

The extension is trying to avoid cross-scripting issues by using JSONP.

Example:  

The file in the extension is "styles.css", which will work in a non-cross-site scenario. In a cross-site scenario, RequireJS will look for a "style.css.js" file instead, which typically is not available.

Proposed action  

If you have access to the QMC and can update the extension, wrap the file inside a corresponding js-file. The format required by RequireJS is:

define([], function () { return "the text from the original file";});

Information noteYou must re-install the extension, just putting the file in the folder will not work.

Did this page help you?

If you find any issues with this page or its content – a typo, a missing step, or a technical error – let us know how we can improve!