# 折線圖

![折線圖範例。](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/Resources/Images/ui_gen_IntroLine.png)

圖表是數值資料的圖形表示法。您可以將現有圖表切換為其他表示法，只要變更圖表屬性：一般頁面中的圖表類型即可。

折線圖可使用值點之間的線段、僅使用值點或同時使用線段和值點來呈現資料。折線圖非常適合用於顯示變化或趨勢資料。

建立新折線圖的最快方式，就是從工具功能表中選取快速圖表精靈。

在折線圖上按一下滑鼠右鍵，便會顯示折線圖：物件功能表。折線圖為使用中的物件時，也可以從物件功能表中存取。

另請參閱：

[快速圖表精靈](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Quick_Chart_Wizard.htm)

[圖表類型](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Chart_types.htm)

## 新增圖表

按一下工具列中的建立圖表工具、在空白工作表區域上按一下滑鼠右鍵並選取物件功能表的新增工作表物件、圖表，或選取版面配置功能表的新增工作表物件、圖表，即可建立新圖表。這將開啟一連串的圖表屬性頁面。

在首先出現的頁面中，已設定圖表和標題 (可選) 的名稱和類型，按一下下一步按鈕可開啟第二頁等。輸入足夠的資訊後，就會啟用下一步和/或完成按鈕，而使用者可以按順序前往下一頁或完成。

工作表顯示圖表之後，只要在圖形上按一下滑鼠右鍵並選取屬性，或啟動圖形 (按一下標題區域) 並選取物件功能表中的屬性，即可修改圖表。

## 物件功能表

在圖表上按一下滑鼠右鍵，便會顯示浮動功能表。圖表為使用中時，此功能表也會顯示在物件功能表之下。

功能表包含下列命令：

物件功能表命令

| 命令 | 描述 |
| --- | --- |
| 屬性... | 開啟屬性對話方塊，可在其中設定用於定義圖表的參數。 |
| 備註 | 允許建立和共用目前物件的備註。 |
| 分離 | 圖表標題會附加「(分離)」文字，且圖表不再隨文件中的選項進行更新 (儘管選項實際上是從圖表選取亦不更新)。只有在圖表已連結時才可使用此命令。複製圖表，然後將其分離，即可直接比較複本和原稿的差異。 |
| 連結 | 連結已分離的圖表。圖表會變成動態連結至資料。只有在圖表已分離時才可使用此命令。 |
| 設定參考 | 選擇此選項可設定圖表參考，亦即，含有目前選項的圖表固定繪圖。在文件中進一步選取選項時，參考繪圖會保留，但背景會顯示為灰色。圖表軸等項目將調整為一律涵蓋最大的背景資料集和目前資料集。目前資料集一律繪製在參考繪圖最上層，也就是說，目前資料集繪圖可能會遮蔽使一些參考繪圖部分。背景顯示為灰色的方式可透過參考模式設定來控制，這位於圖表屬性：一般頁面。參考繪圖僅可在部分圖表類型中顯示，例如：長條圖、折線圖、組合圖、雷達圖、散佈圖、格線圖，以及含指針的量測計圖。含有向下探查群組或循環群組的圖表無法設定參考。關閉文件或重新載入資料時，參考值會遺失。使用設定參考選項時，可包含的物件數目上限為 500。 |
| 清除參考 | 設定參考後，此命令將由設定參考命令取代。選擇此選項，則先前的參考設定將予以清除，且圖表將還原成一般繪圖模式。 |
| 再製 | 複製相同的一個圖表。如果再製了分離的圖表，將會連結此再製品。 |
| 順序 | 只有在啟動檢視功能表的設計格線命令、或勾選一律顯示設計功能表項目 (位於使用者喜好設定：設計下方) 時，此串聯功能表才可用。其中包含四個命令，用於設定工作表物件的版面配置圖層。有效的圖層編號為 -128 到 127。<br><br><ul> <li><span>移到最上層</span>：將工作表物件的版面配置圖層設定為目前工作表中任何工作表物件目前所使用的最大值。 </li> <li><span>移到最下層</span>：將工作表物件的版面配置圖層設定為目前工作表中任何工作表物件目前所使用的最小值。 </li> <li><span>上移一層</span>：將工作表物件的版面配置圖層增加一層。最大值為 127。</li> <li><span>下移一層</span>：將工作表物件的版面配置圖層減少一層。最小值為 -128。 <br></li> </ul> |
| 清除所有選項 | 清除圖表中維度和運算式的所有選項。 |
| 列印... | 開啟列印對話方塊，可在其中指定列印設定。 |
| 列印為 PDF... | 開啟已預先選取 Microsoft Print to PDF 印表機的列印對話方塊。按列印按鈕之後，將會提示您輸入 PDF 輸出檔案的檔案名稱。此命令僅在您的系統中有可用的 PDF 印表機時才可供使用。 |
| 將值傳送至 Excel | 將基礎資料 (相當於圖表的連續表) 匯出至 Microsoft Excel，若 Excel 尚未執行，系統會自動啟動該程式。表格會顯示為新的 Excel 工作表。若要使此功能正常運作，請務必在電腦中安裝 Microsoft Excel 2007 或以上版本。 |
| 匯出... | 開啟對話方塊，將圖表的影像儲存為檔案。影像可另存為 png、jpg、bmp 或 gif 檔。 |
| 複製至剪貼簿 | 此串聯功能表包含工作表物件的各種複製選項。<br>值<br>以表格形式將值複製到剪貼簿。<br>影像<br>將圖表物件的影像複製到剪貼簿。視使用者喜好設定：輸出頁面中的設定而定，影像可能會包含或排除工作表物件的標題和框線。<br>物件<br>將整個工作表物件複製到剪貼簿，並貼到版面配置的其他處，或者貼到 QlikView 目前執行個體內所開啟的其他文件上。 |
| 連結物件 | 以下列命令開啟連結物件的功能表。<br><br><ul> <li><span>調整連結物件的位置</span>：將所有工作表上的所有連結物件調整至與醒目提示項目相同的位置與大小。 <br></li> <li><span>取消連結此物件/取消連結物件</span>：解除物件之間的連結，使其成為具有不同物件識別碼的不同物件。 </li> </ul> |
| 最小化 | 圖示化物件。按一下物件標題 (如有顯示) 中的 the Minimize icon 圖示會產生相同的效果。只有在標題頁面中的物件屬性對話方塊允許使用最小化時，此命令才可供使用。 |
| 最大化 | 將物件放大至填滿工作表。按一下物件標題 (如有顯示) 中的 the Maximize icon 圖示會產生相同的效果。只有在標題頁面中的物件屬性對話方塊允許使用最大化時，此命令才可供使用。 |
| 還原 | 將最小化或最大化物件還原為先前的大小和位置。按兩下最小化物件圖示，或者按一下最大化的物件標題 (如有顯示) 中的 the Restore icon 圖示會產生相同的結果。此命令僅適用於最小化或最大化物件。 |
| 說明 | 開啟 QlikView 說明。 |
| 移除 | 從工作表移除工作表物件。 |

## 圖表屬性：一般

在一般頁面上，您可以設定標題和圖表類型之類的屬性。這是快速圖表精靈和圖表屬性對話方塊的第一頁。

一般圖表屬性

| 屬性 | 描述 |
| --- | --- |
| 視窗標題 | 將在視窗標頭顯示的標題。 標題也可定義為供標籤文字動態更新的計算公式。按一下 ... 按鈕可開啟編輯會運算式對話方塊，以便編輯長公式。<br><br>[計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 顯示圖表中的標題 | 依預設，定義的第一運算式標籤會設為與圖表標題相同。如果不應顯示圖表標題，請清除此核取方塊。若要顯示原始標題，只要勾選此核取方塊即可。標題也可定義為供標籤文字動態更新的計算公式。按一下 ... 按鈕可開啟編輯會運算式對話方塊，以便編輯長公式。 樞紐分析表或連續表不會顯示圖表標題。<br><br>[計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 標題設定 | 按一下標題設定按鈕，即可定義圖表標題的進階設定。 |
| 列印設定 | 按一下列印設定按鈕將開啟列印設定對話方塊，可在其中定義邊界和頁首/頁尾格式。列印設定對話方塊有兩個頁面：列印版面配置及列印頁首/頁尾。<br><br>[列印：版面配置](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Print_Layout.htm) 及 [列印：頁首/頁尾](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Print_Header_Footer.htm) |
| 輪替狀態機 | 在清單中選擇其中一個可用的狀態。下列輪替狀態機一律可供使用。<br><br><ul> <li><span>繼承</span>：除非 QlikView 開發人員覆寫，否則工作表和工作表物件一律處於<span>繼承</span>狀態。此設定是從上一層物件所繼承，若選擇繼承選項，工作表中的圖表即可取得與該工作表相同的設定。 </li> <li><span>預設狀態</span>：此為大部分使用 QlikView 會發生的狀態，以 $ 表示。QlikView 文件一律處於<span>預設狀態</span>。 </li> </ul> |
| 物件識別碼 | 此作為巨集用途。每個工作表物件都會指派一組唯一識別碼。我們建議您僅使用英數字元作為 ID。 連結物件會共用相同的物件識別碼。您可以稍後再編輯此識別碼。<br><br>圖表的識別碼從 CH01 開始。<br><br>[內部巨集解譯器](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm) |
| 分離 | 如果啟用將會分離圖表，也就是說，圖表不會再隨著進行選取時動態更新。 |
| 唯讀 | 如果啟用，圖表將變成唯讀，也就是說在圖表中按一下滑鼠或繪製無法進行選取。 |
| 計算條件 | 在此文字方塊中輸入運算式，會設定要顯示圖表所需符合的條件。若沒有符合條件，「未符合計算條件」文字將會顯示在圖表中。 輸入的值可作為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。 |
| 圖表類型 | 您可以在圖表類型群組中選取圖表的基本版面配置。如需各個圖表類型的詳細資訊，請參閱[圖表類型](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Chart_types.htm)。 |
| 快速類型變更 | 在此群組中，您可以在圖表中啟用圖示，使用者可以使用此圖示變更圖表類型，不需要移至圖表屬性對話方塊。<br><br><ul> <li><span>允許的類型</span>：在此清單中，您可以選取下拉式清單中應該出現的圖表類型。必須選擇兩個以上的類型，才能啟用快速類型變更。 </li> <li><span>喜好的圖示位置</span>：在圖形圖表中，可以將快速類型變更圖示放在圖表內或工作表物件標題中。在表格圖表中，標題是唯一的替代選項。 </li> </ul> |
| 重設使用者調整大小 | 按此按鈕之後，將重設圖形圖表中圖例和標題等等所有的使用者調整大小。個別物件的停駐將不受影響。 |
| 重設使用者停駐 | 按此按鈕之後，將重設圖形圖表中圖例和標題等等所有的使用者停駐。 |
| 錯誤訊息 | 開啟自訂錯誤訊息對話方塊。<br><br>[自訂錯誤訊息](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Custom_Error_Messages.htm) |
| 參考模式 | 從圖表的內容功能表中使用設定參考選項時應該如何繪製參考背景的設定。此選項僅適用於某些圖表。 |

另請參閱：

[調整圖表元件大小與移動圖表元件](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Sizing_and_moving_chart_components.htm)

[圖表與表格中的選項](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Selections_in_charts_and_tables.htm)

## 圖表屬性：維度

圖表屬性：維度頁面的開啟方式是：以滑鼠右鍵按一下圖表並選取屬性，或在圖表為作用中時，選取物件功能表中的屬性。

當您建立圖表時，應該先問自己兩個問題：

* 您想要查看什麼？長條圖中的長條應該有多大？答案會是「銷售額加總」或其他類似的答案。這是在運算式標籤上設定的。
* 您要依據什麼標準進行分組？您要讓哪些欄位值做為長條圖之中長條的標籤？答案會是「按照國家」或其他類似的答案。這是在維度標籤上設定的。

圖表可以顯示一或多個維度。上限取決於實際圖表類型、資料的複雜度和可用的記憶體。圓形圖、折線圖和散佈圖最多可以顯示兩個維度，長條圖、方塊圖和格線圖則可顯示三個維度。雷達圖和漏斗圖只能顯示一個維度，而量測計圖完全不使用維度。其他維度則予以忽略。

圖表維度會從 圖表屬性：維度頁面上指定的欄位獲取其值。一個維度不限於只能有一個欄位，也可以包含一組欄位 (請參閱下文的編輯群組)。

維度可以是一個欄位、一組欄位或一個運算式 (計算維度)。它也可以是合成建立的維度

選取 (按一下，或按住 Ctrl 並按一下) 並使用新增&gt; 或 &lt;移除按鈕，或直接按兩下選項，即可來回移動欄位。

圖表維度也可從運算式計算得出。

維度屬性

| 屬性 | 描述 |
| --- | --- |
| 可用欄位/群組 | 列出可做為維度 (亦即沿著一般長條圖的 X 軸) 的所有欄位/欄位群組。在欄位群組中，向下切入群組前面有一個垂直箭頭，循環群組前面有一個彎箭頭。<br><br>群組是在 文件屬性︰群組頁面中定義。 按一下所需項目即可選取要使用/移除的項目。使用新增 &gt; 或 &lt; 移除按鈕將其移至所需的資料行。<br><br>不同圖表類型可以顯示的維度數各不相同。<br><br>多個內部表格中出現的所有欄位前面會有鑰匙符號。圓形圖、折線圖和散佈圖無法顯示兩個以上的維度。在長條圖中，最多可顯示三個維度。<br><br>[文件屬性：群組](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Groups.htm) |
| 顯示系統欄位 | 勾選此選項將會顯示可用欄位/群組資料行中的系統欄位。 |
| 從表格中顯示欄位 | 您可以在此處控制哪些欄位/群組出現在可用欄位/群組清單中。下拉式清單預設會顯示替代的所有表格。<br><br>替代的所有表格 (合格的) 會顯示所屬表格名稱限定的欄位，這表示索引鍵 (連接) 欄位將列出不只一次。(此替代選項僅用於檢視用途，與載入指令碼中的[Qualify](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptRegularStatements/Qualify.htm) 欄位毫無關聯。)<br><br>亦可一次檢視一個表格的欄位。請注意，可用的群組一律都會列出。 |
| 編輯群組... | 此按鈕可以直接開啟文件屬性：群組頁面，可在其中定義要用作維度的欄位群組。 |
| 動畫... | 開啟動畫對話方塊之後，即可將圖表的第一維度用於動畫。動畫只能用於圓形圖以外的點陣圖圖表。使用動畫有一些功能限制。 |
| 細網紋... | 開啟細網紋設定對話方塊，您可以在其中按照第一維度建立圖表的陣列。任何類型的點陣圖圖表都可以變成細網紋顯示。 |
| 已使用的維度 | 此清單包含目前選取做為圖表維度的維度。各種類型的圖表可用的維度數各不相同。任何指定類型的多餘維度將予以忽略。<br><br>在表格中使用維度時，透過屬性運算式可以動態設定維度資料儲存格的格式。只要在維度輸入屬性運算式，圖示就會從灰階轉為彩色，如果是文字格式，則會從灰階轉為黑色。這些設定的優先順序高於圖表設定。按一下任何維度前面的 "+" 展開圖示，即可顯示維度屬性運算式的預留位置。<br><br><ul> <li><span>背景色彩</span>：按兩下<span>背景色彩</span>即可輸入屬性運算式，以計算維度儲存格的維度背景色彩。使用的運算式應會傳回有效的色彩呈現 (表示紅綠藍三原色的數字，如 Visual Basic 中所定義)。使用其中一個特別的圖表色彩函數即可進行。如果運算式的結果並非有效的色彩呈現，程式將使用預設的黑色。 </li> <li><span>文字色彩</span>：按兩下<span>文字色彩</span>即可輸入屬性運算式，以計算維度儲存格的維度文字色彩。使用的運算式應會傳回有效的色彩呈現 (表示紅綠藍三原色的數字，如 Visual Basic 中所定義)。使用其中一個特別的圖表色彩函數即可進行。如果運算式的結果並非有效的色彩呈現，程式將使用預設的黑色。 <p><a href="https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm">色彩函數</a></p></li> <li><span>文字格式</span>：按兩下<span>文字格式</span>可輸入屬性運算式，以計算各個維度儲存格中表格儲存格的文字字型樣式。做為文字格式運算式的運算式對於粗體文字會傳回包含 '&lt;B&gt;' 的字串、對於斜體文字會傳回包含 '&lt;I&gt;' 的字串，和/或對於底線文字會傳回包含 '&lt;U&gt;' 的字串。 <br></li> </ul><br><br>按一下升階和降階按鈕之後，即可排序已使用的維度清單中的維度。 |
| [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Line_Chart.htm) [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Line_Chart.htm)新增計算維度... | 新增維度並將其開啟，以便在編輯運算式對話方塊中進行編輯。圖表維度通常在一個欄位中，但是也可以動態計算。計算維度包含涉及一或多個欄位的運算式。所有標準函數均可使用。不可使用彙總函數，但是可加入Aggr函數進行巢狀彙總。<br><br>[計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 編輯... | 開啟維度以便在編輯運算式對話方塊中進行編輯。如需計算維度的詳細資料，請參閱上文的新增計算編輯...。 |
| 所選維度的設定 | 在此群組中，您可以找到個別維度的設定。<br><br>啟用條件式：勾選此核取方塊後，按下方編輯方塊中的 ... 按鈕，即會根據輸入的條件運算式值動態地隱藏或顯示維度。<br><br>值為 NULL 時隱藏：如果啟用此核取方塊，則上方已使用的維度中所選取的維度值若為 NULL，將不會顯示在圖表中。<br><br>顯示所有值：啟用此核取方塊可顯示任何選項的所有維度值。由於排除維度值的運算式值為零，因此必須取消選取呈現方式頁面的隱藏零值選項，這樣顯示所有值才會有作用。若您使用運算式作為維度，顯示所有值將不適用。<br><br>顯示圖例：勾選顯示圖標時，將會沿著 X 軸顯示欄位值的「名稱」。<br><br>標籤：勾選標籤選項之後，將顯示欄位的名稱。在下方的文字方塊中可編輯標籤。此外，也可以將標籤定義為供標籤文字動態更新的計算標籤運算式。按一下 ... 按鈕，即可開啟編輯運算式對話方塊，以便編輯長公式。如需詳細資訊，請參閱 [計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)<br><br>進階…：此按鈕會開啟進階欄位設定對話方塊，其中提供欄位值影像表示法和特殊文字搜尋選項的設定。如需詳細資訊，請參閱 [Advanced Field Settings](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Advanced_Field_Settings.htm)<br><br>註解：註解欄位可以用來描述選取的維度。可以將註解輸入為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。<br><br>分頁符號：此設定僅適用於在樞紐分析表或連續表的列印成品中加入分頁。其中有三個模式可供使用，效果如下：<br><br><ul> <li><span>無分頁</span>：視需要只在每頁的頁尾插入分頁符號。 </li> <li><span>條件式分頁</span>：除了後續維度值的所有列均可容納於目前頁面之外，才插入分頁符號。 </li> <li><span>強制分頁</span>：無論維度值如何變更，均插入分頁符號</li> </ul> |

## 圖表屬性：維度限制

可以設定圖表類型的維度限制，但是量測計圖和樞紐分析表除外。

維度限制標籤能夠控制可在指定圖表中看見的維度値數目。

探討這一點之前，必須先描述下拉式清單的三個選項所產生的效果。下拉式清單包含三個值：第一個、最大和最小。這些值可以控制計算引擎對於傳回到圖表引擎的値進行排序的方式。如果要限制維度，必須選取以上其中一個選項。當主要排序可能會覆寫第一維度排序時，便只會對第一個運算式進行排序，而不會對樞紐分析表進行排序。

此屬性頁面可以用來定義維度限制。圖表中的各個維度都是個別設定的。

### 限制

#### 限制使用第一個運算式時要顯示的值

這些屬性可用來決定要根據下方所做的設定在圖表中顯示多少維度值。

#### 僅顯示

如果要顯示最前 x 個值、最大的 x 個值或最小的 x 個值，請選取此選項。如果將此選項設為 5，則會顯示五個值。如果維度啟用了顯示其他選項，則「其他」區段會佔據五個顯示槽之中的一個。 最前選項會根據在屬性對話方塊的排序標籤上所選的選項傳回列。如果圖表為連續表，則會根據當時的主要排序來傳回列。換言之，使用者按兩下任何資料行標頭即可變更顯示的值，並使該資料行成為主要排序。最大選項會根據圖表中第一個運算式以遞減順序傳回列。若在連續表中使用，則在運算式進行互動式排序的同時，顯示的維度值會維持一致。若運算式的順序變更，維度值也 (可能) 會變更。最小選項會根據圖表中第一個運算式以遞增順序傳回列。若在連續表中使用，則在運算式進行互動式排序的同時，顯示的維度值會維持一致。若運算式的順序變更，維度值也 (可能) 會變更。輸入要顯示的值的數量。 輸入的值可作為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。

#### 僅顯示符合以下條件的值：

選取此選項以顯示所有符合此選項特定條件的維度值。選取即可根據總計百分比或確切金額來顯示值。相對於總計選項可啟用相對模式，類似於該屬性對話方塊中運算式標籤上的相對選項。 輸入的值可作為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。

#### 僅顯示累積至以下的值：

選取此選項後，系統會累積目前列為止的所有列數，而結果會與此選項中設定的值進行比較。相對於總計選項可啟用相對模式，類似於該屬性對話方塊中運算式標籤上的相對選項，並將累積值 (根據第一個、最大或最小值) 與整體總計進行比較。輸入的值可作為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。 選取包含界限值可包含具有比較值的維度值。

[計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

資訊備註計算累積限制加總時，將不包含負值。對於具有負值的欄位，建議不要使用相對限制。

資訊備註如果您對計算維度的新增限制，且資料是以相同的計算維度排序，則會在套用排序順序前先套用該維度限制。

### 選項

#### 顯示其他

啟用此選項，將會在圖表中產生其他區段。所有不符合顯示限制比較準則的維度值，都將會分組到其他區段中。如果選取的維度之後還有維度，可使用摺疊內部維度控制是否要在圖表上顯示後續/內部維度的個別值。在標籤欄位中，輸入要顯示在圖表中的名稱。若未輸入文字，便會將標籤自動設為運算式文字。  
輸入的值可作為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。

#### 顯示總計

啟用此選項時，圖表中將會顯示所選維度的總計值。此總計的作用與運算式總計不同，仍需在屬性對話方塊的 **運算式** 標籤上進行設定。 **標籤**: 輸入要顯示在圖表中的名稱。若未輸入文字，便會將標籤自動設為運算式文字。 輸入的值可作為計算公式。按一下 ... 按鈕可開啟編輯運算式對話方塊。

#### 全域群組化模式

該選項僅適用於內部維度。啟用此選項時，僅會在選取的維度上計算限制，先前所有的維度都將予以忽略。如果停用此選項，則會根據前面所有的維度來計算限制。

## 運算式總計相較維度總計

維度總計是由計算引擎產生的，然後會傳回到圖表引擎成為個別列 (或維度值)。這會影響 [其他] 列。使用運算式總計和維度總計的差別如下所示。

![Example comparison between expression totals and dimension totals, which are separated by dimension](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/Resources/Images/ui_gen_Totals.png)

運算式總計與維度總計

使用維度總計時，連續表可以有小計。

## 圖表屬性：運算式

若要開啟圖表屬性：運算式標籤，請以滑鼠右鍵按一下圖表或表格，然後從物件功能表選取屬性。

建立圖表時，應該考量兩個問題：

* 長條等圖形的呈現大小應為何？這些是指運算式 (例如 sum of NetSales)。
* 資料應該如何分組？這些是指維度 (例如，按照國家/地區)。

資訊備註不同圖表及表格類型的運算式標籤看起來不盡相同。如果選項反灰，表示無法供特定圖表或表格類型使用。

### 運算式清單

左上方窗格中的運算式清單是包含許多控制選項的完整樹狀結構控制項。

各個運算式 (或運算式群組) 前面會顯示展開圖示 (標示 '+' 的方塊)。按一下圖示就會開啟基礎的子運算式或屬性運算式。同時此圖示會變成摺疊圖示 ('-')。某些繪圖選項使用子運算式，也就是由兩個以上共同定義繪圖符號 (例如下述的股票或盒狀圖) 的一組運算式。

透過屬性運算式也可以動態設定運算式資料的格式。按一下任一運算式前的展開圖示，可顯示維度屬性運算式的預留位置。此類功能包括：

#### 背景色彩

編輯預設背景色彩運算式即可建立屬性運算式，以計算資料點的繪圖色彩。計算色彩的優先順序高於預設的 QlikView 色彩選項，且必須是使用色彩函數進行的有效色彩呈現。如果運算式的結果並非有效的色彩呈現，程式將使用預設的黑色。使用同一個方法可以建立文字色彩的輔助運算式。

[色彩函數](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

#### 文字色彩

使用背景色彩的同一個方法可以建立文字色彩的輔助運算式 (見上文)。

#### 文字格式

編輯文字格式運算式即可輸入屬性運算式，以計算與資料點相關聯的文字字型樣式 (若是表格：則針對各個維度儲存格輸入表格儲存格中的文字。計算文字格式的優先順序高於樣式。

做為文字格式運算式的運算式對於粗體文字會傳回包含 '&lt;B&gt;' 的字串、對於斜體文字會傳回包含 '&lt;I&gt;' 的字串，和/或對於底線文字會傳回包含 '&lt;U&gt;' 的字串。請注意，字串前面必須有 =。

#### 圓形圖快顯

按一下圓形圖彈出視窗即可輸入屬性運算式，以計算是否應該在擷取的「彈出視窗」位置中繪製與資料點相關聯的圓形切片。這類屬性運算式只會影響圓形圖。

#### 長條位移

按一下長條位移即可輸入屬性運算式，以計算與資料點相關聯之長條或長條區段的位移。位移可以是正位移，也可以是負位移，長條或區段將會據此移動。這在繪製所謂的瀑布圖時相當實用。這類屬性運算式只會影響長條圖。

#### 行樣式

按一下線條樣式即可輸入屬性運算式，以計算與資料點相關聯之線條或線段的線條樣式。這類屬性運算式只會影響折線圖、組合圖和雷達圖。加入 &lt;Wn&gt; 標記可以控制線條的相對寬度，其中 n 是套用於圖表預設線條寬度的乘數。數字 n 必須是介於 0.5 與 8 之間的實數。

範例： &lt;W2.5&gt;

加入 &lt;Sn&gt; 標記可以控制線條的樣式，其中 n 是介於 1 與 4 之間的整數，表示將使用的樣式 (1=實線，2=虛線，3=點狀線，4=虛線/點狀線)。例如：&lt;S3&gt;。&lt;Wn&gt; 和 &lt;Sn&gt; 標記可以自由組合，但是只有第一個標記才有意義。標記必須使用單引號括起來。

#### 顯示值

按一下顯示值即可輸入屬性運算式，以計算是否應該在即使尚未對於主要運算式選取資料點上的值的情況下，以「資料點上的值」值補強資料點繪圖。如果主要運算式已選取資料點上的值，則將忽略屬性運算式。這類屬性運算式只會影響長條圖、折線圖、圓形圖、漏斗圖及組合圖。

### 新增

新的運算式及子運算式，是透過新增按鈕建立的。在以滑鼠右鍵按一下運算式清單時出現的內容功能表中，也可以使用此選項。

### 刪除

刪除按鈕可以讓您移除清單中先前建立的運算式。在以滑鼠右鍵按一下運算式清單中的運算式時出現的內容功能表中，也可以使用此選項。

### 複製

只有在以滑鼠右鍵按一下運算式清單中的運算式或子運算式/屬性運算式時出現的內容功能表中，才可以使用複製選項。對於主要運算式使用此命令時，會將與運算式相關聯的所有資料和設定 (包括標籤) 複製到剪貼簿中，成為 xml 的一部份。

然後會將運算式貼回同一個文件或其他文件的圖表或其他任何 QlikView 圖表中。如果對於屬性運算式使用此命令，只會複製屬性運算式定義。接著可以將屬性運算式貼到同一個或其他圖表中的任何主要運算式。

### 匯出...

只有在以滑鼠右鍵按一下運算式清單中的運算式時出現的內容功能表中，才可以使用匯出... 選項。對於主要運算式使用此命令時，會將與運算式相關聯的所有資料和設定 (包括標籤) 匯出到 xml 檔。

接著可以將運算式匯入回同一個文件或其他文件的同一圖表或其他任何 QlikView 圖表中。此命令會開啟將運算式匯出為對話方塊，您可在其中選擇匯出檔案的目的地。檔案將會有副檔名 Ex.xml。

### 貼上

只有在以滑鼠右鍵按一下運算式清單中的運算式和/或子運算式/屬性運算式時出現的內容功能表中，才可以使用貼上選項。如果先前已經將主要運算式複製到剪貼簿，您可以在運算式清單的空白區域中將它貼上，即可建立一個和複製項相同的新運算式。如果已經複製屬性運算式，您可以在主要運算式中將它貼上。

### 匯入

只有在以滑鼠右鍵按一下運算式清單中的空白區域時出現的內容功能表中，才可以使用匯入選項。此命令會開啟對話方塊，您可在其中瀏覽先前匯出的運算式。匯入的運算式將成為圖表中的新運算式。

### 升階/降階

如果顯示數個運算式，按一下升階和降階按鈕即可進行排序。這會影響資料行等項目在圖表中顯示的順序。

### 群組

如果有兩個以上的運算式可供使用，群組按鈕可用來將多個運算式合併為一個或多個循環群組。在 QlikView 版面配置中，您可以按一下圖表中顯示的循環按鈕，循環顯示屬於一個群組的運算式 (= 循環群組)。以滑鼠右鍵按一下同一個循環圖示，會出現一個快顯視窗清單，其中列出目前不使用的群組所屬的運算式，以便直接選取。

資訊備註

請勿混淆循環群組 (Cycle Group) 與循環群組 (Cyclic Group)！

[非階層式群組 (循環)](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Nonhierarchic_groups_cyclic.htm)

### 取消群組

選取群組所屬的運算式，並按一下取消群組，便會將該運算式抽離群組。如果抽離後只剩一個運算式在循環群組中，也會將最後一個運算式抽離，並且移除群組。

### 啟用

停用此核取方塊，會將該運算式設定為從圖表中省略。

### 相對

啟用此核取方塊，會將圖表設定為以百分比顯示結果，而非以絕對數顯示。此選項不適用於樞紐分析表。

### 隱藏

啟用此核取方塊就不會繪製此運算式，同時保留為此運算式分配的空間。

### 條件式限制

啟用此核取方塊即可以目前選項為基礎定義條件，從而決定是否顯示運算式。若條件評估為 TRUE 或 NULL，則會顯示運算式，若條件評估為 FALSE，則不會顯示運算式

### 標籤

在運算式標籤前面，會使用一或多個圖示來表示該運算式已使用圖表類型及/或選取顯示選項 (見下文)。

### 定義

顯示所選運算式的組合。在此方塊中可以直接編輯運算式。按一下 ... 按鈕之後，將會開啟完整的編輯運算式對話方塊。

### 註解

此註解欄位可供運算式的建立者描述運算式的用途和功能。

### 顯示選項

此群組可用來修改繪製資料點的方式或將在圖表表格的運算式儲存格中輸入的內容。請注意，某些選項僅適用於某些圖表類型，某些選項無法組合併用，而某些選項將利用一或多個其他運算式建立複雜的繪圖。

#### 長條

以長條顯示所選運算式的值。此選項僅適用於長條圖和組合圖。

#### 符號

以符號顯示所選運算式的值。此選項僅適用於折線圖和組合圖。下拉式功能表中有數個不同的符號可選擇。

#### 線條

以線條顯示所選運算式的值。此選項僅適用於折線圖和組合圖。下拉式功能表中有一般、平滑和三種不同的平展線條可選擇。

#### 股票圖

勾選此核取方塊，會以股市標記繪製運算式。運算式清單中的運算式前面會標示自己的圖示，並且顯示為有四個子運算式的空白預留位置。

第一個子運算式將用來繪製股票標記的高點。第二個子運算式將用來繪製低點。這兩個子運算式必須包含有效的定義，才能繪製股票標記。

第三個子運算式是選用的，不過可以用來繪製股票標記的收盤點。第四個子運算式也是選用的，不過可以用來繪製股票標記的開盤點。

勾選運算式的股票核取方塊時，將自動建立新的空白子運算式。為運算式選取股票核取方塊之後，您無法為同一個運算式選取長條、線條、符號、盒狀圖或出現誤差線核取方塊。如果運算式已選取其中任何一個選項，則無法為該運算式選取股票核取方塊。此選項僅適用於組合圖。

#### 盒狀圖

勾選此核取方塊，會以通常用來顯示統計資料的盒狀圖來繪製運算式。運算式清單中的運算式前面會標示自己的圖示，並且顯示為有五個子運算式的空白預留位置。

第一個子運算式將用來繪製盒狀圖的盒狀頂點。第二個子運算式將用來繪製盒狀底點。這兩個運算式必須包含有效的定義，才能繪製盒狀圖。

第三個到第五個子運算式是選用的。使用這些運算式將定義中間值、較高鬚值和較低鬚值。

盒狀圖的一般延伸就是極限值所謂的極端值。將個別運算式繪製為符號，即可呈現這些值。為主要運算式勾選盒狀圖時，將自動建立新的空白子運算式。為運算式選取盒狀圖之後，您無法為同一個運算式選取長條、線條、符號、股票或出現誤差線核取方塊。如果運算式已選取其中任何一個選項，則無法為該運算式選取盒狀圖。此選項僅適用於組合圖。

#### 出現誤差線

勾選此核取方塊，可以利用所選運算式之後的一或兩個運算式，做為在主要運算式資料點頂端繪製的誤差線所用的輔助運算式。如果選取 [對稱]，將只會使用一個輔助運算式，並圍繞資料點對稱繪製。如果選取 [非對稱]，將使用兩個輔助運算式，分別在資料點的上下位置繪製。

誤差線運算式應該會傳回正數。在 [運算式] 清單中，用於誤差線的輔助運算式前面會標示自己的圖示 (對稱)、(非對稱高) 或 (非對稱低)，而且無法用於圖表中的其他任何數值。如果選取的運算式之後沒有定義的運算式，將自動建立新的模擬輔助運算式。此選項僅適用於長條圖、折線圖和組合圖。

#### 資料點上的值

勾選此核取方塊，可以將運算式的結果繪製為資料點頂端的文字。此選項僅適用於長條圖、折線圖、組合圖和圓形圖。此值用於圓形圖時，將在圓形切片旁邊顯示。

#### 座標軸上的文字

勾選此核取方塊，可以將運算式的結果繪製為各個 X 軸值、軸和軸標籤的文字。此選項僅適用於長條圖、折線圖和組合圖。

#### 快顯文字

勾選此核取方塊，可以將運算式的結果顯示在快顯視窗提示氣球訊息中，將游標暫留在版面配置中的圖表資料點上時，就會出現該訊息。無論是否藉由其他任何顯示選項，都可以使用此選項。因此，可以使運算式不出現在圖表中，而出現在暫留快顯視窗中。

#### 表示法

此選項僅適用於連續表和樞紐分析表。

#### 文字

一律會解譯運算式值並顯示為文字。

#### 影像

藉由此選項，QlikView 會嘗試將各個運算式值解譯為影像的參考。此參考可以是影像檔案在磁碟上的路徑 (例如 C:\Mypic.jpg)，也可以是 QlikView 文件中的路徑 (例如 qmem://&lt;Name&gt;/&lt;Peter&gt;)。如果 QlikView 無法將運算式值解譯為有效的影像參考，除非已勾選遺失影像時隱藏文字方塊，否則將直接顯示該值。

#### 循環量測計、線性量測計、號誌燈量測計、LED 量測計

使用這些量測計選項，量測計圖會內嵌於可用的表格儲存格中做為影像。若要修改量測計的版面配置，可以在圖表屬性：呈現方式對話方塊中進行，這從量測計設定按鈕開啟。

#### 迷你圖

透過此選項，QlikView 將以長條圖或折線圖顯示運算式值。量表圖會內嵌於可用的表格儲存格中。圖表的視覺設定，可以透過迷你圖表設定按鈕進行修改。此選項僅適用於連續表。

[Mini chart settings](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Sparkline_Settings.htm)

資訊備註匯出至 Excel 時，將不會顯示迷你圖！

#### 連結

選取此選項，將在定義欄位中輸入運算式，這將在表格儲存格中建立可點擊的連結。運算式應會傳回可解譯為 DisplayText&lt;url&gt;LinkText 的文字。DisplayText 將顯示在表格儲存格中，LinkText 會成為在新的瀏覽器視窗中開啟的連結。

如果定義連結，表格儲存格中的值將加上底線。如果不定義連結，該值將不會加上底線。請注意，在連結處於顯示模式的儲存格中，無法進行選取。按一下 ... 按鈕之後，將會開啟完整的編輯運算式對話方塊。

資訊備註由於安全性限制，URL 連結僅在 Ajax 用戶端中運作。

範例：

=Name & '&lt;url&gt;' & Link

=Name & '&lt;url&gt;www.qlikview.com'

其中 Name 和 Link 是指令碼中載入的表格欄位。

#### 影像格式設定

只有在選取以上影像選項時才可使用。此選項僅適用於連續表和樞紐分析表。此設定描述 QlikView 如何將影像的格式設定為符合儲存格大小。總共有四個替代選項：

* 無延展：如果選取此選項，則影像將依照原樣顯示，不進行任何延展。這可能會使影像中的某些部份無法顯示，或者儲存格僅顯示部分影像。
* 填滿：如果選取此選項，則影像將延展為符合儲存格大小，但不保留影像外觀比例。
* 保持比例：如果選取此選項，則影像將盡可能延展至符合儲存格大小，同時保留影像外觀比例。
* 保持比例填滿：如果選取此選項，則影像長寬兩個方向將延展至符合儲存格大小，同時保留影像外觀比例。這通常會造成影像其中一個方向遭到裁切。

### 累積

選擇此群組中的設定之後，您可以決定是否累積圖表中的值。在累積的圖表中，各個 Y 值將新增到下列 X 值的 Y 值。例如，在顯示每年銷售總額的累積長條圖中，1996 年的值z 新增到 1997 年的值。

如果圖表包含數個運算式，請選取將在 [運算式] 清單中累積值的運算式。累積不適用於樞紐分析表。

#### 無累積

如果選取此選項，將不會累積所選圖表運算式的 Y 值。

#### 完全累積

如果選取此選項，各個 Y 值將累積運算式所有先前的 Y 值。請參閱上文的累積。完整累積不適用於包含 NULL 或 0 值的多個維度。

資訊備註完整累積在啟用圖表細網紋時不適用。

#### 累積先前 n 個步驟

在方塊中輸入數字之後，即可設定將累積的運算式 Y 值數。請參閱上文的累積。

### 總計模式

只有針對連續表圖表物件的所選運算式才會啟用此群組。有三個可能的設定：

* 無總計：不會計算選取的運算式總計。
* 運算式總計：在下一個層級評估運算式的總計。例如，如果某運算式產生多位員工的平均每月薪資，則運算式總計將產生所有薪資的平均總計。
* 列的 F(x)：如果選取此選項，將使用從下拉式清單選取的彙總函數 (一般加總) 累積所選運算式各個資料點的個別值 (長條圖中的各個長條、連續表中的各列等等)。

資訊備註第一個字串或最後一個字串是在表格中找到的最高或最低的值，按字母順序排序。按字母順序排序從 0 至 9 開始，後面是 A 至 Z。

### 長條框線寬度

指定此運算式在長條圖和組合圖中繪製長條的框線寬度。可以指定公釐、公分、英吋 (")、像素 (px、pxl)、點 (pt、pts) 或文件單位 (du) 做為該值的單位。

### 圖例運算式

使用數個運算式時，此選項會在圖表旁邊顯示一個圖例，用來呈現運算式及其對應色彩。

### 趨勢線

在選取的 QlikView 圖表中，統計趨勢線可以補強或取代運算式繪圖。

只有在散佈圖、折線圖，以及最多一個維度和一個運算式顯示為長條的長條圖/組合圖中，才會顯示趨勢線。若是其他類型的圖表，趨勢線群組中的設定並不適用，而且不會有作用。在散佈圖中，資料點會視為 y=f(x)。若是長條圖、折線圖和組合圖，可以取消選取顯示選項下的所有選項，而且仍然可以新增不需要基礎資料點即可繪製的趨勢線。指定預測和/或回測間隔 (軸頁面) 即可外插長條圖、折線圖和組合圖中的趨勢線。外插的線條將會是點狀線。離散 X 軸的圖表中出現的趨勢線將以標示符號的線條呈現。這條線只會顯示在一個連續軸上。

* 平均：將平均繪製為直線。
* 線性：繪製線性迴歸線。
* 二次多項式：繪製第 2 度的多項式趨勢線。
* 三次多項式：繪製第 3 度的多項式趨勢線。
* 四次多項式：繪製第 4 度的多項式趨勢線。
* 指數：繪製指數趨勢線。
* 顯示方程式：如果為特定運算式勾選此核取方塊，將使用以圖表中的文字呈現的趨勢線方程式來補強運算式的趨勢線。
* 顯示 R2：如果為特定運算式勾選此核取方塊，將使用以圖表中的文字呈現的測定係數來補強運算式的趨勢線。

[表格圖表的線性迴歸](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/NestedAggregations/linear-regression-table-charts.htm)

## 圖表屬性：排序

圖表屬性：排序頁面的開啟方式是：以滑鼠右鍵按一下圖表並從物件功能表選取屬性。

在此可以從許多可用的排序順序中決定圖表維度的排序順序。

圖表屬性：排序頁面 (針對連續表) 提供稍微不同的選項。

[圖表屬性：排序 (連續表)](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Straight_Table.htm#Chart)

維度清單包含圖表的維度。若要指派排序順序，請標記維度，然後選擇右邊的一或多個排序順序。

維度排序選項

| 選項 | 描述 |  |
| --- | --- | --- |
| Y 值 | 維度值將按照 Y 軸的數值進行排序。此選項不適用於計算維度。 |  |
| 狀態 | 維度值將按照邏輯狀態排序，亦即選取值 &gt; 選用值 &gt; 排除值。 |  |
| 運算式 | 維度值將按照在此排序選項下方的文字編輯方塊中輸入的運算式進行排序。 |  |
| 頻率 | 維度值將按照表格中的出現次數進行排序。 |  |
| 數值 | 維度值將按照數值進行排序。 |  |
| 文字 | 維度值將按照字母順序進行排序。 |  |
| 載入順序 | 維度值將按照初始載入順序進行排序。 |  |

群組中有一個由上到下的階層，因此當選取的排序順序相衝突時，將優先使用第一個出現的排序順序。可以切換遞增和遞減或 A -&gt; Z 和 Z -&gt; A，以反轉選取的排序順序。

按一下預設按鈕之後，會將維度值設定為排序對話方塊中定義的預設值。

只有在維度清單中選取群組維度時，置換群組排序順序核取方塊才可供使用。一般而言，透過群組屬性，即可針對群組中的各個欄位決定群組維度的排序順序。無論群組中的哪個欄位為使用中，啟用此選項之後，就可以置換群組層級的任何這類設定，並且為維度套用單一排序順序。

## 圖表屬性：樣式

在此頁面上，您可以決定圖表的基本樣式。並非所有列出的功能都適用於各個圖表類型。

* 外觀：選擇其中一個可用的樣式。在某些情況下，這不只可能會影響圖表的外觀，也可能會影響圖表的功能。

* 方向：設定圖表的垂直或水平方向。

* 子類型：在此群組中，可為長條圖設定群組化或堆疊模式，或為雷達圖設定重疊或堆疊模式。只有在圖表顯示兩個維度或顯示一個維度和多個運算式時，此設定才有作用。堆疊長條中的負值會個別向下堆疊在 X 軸之下。對於長條圖，使用連續軸縮放比例時，堆疊版面配置是唯一允許的版面配置。  
    
  對於以多個維度和運算式呈現的長條圖，適用下列原則：

  * X 軸最多可以顯示兩個維度。
  * 多色堆疊長條可以顯示第三維度。
  * 只有表格圖表能夠顯示三個以上的維度。
  * 啟用兩個以上的運算式時，X 軸會顯示前兩個維度，而多色堆疊長條則會顯示運算式。
  * 啟用兩個以上的運算式，而子群組設為堆疊時，一個堆疊內的所有運算式將會按照一個軸來計算 (預設為左軸)。就算設定為按照左軸計算一個運算式，按照右軸計算另一運算式，情況也是一樣。

  下列清單顯示如何透過多個維度和運算式顯示子類型：

  * 一個維度
    * 1 個運算式：單一長條
    * 2+ 個運算式：運算式群組化或堆疊
  * 兩個維度
    * 1 個運算式：維度群組化或堆疊
    * 2+ 個運算式：維度群組化
  * 三個維度
    * 1 個運算式：第 1 和第 2 維度群組化，而第 3 維度堆疊
    * 2+ 個運算式：第 1 和第 2 維度群組化，而運算式堆疊。
  * 四個維度
    * 1 個運算式：第 1 和第 2 維度群組化，而第 3 維度堆疊
    * 2+ 個運算式：第 1 和第 2 維度群組化，而運算式堆疊。

* 3D 視圖：此群組中的設定會定義在 3D 模式中檢視圖表的角度。

  * 頂角：定義 3D 視圖的垂直角度。此值必須是介於 5 與 45 之間的整數。
  * 側角：定義 3D 視圖的邊角。此值必須是介於 5 與 45 之間的整數。

* 繪圖色彩樣式：此控制項可用來將色彩樣式套用於圖表中的所有繪圖色彩。在下拉式清單中選取樣式時，色彩頁面的色階配對下出現的所有色彩將變更為選取的樣式。變更會立即進行，而且直到下次進入對話方塊的此頁面時，才會儲存設定。色階配對中實際基準色彩不受影響。繪圖色彩樣式並不完全適用於所有的圖表外觀。提供下列選項：

  * 單色：將色階配對上所有的色彩設定為純色。
  * 深色漸層：將色階配對上所有的色彩設定為由淺變黑的色彩漸層。
  * 淺色漸層：將色階配對上所有的色彩設定為由淺變深的色彩漸層。
  * 光面：讓所有長條呈現光面外觀。

* 繪圖區背景樣式：此控制項可用來變更繪圖區背景的外觀。此設定僅適用於有繪圖區的圖表。提供下列選項：

  * 圖文框：會在繪圖區周圍繪製一個框架。
  * 陰影：此選項能夠在繪圖區背景產生陰影效果。
  * 最小：這項設定可移除繪圖區背景。

* 預覽：提供圖表基本視覺屬性的預覽。

## 圖表屬性：呈現方式 (長條圖 - 折線圖- 組合圖- 雷達圖- 馬賽克圖)

此標籤可聯合用於長條圖、折線圖、組合圖、雷達圖和Mekko 圖。

長條設定群組包含長條圖和組合圖中所使用長條的各種顯示選項。

長條設定

| 設定 | 描述 |
| --- | --- |
| 長條距離 (-6 - 8) | 設定叢集中長條之間的距離。負數將使長條重疊。允許介於 -6 與 8 之間的值。 |
| 叢集距離 (0 - 8) | 代表叢集長條圖中群組值之間的距離。允許介於 0 與 8 之間的值。 |
| 允許精簡長條 | 若是非連續 X 軸的圖表，QlikView 只會顯示可納入繪圖區的資料點數。其餘的資料點將遭到截斷，不會出現在圖表中。長條預設是以四像素的最小寬度繪製的，使其相當容易區別。勾選此選項能夠使長條的寬度壓縮到 1 像素。 |
| 顯示所有長條 | 若是非連續 X 軸的圖表，QlikView 只會顯示可納入繪圖區的資料點數。其餘的資料點將遭到截斷，不會出現在圖表中。勾選此選項將強制繪製所有資料點。長條可以壓縮 (針對允許細長條)，而且有些長條會被其他長條遮住一部份。 |

如果在圖表屬性：運算式頁面的顯示選項下對於一或多個圖表運算式選取此選項，則可以在資料點上的值群組中，對於資料點上的值設定顯示選項。

資料點設定上的值

| 設定 | 描述 |
| --- | --- |
| 顯示最大值 | 在此方塊中，您可以指定在圖表中顯示值的資料點數上限。若未指定任何限制，將會顯示所有資料點的值，這可能會影響圖表的可讀性。 |
| 垂直 | 垂直顯示值。 |
| 區段內的繪圖值 | 勾選此核取方塊將在區段內的資料點上繪製值，而不是在區段上繪製。 |
| 持續在頂端顯示總計 | 勾選此核取方塊，可針對堆疊長條圖和 Mekko 圖在每個長條頂部額外顯示總值。僅在您選擇了區段內的繪圖值時才可使用此選項。 |

在錯誤長條群組中，可以決定圖表中所使用任何錯誤長條的顯示選項。

錯誤長條設定

| 設定 | 描述 |
| --- | --- |
| 寬度 | 指定錯誤長條的寬度。 |
| 粗細 | 指定錯誤長條的粗細。 |
| 色彩 | 設定錯誤長條的色彩。 |

在線條/符號設定群組中，可以決定折線圖和組合圖中所使用線條和資料點符號的顯示選項。也可以決定趨勢線的寬度。

線條/符號設定

| 設定 | 描述 |
| --- | --- |
| 線條寬度 | 若指定了線條表示法，即會決定線寬。 可以指定公釐、公分、英吋 (")、像素 (px、pxl)、點 (pt、pts) 或文件單位 (du) 做為該值的單位。 |
| 符號大小 | 若指定了符號表示法，即會決定符號的大小。 |
| 趨勢線寬度 | 此設定可決定趨勢線的寬度。 |
| 使用完整符號組 | 此替代選項提供更多符號表示法 (如環形、三角形等) |

更多呈現方式設定

| 設定 | 描述 |
| --- | --- |
| 半透明 | 如果要繪製半透明的填色線條，請勾選此選項。 |
| 醒目提示 | 勾選此選項之後，當滑鼠指標暫留在符號及/或線條上時，就會醒目提示符號及/或線條。圖表包含圖例時，圖例也會醒目提示，以便清楚看出多個重疊值的其中一個值。 |
| 隱藏零值 | 此核取方塊可以去除空白或僅包含零的維度。此選項預設為已選取。<br>長條上的零<br>只有在取消選取隱藏零值時，此選項才適用。如果勾選此核取方塊，並且在圖表屬性：運算式的顯示選項下，對於圖表運算式選取資料點上的值，則零值將會顯示為資料點上的文字。在其他情況下，則會隱藏零值。 |
| 隱藏遺失值 | 如果勾選此核取方塊，所有運算式的所有欄位中，僅與 Null 值相關聯的所有維度欄位組合，都不會計入計算中。此選項預設為已選取。僅在特殊情況下 (例如想要計數圖表中的 null 值) 關閉此功能才有用處。 |
| 快顯視窗標籤 | 選取是否要在滑鼠指標碰到值時於快顯視窗中顯示維度和運算式值。按一下設定...以自訂要為哪些維度和運算式顯示快顯標籤。 |

在圖例群組中，您可以控制圖表中顯示的維度資料標籤。勾選此核取方塊可顯示資料標籤。只有圖表目前的最上層才會顯示資料標籤。

圖例設定

| 設定 | 描述 |
| --- | --- |
| 顯示圖例 | 勾選此替代選項，即可在圖表中包含圖例 (預設為已勾選)。按一下設定... 按鈕，即可變更圖標。如果圖表沒有維度，但是有數個運算式，則取消勾選此核取方塊將在軸上顯示運算式。 |
| 限制圖例 (字元) | 啟用此核取方塊，可限制軸上和圖表圖例中顯示的維度值字串長度。在圖表中，截斷的值後面會顯示 ...。 |

[圖例設定](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Legend_Settings.htm)

在圖表捲動群組中，您可以設定圖表中的捲動方式。

圖表捲動設定

| 設定 | 描述 |
| --- | --- |
| 啟用 X 軸捲軸 | 勾選此核取方塊可在 X 軸顯示捲動控制項。該捲軸可用來捲動所顯示的 X 軸值選項。任何一個時間顯示的值數目將是在超過項目數量限制時下設定的數目。 |
| 反轉 | 勾選此方塊會以相反順序顯示值。 |

在參考資料行群組中，您可以定義從連續 X 軸或 Y 軸上的指定點與圖表繪圖區交會的參考資料行 (格線)。視窗會列出現有的參考資料行。

參考資料行選項

| 選項 | 描述 |
| --- | --- |
| 新增 | 開啟參考資料行對話方塊，您可以在其中建立圖表中的新參考資料行。 |
| 編輯 | 醒目提示清單中的現有參考資料行，並且按一下此按鈕，即可在參考資料行對話方塊中編輯其屬性。 |
| 刪除 | 醒目提示清單中的現有參考資料行，並且按一下此按鈕，即可刪除清單中的參考資料行。 |

[參考資料行](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Reference_Lines.htm)

圖表中的文字群組可以用來將自由浮動文字新增到圖表。

圖表中的文字選項

| 選項 | 描述 |
| --- | --- |
| 新增 | 開啟圖表文字對話方塊，您可在其中建立新的圖表文字。 |
| 編輯 | 醒目提示清單中現有的文字，然後按一下此按鈕，即可在圖表文字對話方塊中編輯其屬性。 |
| 刪除 | 醒目提示清單中現有的文字，然後按一下此按鈕，即可刪除清單中的文字。 |

[圖表文字](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Chart_texts.htm)

自由浮動文字會出現在圖表的左上方位置，但是可以在圖表處於圖表版面配置編輯模式時重新調整位置。

[調整圖表元件大小與移動圖表元件](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Sizing_and_moving_chart_components.htm)

## 軸

您可在軸頁面上設定 X 軸和 Y 軸的顯示屬性。

## 圖表屬性：色彩

圖表屬性：色彩頁面的開啟方式是：在圖表視窗上按一下滑鼠右鍵，然後選擇物件功能表中的屬性命令即可。

在資料外觀群組中，最多可以將 18 個不同的色彩指派給圖表的維度欄位值。

外觀設定

| 設定 | 描述 |
| --- | --- |
| 色彩 1 - 18 | 可以將色彩定義為單色或色彩漸層。若要自訂色彩，請按一下其按鈕，開啟色彩區域對話方塊。<br><br>取得預設色彩按鈕會將色階配對重設為 QlikView 的預設設定。<br><br>復原色彩變更按鈕會傳回進入此對話方塊時套用的色彩設定。<br><br>進階... 按鈕會開啟進階色彩配對對話方塊，可以在其中設定色彩配對，並在工作表、文件、使用者及 QlikView 預設層級中擷取。 |
| 多色 | 取消勾選此選項將使得所有長條呈現同一個色彩。 |
| 固定色彩 | 勾選此選項將鎖定色階配對，使每個值都有永久指派的色彩。 |
| 重複最後色彩 | 勾選此選項會將色階配對中的第 18 個色彩指派給第 18 個值之後的任何一個值。如果取消勾選，將從 1 到 18 連續重複色彩。 |

在框架背景中，群組色彩設定是針對繪圖區背景和繪圖區周圍區域的背景而設定的。

背景設定

| 設定 | 描述 |
| --- | --- |
| 色彩 | 以彩色背景繪製圖表。可以對於繪圖區和周圍區域設定不同的色彩。<br><br>按下任一按鈕，均可開啟色彩區域對話方塊。<br><br>提示備註背景色彩設定可以結合以下的影像及/或僅限繪圖區選項。 |
| 背景 | 繪圖區周圍背景或某些圖表、整個圖表的背景所用的色彩。按一下按鈕開啟色彩區域對話方塊，可在其中將色彩定義為純色或漸層。預設色彩為白色。 |
| 繪圖區 | 圖表的繪圖區所用的色彩。按一下按鈕開啟色彩區域對話方塊，可在其中將色彩定義為純色或漸層。預設色彩為淺灰色。這項設定不適用於圓形圖、方塊圖、漏斗圖和雷達圖。 |
| 影像 | 選取此替代選項並按一下影像按鈕，即可開啟選取影像對話方塊，可在其中匯入背景圖片。<br><br>勾選此替代選項可以將匯入的圖片侷限於僅限繪圖區。 |
| 動態影像 | 輸入計算運算式以顯示隨選項變化的動態背景影像。適用於長條圖、折線圖、組合圖、散佈圖和格線圖。 |
| 透明度 | 設定圖表背景的透明度。設為 0% 表示背景將完全不透明，呈現以上背景色彩之下定義的色彩。設為 100% 表示背景將完全透明。 |

在繪圖區框線群組中，您可以對於繪圖區周圍的矩形指派寬度和色彩。

## 圖表屬性：數字

此屬性頁面適用於使用中圖表，其中包含設定值格式的下列控制項：

數字格式

| 格式 | 描述 |
| --- | --- |
| 運算式預設 | 使用運算式提供的數字格式顯示數值。 |
| 數字 | 依照在整數位數微調按鈕方塊中設定的位數顯示數值。 |
| 整數 | 以整數顯示數值。 |
| 固定至 | 依照在小數位數微調按鈕方塊中所設定的小數位數來顯示有小數位數的數值。 |
| 金額 | 依照在預覽文字方塊中顯示的格式顯示數值。預設格式為 Windows 貨幣設定。 |
| 日期 | 依照在格式模式編輯方塊中設定的格式，顯示可解譯為日期的值。在預覽文字方塊中會顯示此格式範例。 |
| 時間 | 依照在格式模式編輯方塊中設定的格式，顯示可解譯為時間的值。在預覽文字方塊中會顯示此格式範例。 |
| 時間戳記 | 依照在格式模式編輯方塊中設定的格式，顯示可解譯為日期+時間的值。在預覽文字方塊中會顯示此格式範例。 |
| 時間間隔 | 將時間顯示為循序增加的時間 (例如，若格式 = 分鐘，即會將值顯示為自行事曆開始算起的分鐘數 (1899:12:30:24:00)。 |

以百分比 (%) 顯示按鈕會使用下列格式操作：數字、整數和固定至。

小數和千位分隔符號可在分隔符號群組中的編輯方塊中設定。

在符號編輯方塊中，可輸入單位符號、1000、1000 000 和 1000 000 000。

ISO 按鈕會設定 ISO 標準的時間、日期和時間戳記格式。

系統按鈕會設定系統設定的格式。

## 字型

可以在此處設定要使用的字型、字型樣式和字型的大小。

可以為任何單一物件設定字型 (物件屬性：字型)，也可以為文件中的所有物件設定字型 (套用至物件，位於文件屬性：字型)。

此外，可以在字型：共有兩個預設字型：

1. 第一個預設字型 (列表框、圖表等) 用於大多數物件，包括列表框和圖表。
2. 第二個預設字型 (文字物件和按鈕) 用於按鈕和文字方塊，這些都是通常需要較大字型的物件。

最後，可以在字型：

也可以為圖表、按鈕及文字物件 (除了搜尋物件) 指定字型色彩。色彩可以固定，也可以從運算式動態計算色彩。運算式必須是使用色彩函數建立的有效色彩呈現。如果運算式的結果不是有效的色彩呈現，字型色彩將使用預設的黑色。

[色彩函數](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他設定為：

* 延伸陰影： 如果勾選此選項，會將延伸陰影新增到文字。
* 底線： 如果勾選此選項，文字將加上底線。

預覽窗格會顯示所選字型的範例。

## 版面配置

如果從 [物件屬性] 頁面進行設定，則版面配置設定只會套用於目前物件。   
如果從 [文件屬性] 頁面進行設定，則版面配置設定將套用於文件中指定類型的所有物件。

### 使用框線

啟用此設定可在工作表物件周圍使用框線。在下拉式功能表中選取框線，即可指定框線的類型。

* 陰影濃度：陰影濃度下拉式功能表能夠設定工作表物件周圍的陰影濃度。另外也可以選擇無陰影。
* 框線樣式：提供下列預先定義的框線類型：
  * 實線：單色框線。
  * 壓下：提供看似從背景壓下工作表物件的框線。
  * 凸起：提供看似從背景凸起工作表物件的框線。
  * 圍牆：提供看似工作表物件周圍有一道牆的框線。
* 框線寬度：此選項適用於所有框線類型。可以指定公釐、公分、英吋 ("、inch)、像素 (px、pxl、pixel)、點 (pt、pts、point) 或文件單位 (du、docunit) 做為寬度的單位。
* 色彩：按一下此按鈕可開啟對話方塊，可在其中從調色盤為所有框線類型選擇適當的基準色彩。
* 彩虹：為所有框線類型建立彩虹色框線。彩虹將以工作表物件頂端選取的基準色彩開始。

在文件屬性：一般的樣式模式中選擇簡化時，不會顯示框線類型選項，只會有陰影濃度下拉式功能表和框線寬度設定。

### 圓角

在圓角群組中，可定義工作表物件的一般形狀。這些設定可用來繪製從正圓形/橢圓形到超橢圓形再到矩形的工作表物件。您需要在文件屬性：一般中選擇進階 樣式模式，才可使用圓角下所指定的預設值。

* 圓角：勾選此選項可設定圓角形狀的替代選項。
* 邊角：未勾選方塊的邊角將改為繪製矩形。
* 方正度：介於 2 與 100 之間的變數，其中 100 定義含正方形邊角的矩形，而 2 對應於正橢圓形 (1:1 外觀比例的圓形)。介於 2 與 5 之間的方正度通常最適合呈現圓角。
* 圓角半徑：此設定可決定固定距離 (固定) 或整體象限百分比 (相對 (%)) 的圓角半徑。這項設定可讓您控制在方正度下所設定基礎一般形狀會影響的邊角範圍。可以指定公釐、公分、英吋 ("、inch)、像素 (px、pxl、pixel)、點 (pt、pts、point) 或文件單位 (du、docunit) 做為距離的單位。

### 圖層

在圖層群組中，可以將物件定義為位於下列三個圖層中的其中一個圖層：

* 下層：具有下層圖層屬性的工作表物件一律無法遮蔽一般和上層圖層的工作表物件。它只能放置在下層圖層的其他工作表物件上方。
* 一般：建立時，工作表物件會位於一般 (中間) 圖層。一般圖層中的工作表物件絕對不會被下層圖層中的工作表物件遮蔽，但無法遮蔽上層圖層中的物件。
* 上層：上層圖層中的物件絕對不會被一般和下層圖層中的物件遮蔽。只有上層圖層中的其他工作表物件才能放在該物件上面。
* 自訂：上層、一般和下層買層分別對應於內部編號為 1、0 和 -1 的各層。事實上，介於 -128 與 127 之間所有的值均可接受。選擇此選項可輸入您選擇的值。

### 佈景主題製作工具...

開啟佈景主題製作工具，您可在其中建立版面配置佈景主題。

### 套用佈景主題...

您可將版面配置佈景主題套用至物件、工作表或文件。

[版面配置佈景主題](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 顯示

在顯示群組中，可以指定工作表物件顯示的條件：

* 永遠：將一律顯示工作表物件。

* 條件式： 工作表物件的顯示或隱藏取決於條件函數，該函數將按照選項等持續評估。只有在條件傳回 FALSE 時才會隱藏工作表物件。

  [條件函數](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

資訊備註

具有文件管理員權限的使用者可透過選擇文件屬性：安全性中的顯示所有工作表和工作表物件來覆寫所有顯示條件。按 Ctrl+Shift+S 即可切換這項功能。

[文件屬性：安全性](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 選項

在選項群組中，可以不允許移動工作表物件和調整工作表物件大小。只有在文件屬性：版面配置和工作表屬性：安全性中啟用對應的核取方塊，此群組中的設定才會產生關聯。

* 允許移動/調整大小：如果取消選取此選項，將無法移動工作表物件或調整工作表物件大小。
* 允許複製：如果取消選取此選項，將無法複製工作表物件。
* 允許資訊：使用 info 函數時，只要欄位值有相關聯的資訊，視窗標題就會顯示資訊圖示。如果不要讓標題顯示資訊圖示，您可以取消勾選此選項。  
    
  [Info](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 調整成資料大小：一般而言，當選項造成表格大小小於工作表物件的配置大小時，QlikView 中的所有表格工作表物件周圍的框線將會縮小。取消勾選此核取方塊之後，將關閉這項自動調整大小的功能，並留下任何剩餘的空白空間。

### 捲軸

許多可變更捲軸版面配置的控制項位於捲軸群組中：

* 保留捲軸位置：啟用這項設定後，在其他物件進行選取時，QlikView 將嘗試以捲軸來保留表格和圖表的捲動位置。這項設定也必須在使用者喜好設定：物件中啟用。您關閉文件時，將不會保留捲軸位置。
* 捲動按鈕：設定捲動按鈕色彩。按一下此按鈕可選取色彩。請注意，中灰色調通常能夠呈現最佳的捲軸效果。按一下適當按鈕開啟色彩區域對話方塊，即可在其中將色彩定義為單色或漸層。
* 捲軸背景：設定捲軸背景色彩。按一下此按鈕可選取色彩。
* 捲軸寬度：此控制會同時影響捲軸符號的寬度和相對大小。
* 捲動樣式：設定捲軸樣式。在下拉式控制項中選取樣式。典型捲軸樣式對應於 QlikView 4/5 捲軸。標準捲軸樣式呈現較現代的外觀。第三個樣式是淺色，這是寬度較細且色彩較淺的捲軸。  
  樣式模式必須設為進階，才能看到捲軸樣式。在一般索引標籤中開啟設定下拉式功能表並選取文件屬性，即可找到此設定。

* 套用於...：開啟標題和框線屬性對話方塊，可在其中設定版面配置頁面上所設定屬性要套用的位置。

## 標題

如果標題設定是從物件屬性頁面設定的，則只會套用至目前的物件。   
如果標題設定是從文件屬性頁面設定的，將套用於文件中指定類型的所有物件。

在標題頁面上，指定與物件的一般版面配置完全不同的版面配置選項。

* 顯示標題： 勾選此選項時，將在工作表物件的頂端顯示標題。清單方塊和其他「方塊物件」預設會開啟此選項，但按鈕、文字物件和線條/箭頭物件則不會開啟此選項。
* 標題文字：在文字方塊中，您可以輸入將在工作表物件的標題中顯示的標題。使用字型... 按鈕即可變更標題字型。

設定不同狀態的標題色彩。使用中色彩和非使用中色彩可以個別設定。

按一下背景色彩或文字色彩按鈕，即可開啟色彩區域對話方塊。在色彩區域對話方塊中，可以將背景色彩定義為單色或漸層色彩。可以使用色彩函數將文字色彩定義為固定或計算色彩。

[色彩函數](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 自動換行：如果勾選此選項，標題將分為兩行或多行顯示。
* 標題高度 (行數)：在此編輯方塊中設定標題行數。

正常或最小化 QlikView 工作表物件的大小/位置設定可以決定和調整 QlikView 物件的確切大小和位置。這些設定的單位為像素：

* X 位置：設定工作表物件的左側相對於工作表左邊的水平位置。
* Y 位置： 設定工作表物件的上側相對於工作表上緣的垂直位置。
* 寬度：設定 QlikView 工作表物件的寬度。
* 高度：設定 QlikView 工作表物件的高度。

使用標題對齊選項可以更改標題標籤的方向：

* 水平：標籤可以水平對齊：在標題區域內靠左、置中或靠右。
* 垂直：標籤可以垂直對齊：在標題區域內靠上、置中或靠下。

特殊圖示   
工作表物件的多個物件功能表命令都可以設定為標題圖示。勾選清單中各個命令左邊的核取方塊，即可選取將顯示為標題圖示的命令。

資訊備註請謹慎使用特殊標題圖示。過多圖示只會造成使用者混淆。

* 允許最小化：勾選此選項時，如果物件能夠最小化，工作表物件的視窗標題將顯示最小化圖示。此外，按兩下標題也能夠將物件最小化。

* 自動最小化：勾選允許最小化時，就可以使用此選項。對於同一個工作表上的多個工作表物件勾選自動最小化時，即可隨時將所有物件自動最小化，只保留一個物件不會最小化。例如，交替顯示同一個工作表區域中的數個圖形時，這相當實用。

* 允許最大化：勾選此選項時，如果物件能夠最大化，工作表物件的視窗標題將顯示最大化圖示。此外，按兩下標題也能夠將物件最大化。如果同時勾選允許最小化和允許最大化，按兩下只會將物件最小化。

* 說明文字：您可以在此處輸入將在快顯視窗中顯示的說明文字。可以將說明文字指定為計算公式。此選項不適用於文件層級。按一下 ... 按鈕可開啟編輯會運算式對話方塊，以便編輯長公式。

    
  [計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，輸入工作表物件的描述。可以將說明圖示新增到物件的視窗標題。將滑鼠指標移到圖示上方時，文字就會在快顯視窗中顯示。