# 編輯運算式對話方塊

選取圖表屬性：運算式中的運算式清單下方的新增按鈕，或以滑鼠右鍵按一下現有的運算式，並選取新增運算式或編輯運算式，即可開啟編輯運算式對話方塊。

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Define_Expression.htm)雖然此對話方塊主要用於圖表運算式，不過只要需要運算式，相同的對話方塊也可以用來建置或編輯其他運算式。按一下程式的文字編輯方塊旁邊的三點符號按鈕，就可以存取此對話方塊。

對話方塊的主要構成部分是運算式編輯區域，可調整大小以容納大型運算式，而在該區域底下則為標籤區域中，其中含有四個標籤：欄位、函數、變數和影像。

## 撰寫運算式

您可以在所選運算式的編輯區域中輸入整個運算式，但通常更為方便的做法是，在下列所述的標籤區域來建置運算式。運算式需要以 = 開始。

只有在程式接受運算式語法，也就是運算式有效時，才會顯示運算式確定標籤。否則，標籤將顯示數個錯誤訊息 (檔案名稱錯誤、運算式發生錯誤、運算式後面出現無用項目) 的其中一個。只有在運算式有效的情況下，才需要按一下確定按鈕離開對話方塊。

## 運算式標籤選項

編輯運算式對話方塊標籤包含下列用於建置運算式的選項。

### 欄位

欄位標籤擁有的控制項，可用來根據欄位資料以建立統計彙總函數。

欄位選項

| 選項 | 描述 |
| --- | --- |
| 彙總 | 第一個下拉式清單包含一個可用統計彙總函數的清單。(First String 和 Last String 函數可用於顯示樞紐分析表中文字等內容。) |
| 表格 | 此下拉式清單可讓您將顯示在下方欄位清單中的欄位限制為一個特定內部表格。 |
| 欄位 | 此下拉式清單包含可用欄位名稱的清單。<br><br>MEASURE (量值) 欄位只能用於基本彙總函數彙總函數 Sum、Avg、Count、Min 和 Max。 |
| 顯示系統欄位 | 勾選此替代選項可將系統欄位納入欄位清單中。 |
| 相異 | 統計函數預設會計算出現次數。勾選相異選項後，就會排除重複值再計算運算式。 |
| 貼上 | 按一下此按鈕可輸入您的選項作為運算式的元件。 |

### 函數

函數標籤擁有的控制項，可用來將一般 QlikView 函數輸入到運算式中。

函數選項

| 選項 | 描述 |
| --- | --- |
| 函數類別 | 此下拉式清單可讓您將顯示在下方函數名稱清單中的函數限制為一次僅有單一類別。 |
| 函數名稱 | 此下拉式清單包含所有可用 QlikView 函數的清單 (除了數量有限的專用指令碼函數以外)。<br>函數標籤底部的窗格會顯示所選函數的引數語法。 |
| 貼上 | 按一下此按鈕可輸入您的選項作為運算式的元件。 |

### 變數

變數標籤擁有的控制項，可用來將一般 QlikView 變數輸入到運算式中。

變數選項

| 選項 | 描述 |
| --- | --- |
| 變數 | 此下拉式清單包含目前文件已定義的所有變數清單。 |
| 顯示系統變數 | 勾選此替代選項可將系統變數納入變數清單中。 |
| 貼上 | 按一下此按鈕可輸入您的選項作為運算式的元件。 |

變數標籤底部的窗格中會顯示在變數清單中任何所選變數的目前值。

### 影像

影像標籤擁有的控制項，可用來存取可在 QlikView 中使用的內部檔案，也可以存取其他相關聯的影像檔案。請注意，此功能對於版面配置的特定部分可能有所限制。影像標籤右方的窗格中會顯示目前選取的影像。

影像選項

| 選項 | 描述 |
| --- | --- |
| 影像資料夾 | 此下拉式清單包含可用影像資料夾的清單。 |
| 影像 | 此下拉式清單包含所選資料夾可用影像的清單。 |
| 進階... | 按一下此按鈕可直接從影像選取器對話方塊中選取圖片。 |
| 貼上 | 按一下此按鈕可輸入您的選項作為運算式的元件。 |

## 編輯運算式功能表選項

此外，編輯運算式對話方塊中還包含下列功能表命令和按鈕。

### 檔案功能表

檔案功能表選項

| 選項 | 描述 |
| --- | --- |
| 匯出為運算式檔案... | 使用匯出為運算式檔案命令，即可將運算式編輯方塊的內容另存為表格檔案。所存檔案的副檔名為 .qve。 |
| 插入檔案... | 使用插入檔案... 命令，即可將先前建立的運算式檔案插入指令碼中。 |
| 色彩混合精靈... | 可使用色彩混合精靈來建立色彩混合運算式。 |
| 列印 | 開啟 Windows 標準列印對話方塊可列印運算式。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+P。 |

### 編輯功能表

編輯功能表選項

| 選項 | 描述 |
| --- | --- |
| 復原 | 復原上一個變更。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+Z。 |
| 重做 | 重做上一個復原。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+Y。 |
| 剪下 | 將醒目提示的文字匯出到剪貼簿。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+X。 |
| 複製 | 將醒目提示的文字複製到剪貼簿。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+C。 |
| 貼上 | 將剪貼簿的內容貼上對話方塊中游標所在的位置。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+V。 |
| 清除 | 清除整個運算式。 |
| 全選 | 選取整個運算式。 |
| 尋找/取代... | 開啟一個對話方塊，可在其中尋找並取代運算式中的數字以及字元。利用下列鍵盤快速鍵即可叫用此命令： Ctrl+F。 |

### 設定功能表

設定功能表選項

| 選項 | 描述 |
| --- | --- |
| 設定... | 開啟使用者喜好設定：編輯器。 |

## 瞭解更多資訊

* [圖表運算式](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/chart-expressions.htm)
* [計算公式的運算式語法](https://help.qlik.com/zh-TW/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)