# 网络图

网络图（网络图）让您绘制连接的节点的网络以及从数据集到工作表的边缘。网络图示出信息如何流动、组件如何相互作用以及组件是否存在于网络中。网络图包括在可视化捆绑中。

网络图可提供高度概览或非常详细。节点表示系统组件，而边缘示出信息从一个组件到另一个组件的移动。网络节点连接至它们与之交互最多的节点。该可视化使用不同的样式、颜色、大小和图像来表示不同的网络级别。

[Network Chart](https://play.vidyard.com/eB5dYhHpX6d2ZUcWQnq6kK)

## 所包含的内容

您需要通过四个可选维度定义三个维度：

* 节点标识符：该维度控制哪些节点存在于图表中。
* 节点标签：该维度设置每个节点的标签。
* 节点父项：该维度设置节点的父项，并控制节点之间的关系。它需要包含要连接的父项的节点标识符的值。
* 节点组（可选）：您可使用该维度来将节点分组。相同组中的所有节点具有相同颜色。

您最多可使用三个度量来增强图表。所有度量均为可选，但是您需要以下面的顺序添加它们：

1. 工具提示：您可设置悬停在节点上方时显示在工具提示中的值。
2. 节点大小：您可根据度量设置节点的大小。
3. 边缘大小：您可根据度量设置节点之间线的宽度。

信息注释您需要添加工具提示，然后才能设置节点大小。在添加工具提示和节点大小之后，可设置边缘大小。

## 适用场景

网络图可示出计算机或电信网络。它们示出网络的组件以及它们的交互方式。例如，一组连接的计算机、打印机、调制解调器、集线器和路由器。该类图表在以下情况下有用：

* 计划网络的结构。
* 协调现有网络的更新。
* 对网络问题进行报告和故障排除。
* 保持对组件的跟踪。
* 记录详细的网络文档。

## 设置数据的格式

网络图需要根据网络数据模型一致结构化的数据，其中每个记录可具有多个父项和子项。每个记录需要至少包含：

* 标识节点、节点标识符的字段节点标识符值必须为整数值，从 0 开始，并且为相继次序。
* 带节点名称的字段。
* 定义父节点的字段。该值需要为另一节点的节点标识符。如果该字段为空，并且没有其他记录涉及该节点，则会创建断连的节点。

提示注释还可使用分层数据模型，其中每个节点具有单个父项。由此将创建树形图表。

以下是您可在文本编辑器中保存并在新应用程序中加载的一些 数据。您需要加载两个 文件。显示了不同机场之间的乘客流。

* ID 是机场节点的标识符。
* Name（名称）是机场节点的名称。这可用作节点的标签。
* LinkTo（链接至）包含父节点的节点标识符。
* Group（组）说明了节点组。这可用于根据组将节点着色。
* Volume（量）是 ID 和 LinkTo（链接至）之间的乘客流量。这可用作边缘大小中的度量。
* NodeVolume 是节点的总乘客流量。这在单独的表格中加载，因为图表无法自动汇聚值。

示例 1: Airports1.csv

```
ID;Name;LinkTo;Group;Volume
0;Frankfurt;;0;
1;London;0;1;5
2;Madrid;0;1;4
2;Madrid;1;1;8
3;Warsaw;0;1;7
4;Arlanda;0;1;1
3;Warsaw;1;1;5
4;Arlanda;1;1;6
5;Tunis;0;2;8
5;Tunis;2;2;4
6;Berlin;0;1;6
6;Berlin;4;1;4
7;Rome;0;1;6
7;Rome;6;1;3
8;San Francisco;0;3;2
9;New York;0;3;9
```

示例 2: Airports2.csv

```

ID,NodeVolume
0,48
1,24
2,16
3,12
4,11
5,12
6,13
7,9
8,2
9,9
```

## 创建网络图

网络图的示例示出全球不同的机场如何基于数据集连接。它使用来自[数据格式化](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/network-diagram.htm#Formatti)的示例数据集。准备方式为：将示例数据集保存在文本文件中，新建应用程序，并加载示例数据集。

执行以下操作：

1. 在资产面板中，打开自定义对象 &gt; Visualization bundle 并将网络图表对象拖动至工作表。

2. 单击顶部添加维度按钮并选择 ID 作为节点标识符。

3. 单击第二个添加维度按钮并选择名称作为节点标签。

4. 单击第三个添加维度按钮并选择 LinkTo 作为父节点。

5. 在属性面板中，单击数据。单击节点组下的添加按钮，并选择组作为组维度。

6. 在度量下，单击工具提示下的添加按钮，并选择 Volume &gt; Sum(NodeVolume)。

7. 单击节点大小下的添加按钮，并选择 Volume &gt; Sum(NodeVolume)。

8. 单击边缘大小下的添加按钮，并选择 Volume &gt; Sum(Volume)。

   图表显示：

   ![具有动态边缘类型的四个维度和三个度量的图表，带点节点以及可见的曲线值。](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/ex_gen_networkchart.png)

## 更改图表的外观

您可用一个或多个功能自定义自己的图表。

### 配置边缘类型

您可在属性面板中的设置 &gt; 边缘类型下配置图表节点之间曲线的形状。从菜单选择图表曲线的形状选项。

示例：

带动态边缘类型（曲线）的图表。

带动态边缘类型（曲线）的图表。

带动态边缘类型（曲线）的图表。   
![带动态边缘类型（曲线）的图表。](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/b2_335x227.png)

带弯曲 CW 边缘的相同图表。

带弯曲 CW 边缘的相同图表。

带弯曲 CW 边缘的相同图表。 ![带弯曲 CW 边缘的相同图表。](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/bild7_337x292.png)

### 切换边缘值

边缘值表示图表节点及其宽度之间曲线的值。该选项隐藏每条曲线的数值。要隐藏值，移动属性面板中设置 &gt; 显示边缘值下的滑动按钮至左侧以关闭选项。

### 配置边缘标签

边缘标签值为每个图表曲线的数值。您可更改这些内容的位置或隐藏标签。

* 隐藏边缘标签值：该选项隐藏网络图的边缘标签。在属性面板中的设置 &gt; 显示边缘值下切换滑动按钮。

* 边缘标签位置：该选项决定边缘值显示在每条图表曲线上的什么位置，例如：上方或下方。从菜单选择适用的选项。

### 配置节点形状

您可自定义节点的形状，例如：点、正方形、菱形或三角形。转到属性面板中的设置 &gt; 节点形状，并从菜单选择节点形状。

### 切换阴影选项

该选项让您关闭图表曲线后面的阴影效果（用于突出显示背景）。在属性面板中的设置 &gt; 显示阴影下切换滑动按钮。

### 排序

在系统将排序顺序选择为默认的情况下，对于所有维度和度量，排序设置为自动（在属性面板中的排序 &gt; 所选的维度或度量下）。您可通过表达式单独更改它们。

执行以下操作：

1. 在属性面板中打开排序下的维度或度量。
2. 将排序滑动按钮移动至左侧以将选项从自动变为自定义。
3. 单击排序表达式 复选框。
4. 在表达式下输入排序字符串并按 Enter。您还可使用表达式编辑器 (the 表达式 icon) 中的表达式更改颜色。
5. 通过从下面的菜单选择升序或降序选择开始顺序。

### 数字格式

可将度量格式化。可将不同的格式应用至相同值，例如金额、数据、持续时间。图表更新以反映更改的数字类型。

执行以下操作：

1. 单击属性面板中的数据 &gt; 度量并单击所选度量。
2. 从数字格式菜单选择适用的数字格式。
3. 在面板字段中输入详细信息。这些在配置图表时选择“自动”以外的选项时显示。

## 使用样式面板进一步自定义外观

在属性面板中的外观下有大量样式设定按钮可供您使用。

单击外观&gt;演示文稿下的the 样式 icon以进一步自定义图表的样式。 您可以通过单击每个部分旁的 ![](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) 重置样式。单击 ![](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg)全部重置可重置样式面板中所有可用标签的样式。

有关设置单个可视化样式的常规信息，请参见[将自定义样式应用于可视化](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm)。

### 自定义文本

可以在外观 &gt; 常规下设置标题、副标题和脚注的文本。若要隐藏这些元素，请关闭显示标题。

图表上不同标签的可见性取决于特定于图表的设置和标签显示选项。这些可以在属性面板中进行配置。

您可以设置图表中显示的文本的样式。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在常规选项卡上，设置以下文本元素的字体、强调样式、字体大小和颜色：

   * 标题

   * 副标题

   * 脚注

### 自定义背景

可以自定义图表的背景。可以通过颜色和图像来设置背景。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon 。

3. 在样式面板的一般选项卡上，您可以选择背景颜色（单色或表达式）。您也可将背景设置为媒体库或 URL 中的图像。

   使用背景色时，请使用滑块调整背景的不透明度。

   使用背景图像时，可以调整图像大小和位置。

### 自定义边框和阴影

您可以自定义图表的边框和阴影。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式面板的常规选项卡上的边框下，调整轮廓大小以增加或减少图表周围的边框线。

4. 选择边框的颜色。

5. 调整拐角半径以控制边框的圆度。

6. 在常规选项卡的阴影下，选择阴影大小和颜色。选择无以移除阴影。

## 限制

有关一般限制的信息，请参阅[限制](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati)。

* 网络图可视化不能在 Qlik NPrinting 报告中使用。

* 网络图中显示的数据集的最大大小为 1400 行。如果选定的数据集较大，则可以从图表中省略节点和链接。

  使用较小的数据集或使用选择来限制数据集。

相关学习:

* [如何配置可视化捆绑网络图？](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Network_chart)

## 了解详情

* [如何配置可视化捆绑网络图？](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Network_chart)