# 多 KPI 图表

多 KPI 图表（多 KPI）是可视化，可让您为不同的维度值示出多个 KPI 值。可使用各种条件格式设置单独自定义值。这可让目标的查看和跟踪更便利。它包括在可视化捆绑中。

* 图表使用度量和一个维度示出 KPI。

* 最多可同时显示 15 个度量和 80 个值。

* 可将所有 KPI 值分组或单独显示它们。

* 可使用例如颜色、图标、标签、字体大小、对齐、样式、不同工作表的链接等独立地自定义每个值。

* 图表支持图形添加、将对象嵌入图表以及以信息图方式显示度量。

[Multi KPI chart](https://play.vidyard.com/CeNBzWZYX7hsBqPfm35HFe)

## 适用场景

多 KPI 图表在您希望便利地查看、了解和跟踪目标的绩效时有用。它还在您希望使用条件格式自定义各个 KPI 值时有用。您可将 KPI 链接至单独的工作表并将对象插入以表示信息或数据。

## 创建多 KPI 图表

您可以在编辑的工作表上创建多 KPI 图。

执行以下操作：

1. 在资产面板中，打开自定义对象 &gt; Visualization bundle 并将多 KPI 对象拖动至工作表。
2. 单击添加度量按钮并选择 KPI 图表的主度量。显示主度量和所选度量的 KPI 值。
3. 在属性面板中单击数据 &gt; 维度下的添加并选择维度。

如果您选择了度量和维度，则会显示多 KPI 图。

示例：

为维度（城市）的不同值示出带度量（利润值 %）的图表。

为维度（城市）的不同值示出带度量（利润值 %）的图表。

为维度（城市）的不同值示出带度量（利润值 %）的图表。 ![一个多 KPI，其中一个度量值显示每个维度的不同值。](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/2_694x93.png)

## 添加其他度量

可在数据 &gt; 维度下的属性面板中，将额外度量添加至自己的图表。图表更新以反映添加的度量。最多可同时显示 15 个度量和 80 个值。主度量始终是为每个维度列出的顶部度量。在您添加更多度量时，它们以输入顺序出现在初始 KPI 值下方。

示例：

带两个度量（利润值 %，数量）的图表按维度（城市）分组。

带两个度量（利润值 %，数量）的图表按维度（城市）分组。

带两个度量（利润值 %，数量）的图表按维度（城市）分组。 ![一个多 KPI，每个维度有两个度量。](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/3_681x141.png)

## 自定义 KPI

您可用一个或多个条件设置自定义您的 KPI 值。您可将数个 KPI 一起添加，将它们分组并链接至不同工作表。您还可单独地配置 KPI 值，方法是用一个或多个条件设置（诸如文本、颜色、图标、图形等）区分它们。

有关条件设置选项，请参见[自定义您的 KPI](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/customizing-your-KPIs.htm#Limitati)。

## 自定义样式设定

在属性面板中的外观下有大量样式设定按钮可供您使用。

单击外观&gt;演示文稿下的the 样式 icon以进一步自定义图表的样式。 您可以通过单击每个部分旁的 ![](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) 重置样式。单击 ![](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg)全部重置可重置样式面板中所有可用标签的样式。

有关设置单个可视化样式的常规信息，请参见[将自定义样式应用于可视化](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm)。

### 自定义文本

可以在外观 &gt; 常规下设置标题、副标题和脚注的文本。若要隐藏这些元素，请关闭显示标题。

图表上不同标签的可见性取决于特定于图表的设置和标签显示选项。这些可以在属性面板中进行配置。

您可以设置图表中显示的文本的样式。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在常规选项卡上，设置以下文本元素的字体、强调样式、字体大小和颜色：

   * 标题

   * 副标题

   * 脚注

### 自定义背景

可以自定义图表的背景。可以通过颜色和图像来设置背景。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon 。

3. 在样式面板的一般选项卡上，您可以选择背景颜色（单色或表达式）。您也可将背景设置为媒体库或 URL 中的图像。

   使用背景色时，请使用滑块调整背景的不透明度。

   使用背景图像时，可以调整图像大小和位置。

### 自定义边框和阴影

您可以自定义图表的边框和阴影。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式面板的常规选项卡上的边框下，调整轮廓大小以增加或减少图表周围的边框线。

4. 选择边框的颜色。

5. 调整拐角半径以控制边框的圆度。

6. 在常规选项卡的阴影下，选择阴影大小和颜色。选择无以移除阴影。

## 限制

有关一般限制的信息，请参阅 [限制](https://help.qlik.com/zh-CN/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati)。

多 KPI 图表不能在 Qlik NPrinting 报告中使用。

相关学习:

* [如何配置可视化捆绑多 KPI 图表？](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)

## 了解详情

* [如何配置可视化捆绑多 KPI 图表？](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)