# 词云图

词云图（词云图）可让您可视化文本数据。显示文本值并且大小基于度量值。度量为您想要衡量的任何东西，例如：所用时间、字母顺序、按重要性或按上下文。您可用不同形状、字体、布局和颜色方案自定义图表。它包括在可视化捆绑中。

词云图以不同大小和颜色显示食品项目。

词云图以不同大小和颜色显示食品项目。

词云图以不同大小和颜色显示食品项目。 ![词云图以不同大小和颜色显示食品项目。](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/w3_629x440.png)

[Word Cloud Chart](https://play.vidyard.com/sSKNa6FvwbF25674c34vyV)

## 要求

词云图必须有一个维度和一个度量。

## 适用场景

词云图让您根据度量可视化并确定值的重要性。根据度量，值越重要，它在云中就显示得越大。

## 创建词云图

您可以在编辑的工作表上创建词云图。

执行以下操作：

1. 在资产面板中，打开自定义对象 &gt; Visualization bundle 并将词云图对象拖动到工作表上。
2. 单击添加维度按钮并选择维度。
3. 单击添加度量按钮以选择图表的度量。

一旦选择了维度和度量，则会自动显示词云图。

## 更改词云图的外观

您可用一个或多个功能自定义自己的词云图。

### 更改取向

您可通过属性面板中的外观 &gt; 设计 &gt; 方向设置方向数目。您可从 1 至 10 之间的整数设置。

* 1 将以相同方向显示所有单词，通过外观 &gt; 设计 &gt; 起始角度设置。
* 2 将以两个方向显示单词，即外观 &gt; 设计 &gt; 起始角度以及外观 &gt; 设计 &gt; 结束角度。
* 3-10 将以相同的方向数显示单词，这些方向介于外观 &gt; 设计 &gt; 起始角度以及外观 &gt; 设计 &gt; 结束角度。

示例：

词云图以不同方向显示食品项目。

词云图以不同方向显示食品项目。

词云图以不同方向显示食品项目。![词云图以不同大小、方向和颜色显示食品项目。](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/w5_629x383.png)

### 调节开始和结束角度

您可在属性面板中的外观 &gt; 设计 &gt; 起始角度下调节词云的起点（角度）参数，并在外观 &gt; 设计 &gt; 结束角度中调节终点。角度可具有正值或负值。

### 更改字体大小

您可在属性面板中外观 &gt; 设计 &gt; 字体最大大小的下设置最大词字体大小，并在外观 &gt; 设计 &gt; 字体最小大小下设置最小值。

如果设置较大的字体大小，则可能会导致较大的单词不适合显示在图表中。

### 更改刻度

词云图刻度可为线性或为对数刻度。在属性面板的外观 &gt; 设计 &gt; 刻度下选择刻度线性或对数。仅正值可用于对数刻度。零或负值不会返回内容。

### 设置自定义范围

您还可指定一系列颜色或从预先定义的颜色方案中进行选择。

执行以下操作：

1. 单击属性面板中的外观 &gt; 设计。
2. 确保将启用颜色范围设置为“开”（默认）。
3. 单击始自旁的调色盘并选择一种颜色。
4. 单击截至旁的调色盘并选择一种颜色。

您可通过单击调色盘中的画架符号并选择一种颜色来设置自己的颜色范围。您还可在画架符号旁的字段中输入颜色代码字符串。颜色应当为有效的 CSS 色。

执行以下操作：

1. 单击属性面板中的外观 &gt; 设计。

2. 将启用自定义范围滑动按钮移动至左侧以关闭选项。

3. 在刻度颜色下选择颜色方案。

   ![词云图以自定义颜色显示食品项目。](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/w7_592x332.png)

词云图以不同大小和颜色显示食品项目。

### 格式化数字

可将度量值格式化。可将不同的格式应用至相同值，例如金额、日期、持续时间。图表更新以反映更改的数字类型。

执行以下操作：

1. 单击属性面板中的数据 &gt; 度量并单击一个度量。
2. 从数字格式菜单选择适用的数字格式。
3. 在面板字段中输入详细信息。这些在进一步配置图表时选择“自动”以外的选项时显示。

## 使用样式面板进一步自定义外观

在属性面板中的外观下有大量样式设定按钮可供您使用。

单击外观&gt;演示文稿下的the 样式 icon以进一步自定义图表的样式。 您可以通过单击每个部分旁的 ![重置](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) 重置样式。单击 ![重置](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) 全部重置可重置样式面板中所有可用标签的样式。

有关设置单个可视化样式的常规信息，请参见[将自定义样式应用于可视化](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm)。

### 自定义文本

可以在外观 &gt; 常规下设置标题、副标题和脚注的文本。若要隐藏这些元素，请关闭显示标题。

图表上不同标签的可见性取决于特定于图表的设置和标签显示选项。这些可以在属性面板中进行配置。

您可以设置图表中显示的文本的样式。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在常规选项卡上，设置以下文本元素的字体、强调样式、字体大小和颜色：

   * 标题

   * 副标题

   * 脚注

### 自定义背景

可以自定义图表的背景。可以通过颜色和图像来设置背景。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon 。

3. 在样式面板的一般选项卡上，您可以选择背景颜色（单色或表达式）。您也可将背景设置为媒体库或 URL 中的图像。

   使用背景色时，请使用滑块调整背景的不透明度。

   使用背景图像时，可以调整图像大小和位置。

### 自定义边框和阴影

您可以自定义图表的边框和阴影。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式面板的常规选项卡上的边框下，调整轮廓大小以增加或减少图表周围的边框线。

4. 选择边框的颜色。

5. 调整拐角半径以控制边框的圆度。

6. 在常规选项卡的阴影下，选择阴影大小和颜色。选择无以移除阴影。

## 限制

有关一般限制的信息，请参阅[限制](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati)。

* 词云图每个条目最多可处理 100 个词。
* 占用空间比图表更多的词不会显示。您可调节字体大小以显示更多值，但是我们不建议您使用具有长文本值的字段。
* 词云图不能在 Qlik NPrinting 报告中使用。

相关学习:

* [如何配置可视化捆绑词云图？](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Word_cloud_chart)

## 了解详情

* [如何配置可视化捆绑词云图？](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Word_cloud_chart)