# 垂直表

垂直表同时显示多个字段，其中每行的内容在逻辑上相互关联。一个表可以根据需要由任意多个维度和度量组成。 垂直表包括在可视化捆绑中。

应用程序创建者可以同时添加多个字段，在列级别自定义表，添加替代维度和度量，设置列宽，应用分页，并打开图表探索。

图表探索允许没有编辑权限的用户在分析模式下自定义原始垂直表。这些用户可以添加或删除列、更改排序顺序、将列重新排列以及进行选择。然后，他们可以共享、下载、订阅新的表格布局或为新的表格布局添加书签。用户在图表探索模式下所做的更改不会被分析工作表的其他用户看到。

信息注释此页面是关于可视化捆绑垂直表的。有关本机表对象的信息，请参阅[表格](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/Table/table.htm)。

[Straight Table](https://play.vidyard.com/ywyRFWEi4qfvCa1ED1oj6B)

## 适用场景

如果您想要查看详细的数据和精确的值（而不是值的可视化），可以使用垂直表。当您想要比较单个值时，表格很有用。向下钻取组维度在表格中非常有效。在有限的空间内，您可以向下钻取到下一级别的详细信息，并分析更新的度量值。如果希望用户能够在分析模式下创建自定义表，请使用此表。

### 优势

您可以通过不同方式对表格进行筛选和排序。表格中可以包含许多值，并且当您在表格中向下钻取时，可以充分利用工作表上的有限空间。当您想要查看确切的值而非趋势或图案时，表格是极好的选择。表格是将数据导出到其他程序中的一种简单方法。

### 劣势

如果垂直表包含许多值，则很难获得各值关联的概述。并且，也很难以确定表格中的不规则性。

## 优化表格的最佳实践

如果一个表有太多的维度和度量，那么它的加载速度可能会很慢。作为最佳实践，将大多数字段和表达式添加为替代列。这鼓励用户使用图表探索只添加他们需要的字段。

您还可以通过确保表具有 10 列或更少的列来提高性能。

从单个数据源提取字段的表将比包含多个数据源中字段的表执行效果更好。

## 创建垂直表

您可以在编辑的工作表上创建垂直表。

执行以下操作：

1. 在资产面板中，打开自定义对象 &gt; Qlik Visualization bundle 并将垂直表对象拖动到工作表中。
2. 单击添加列将项目添加到表中。将打开下拉列表。
   * 字段和主条目：打开一个可搜索的对话框，显示每个字段和主条目。您可以选择添加任何项目作为维度或度量。
   * 自定义表达式：打开一个对话框，您可以在其中键入表达式或打开表达式编辑器 the 打开表达式编辑器 icon。
3. 在“属性”面板的数据下，单击 the 打开“添加数据资产”菜单 icon 以向表中添加更多维度或度量。

创建表格时，可能需要在属性面板中调整其外观和其他设置。有关样式设置的更多信息，请参阅[垂直表样式设定](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Styling)。

提示注释默认情况下，列宽都设置为一个值，因此它们的总和等于图表的宽度。您可以通过拖动标题分隔线来调整列宽度。双击标题分隔符可设置宽度以适应内容。

## 使用表格条目

执行以下操作：

1. 在属性面板的数据选项卡中的列和可选列下，单击任何项目旁的复选框。单击 the 工具 icon 可执行剪切、粘贴和删除等操作。单击列或替代列旁边的复选框，以选择列表中的所有项目。使用箭头图标在每个部分之间移动项目。

   信息注释替代列是用户在使用 [使用图表探索](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Chart) 时可以选择添加到表中的列。

2. 若要更改列顺序，请单击字段或表达式旁边的 the 可拖动列 icon，然后拖动该项。

3. 单击项目名称以打开其各个属性。在这里，您可以更改标签、设置列的背景色、控制文本对齐方式、设置列宽等。有关更多信息，请参阅以下部分。

   信息注释如果文本对齐设置为自动，则列数据会根据数据类型对齐：文本值为左对齐，数值（包括日期相关值）为右对齐。如果将其设置为自定义，则可以靠左、居中或靠右对齐数据。

选择垂直表时，属性面板中的“数据”选项卡。单击了客户字段，因此相关的维度属性显示在左侧。

选择垂直表时，属性面板中的“数据”选项卡。单击了客户字段，因此相关的维度属性显示在左侧。

选择垂直表时，属性面板中的“数据”选项卡。单击了客户字段，因此相关的维度属性显示在左侧。 ![选择了垂直表时的属性面板。](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_vizbundle_straighttable_data.png)

### 使用表达式定义列文本样式

对于每一列，可以设置一个单独的表达式来定义列文本的样式设定方式。如果使用表达式设置列文本的样式，则此表达式将覆盖该列的应用程序主题以及应用于可视化的任何自定义样式设定。

您可以在表达式中使用以下语法来定义样式设定（标签中的字母不区分大小写）：

* `<B>`：加粗

* `<I>`：斜体

* `<U>`：带下划线

* `<S>`：带贯穿线

一次可以应用多个以上选项。

示例：

if(avg(Sales) &gt; 300, '&lt;B&gt;')

if(count(OrderID) = 0, '&lt;S&gt;')

if(sum(Sales) &gt; 100000, '&lt;B&gt;&lt;U&gt;', '&lt;I&gt;')

执行以下操作：

1. 在数据下，选择一个列，然后展开属性中的演示。

2. 在文字样式表达式下，输入表达式。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

### 设置维度表示格式

可以使用属性面板中的表示设置维度列的格式，以显示值、链接或图像。可以选择以下表示：

* 文本：将维度值显示为文本。这是默认值。

* 链接：将值显示为可单击的链接。使用维度值或 URL，或者可以将其他 URL 添加到显示的维度值中。

#### 设置链接格式

信息注释

不支持字符 ; 作为 URL 中的查询参数分隔符。

执行以下操作：

1. 在数据下，选择一个维度，然后展开属性中的演示。

2. 在表示下，选择链接。

3. 在链接设置下，选择以下选项之一：

   * 添加标签：维度在维度表达式或数据表中包含目标 URL。链接按目的地 URL 表达式显示和排序。

     在链接标签下，输入目标 URL 的描述性文本标签。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

   * 添加 URL：维度值将成为可选择的文本链接，这些链接是 URL 的标签。

     在链接 URL 下，输入目标 URL 表达式。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

#### 图像格式设定

警告注释

只能从已安全列出的服务器和域访问垂直表中的图像。管理员通过为每个服务器或域添加 Content-Security-Policies (CSP)，使这些资源在 Administration 中可用。通过控制浏览器可以从服务器请求的资源，CSP 有助于防止跨站点脚本攻击。

信息注释

不支持字符 ; 作为 URL 中的查询参数分隔符。

执行以下操作：

1. 在数据下，选择一个维度，然后展开属性中的演示。

2. 在表示下，选择图像。

3. 在图像设置下，选择以下选项之一：

   * 添加标签：维度包含维度表达式或数据表中图像的绝对 URL。链接按 URL 表达式显示和排序。

     在图像标签下，输入图像的描述性文本标签，当图像悬停在其上时，该标签将显示为替代文本。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

   * 添加 URL：当图像悬停在其上时，维度值将成为显示的替代文本的标签。

     在图像 URL 下，输入目标 URL 表达式。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

4. 在调整大小下，选择以下调整大小选项之一：

   * 始终适应

   * 适应宽度

   * 适应高度

   * 按比例伸展

   * 原始大小

5. 在位置下，选择单元中的图像位置。

### 设置度量表示格式

您可以使用属性面板中的表示设置度量列的格式。可以选择以下表示：

* 文本：以文本形式显示度量值。这是默认值。

* 图像：以图像形式显示测量值。

* 指示器：在测量单元格中显示可定制的指示器符号。可根据喜好，在这些指示器旁边显示或隐藏每个值的文本表示。

* 小图表：显示每个度量值的小型图表。每个小图表都显示了度量在特定维度上的变化，这些维度与表格中的其他维度是分开配置的。

有关代表选项的更多信息概述如下。

#### 图像格式设定

警告注释

只能从已安全列出的服务器和域访问垂直表中的图像。管理员通过为每个服务器或域添加 Content-Security-Policies (CSP)，使这些资源在 Administration 中可用。通过控制浏览器可以从服务器请求的资源，CSP 有助于防止跨站点脚本攻击。

信息注释

不支持字符 ; 作为 URL 中的查询参数分隔符。

执行以下操作：

1. 在数据下，选择一个度量，然后展开属性中的演示。

2. 在表示下，选择图像。

3. 在图像设置下，选择以下选项之一：

   * 添加标签：度量值包含度量表达式或数据表中图像的绝对 URL。链接按 URL 表达式显示和排序。

     在图像标签下，输入图像的描述性文本标签，当图像悬停在其上时，该标签将显示为替代文本。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

   * 添加 URL：当图像悬停在其上时，度量值将成为显示的替代文本的标签。

     在图像 URL 下，输入目标 URL 表达式。单击 the 打开表达式编辑器 icon 以打开表达式编辑器。

4. 在调整大小下，选择以下调整大小选项之一：

   * 始终适应

   * 适应宽度

   * 适应高度

   * 按比例伸展

   * 原始大小

5. 在位置下，选择单元中的图像位置。

#### 向度量添加趋势指示符

您可向度量列添加趋势指示符。这样将在度量值旁显示符号。您可以定义范围，用于确定要显示的符号及其颜色。通过在度量属性中将表示形式设置为指示符，可以启用指示符。

执行以下操作：

1. 在属性面板中，展开数据并单击度量。

   度量属性打开。

2. 在演示下，将表示设置指示符。

3. 单击添加限制按钮下方包含颜色和符号的矩形。您可以设置指示符的颜色和符号。

   如果添加了一个或多个限制，则可以通过单击此矩形中的范围来调整每个范围的颜色和符号。

4. 为指示符设置其他属性，详见下文各部分。

设置指示符限值

您需要通过添加限值，为要用于显示指示符的范围添加限值。您可以三种方式设置限值。

* 使用滑块。
* 在文本框中键入值。
* 设置返回限值的表达式。

在您添加了限值时，您可为每个定义的范围选择指示符的颜色和符号。

设置指示符样式

您可以设置指示符的显示样式。

* 通过选择显示值，您可显示指示符和度量值二者。

* 通过将颜色应用至值，您可将值颜色设置为和指示符颜色相同。

  信息注释启用此设置后，如果图表的其他属性中定义了当前单元格值的颜色，则指标颜色会覆盖该颜色。

* 使用指示符位置，您可将指示符显示在值的右侧或左侧。

* 当您有一个或多个限制时，通过开启渐变可用颜色之间的渐变给指示符着色。

示例

在该 中，我们将趋势指示符添加至 Sales 度量，以指示哪些值低于目标值。指示符限值为：

* 对于低于 $1,000,000.00 的值，显示红色标记。
* 对于在 $1,000,000.01 至 $4,999,999.99 范围内的值，显示黄色标记。
* 对于 $5,000,000.00 以上的值，显示绿色复选标记。

带趋势指示符的表格

带趋势指示符的表格

带趋势指示符的表格![带趋势指示符的表格](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_gen_sn-table_trend_indicator.png)

#### 将度量值格式化为小图表

您可以将度量值表示为一系列小图表，而不是一系列文本值。小图表可根据数据表中的数据可视化度量值，以及您选择的额外维度。

使用小图表可以提供有关突出或相关维度的更多上下文。例如，在包含维度 Product 和度量 Sum(Sales) 的表中，您可以将度量表示为一系列按月份细分每个产品销售额的迷你图表。

执行以下操作：

1. 在属性面板中，展开数据并单击度量。

   度量属性打开。

2. 在演示下，将表示设置小图表。

3. 在选择维度下，选择每个小图表中用于数据可视化的维度。

4. 在类型下选择图表类型。有条形图、点图、迷你图和正/负可用。

5. 为小图表设置其他属性，详见下文各部分。

配置小图表外观

您可以设置使用的颜色，以及是否在小图表上显示点。

展开颜色，访问所有的小图表颜色选项。每种类型的小图表都有不同的设置。

选中或取消选中显示点设置，以显示或隐藏小图表上的数据点。

配置小图表数据

您可以使用以下设置进一步自定义小图表中使用的数据：

* 通过切换包含空值设置，选择是否在小图表中包含空值。

* 小图表可以对您选择的小图表维度最多显示 100 个唯一值的数据。默认情况下，不显示附加维度值。打开显示其他，通过在每个小图表结束时将所有附加维度值合并为一个维度值来表示所有附加维度值。

* 在 Y 轴下，您可以调整 Y 轴使用的数值。使用本地设置，对比小图表中显示的数据集设置 Y 轴值。使用全局设置，可对比所有数据，设置 Y 轴值。您还可以在自动、零作为基线或零作为中心设置中进行选择，配置正值和负值的表示方法。

## 表格排序

您可以通过不同方式对表格进行排序：

* 列排序：从左至右调整维度和度量的顺序。
* 行排序：调整行的排序优先级顺序。
* 内部排序：使用维度和度量的内部排序顺序。
* 交互式排序：在分析期间，您可单击列标题以将表格排序。

### 列排序

默认情况下，列排序顺序按在表格中添加维度和度量的顺序设置。如果先添加 Sales 度量，则会在表格中（最左边）先显示此度量。添加的下一个维度或度量显示在第二列，依此类推。在属性面板的列下，可以更改列排序顺序。

### 行排序

默认情况下，行按首先添加的维度或度量，使用数值降序、文本值升序进行排序。列标题下的小箭头表示按哪列对表格排序。

可以在属性面板的排序下更改行排序。拖动维度和度量可更改排序优先顺序。在许多情况下，排序不仅受排序中的第一个维度或度量影响，而且受后续维度或度量影响。

示例：

在以下屏幕截图中，这些行首先按 Customer 排序，然后依次按 Month 和 Product Type 排序。正如您所看到的，Customer 列和 Month 列包含几个值相同的行（A-2-Z Solutions 和 Month）。Product Type 中的行按字母顺序排序，但仅显示一月向 A-2-Z Solutions 客户销售的产品类型。

![具有排序顺序的表：客户、月份、产品类型。](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_gen_TableSorting.png)

通过更改排序顺序，以便依次按 Product Type 和 Month 二次排序，向 A-2-Z Solutions 客户销售的所有 Product Type 项目都会按字母顺序显示，但仅在 Month 下显示销售产品时的月份。

![具有排序顺序的表：客户、产品类型、月份。](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/ui_gen_TableSorting2.png)

### 内部排序

每个维度和度量都有默认的（自动）内部排序顺序，这种顺序可以更改。在排序下，单击要更改的项目，然后单击切换至自定义排序的按钮。如果对项目内部排序做出的更改与某优先级更高的项目冲突，则此排序可能没有效果。

### 交互式排序

在分析期间，可以设置要排序的列，只需单击列标题即可。第一次单击将根据所选项目的默认排序方式对表格排序。第二次单击将颠倒此排序顺序。交互式排序基于会话，不能保存。如果您想让排序更改成为永久内容，则需要在属性面板中进行更改。

能够编辑工作表的用户可以使用图表探索进行交互排序，单击编辑工作表，然后将这些更改保存到原始表

## 从垂直表中的循环维度中选择激活字段

如果垂直表使用循环维度，则用户可以从循环维度中选择激活字段。

执行以下操作：

1. 单击循环维度列上的 the 菜单 icon 。

2. 单击 the 循环 icon &lt;维度名称&gt; 并从循环维度中选择一个维度。

## 使用插件

在“属性”面板的插件下，垂直表具有以下选项：

数据处理：

* 包括零值：取消选择此选项后，演示文稿中不会包括值为“0”的度量。如果有多个度量值，演示文稿中必须排除值为“0”的所有度量值。

* 计算条件：用于在此文本字段中指定表达式，以设置所显示对象需要满足 (True) 的条件。该值可以作为计算公式输入。例如：count(distinct Team)&lt;3。如果不满足条件，则会显示在已显示消息中输入的消息或表达式。

  当图表或表格由于大量数据而响应缓慢时，计算条件非常有用。可以使用计算条件隐藏对象，直到用户通过应用选择将数据筛选到更易于管理的级别。使用显示的消息属性来引导用户筛选数据。

  [使用计算条件](https://share.vidyard.com/watch/UDRXiPe6LFDgdePb4CuF3L)

## 更改垂直表的外观

在属性面板的外观下，您可以更改垂直表的外观。

### 打开悬停菜单

在外观 &gt; 常规下，使用显示悬停菜单的切换开关来选择是否要在可视化中显示悬停菜单。

### 显示详细信息

在外观 &gt; 常规下，如果您想允许用户选择查看详细信息，如描述、度量和尺寸，请将显示详细信息设置为显示。

### 允许用户查看图表中的表达式

如果要允许用户选择查看表达式，请在外观 &gt; 常规下，将显示表达式设置为显示。

### 显示总计

在外观 &gt; 演示下，您可以配置图表中显示的行是否显示总计。使用总计开关在以下选项之间进行选择：

* 自动：总计（表达式结果）自动包含在表格顶部。
* 自定义：选择是否显示总计，以及是在顶部还是底部显示总计。

如果已选择显示总计，则可以通过为总计标签输入值或表达式来配置总计行的标签。

### 使用分页

在外观 &gt; 演示下，启用使用分页设置以更改图表中显示的行数。使用分页后，将不是一次显示所有行，而是只显示一定数量的行。用户可以使用表格底部的箭头按钮进行导航。

### 使用文本换行

当垂直表中的文本太长，在提供的空间内无法显示时，一些文本不会显示，而是用省略号表示。在外观 &gt; 演示下，可以使用多行文字换行下的设置将文字换行成表格中的多行。该设置可在标题和单元格层级单独控制：

* 将标题中的文本换行（仅限表格标题）

* 将单元格中的文本换行（仅限表格单元格）

提示注释使用这些设置最多可以封装三行文本。对于较长的文本，可在the 样式设置 icon面板中设置较高的行高度限制。请参阅[自定义网格](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#GridSettings)。

### 自定义空值的表示

您可以更改 null 值在垂直表中对度量的表示方式。输入用于替换空值的静态文本。当您使用数值时，这些值被解释为数字而不是文本。这允许您用实际值（如 0）填充缺失的计算。

执行以下操作：

1. 在属性面板中单击外观 &gt; 演示。

2. 在空值文本下，输入将替换空度量值的文本。

### 隐藏列标题

您可以在显示列标题的垂直表顶部隐藏标题，并允许用户更改排序。在外观 &gt; 演示下，激活隐藏标题设置。

## 垂直表样式设定

在属性面板中的外观下有大量样式设定按钮可供您使用。

单击外观&gt;演示文稿下的the 样式 icon以进一步自定义图表的样式。样式面板包含常规和图表选项卡下的各个部分。

您可以通过单击每个部分旁的 ![重置](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) 重置样式。单击 ![重置](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) 全部重置可重置样式面板中所有可用标签的样式。

有关设置单个可视化样式的常规信息，请参见[将自定义样式应用于可视化](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm)。

### 设置文本样式

垂直是一种基于文本的可视化，因此文本可以用多种不同的方式设置样式。您可以在以下级别应用样式：

* 图表级

  * 维度和度量的值及标题

  * 度量合计

  * 空值

* 列级样式

* 行级样式

  * 悬停行为

  * 斑马条纹（交替的颜色行）

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在常规选项卡上，设置以下文本元素的字体、强调样式、字体大小和颜色：

   * 标题

   * 副标题

   * 脚注

4. 在图表选项卡上，设置以下文本元素的字体、强调样式、字体大小和颜色：

   * 标题：为维度和度量设置标题的文本样式。

   * 维度值：设置文本维度值的样式。

   * 度量值：设置度量值的文本样式。

   * 总计：如果您已选择在外观 &gt; 演示下显示总计行，请设置总计的文本样式。

   * null 值：设置 null 值的文本样式。您可以更改强调样式和颜色。

   * 斑马条纹：打开此设置后，可为行设置交替文字颜色。请参阅[应用斑马条纹](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#ZebraStripes)。

也可以为表中的每一列设置文本样式。您可以配置文本颜色、样式和对齐方式。这些设置在属性面板的数据选项卡中配置。如果您单独设置了列的样式，则此样式将覆盖在图表级别应用的任何文本样式。有关更多信息，请参阅[使用表格条目](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Working)。

此外，您还可以自定义用户悬停在行上时文本的显示方式。请参阅[自定义悬停行为](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Customiz)。

### 自定义背景

可以自定义图表的背景。可以通过颜色和图像来设置背景。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式面板的一般选项卡上，您可以选择背景颜色（单色或表达式）。您也可将背景设置为媒体库或 URL 中的图像。

   使用背景色时，请使用滑块调整背景的不透明度。图表标题始终以 100% 不透明度显示。

   使用背景图像时，可以调整图像大小和位置。

4. 在图表选项卡上，自定义以下元素的背景色：

   * 标题（使用了 100% 不透明度）

   * 维度值

   * 度量值

   * 度量标签

   * 总计（使用了 100% 不透明度）

   * 空值

   * 斑马条纹（请参阅 [应用斑马条纹](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#ZebraStripes)）

### 自定义网格

您可以自定义表网格。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在图表选项卡上，用以下元素自定义网格：

   * 行高度：设置行的高度。

   * 边框：设置单元格边框的颜色。

   * 分隔符：设置分隔表头和表体的分隔符的颜色。

### 自定义悬停行为

用户将鼠标悬停在表中的某行上方时，可以设置显示选项。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式设置面板的图表选项卡上的行悬停下，调整以下设置：

   * 若要在用户悬停在表中的行上时高亮显示这些行，请将开关设置为打开。根据偏好关闭行为。

   * 行悬停颜色：设置颜色以在用户悬停在行上时高亮显示该行。

   * 行悬停字体颜色：当用户悬停在高亮显示的行上时，设置该行中文本的颜色。

### 自定义边框和阴影

您可以自定义图表的边框和阴影。

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式面板的常规选项卡上的边框下，调整轮廓大小以增加或减少图表周围的边框线。

4. 选择边框的颜色。

5. 调整拐角半径以控制边框的圆度。

6. 在常规选项卡的阴影下，选择阴影大小和颜色。选择无以移除阴影。

### 应用斑马条纹

使用斑马条纹，您可以在垂直表上添加交替的颜色行。斑马条纹通过增加奇数行和偶数行之间的对比度来提高可读性。

您可以设置奇数行和偶数行的文本和背景颜色。

[Zebra stripes](https://play.vidyard.com/TdruWyqDrG9nqXj7VTnHL4)

执行以下操作：

1. 在属性面板中，展开外观部分。

2. 在外观 &gt; 展示下，单击 the 样式 icon。

3. 在样式面板的图表选项卡上，将斑马条纹设置为打开。

4. 调整以下设置：

   * 颜色（奇数行）：设置奇数行的文字颜色。

   * 背景（奇数行）：设置奇数行的背景颜色。

   * 颜色（偶数行）：设置偶数行的文字颜色。

   * 背景（偶数行）：设置偶数行的背景颜色。

## 使用图表探索

图表探索允许没有编辑权限的应用程序使用者和其他用户在分析模式下自定义原始垂直表。它位于the 图表探索 icon 下的 the 更多 icon 菜单中。

应用程序使用者和查看者可以使用图表探索来添加或删除表中的列、重新排序列、更改列宽以及应用选择项。在图表探索模式下，无法更改工作表上整个表的大小或布局。

图表探索模式是一种快速删除或添加数据，然后共享、下载数据或为新表状态添加书签的好方法。它在许多查看者有不同需求的应用程序中非常有用。图表探索面板不会显示在您共享或下载的结果表中。

如果您使用图表探索模式自定义表，其他用户将无法看到您的更改，除非您将其保存为公共书签。这意味着几个用户可以同时更改同一个表。如果刷新浏览器页面，您的更改将保持可见，但如果注销或会话超时，更改将丢失。如果发生这种情况，表将返回到其默认状态，由创建垂直表的人员设置。如果要保存表格布局，请创建一个书签。 有关详细信息，请参阅[创建书签](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Bookmarks/create-bookmark.htm)。

能够编辑工作表的用户可以使用图表探索进行更改，单击编辑工作表，然后将这些更改保存到原始表

应用程序开发人员可以在属性面板中打开图表探索：

* 启用图表探索：打开此选项可进行图表探索。

* 可见性选项：

  * 自动：当用户打开工作表时，可以看到图表探索面板。

  * 最小化：当用户打开工作表时，图表探索打开，但不可见。用户可以通过单击 the 更多 icon 然后单击 the 图表探索 icon 在悬停菜单中打开它。

要使表项在图表浏览模式下可用，表创建者（或可以编辑工作表的用户）必须将这些字段、主条目或表达式作为列或替代列添加到表中。有关更多信息，请参阅[使用表格条目](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/sn-straight-table.htm#Working)。

垂直表的图表探索。该表有三列：客户、地区、城市。

垂直表的图表探索。该表有三列：客户、地区、城市。

垂直表的图表探索。该表有三列：客户、地区、城市。the 视图模式下的垂直表，图表探索已打开。 icon

同一表的图表探索与上表相同，但表中添加了两个度量：销售额和成本。背景颜色是表达式的结果。

同一表的图表探索与上表相同，但表中添加了两个度量：销售额和成本。背景颜色是表达式的结果。

同一表的图表探索与上表相同，但表中添加了两个度量：销售额和成本。背景颜色是表达式的结果。the 视图模式下的垂直表，图表探索已打开。 icon

## 限制

### 如果特定图表中嵌入了表，则图表探索不可用

如果表嵌入在以下任何对象中，则图表探索不可用：

* 未被选项卡容器替换的现有容器对象。选项卡容器在 Qlik Sense Enterprise on Windows 和 Qlik Sense Desktop 的 November 2024 版本中成为原生容器对象。

  图表探索在已弃用的 ShowHide 容器和 选项卡式容器对象的现有实例中也不可用。但是，不建议将这些对象转换为选项卡容器。相反，从头开始创建一个新的选项卡容器，以便在垂直表中访问图表探索。

* 格子容器

  [网格容器](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/trellis-container.htm)

### 显示的行数

如果启用了分页，则一次只能显示 100 行。如果关闭了分页，则一次只能显示 250 000 行。如果表中的行数超过 250 000 行，则将应用分页。

由于大型表格不实用，且难以管理，因此实用的数量限制远低于理论最大值。在大多数情况下，无需水平滚动就可以查看全部列才会令人满意。

### 可访问性

只有在启用分页的情况下，才能完全访问垂直表。有关键盘导航的更多信息，请参阅[中的键盘导航和快捷方式](https://help.qlik.com/zh-CN/sense/May2025/Subsystems/Hub/Content/Sense_Hub/UserInterface/keyboard-navigation-and-shortcuts.htm)。

相关学习:

* [如何配置可视化捆绑垂直表？](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Straight_table)

## 了解详情

* [如何配置可视化捆绑垂直表？](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Straight_table)