# 多选框

![多选框](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/Resources/Images/ui_gen_MultiBox.png)

由于其独特选项可根据 applicability () 排序对显示字段排序，多选框可为在相同工作表上显示大量列表框提供最终问题解决方案。此根据适应性排序选项可从多选框属性：一般页面），可在现有图表中的不同表示之间切换。

右键单击多选框可显示对象菜单。

## 对象菜单

多选框 对象 菜单拥有三种版本。如果单击标题区域，浮动菜单会包含适用于全框的指令；如果个别字段位于指针之下，则菜单会扩展以包括适用于该字段的指令。最后，如果首先打开一个文件，浮动菜单仍将拥有另一种布局。菜单合并指令为：

对象菜单命令

| 命令 | 说明 |
| --- | --- |
| 属性... | 打开多选框属性对话框，您可在其中设置许多参数。 |
| 注 | 允许创建和共享当前对象的注释。 |
| 顺序 | 此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）时可用。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。<br><br><ul> <li><span>置于顶层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。 </li> <li><span>置于底层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。 </li> <li><span>上移一层</span>：以 1 为增量增加工作表对象的布局层。最大值为 127。</li> <li><span>下移一层</span>：以 1 为减量减少工作表对象的布局层。最小值为 -128。 <br></li> </ul> |
| 搜索 | 打开搜索框。<br><br>更多信息，请参阅[搜索](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Text_search_and_numeric_search.htm#Search) |
| 模糊搜索 | 打开模糊搜索模式的文本搜索框。<br><br>更多信息，请参阅[模糊搜索](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Text_search_and_numeric_search.htm#FuzzySearch) |
| 高级搜索 | 打开高级搜索对话框。此对话框可用于输入高级搜索表达式。该命令还可以通过以下键盘快捷方式调用： Ctrl+Shift+F。<br><br>更多信息，请参阅[高级搜索对话框](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Advanced_Search_dialog.htm) |
| 选择可能值 | 所有字段的不排除的值都将被选定。 |
| 选择排除项 | 所有字段的排除的值都将被选定。 |
| 全选 | 选择字段的全部值。 |
| 清除所有选择项 | 清除复选框的全部当前选择项。 |
| 清除 | 清除字段的全部当前选择项。 |
| 清除其他字段 | 清除其他全部工作表对象中的选择项，包括当前复选框其他字段中的选择项，同时维持当前多项框特定字段中的选择项。 |
| 锁定 | 锁定字段的选中值。 |
| 锁定所有选择项 | 锁定多选框的选中值。 |
| 解锁 | 解锁字段的已锁定值。 |
| 解锁所有选择项 | 解锁多选框的锁定值。 |
| 打印... | 打开打印对话框，可在其中指定打印设置。 打印多选框仅在单值显示在每个字段内时有意义（原因在于只限选中的值或只限关联的值）。<br><br>[打印：一般](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Print_General.htm#Print:) |
| 以 PDF 打印... | 打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。 |
| 发送到 Excel | 将可能的（包括选定的）值导出到 Microsoft Excel。如果 Excel 还未运行，将会自动开启。导出的值将出现在新 Excel 工作表中。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。 此运算符仅在单值显示在每个字段内时有意义（原因在于它只限选中的值或只限关联的值）。 |
| 导出... | 打开对话框，您可在其中导出用作表格的多项框到选择的文件。该文件可以保存为以下任意格式：逗号分隔、分号分隔、制表符分隔、超文本 (HTML)、XML 和 Excel （xls 或 xlsx）。默认格式为 \*.qvo (QlikViewOutput)，是一个制表符分隔文件。 |
| 复制到剪贴板 | 此层叠菜单包含用于工作表对象的各种复制选项。<br>数据<br>复制多项框的数据行到剪贴板。<br>单元格值<br>右键单击（调用对象菜单时），复制多项框单元格的文本值到剪贴板。<br>图片<br>将工作表对象的图片复制到剪贴板。取决于用户首选项对话框和导出页面中的设置，该图片将包含或不包含工作表对象的标题和边框。<br>对象<br>复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。 |
| 链接对象 | 对链接对象打开带有以下命令的菜单。<br><br><ul> <li><span>调整链接对象的位置</span>：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。 <br></li> <li><span>断开此对象/断开对象</span>：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。 </li> </ul> |
| 最小化 | 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。 |
| 最大化 | 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。 |
| 还原 | 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。 |
| 帮助 | 打开 QlikView 帮助。 |
| 移除 | 从工作表移除工作表对象。 |

## 一般

多选框选项

| 选项 | 说明 |
| --- | --- |
| 标题 | 在标题窗口中，多选框可以获得一个名称，以便显示在窗口标题中。标题也可以计算公式定义，以便动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 备用状态 | 在下拉菜单中选择一个可用的状态。以下备用状态始终可用。 继承：工作表和工作表对象通常处于继承状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。 默认状态：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于默认状态。 |
| 可用字段 | 数据源字段的名称显示在此列中。全部字段（排除系统字段）最初显示在此列中。要包括系统字段，请选中显示系统字段。<br><br>[系统字段](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/System_fields.htm)<br><br>带有关键字段符号的关键字段将显示。 通过单击可以选择要使用/移除的项目。使用添加 &gt;或&lt; 移除按钮将其移动至所需列。 |
| 在多选框内显示的字段 | 选择自可用字段列表并包括在多选框中的字段的名称会显示在此列中。最初没有任何字段显示在此列中。<br>当选择此列表中的字段时，您可以在编辑窗口中为其设置自定义标签。 |
| 显示表中字段 | 在这里，可以确定显示在可用字段列表中的具体字段。默认情况下，下拉列表将显示替代性全部表格。<br>替代性全部表格（限定）将按表格中显示的名称显示合格的字段。即将多次列出关键（连接）字段。（此替代项仅用于查看目的，不会对加载脚本中的 [Qualify](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptRegularStatements/Qualify.htm) 字段产生任何影响。）<br>此外，也可以一次查看一个表格的字段。 |
| 表达式 | 打开编辑表达式对话框，在此可创建表达式，然后用作多选框的显示字段。 |
| 编辑... | 打开编辑表达式对话框，在在多选框内显示的字段列中进行选择。 |
| 上移 | 在显示顺序中向上移动字段。 |
| 下移 | 在显示顺序中向下移动字段。 |
| 计数顺序 | 按数字顺序排序在多选框内显示的字段列中的字段。 |
| 加载顺序 | 按加载顺序排序在多选框内显示的字段列中的字段，即从数据库中读取字段的顺序。 |
| 文本顺序 | 按字母顺序排序在多选框内显示的字段列中的字段。 |
| 根据适应性排序 | 当选中此选项时，在多选框内显示的字段的排序会在选择期间自动更新，因此，带有非排除字段值的字段会在列表中上移，而没有可能值的字段则会下移。在许多情况下，此选项可实现在单个多选框中使用数百个字段。 |
| 对象 ID | 这用于宏目的。每个工作表对象均会分配一个唯一 ID。我们建议您在 ID 中只使用字母数字字符。 对于多选框，ID 以 MB01 开头。 链接对象共享相同的对象 ID。您可以稍后编辑此 ID 号。<br><br>[内部宏解释器](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm) |

## 排序

右键单击工作表对象（列表框、多选框、表格框、图表或滑块/日历对象），然后从浮动菜单选择属性（或主工作表菜单中的对象：属性），可以打开排序标签。在这里，可以设置工作表对象中的值排序。对于某些工作表对象可能部分排序选项不可用。

按选项排序

| 排序方式： | 结果 |
| --- | --- |
| 州 | 字段值根据其逻辑状态（选中，可选或排除）排序。<br>自动升序设置可以根据状态排列列表框（或多选框中包含字段值的下拉列表）顺序（只有当列表框包含垂直滚动条的时候）。但是，如果扩大列表框以显示所有值，将完全关闭排序状态。 |
| 表达式 | 根据输入到此排序选项下面的文本编辑框中的表达式排列字段值。如果使用表达式排序标准，必须通过集表达式定义记录集。注意：表达式排序标准只适用于数字字段而不适用于文本字段。<br><br>[集合分析和集合表达式](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/SetAnalysis/set-analysis-expressions.htm) |
| 频率 | 按频率（表格中的数字发生次数）排列字段值。 |
| 数值 | 按数值排列字段值。 |
| 文本 | 按字母顺序排列字段值。 |
| 加载顺序 | 按首次加载顺序排列字段值。 |

默认按钮排序可以设置默认排序。

优先顺序依次为状态，表达式，频率，数值，文本，加载属性。每一个排序标准都可以设置为升序或降序。

## 外观

多选框属性：外观标签的打开方式是：右键单击多选框并在对象菜单中选择属性命令。在这里，可以调整多选框单元格的布局。多选框中不同的字段可独立进行调整。- 关闭复选框 - 的布局也可以调整。

对齐属性

| 属性 | 说明 |
| --- | --- |
| 对齐 | 您可在此设置字段值的对齐。文本和数值的对齐可单独设置。 |

多行属性

| 属性 | 说明 |
| --- | --- |
| 多行设置 | 您可在此组中设置多选框字段单元格，以便在多行中显示值，这对于长文本字符串极为有用。<br>文本换行<br>选择此选项，单元格会在多行中显示内容。<br>标题高度n行数<br>在这里指定单元格行数的限值。 |
| 频率 | 显示<br><br>切换状态，即是否显示选定字段值的频率。频率是指值出现的可选组合的数量。<br>以百分百比表示<br>切换状态，是以绝对数显示频率，还是以总条目数的百分比显示频率。 |

外观属性

| 属性 | 说明 |
| --- | --- |
| 高级 | 此按钮用于打开高级字段设置对话框，您可在其中设置字段高级设置和特殊文本搜索选项的图片呈现形式。 |
| 单列 | 如果选中此选项，多选框字段值将总是显示在单列中。 |
| 隐藏水平滚动条 | 选中此选项以隐藏水平滚动条（通常当字段值太长，超过多选框指定的宽度时会显示该滚动条）。此时，将根据需要截短字段值。 |
| 根据列排序 | 在超过一列的多选框字段中，按指定的排序顺序逐行显示值。根据列排序选项用于切换为逐列显示。 |
| 单元格边框 | 字段值由水平线分隔，类似于表格的行。当选中了文本换行选项时，单元格边框自动激活，但可能随后关闭。 |
| 隐藏排除项 | 切换是否显示排除的字段值。排除值也可以变成不可选。 |
| 只读 | 此复选框可以禁用直接在此特定多选框字段所做的选择项，仅让其表现为一个显示工具。 |
| 忽略 NULL 值 | NULL 值不被视为显示特定字段正值的理由。<br><br>信息注释错误使用此选项可能会导致在多选框中显示未纠正的数据。 |
| 覆盖锁定字段 | 此复选框允许在特定多选框字段中进行选择，即使该字段已被锁定。对于在文档其他部分所作的选择，该字段仍将保持锁定。 |
| 网格类型 | 此复选框可以更改多选框布局，以使每个标签可以放置在其相应字段上方。 |
| 只读 | 此复选框可以禁用直接在多选框字段中所做的选择项，仅让其显示工具。 |
| 近色 | 设置关闭多选框的数据列单元格的颜色。单击此按钮可打开颜色区域对话框，在当中可将颜色定义为纯色或渐变色。 |
| 将下拉列表限制为*n*行 | 限制多选框中打开的下拉式列表框的长度。在编辑框中输入要显示的值的最大数量。 |
| 样式 | 在样式边框和浅色之间选择。 |
| 背景... | 打开背景设置对话框。 |

## 字段高级设置

字段高级设置对话框可以从多选框属性：外观、表格框属性：外观和图表属性：维度进行访问。下述图片选项不可用于位图图表。

### 图片选项

图片选项

| 选项 | 说明 |
| --- | --- |
| 呈现形式 | 提供了以下替代选择：<br>文本<br>一旦选择此选项，将总是解释表达式值并将其显示为文本。<br>图片<br>当选择此选项时，QlikView 尝试将每个表达式值解释为图片的参考。该参考可能是磁盘上图片文件的路径（例如，C:\Mypic.jpg）或在 QlikView 文档内部（例如，qmem://&lt;Name&gt;/&lt;Peter&gt;）。如果 QlikView 不能将表达式值解释成有效的图片参考，则将显示它本身的值。<br>信息作为图片<br>一旦选择此选项，QlikView 将通过脚本内的 info load/select 语句来显示链接至字段值的图片信息。当字段值无可用的图片信息时，除非选中图片丢失时隐藏文本框，否则字段值不会显示。此选项不可用于位图图表。 |
| 图片格式 | 仅当选择了以上图片选项时才可用。该设置描述 QlikView 如何格式化图片以适应单元格。有四种替代方案。<br>没有拉伸<br>如果选定该选项，图片将以原样显示，不作任何伸展。这可能会导致部分图片无法显示或仅填充部分的单元格。<br>填充<br>如果选择该选项，在不影响固定图片纵横比的前提下图片将被拉伸填充单元格。<br>保持长宽比<br>如果选择该选项，在固定图片纵横比的同时图片将被尽量拉伸填充单元格。这通常导致产生区域，要么在两侧，要么在图片未填充的上部和下部。<br>以固定长宽比填充<br>如果选择该选项，在固定图片纵横比的同时图片将被向两个方向拉伸填充单元格。这通常导致图片在某个方向上的多余部分被裁剪。 |
| 图片丢失时隐藏文本 | 如果选择了该选项，并且由于某些原因不能翻译成为图片参考的说明，则 QlikView 将不会显示字段值文本。单元格将会留空。 |
| 选择项样式覆盖 | 如果显示样式为图片，而非文本，则有必要换用选择项样式（而非选择文档默认设置），以确保字段值的逻辑状态清晰可见。使用选择项样式覆盖中的下拉式列表，在其中选择合适的选择项样式，例如圆角标记。 |

### 搜索选项

此组可用于控制适用于已打开多选框的文本搜索的某些方面，并可实现在表格中下拉选择。

搜索选项

| 选项 | 说明 |
| --- | --- |
| 在搜索中包含“排除值” | 此设置可指定是否在文本搜索中包括“排除值”。以下替代选择可用：<br>&lt;使用默认设置&gt;<br>用户首选项下指定的默认设置适用。<br>是<br>排除值始终包含在文本搜索中。<br>否<br>排除值绝不会包括在文本搜索中，但可选值则通常包括在内。 |
| 默认搜索模式 | 此设置可指定文本搜索使用的初始默认搜索模式。总是可以通过输入包含 \* 或 ~ 的搜索字符串来更改模式。以下替代选择可用：<br>&lt;使用默认设置&gt;<br>用户首选项下指定的默认设置适用。<br>使用通配符搜索<br>搜索字符串首字符是两个通配符，两者间有光标，这样可方便使用通配符搜索。<br>使用模糊搜索<br>初始搜索字符串可以是波浪号 (~)，以表示模糊搜索。<br>使用常规搜索<br>无需添加更多字符到搜索字符串。无通配符亦可执行常规搜索。 |

## 数字

多选框属性：数字标签的打开方式是：右键单击多选框并在浮动菜单中选择属性命令。

此属性页面提供多选框的所有字段的格式设置。选择字段文本框中的一个或多个字段（单击，Shift-单击或 Ctrl-单击），可单独为字段设置数字格式。

每个字段都有默认数字格式，此数字格式可在文档属性：数字页面中进行设置。不过，可以使用单个工作表对象的分隔数字格式。要做到此点，选中替代的覆盖文档设置并在以下组控件中指定一个数字格式。此属性页面应用于在用的对象，并包含以下控制，用于格式化值：

编号属性

| 属性 | 说明 |
| --- | --- |
| 混合 | 数值和文本。原始格式显示的数值 |
| 数字 | 显示精密微调框中设置带数位数字的数值。 |
| 整数 | 显示数值为整数。 |
| 固定为 \_ 位小数 | 显示小数微调框中设置的数值为带小数位数的小数值。 |
| 货币 | 以格式样式编辑框设置的格式显示数值。格式示例显示在预览文本框中。默认格式为 Windows 货币设置。 |
| 日期 | 以格式样式编辑框设置的格式显示可被解释为日期的数值。格式示例显示在预览文本框中。 |
| 时间 | 以格式样式编辑框设置的格式显示可被解释为时间的数值。格式示例显示在预览文本框中。 |
| 时间戳 | 以格式样式编辑框设置的格式显示可被解释为日期+时间的数值。格式示例显示在预览文本框中。 |
| 时间间隔 | 显示时间为顺序时间增量（如格式 = mm 显示数值为自日历起始时间开始计算的分钟数（ 1899:12:30:24:00）。 |

显示百分比 (%) 按钮按以下格式运行：数字，整数与固定为。

小数和千分位分隔符可在分隔符组的编辑框中设置。

ISO 按钮使用 ISO 标准设定日期，时间和时间戳的格式。

系统按钮应用系统设置到格式。

更改文档格式按钮可用于打开文档属性：数字页面，在该页面上可编辑任何字段的默认数字格式。

## 了解详情

* [文档属性：数字](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Number.htm)

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。