# 文件菜单

文件菜单是一种下拉式菜单，位于屏幕顶部，并且包含以下指令：

* 新建：打开新的 QlikView 窗口并允许创建新的 QlikView 文件。

* 打开...：打开一个新的 QlikView 窗口，并允许 打开 QlikView 文件或表格文件。打开表格文件会自动打开文件向导。该命令还可以通过以下键盘快捷方式调用： Ctrl+O。

* 在服务器上打开...：打开一个对话框，可在其中连接到 QlikView Server 并浏览要在客户端模式下打开的文档。  
  该命令还可以通过以下键盘快捷方式调用： Ctrl+Shift+O。

  信息注释在客户端打开 QlikView Server 上的文档时，与打开本地文档不同，在处理文档时您的权限可能会受到限制。您在客户端可能无法添加或删除工作表对象，具体取决于该文档是否支持协作。不能添加或删除工作表。此外，并非所有属性对话框均可存取，并非所有宏均可更改，并非所有脚本均可存取，并非所有数据均可重新加载，或者并非所有文档均可保存。

* 刷新文档：此命令仅适用于在 QlikView Server 上打开的文档，且仅当服务器上有该文档的较新版本时可用。调用刷新时，可以存取最新数据，同时可以维持包括选择项和布局状态的会话。

* 打开 URL...：打开打开 URL对话框。在此对话框中，输入有效的 URL 到任意网页。网页会在 QlikView 内以独立窗口打开。此功能可用于 QlikView Publisher 接入点，或用于页面通过 AJAX 客户端显示 QlikView 服务器文档。如同 QlikView 标准文档窗口，已打开的网页可通过 窗口菜单访问。

* 打开 FTP...：打开一个新的 QlikView 窗口，允许从 FTP 服务器打开 QlikView 文件或表格文件。打开表格文件会自动打开文件向导。

* 关闭：关闭激活的 QlikView 文件。

* 收藏夹：此级联菜单控制用户自定义的收藏夹文档列表，该列表独立于最近文档列表进行管理（见下文）。

* 保存：将当前配置保存在 QlikView \n 文件中。数据、脚本和布局均已保存。该命令还可以通过以下键盘快捷方式调用： Ctrl+S。如果您要使用 AJAX 客户端共享 QlikView 文档，则文件名不得包含井号 (#) 字符。

* 另存为...：以新名称将当前配置保存在新的 QlikView 文件中。该命令还可以通过以下键盘快捷方式调用： F12。如果您要使用 AJAX 客户端共享 QlikView 文档，则文件名不得包含井号 (#) 字符。

* 保存链接...：将 QlikView Server 上打开的文档链接作为文本文件保存到本地计算机。文件会拥有 qvw 扩展名，但不包含任何数据或布局。当打开此类链接文档时，QlikView 会尝试重新连接到服务器，并打开 QlikView 服务器上的文档。此指令不可用于本地文档。

* 以附件形式发送邮件...：仅在处理本地文档时可用。创建一封附有当前 QlikView 文档副本的邮件。邮件收件人将能够打开 QlikView 文档，前提是他们拥有 QlikView 的访问权限以及该文档的访问权限（如果使用了部分访问安全）。为使此指令生效，必须在电脑上配置邮件客户端。

* 以链接形式通过电子邮件发送书签...：仅在使用 QlikView Server 文档时可用。创建带当前服务期文档 URL 链接的邮件。在 URL 中创建（包括布局状态）和编码临时服务期书签。邮件收件人能够使用 URL 链接打开服务器文档，并查看正在查看的内容，假如他拥有其中文档和数据的访问权限。为使此指令生效，必须在电脑上配置邮件客户端。QlikView 服务器必须配置，以允许使用服务器书签。

* 打印...：打开标准 打印 对话框，允许打印当前工作表对象。此指令不可用于列表框。该命令还可以通过以下键盘快捷方式调用： Ctrl+P。

* 打印为 PDF...：打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。 该命令还可以通过以下键盘快捷方式调用： Ctrl+Shift+P。

* 打印可能值...：打开标准打印对话框，允许打印当前列表框的可能（已选和可选）值。此命令仅可用于列表框。

* 将可能值打印为 PDF...：将列表框和复合框打印为 PDF 时，必须使用此命令。

* 打印工作表...：打开打印对话框，可打印当前工作表的图像。

* 打印预览...：显示可打印工作表对象的预览。

* 源代码管理

  信息注释此功能已被弃用。请参阅支持结束前的最终文档版本：[文件菜单](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/File_menu.htm)

* 导出：

  * 导出内容...：此替代仅在可导出的工作表对象处于激活状态时可用。然后，它会执行工作表对象的对象菜单内的导出操作。
  * 导出工作表 图像...：打开一个对话框，用于将当前工作表的图像保存到文件中。
  * 导出文档布局：打开用于将文档布局另存为 XML 文件的对话框。文档中的任何数据都不会保存到 XML 文件中。

* 编辑脚本...：打开编辑脚本对话框。您可在此写入并执行脚本，以打开和连接到数据库。

* 重新加载：执行当前的加载脚本并将数据重新加载到激活的 QlikView 文档中。自从上次重新加载完成之后，如果数据库的内容发生更改，则需要完成此操作。该命令还可以通过以下键盘快捷方式调用： Ctrl+R。

* [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/File_menu.htm)部分重新加载：执行当前加载脚本，包括所有脚本命令，例如 Drop table，并将数据重新加载到激活的 QlikView 文档。但是，仅先前带有 Replace 或 Add 前缀的加载和选择语句的表格会重新加载。未受此类加载或选择语句影响的数据表格不受部分重新加载的影响。该命令还可以通过以下键盘快捷方式调用： Ctrl+Shift+R。

* [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/File_menu.htm)缩减数据：打开包含以下两个命令的菜单：

  * 保留可选值：通过删除所有排除值来缩减 QlikView 数据库。
  * 删除所有值：通过从 QlikView 数据库中删除所有值，但保留数据库结构和布局来创建模板。

* 表查看器...：打开“表查看器”对话框，可在其中通过表、字段和关联的图形视图查看已加载数据的结构。该命令还可以通过以下键盘快捷方式调用： Ctrl+T。

* 最近使用的文档列表：最近使用的 QlikView 文档列表。显示的文档数可在设置： 用户首选项对话框中设置。默认数字为 8。选择其中一个值等于打开指令。

* 退出：关闭打开的文档并退出 QlikView。

[QlikView 文件](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/QlikView_file.htm)

[文件向导：类型](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/File_Wizard_Type.htm)

[连接到服务器](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Connect_to_Server.htm)

[打开互联网文件或打开 QlikView 文件](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Open_Internet_Files.htm)

[导出和打印](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Print_General.htm)

[编辑脚本对话框](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

[部分重新加载](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Partial%20Reload.htm)

[表视图](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Table_Viewer.htm)