# 按钮

![Example clear selections button](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/Resources/Images/ui_gen_Button.png)

按钮可以在 QlikView 中创建和定义，用于执行命令或操作。按钮基本上可分为三种类型：启动/导出，快捷方式和宏按钮。

右键单击该对象将显示按钮：对象菜单。当按钮为活动对象时，其还可从对象菜单存取。

## 对象菜单

右键单击该对象可打开对象菜单按钮。此菜单命名包括：

对象菜单命令

| 命令 | 说明 |
| --- | --- |
| 属性... | 打开按钮属性对话框，您可在其中设置许多参数。 |
| 注 | 允许创建和共享当前对象的注释。 |
| 顺序 | 此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）时可用。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。<br><br><ul> <li><span>置于顶层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。 </li> <li><span>置于底层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。 </li> <li><span>上移一层</span>：以 1 为增量增加工作表对象的布局层。最大值为 127。</li> <li><span>下移一层</span>：以 1 为减量减少工作表对象的布局层。最小值为 -128。 <br></li> </ul> |
| 发送到 Excel | 将文本导出到 Microsoft Excel。如果 Excel 还未运行,将会自动开启。文本就爱你过显示在新 Excel 工作薄中的单个单元格内。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。 |
| 复制到剪贴板 | 此层叠菜单包含用于工作表对象的各种复制选项。<br><br><ul> <li><span>文本</span>：将显示在此按钮上的文本复制到剪贴板。 <br></li> <li><span>图片</span>：将工作表对象的图片复制到剪贴板。取决于<span>用户首选项</span>对话框和<span>导出</span>页面中的设置，该图片将包含或不包含工作表对象的标题和边框。 <br></li> <li><span>对象</span>：复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。 </li> </ul> |
| 链接对象 | 对链接对象打开带有以下命令的菜单。<br><br><ul> <li><span>调整链接对象的位置</span>：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。 <br></li> <li><span>断开此对象/断开对象</span>：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。 </li> </ul> |
| 最小化 | 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。 |
| 最大化 | 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。 |
| 还原 | 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。 |
| 帮助 | 打开 QlikView 帮助。 |
| 移除 | 从工作表移除工作表对象。 |

## 一般

在文本组中，可以设置按钮上显示的文本属性。

文本属性

| 属性 | 说明 |
| --- | --- |
| 文本 | 在贴有按钮标签的文本字段中输入文本。该文本可以作为计算公式定义。文本可由几行构成，如要分行，可按回车键。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 对齐 | 按钮文本可以是左对齐，中线对齐或右对齐。 |

在背景组中，可以指定按钮的背景。下拉列表提供三种不同的基本按钮样式供选择，还有附加设置：

背景样式和属性

| 选项 | 说明 |
| --- | --- |
| 水蓝色 | 新按钮默认样式。提供带三维玻璃状外观的圆角按钮。 |
| 素色 | 生成传统素色 QlikView 按钮。<br><br><ul> <li><span>系统默认设置</span>：为操作系统的按钮提供使用色彩定义的纯色背景。 </li> </ul> |
| 图片 | 生成图片按钮。图片既可以是单张静态图片，也可以是三张合并图像，每张图片对应每个按钮的三种可能状态（激活，非激活或凹陷）。<br><br><ul> <li><span>组合图片</span>：勾选此单选按钮，并使用<span>选择图片...</span>按钮浏览图片，以便分配三状态合并图像给按钮。图片文件必须由三张按钮图片构成：第一张为激活按钮图片，第二张为凹陷按钮图片，第三张为暗淡（非激活）按钮图片。 <br></li> <li><span>单张图片</span>：勾选此单选按钮，并使用<span>选择图片...</span>按钮浏览图片，以便分配单状态合并图像给按钮。支持的图片类型包括 jpg，png，bmp，gif 和动画形式的 gif。 </li> </ul> |
| 颜色 | 如果希望按钮带有色彩背景（图片设置不可用），选择此单选按钮。单击色彩按钮可打开色彩区域对话框，在当中可将色彩定义为纯色或渐进色。 |
| 透明度 | 设置按钮背景透明度。设置为 100% 时，背景将完全透明。不论颜色或图片是否用于背景，透明度均适用。 |
| 备用状态 | 在下拉菜单中选择一个可用的状态。以下备用状态始终可用。<br><br><ul> <li><span>继承</span>：工作表和工作表对象通常处于<span>继承</span>状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。 </li> <li><span>默认状态</span>：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于<span>默认状态</span>。 </li> </ul> |

附加按钮属性

| 选项 | 说明 |
| --- | --- |
| 对象 ID | 当前按钮的唯一 ID。每个工作表对象在创建时都会分配一个唯一的 ID，以便通过自动化进行控制。ID 由定义对象类型的字母和数字组合构成。文档的第一个按钮将分配 ID BU01。共享对象共享相同的对象 ID。对象 ID 可以更改为任何其他字符串，该字符串当前不可用于文档内的任何其他工作表对象，工作表或书签。 |
| 启用条件 | 此处输入的表达式用于确定按钮的状态。如果表达式返回 0，则按钮禁用；如果表达式返回 1，则按钮启用。如果未输入表达式，则假定为 1。因基本状态而禁用的按钮不可能通过条件启用。 |
| 打印设置... | 按下此按钮可以打开打印设置对话框，并在其中定义页边距和页眉/页脚。 |

## 操作

在此定制动作页面可设置某些对象：

* 按钮
* 文本对象
* 仪表盘
* 直线/箭头对象

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Button2.htm)定制动作包括启动外部应用程序或从 QlikView 导出数据。

* 添加：打开添加操作对话框，在这里可以选择操作对象。在列表中选择定制动作类型。根据此定制动作，各种定制动作参数将显示在定制动作页面。在执行第一个操作之前，将计算所列操作的输入参数。如果在执行开始后更改了参数（例如，如果某个操作被前一个操作更改），则不会在操作链中注册该更改。
* 删除：从对象移除定制动作。
* 上移：向上移动定制动作列表中的所选定制动作。
* 备用状态：设置操作状态。此设置仅与选择项或书签操作相关。

## 添加操作对话框

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Button2.htm)以下定制动作可通过添加定制动作对话框添加。在所有包含 ... 按钮的字段中，均可以输入一个计算公式。

[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

### 选择项

选择操作

| 操作 | 说明 |
| --- | --- |
| 在字段中选择 | 选择指定的值和字段。在搜索字符串中，您可指定搜索掩码，例如 (A\|B) 将同时选择 A 和 B。仅非数值需要引用，并且可连同数值被忽略。 |
| 选择排除项 | 在指定字段选择排除值。 |
| 选择可能值 | 在指定字段中选择可能值。 |
| 切换选择 | 在当前选择项和指定的字段及搜索字符串中选择。在搜索字符串中，您可指定一个搜索掩码。如指定 (A\|B)，则将选择 A 和 B。 |
| 前进 | 在选择项清单中前进一步。 |
| 后退 | 在选择项清单中后退一步。 |
| Pareto 选择 | 根据表达式及百分比在指定字段做出 pareto 选择。这种类型的选择项用于选择一种度量的顶部贡献者，通常符合 80/20 规则。例如，要想找出贡献了 80% 营业额的顶端客户，Customer 应作为字段使用，sum(Turnover) 应用作表达式，80 应用作百分比。 |
| 字段锁定 | 在指定字段中锁定选择项。 |
| 全部锁定 | 锁定所有字段中的全部值。 |
| 字段解锁 | 在指定字段中解锁选择项。 |
| 全部解除 | 解锁所有字段中的全部值。 |
| 解锁并清除全部 | 解锁全部值并清除所有字段中的全部选择项。 |
| 清除其他字段 | 清除指定字段以外的所有相关字段。 |
| 全部清除 | 清除全部选择项，已锁定选择项除外。 |
| 清除字段 | 清除指定字段。 |
| 复制状态内容 | 从源状态复制选择项到目标状态。仅当定义替换状态后才可用。 |
| 切换状态目录 | 切换状态 1 和状态 2 之间的选择项。仅当定义替换状态后才可用。 |

### 布局

布局操作

| 操作 | 说明 |
| --- | --- |
| 激活对象 | 激活对象 ID 指定的对象。此函数无法在 AJAX 客户端中工作。 |
| 激活工作表 | 激活工作表 ID 指定的工作表。 |
| 激活下一张工作表 | 打开文档中的下一张工作表。 |
| 激活上一张工作表 | 打开文档中的上一张工作表。 |
| 最小化对象 | 最小化对象 ID 指定的对象。 |
| 最大化对象 | 最大化对象 ID 指定的对象。 |
| 恢复对象 | 恢复对象 ID 指定的对象。 |
| 设置状态名称 | 将指定的状态应用到由对象 ID 所指定的对象。仅在定义的备用状态下才可用。 |

### 书签

* 应用书签：应用书签 ID 指定的书签。如果两个书签拥有相同的 ID，将会应用文档的书签。要应用服务器书签指定服务器\书签 ID。
* 创建书签：从当前的选择项创建一个书签。指定书签 ID 及书签名称。选择 **隐藏**创建隐藏书签。
* 替换书签：用当前的选择项替换书签 ID 指定的书签。

### 打印

* 打印对象：打印对象 ID 指定的对象。如果要将对象发送到默认打印机以外的打印机，请指定打印机名称。（不可用作文档和工作表触发器。）
* 打印工作表：打印工作表 ID 指定的工作表。（不可用作文档和工作表触发器。）此函数无法在 AJAX 客户端中工作。
* 打印报表：打印 报告 ID指定的报告。如果要将报告发送到默认打印机以外的打印机，请指定打印机名称。如果您要显示 Windows 打印对话框，请标记复选框显示打印对话框。（不可用作文档和工作表触发器。）

### 外部

* 导出：导出一份包含一组特定字段的表格，但只有对于作出的选择适用的记录才会导出。单击 操作页面中的设置按钮打开导出操作设置对话框。此项不可用作文档和工作表触发器。

  信息注释此函数无法在 AJAX 客户端中工作。

* 启动：启动一项外部计划。以下设置可在操作对话框中进行配置：

  * 应用程序：单击浏览... 可找到应启动的应用程序。（不可用作文档和工作表触发器。）
  * 文件名：输入应使用以上指定的应用程序打开的文件的路径。（不可用作文档和工作表触发器。）
  * 参数：在应用程序启动位置指定命令行参数。（不可用作文档和工作表触发器。）
  * 工作目录：为启动应用程序设置工作目录。（不可用作文档和工作表触发器。）
  * 关闭 QlikView 时退出应用程序：当退出 QlikView 时，强制关闭应用程序。（不可用作文档和工作表触发器。）

    信息注释此函数无法在 AJAX 客户端中工作。

* 打开 URL：您可在另一个 QlikView 文档中，使用打开 URL 来打开指向 QlikView 文档的 URL（文档链接）。该设置在默认网络浏览器中打开 URL。该功能不能用作文档和工作表触发器。如果使用打开 URL，确保以小写在操作字符串中输入文档名称。  
  在可行时，使用打开 QlikView 文档而非打开 URL。

  信息注释默认情况下，禁止在 URL 中使用 Javascript。

  您可以通过更改 custom.config 文件中的 `PreventJavascriptInObjectActions` 参数来允许 URL 中的 Javascript。

* 打开 QlikView 文档：您可在另一个 QlikView 文档中，使用打开 QlikView 文档 来打开 QlikView 文档（文档链接）。该功能不能用作文档或工作表触发器。更多信息，请参阅[文档链接示例](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Button2.htm#Document)。

* 执行宏：输入要执行的宏的路径和名称。输入以后可能在编辑模块对话框中为其创建宏的任何名称，或一个 动态更新的计算表达式。

* 设置变量：为指定的变量分配一个值。

* 显示信息：显示相关信息，如一个文本文件或字段中指定的字段图片。此函数无法在 AJAX 客户端中工作。

* 关闭这个文档：关闭当前 QlikView 文档。

* 重新加载：在当前文档中执行重新加载。此函数无法在 AJAX 客户端和 IE 插件中工作。

* 动态更新：在当前加载的文档中执行数据动态更新。动态更新状态将被输入 Statement 字段中。  
  动态更新的预期用途使 QlikView 管理员可以从单一源传送数量有限的数据到 QlikView 文档，同时无需执行重新加载文档。这时连接到 QlikView Server 的多个客户端可执行分析。

  信息注释更新的信息只存储在 RAM，如果执行重新加载文档，使用动态更新添加或更新的任何数据都将丢失。

  以下语法描述了可能与动态更新功能一起使用的语句及其组件：

  * statements ::= statement { “;” statement }
  * statement ::= insert\_statement | update\_statement | delete\_statement | begin\_transaction\_statement | commit\_transaction\_statement
  * insert\_statement ::= "INSERT" "INTO" ("\*" | table\_name) field\_list "VALUES" value\_list {"," value\_list} ["KEY" ["AUTO" | (" (" field\_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]{"," value\_list}
  * update\_statement ::= "UPDATE" ("\*" | table\_name) set\_clause {"," | set\_clause} "WHERE" condition ["AUTO" "INSERT"]
  * delete\_statement ::= "DELETE" "FROM" ("\*" | table\_name] "WHERE" condition
  * begin\_transaction\_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans\_name]
  * commit\_transaction\_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans\_name]
  * table\_name ::= identifier | quoted\_name
  * field\_list ::= "(" field\_name {"," field\_name} ")"
  * value\_list ::= "("value {"," value} ")"
  * set\_clause ::= "SET" field\_name "=" any\_valid\_non\_aggregated\_qlikview\_expression
  * field\_name ::= identifier | quoted string
  * value ::= identifier | any\_qlikview\_number | quoted string
  * condition ::= any\_valid\_non\_aggregated\_qlikview\_expression
  * identifier ::= any\_qlikview\_identifier
  * quoted\_string ::= "[" [^]]+ "]"

  示例：

  `  UPDATE AbcTable SET Discount = 123 WHERE AbcField=1 `

  信息注释 要使用此功能，文档和服务器都必须能够支持动态更新。

#### 文档链接示例

您可使用打开 QlikView 文档来创建文档链接。

可以应用以下设置：

* 传输状态：将选择项从初始文档传输至目标文档。目标文档将首先会清除选择项。

* 应用状态到当前选择项之上：保留目标文档的选择项并将原始文档的选择项应用到它们之上。

  信息注释 如果在两个文档中创建的选择项冲突，使用应用状态到当前选择项之上可能返回意外的结果。

* 在相同的窗口中打开：在使用 AJAX ZFC 客户端时在相同浏览器选择项卡中打开新文档。

  信息注释对于非域用户，在使用 QlikView 插件时，不支持打开 QlikView 文档操作。

QlikView 文档：必须包括目标文件的扩展名。只要链接的文档存储在相同文件夹结构中（挂载），则支持在所有客户端中从一个 QlikView 文档到另一个导航的相对路径。

以下示例示出了如何将文件路径写入目标文件：

示例：位于相同文件夹结构中的文件（相同挂载）。

* 如果目标文件位于相同文件夹中：  
  DestinationDoc.qvw

* 如果目标文件位于子文件夹中：  
  SubFolder/DestinationDoc.qvw

* 如果目标文件位于上层文件夹中：  
  ../DestinationDoc.qvw

* 如果目标文件位于上层和同层文件夹中：  
  ../ParallelFolder/DestinationDoc.qvw

示例：文件位于不同的文件夹结构中（不同挂载）。在 Ajax 客户端中仅支持不同挂载之间的相对路径。

* 如果目标文件位于不同挂载中：  
  ../DifferentMount/DestinationDoc.qvw

示例：使用挂载路径来指向 QlikView 文档。在 Ajax 客户端中仅支持设置指向挂载的文件夹的路径。

* 如果目标文件位于相同挂载的文件夹中：  
  \Mount\DestinationDoc.qvw

* 如果目标文件位于不同挂载的文件夹中：  
  \DifferentMount\DestinationDoc.qvw

  信息注释带有已挂载文件夹的文档链接不适用于 QlikView 插件。

示例：使用绝对路径来指向 QlikView 文档。在 Ajax 客户端和 QlikView Desktop 中支持使用文档链接的绝对路径。

* 指向本地 Local Root 文件夹或挂载的绝对路径：  
  C:\...\DestinationDoc.qvw

* 指向网络共享的绝对路径：  
  \\SharedStorage\...\DestinationDoc.qvw

Qlik Sense Cloud 应用中心中的 QlikView 应用：您需要 AppId，而非路径。需要在 QlikView Desktop 中准备和更新应用程序。当应用程序在应用中心中打开时，可以在 URL 中找到 AppId。

示例

如果 URL 为 https://qcs.us.qlikcloud.com/qv/opendoc.htm?document=1cc71b323f172f93a8121ce1456cdg。则 AppId 为 1cc71b323f172f93a8121ce1456cdg。

信息注释触发其他操作的操作即所谓的层叠操作，可能会导致无法预测的后果，并且不受支持！

信息注释

当与 QlikView Server 上的文档一起使用时，某些宏触发器的行为会受限。

[使用 QV-Server 上 QV 文档中的宏](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/UsingMacrosonQVS.htm)

## 导出操作设置对话框

### 选择项

在该组中您设置应为导出选择什么字段。

选择选项

| 选项 | 说明 |
| --- | --- |
| 字段 | 在此字段框中您可以看见一个可用字段的列表。 |
| 导出行 | 在该组中您可以看见您为导出选择的字段。您允许多个值的字段用星号标记。 |
| 添加 &gt; | 向导出行对话框添加字段。 |
| &lt;删除 | 从导出行删除字段。 |
| 上移 | 将所选字段向上移动一步，即在导出表中向左移动一步。 |
| 下移 | 将所选字段向下移动一步，即在导出表中向右移动一步。 |
| 多个值(\*) | 通过标记导出行对话框中的字段并选中此控件，您使一个字段可以在导出列表中拥有几个值。 |

### 导出至

在该组中您可以选择您是要将值导出到一个文件还是到剪贴板。

导出选项

| 选项 | 说明 |
| --- | --- |
| 文件 | 如果您导出到一个文件，您必须标记此复选框并输入文件名。如果未输入文件名，值将导出到剪刀贴板上。该文件名可以作为计算公式输入。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 浏览 | 打开导出文件对话框，使您可以浏览一个要将值导出到其中的文件。 |
| 剪贴板 | 默认设置。如果以上未指定文件名，值将导出到剪刀贴板上。 |
| 字段选择项 | 如果选中了此控件，导出文件将为每一个所选字段在一行上拥有全部可能的字段值，它们之间由制表符分隔。 |
| 包括标签 | 如果选中了此控件，行中的首个位置（当字段选择项已设置）或首个记录（当记录已设置）将包括该字段名。 |
| 记录 | 如果选中了此控件，导出文件将为每一个所选字段拥有一列，它们之间由制表符分隔。 |
| 附加到现有文件上 | 如果选中了此控件，如果文件已存在，导出将会附加到导出文件上。当向一个现有文件附加时，标签将不会导出。如果没有导出文件，此标记则没有意义。 |

### 数字格式

有些其他程序可能有困难用数字格式正确处理数字。QlikView 为要导出至文件或剪贴板数字数据格式提供了三个选项。

新导出按钮将继承用户首选项：导出页面中的设置。但可为每一个导出按钮进行单独设置。

* 完整格式：指导 QlikView 导出数字数据的完整格式，与其在文档工作表对象中显示的一样。
* 没有千位分隔符：从数字数据中删除任何千位分隔符。
* 无格式化：从数据中删除所有数字格式并导出原始数字。小数位分隔符将如系统设置（控制面板）中那样定义。

信息注释

当与 QlikView 服务器上的文档一起使用时，某些宏触发器的行为会受限。

[使用 QV-Server 上 QV 文档中的宏](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/UsingMacrosonQVS.htm)

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。