# 表格框

![An example of a table box](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_TableBox.png)

表格框是指同时显示几个字段的工作表对象。每行的内容在逻辑上相互关联。各列内容可以是取自于不同的内部表格，让用户从任何可能的字段组合创建表格。

右键单击表格框显示对象菜单。

信息注释如果您将没有链接的数据表中的大量字段数据添加到表格框中，则 QlikView 会创建笛卡尔连接来解析所需的链接，这可能导致内存耗用过高以及其他性能问题。

## 使用表格框

### 排序

只需右键单击该列然后从上下文菜单选择排序便可按任意列排列表格框。双击列标题进行排序。从上下文菜单选择排序或双击同一列标题将颠倒排序顺序。

### 更改列顺序

各列顺序可以通过拖放方法进行更改。首先让鼠标指向列标题，然后按住鼠标并将该列拖放到新位置。取消选中允许拖放复选框（在表格框属性：外观页面中）可禁用此功能。

## 对象菜单

表格框对象菜单有两个不同的版本。如果单击了标题区，浮动菜单将包含适用于整个框的命令，如果光标放在某个字段上，菜单将扩大至包括适用于该字段的命令。菜单合并指令为：

* 属性...：打开表格框属性对话框，您可在其中设置许多参数。
* 注： 允许创建和共享当前对象的注释。
* 按数据调整列：按每列中最宽的数据调整表格中的所有列的宽度。在计算中也包括页眉。
* 同等列宽：将表格中的列宽设置为与您单击的列宽度相等。
* 排序：按您单击的字段排序记录。
* 自定义格式单元格：打开自定义格式单元格对话框，您就可以格式化所单击的列和带状区域单元格。此层叠菜单只有当激活了视图菜单的设计网格命令时才可用。
* 顺序：此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）时可用。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。
  * 置于顶层：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。
  * 置于底层：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。
  * 上移一层：以 1 为增量增加工作表对象的布局层。最大值为 127。
  * 下移一层：以 1 为减量减少工作表对象的布局层。最小值为 -128。
* 更改值：只可用于显示输入字段的表格框列。在输入模式设置单击单元格。相当于在单格中单击输入图标。
* 恢复值：只可用于显示输入字段的表格框列。打开一个带三个选项的层叠菜单。
  * 恢复单个值：在脚本中将单击的字段值中的值恢复到其默认值。
  * 恢复可能值：从脚本中将所有可能的字段值恢复到其默认值。
  * 恢复所有值：从脚本中将所有字段值恢复到其默认值。
* 选择可能值：所有字段的不排除的值都将被选定。
* 选择排除项：所有字段的排除的值都将被选定。
* 全选：选择字段的全部值。
* 清除所有选择项：清除表格框中显示的所有字段中的选择。
* 清除：清除字段的全部当前选择项。
* 清除其他字段：在当前字段中选择所有可能的值，然后清除所有其他字段中的选择。
* 锁定：锁定字段的选中值。
* 解锁：解锁字段的已锁定值。
* 打印...： 打开打印对话框，可在其中指定打印设置。
* 以 PDF 打印...： 打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。
* 发送到 Excel...： 将可能的（包括选定的）值导出到 Microsoft Excel。如果 Excel 还未运行，将会自动开启。导出的值将出现在新 Excel 工作表中。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。
* 导出...：将表格的内容导出到一个您选择的文件中。该文件可以保存为以下任意格式：逗号分隔、分号分隔、制表符分隔、超文本 (HTML)、XML 和 Excel （xls 或 xlsx）。默认格式为 \*.qvo (QlikViewOutput)，是一个制表符分隔文件。将表格框导出为 HTML 格式时，其中的图片不会随之导出。
* 复制到剪贴板：此层叠菜单包含用于工作表对象的各种复制选项。
  * 完整表格：将表格复制到剪贴板，包括完整的页眉及选择状态。
  * 表格数据区：只将表格的值复制到剪贴板。
  * 单元格值：右键单击（调用对象菜单时），复制列表框单元格的文本值到剪贴板。
  * 图片：将工作表对象的图片复制到剪贴板。图像将包括或不包括工作表对象标题和边框，具体取决于用户首选项：导出页面中的设置。脚本隐藏部分生成的表格不会显现为 $Table 系统字段内的名称。
  * 对象：复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。
* 链接对象： 对链接对象打开带有以下命令的菜单。 调整链接对象的位置：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。   
  断开此对象/断开对象：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。

* 最小化： 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。
* 最大化： 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。
* 还原： 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。
* 帮助： 打开 QlikView 帮助。
* 移除： 从工作表移除工作表对象。

## 自定义格式单元格对话框

此对话框允许您将自定义格式应用到表格单元格的一个或多个组中。它可从表格框、垂直表或透视表的对象菜单进行调用，前提是视图菜单的设计网格命令处于激活状态，或者选中总是显示设计菜单项目（在用户首选项：设计下）。

将会受到影响的单元格组由您在要调出命令的表格中右键单击处决定。要作为一个单元格式化的单元的最小组是表格框中的一个字段（通常为列）或者表格图表中的一个表达式/维度。如果使用了条带，每一个条带都将单独格式化。

无论何时使用此对话框自定义格式化表格的任何一部分，在表格属性对话框中的样式页面的样式将会被设置为[自定义]。如果您将样式的设置改变回其以前定义的样式，该自定义格式化将会丢失。

信息注释表格样式通常由来源于属性表达式的任何格式化取代。

* 表格预览窗格：预览窗格显示对表格单元组做出的格式更改。不象右侧的较小的预览，样式文本，它在上下文中以及在视觉提示及/或属性表达式格式化之后显示变化。   
  在此栏中，可以在表格上自由移动，并将格式应用到单元格的不同组上。只是单击一个单元格来移动格式化焦点。
* 撤消：撤消按钮可以用于一步一步地撤消在自定义格式单元格对话框中做出的更改。   
  在离开自定义格式单元格对话框后，在些对话框中做出的所有更改都可通过只单击一下主工具栏中的撤消按钮即可取消。
* 重做：重做按钮可以用于一步一步地重新应用在自定义格式单元格对话框中以前通过撤消按钮取消的更改。
* 样式文本：这是显示做出的设置的预览单元格。
* 背景颜色：定义单元格背景颜色。
* 文本颜色：定义单元格文本颜色。
* 单元格前面边界：在此处您定义单元格前面的边框。有一个下拉菜单用于设置边框样式和一个按钮用于设置边框颜色。注意单元格边框将会在单元格之间合并，这可能使表格中的实际边框看起来与预览中有所不同。
* 单元格后面边框：在此处您可定义单元格后面的边框。有一个下拉菜单用于设置边框样式和一个按钮用于设置边框颜色。注意单元格边框将会在单元格之间合并，这可能使表格中的实际边框看起来与预览中有所不同。
* 文本设置：在此组中，您可以看见一个适用于单元格的文本修饰语。
  * 文本大小：使用下拉菜单将大小修饰应用至表格中使用的通用字体上。
  * 加粗：勾选此复选框显示粗体。
  * 斜体：勾选此复选框显示斜体。
  * 下划线：勾选此复选框显示下划线。
  * 投影：勾选此复选框使文本有投影。
* 将更改应用于：改变通常只应用于表达式，维度或字段（表格框），在这里您可右键单击进入对话框。在此下拉菜单的帮助下，您可选择将相同的格式应用到其他表达式，维度或字段上。

## 一般

表格框属性：一般页面的打开方式为：右键单击表格框并在浮动菜单中选择属性命令，或者当激活一个表格框时选择对象菜单中的属性打开。

* 标题：在 标题 窗口中，表格框可以获得一个名称，以便显示在窗口标题中。 标题也可以计算公式定义，以便动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

* 可用字段：数据源字段的名称显示在此列中。全部字段（排除系统字段）最初显示在此列中。要包括系统字段，请选中显示系统字段。 通过单击可以选择要使用/移除的项目。使用添加 &gt;或&lt; 移除按钮将其移动至所需列。

* 在表格框中显示的字段：选择自可用字段列表并包括在表格框中的字段的名称会显示在此列中。最初没有任何字段位于此列中。   
  当选择此列表中的字段时，您可以在编辑窗口中为其设置自定义标签。

* 显示系统字段：勾选此复选框使系统字段显示在可用字段列中。

* 显示表中字段：在这里，可以确定显示在可用字段列表中的具体字段。默认情况下，下拉列表将显示替代性全部表格。如果您想要列表显示来自特定表格的字段，请在下拉式列表中选择表格名称。   
  替代性全部表格（限定）将按表格中显示的名称显示合格的字段。即将多次列出关键（连接）字段。（此替代项仅用于查看目的，不会对加载脚本中的 [Qualify](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptRegularStatements/Qualify.htm) 字段产生任何影响。）

* 上移：在显示顺序中向上移动字段。

* 下移：在显示顺序中向下移动字段。

* 计数顺序：按数字顺序排序在表格框中显示的字段列中的字段。

* 加载顺序：按加载顺序排序在表格框中显示的字段列中的字段，即从数据库中读取字段的顺序。

* 文本顺序：按字母顺序排序在表格框中显示的字段列中的字段。

* 备用状态：

  在下拉菜单中选择一个可用的状态。以下备用状态始终可用。

  * 继承：工作表和工作表对象通常处于继承状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。
  * 默认状态：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于默认状态。

* 对象 ID：这用于宏目的。每个工作表对象均会分配一个唯一 ID。我们建议您在 ID 中只使用字母数字字符。 对于表格框，ID 以 TB01 开头。 链接对象共享相同的对象 ID。您可以稍后编辑此 ID 号。

  [内部宏解释器](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm)

* 计算条件：指定必须执行的计算条件，以便显示表格框。只要未满足条件，“计算条件未执行”信息即会显示。

* 错误信息：表格框（和图表）内的标准错误信息可在自定义错误消息对话框中自定义，该对话框可通过按错误信息按钮打开。

  [自定义错误信息](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Custom_Error_Messages.htm)

## 排序

表格框属性：排序标签的打开方式是：右键单击表格框并在浮动菜单中选择属性命令。

表格框的字段会显示在排序优先级列表中。字段的顺序会在执行排序执行时确定应用何种排序。使用上移和下移按钮可以更改字段的顺序。对于列表中的每个字段，您可以指定排序程序中使用何种标准。排序标准描述如下。

排序方式：

* 表达式：字段值依据输入此排序选项下文本编辑框的任意表达式进行排序。
* 频率：切换状态，以确定是否依据频率对值进行排序。
* 数值：切换状态，以确定是否依据数值对值进行排序。
* 文本：切换状态，以确定是否依据 ASCII 标准按字母顺序对值进行排序。
* 加载顺序：切换状态，以确定是否依据加载顺序对值进行排序。

如果指定超过一种排序，则排序将是表达式，频率，数值，文本，加载顺序。

## 外观

表格框属性：外观标签的打开方式是：右键单击表格框并在浮动菜单中选择属性命令。

您可在此对话框中确定表格框的布局。

* 对齐：通过选择字段列表中的字段和对齐组中的适当选项，字段值的默认对齐可以单独设置为文本和数值。文本值默认左对齐，数值默认右对齐。
* 当字段为 NULL 值时隐藏行：如勾选，包含字段值（来自选定字段的空值）的行将被移除。“无值”可借助空值理解。
* 下拉选择：如勾选，将在选定字段的列标题左边添加下拉箭头图标。单击该图标可从下拉字段列表中存取字段。产生的效果完全类似于在多选框中进行选择。

* 高级...：此按钮用于打开高级字段设置对话框，您可在其中设置字段高级设置和特殊文本搜索选项的图片呈现形式。
* 多行设置：您可在此组中设置表格页眉和数据单元格，以便在多行中显示值，这对于长文本字符串极为有用。
  * 文本换行标题高度 n 行数定此选项，标题将在不只一行中显示其内容。您可在此制定所需的页眉行数限制。
  * 文本换行单元格高度 n 行数：选择此选项，单元格会在多行中显示内容。您可在此制定所需的单元格行数限制。

* 垂直标签：如勾选，将旋转全部字段标签到垂直位置。
* 允许拖放：如勾选，单击并拖放该标题将可以排列表格框字段的顺序。
* 排序指示器：如勾选，在表格当前使用的排序条件字段标题列的右侧将添加一个排序指示器图标。图标会快速翻转，以反映升序或降序排序顺序。
* 选择项指示器：如勾选，在表格当前使用的排序条件字段标题列的右侧将添加一个排序指示器图标。图标会快速翻转，以反映升序或降序排序顺序。
* 隐藏页眉行：如勾选，将显示不含标题（标签）行的表格。

## 样式

该样式页面适用于所有 QlikView表格、表格框、透视表和垂直表。您可在此设置表格格式样式。

* 当前样式：从下拉式列表中选择合适的表格样式。如果值[Custom]显示在下拉控件中，则自定义样式已应用至表格。如果您将设置改回为预定义的一种样式，则自定义格式会丧失。

* 每 \_ 行条纹数：您可在此指定时间间隔阴影条纹是否显示以及显示多长时间。

* 缩进模式：此设置仅对透视表有效。勾选此替代选项，可稍微更改表格样式，这对于在表格宽度限制范围内容纳多个维度标签尤其有用。

  * 仅使用第一个维度标签：此设置仅可用于缩进模式的透视表，并且可进一步修改透视表的样式。

* 垂直维度单元格边框：此设置确定是否显示维度列的垂直单元格边框。

* 垂直表达式单元格边框：此设置确定是否显示表达式列的垂直单元格边框。

* 边框在间隔之上：假设已在高级字段设置对话框中定义间距，表格样式可通过勾选此替代选项进行小的修改。

  [Advanced Field Settings](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Advanced_Field_Settings.htm)

* 背景...：打开背景设置对话框。

* 单元格背景颜色透明度：如果颜色或图片已经应用背景设置，您可以在此调整单元格背景内该颜色或图片的透明度。

* 单元格边框透明度：设置单元格边框应如何凸显。

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。