# 垂直表

![垂直表的示例。](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_IntroStraight.png)

图表为数值数据的图形呈现形式。透视表和垂直表是特殊的两种数据呈现形式，因为它们可以以表格形式显示数据，而保留图表的全部属性。通过更改图表类型（位于图表属性：一般页面），可在现有图表中的不同表示之间切换：

相对于透视表，垂直表无法显示子合计或用作交叉表。另一方面，垂直表的任意列都可以进行排序，并且每一行都包含一个维度与表达式的组合。

创建垂直表最快的方法是从工具菜单中选择快速图表向导。

右键单击垂直表将显示垂直表：对象菜单。当垂直表为活动对象时，其还可从对象菜单存取。

另请参阅：

[快速图表向导](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Quick_Chart_Wizard.htm)

[图表类型](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Chart_types.htm)

## 使用垂直表

## 排序

只需右键单击该列然后从上下文菜单选择排序便可按任意列来排列垂直表。这相当于移动该列到垂直表属性对话框排序页面的优先顺序列表的顶部。另一种替代方法是双击该列标题进行排序。

## 重新排列各列

用鼠标拖放维度列和表达式列可移动它们。首先令鼠标指到列标题，然后按住鼠标将该列拖放到新位置。可以将维度和表达式以任何顺序混合。

可以从 [图表属性：外观（垂直表）](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Straight_Table.htm#Chart2) 重置列顺序。

## 对象菜单

右键单击该对象可打开垂直表对象菜单。此菜单命名包括：

* 属性...：此命令可打开属性对话框，在此可设置定义垂直表的参数。

* 注： 允许创建和共享当前对象的注释。

* 分离： 在图表标题上附加文本“（分离）”。当在文档中进行选择时，该图表不再会被更新（虽然实际上仍可在该图表上进行选择）。仅当附加了图表时此命令方可用。通过复制图表并分离它，可直接比较图表副本和原始图表。

* 附加： 附加已分离的图表。图表以动态方式链接到数据。仅当图表已分离时此命令才可用。

* 复制：复制一份相同的垂直表。如果复制了分离的垂直表，则复制副本将被附加。

* 按数据调整列：调整每个表格的列宽到其最长数据字符串处。计算中包括页眉。

* 同等列宽：如果将鼠标指针放在垂直表的一列上，此命令在浮动菜单中变行可用（不是在主菜单条对象 菜单中）。   
  该命令按照所指的宽度为表格的所有列设置列宽。   
  列宽可以通过将指针移动到更的右侧边缘（指针外观改变）单独调整及拖动。

* 排序：如果将鼠标指针放在垂直表的一列上，此命令在浮动菜单中变行可用（不是在主菜单条对象 菜单中）。表格的行将按指定列排序。排序顺序在图表属性：排序页面中设置。

* 自定义格式单元格：打开自定义格式单元格对话框，您就可以格式化所单击的列和带状区域单元格。此层叠菜单只有当激活了视图菜单的设计网格命令时才可用。

  [Custom Format Cell dialog](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Custom_Format_Cell_dialog.htm)

* 顺序：此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）时可用。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。

  * 置于顶层：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。

  * 下移一层：以 1 为减量减少工作表对象的布局层。最小值为 -128。

  * 上移一层：以 1 为增量增加工作表对象的布局层。最大值为 127。

  * 置于底层：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。

* 更改值：只可用于包含一个输入字段的 inputsum 聚合的表达式列。在输入编辑模式设置单击单元格。相当于在单格中单击输入图标。

* 恢复值：只可用于包含一个输入字段的 inputsum 聚合的表达式列。打开一个带三个选项的层叠菜单。

  * 恢复单个值：在脚本中将单击的单元格的基础字段值恢复到其默认值。
  * 恢复可能值：从脚本中将所有可能的基础字段值恢复到其默认值。
  * 恢复所有值：从脚本中将所有基础字段值恢复到其默认值。

* 清除所有选择项：在表格的维度和表达式中清除全部选择。

* 打印...： 打开打印对话框，可在其中指定打印设置。

* 以 PDF 打印...： 打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。

* 发送到 Excel...：将表格导出到 Microsoft Excel。如果 Excel 还未运行，将会自动开启。表格将出现在新 Excel 工作表中。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。

* 导出...：打开另存为对话框，可以指定导出数据内容的路径，文件名称和（表格）文件类型。 提供的文件格式包括各种分隔符分隔的文本文件格式、HTML、XML、XLS、XLSX 和 QVO（QlikView 导出文件）。

  信息注释当导出至 Excel 表时，最小的图表将不会显示。

* 复制到剪贴板：此层叠菜单包含用于工作表对象的各种复制选项。

  * 完整表格：将表格复制到剪贴板，包括完整的页眉及选择状态。
  * 表格数据区：只将表格的值复制到剪贴板。
  * 单元格值：将右键单击的单元格的文本值 (当调用对象菜单时）复制到剪贴板上。
  * 图片：将工作表对象的图片复制到剪贴板。图像将包括或不包括工作表对象标题和边框，具体取决于用户首选项：导出页面中的设置。
  * 对象：复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。

* 链接对象： 对链接对象打开带有以下命令的菜单。 调整链接对象的位置：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。   
  断开此对象/断开对象：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。

* 最小化： 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。

* 最大化： 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。

* 还原： 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。

* 帮助： 打开 QlikView 帮助。

* 移除： 从工作表移除工作表对象。

## 图表属性：一般

在一般 页面上，可以将图表属性设置为标题和图表类型。这是快速图表向导和 图表属性对话框的第一个页面。

一般图表属性

| 属性 | 说明 |
| --- | --- |
| 窗口标题 | 窗口页眉内显示的标题。 标题也可以计算公式定义，以便动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 显示图表标题 | 在默认情况下，将定义的第一个表达式标签设定为图表标题。如果未显示任何图表标题，则清除复选框。要显示原始标题，只需选中复选框。标题也可以计算公式定义，以便动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。 图表标题不会显示在透视表或垂直表内。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 标题设置 | 单击标题设置按钮，定义图表标题的高级设置。 |
| 打印设置 | 单击打印设置按钮打开打印设置对话框，可在其中定义页边距和页眉/页脚格式。打印设置对话框有两页，打印布局和打印页眉/页脚。<br><br>[打印：“布局”](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Print_Layout.htm) 和 [打印：页眉/页脚](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Print_Header_Footer.htm) |
| 备用状态 | 在下拉菜单中选择一个可用的状态。以下备用状态始终可用。<br><br><ul> <li><span>继承</span>：工作表和工作表对象通常处于<span>继承</span>状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。 </li> <li><span>默认状态</span>：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于<span>默认状态</span>。 </li> </ul> |
| 对象 ID | 这用于宏目的。每个工作表对象均会分配一个唯一 ID。我们建议您在 ID 中只使用字母数字字符。 链接对象共享相同的对象 ID。您可以稍后编辑此 ID 号。<br><br>对于图表，ID 以 CH01 开头。<br><br>[内部宏解释器](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm) |
| 分离 | 如果启用，即可分离图表。意即图表不再随选择而动态更新。 |
| 只读 | 如果启用，则图标变为只读形式。换言之，无法以在图表内单击或使用鼠标绘画的方式作出选择。 |
| 计算条件 | 可在此文本框内输入一个表达式，用于设置所显示图表需要执行的计算条件。如果未执行计算条件，则图表将显示文本“计算条件无法实现”。 该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。 |
| 图表类型 | 在图表类型组中，可以选择图表的基本布局。欲了解每个图表类型的更多信息，请参阅[图表类型](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Chart_types.htm)。 |
| 快速转换类型 | 可以在此组中启用图表内的图标，借此图标，用户无须转至图表属性对话框，即可单击此图标更改图表类型。<br><br><ul> <li><span>允许的类型</span>：可在此列表中选择哪些图表类型将显示在下拉列表中。要启用快速转换类型，必须选择两个或更多类型。 </li> <li><span>指定的图标位置</span>：在图形图表中，快速转换类型图标可定位在图表或工作表对象标题之中。在表格图表中，标题是唯一的替代项。 </li> </ul> |
| 重置用户大小调整 | 按此按钮可重置图形图表内全部用户大小调整（包括图例和标题等）。单个项目的靠接不受影响。 |
| 重置用户靠接 | 按此按钮可重置图形图表内全部用户靠接（包括图例和标题等）。 |
| 错误信息 | 打开自定义错误信息对话框。<br><br>[自定义错误信息](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Custom_Error_Messages.htm) |
| 参考模式 | 此设置用于指定当用图表上下文菜单设置参考值选项时如何绘制参考背景。此设置仅适用于部分图表。 |

另请参阅：

[调整和移动图表组件](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Sizing_and_moving_chart_components.htm)

[在图表和表格中选择](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Selections_in_charts_and_tables.htm)

## 图表属性：维度

图表属性：维度页面可在图表已激活的情况下，通过右键单击图表并选择属性，或者通过选择对象菜单中的属性来打开。

创建图表时，您首先应该询问自己两个问题：

* 您想要查看什么？条形图的条形大小对应什么？答案可以是“销售额总和”或类似回答。这可在表达式标签上设置。
* 您想要依据什么标准分组？您想要使用哪些字段值作为条形图的条形标签？答案可以是“每个国家”或类似回答。这可在维度标签上设置。

图表可以显示一个或多个维度。上限值取决于实际图表类型，数据的复杂性和可用的内存。饼图，折线图和散点图可以显示两个维度，条形，块状和网格图表（三）的最大值。雷达和漏斗图仅会显示单维度，表盘图表根本不使用维度。更多的维度会被忽略。

图表维度会从图表属性：维度页面上指定的字段中取得其值。维度还可由一组字段构成，而不是单个字段（参阅以下编辑组）。

维度可以使单个字段，组或表达式（计算维度）。它也可能是合成创建的维度。

通过选择（单击，Ctrl-单击）和使用添加&gt;或&lt;移除按钮，或者直接双击选择项，即可前后移动字段。

图表维度还可利用表达式计算。

维度属性

| 属性 | 说明 |
| --- | --- |
| 可用字段/组 | 列出可用作维度的所有字段/字段组（即沿着典型条形图的 X 轴）。字段组会先于向下钻取组的垂直箭头或的循环组曲形箭头。<br><br>在文档属性：组页面上可以定义组。 通过单击可以选择要使用/移除的项目。使用添加 &gt;或&lt; 移除按钮将其移动至所需列。<br><br>显示的维度数量因不同的图表类型而异。<br><br>显示在不止一个内部表格中的全部字段可以关键字符号开头。饼图，折线图和散点图不会显示超过两个维度。条形图最多可显示三个维度。<br><br>[文档属性：组](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Groups.htm) |
| 显示系统字段 | 勾选此选项可在可用字段/组列中显示系统字段。 |
| 显示表中字段 | 您可以从此控制哪些字段/组显示在可用字段/组列表中。默认情况下，下拉列表将显示替代性全部表格。<br><br>替代性全部表格（限定）将按表格中显示的名称显示合格的字段。即将多次列出关键（连接）字段。（此替代项仅用于查看目的，不会对加载脚本中的 [Qualify](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptRegularStatements/Qualify.htm) 字段产生任何影响。）<br><br>此外，也可以一次查看一个表格的字段。注意，可用组总是会列出。 |
| 编辑组别... | 此按钮可直接打开文档属性：组页面，您可在其中定义用作维度的字段组。 |
| 动画... | 打开动画对话框，您可借此使用图表的首个动画维度。动画仅适用于除饼图之外的位图图表。在使用动画时，某些功能会受到限制。 |
| 网格图... | 打开网格图设置对话框，您可在其中基于第一维度创建图表阵列。任何类型的位图图表均可以网格图显示。 |
| 已使用的维度 | 此列表包含当前选择用作图表内维度的维度。可以使用的维度数量因图表类型而异。任何特定类型的多余维度均会忽略。<br><br>用于表格之中时，维度数据单元格会借助特性表达式动态格式化。每当为维度输入一个属性表达式时，它的图标将从灰色转为彩色，或在文本格式中，从灰色变为黑色。这些设置会先于图表设置。点击任何维度前方的 "+" 表达式，显示占位符或维度的特性表达式。<br><br><ul> <li><span>背景颜色</span>：双击<span>背景颜色</span>，为计算维度单元格的单元格背景颜色输入属性表达式。所用的表达式应返回有效的颜色呈现形式（在 Visual Basic 中定义的表示红色，绿色和蓝色成分的数字）。使用一个特殊图表颜色函数即可实现。如果表达式的结果并非一个有效的颜色呈现形式，则程序将会使用黑色作为默认颜色。 </li> <li><span>文本颜色</span>：双击<span>文本颜色</span>为计算维度单元格的单元格文本颜色以输入属性表达式。所用的表达式应返回有效的颜色呈现形式（在 Visual Basic 中定义的表示红色，绿色和蓝色成分的数字）。使用一个特殊图表颜色函数即可实现。如果表达式的结果并非一个有效的颜色呈现形式，则程序将会使用黑色作为默认颜色。 <p><a href="https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm">颜色函数</a></p></li> <li><span>文本格式</span>：双击<span>文本格式</span>为计算每个维度单元格中表格单元格的文本字体样式以输入属性表达式。用作文本格式表达式的表达式应返回一个字符串，包含粗体文本的 '&lt;B&gt;' 、斜体文本的 '&lt;I&gt;' 及/或下划线文本的 '&lt;U&gt;'。 <br></li> </ul><br><br>使用上移和下移按钮可对已使用的维度列表中的维度进行排序。 |
| [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Straight_Table.htm) [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Straight_Table.htm)添加计算维度 | 添加新维度并将其打开，以便在编辑表达式对话框中编辑该维度。图表维度往往位于单个字段内，但也可动态计算。计算维度由设计一个或多个字段的表达式构成。所有标准函数均可使用。聚合函数可能不必使用，但若要实现嵌套聚合，还需要将Aggr函数包括在内。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 编辑... | 打开维度，以在编辑表达式对话框中进行编辑。参阅上述添加计算维度，了解计算维度详情。 |
| 选定维度的设置 | 您可在此组种找到个别维度的设置。<br><br>启用条件：单击下面编辑框中的 ... 按钮，通过勾选此复选框可隐藏或动态显示维度（取决于输入的条件表达式的值）。<br><br>当数值是空值时隐藏：启用此复选框后，如果数值是空值，上述已用维度中的选中维度不会显示在图表中。<br><br>显示所有数值：启用此复选框可显示所有维度值，不论选择项为何。为避免维度值因表达式值为零而被排除，必须取消选择外观页面中的隐藏零值，以便显示所有数值生效。如果您使用表达式作为维度，则显示所有值将不适用。<br><br>显示图例：当勾选显示图例时，字段值的“名称”沿 X 轴显示。<br><br>标签：一旦勾选标签选项，字段名会显示。标签可在以下文本框中编辑。标签也可定义为计算标签表达式进行定义，以便动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。更多信息，请参阅[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)<br><br>高级...：此按钮用于打开高级字段设置对话框，您可在其中设置字段高级设置和特殊文本搜索选项的图片呈现形式。更多信息，请参阅[Advanced Field Settings](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Advanced_Field_Settings.htm)<br><br>注释：一个注释字段，可以在其中描述所选维度。该注释可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。<br><br>分页符：此设置仅应用于在透视表或垂直表中启用打印输出内的分页符。三种模式可用，并且会产生以下效果：<br><br><ul> <li><span>无拆分</span>：仅会按要求在每页末端插入分页符。 </li> <li><span>有条件的拆分</span>：将插入分页符，除非当前页配备所有带以下维度值的行。 </li> <li><span>强制拆分</span>：只要维度值发生改变，即插入分页符。</li> </ul> |

## 图表属性：维度限制

维度限制可用于图表类型，仪表盘图表透视表除外。

维度限制标签可控制在给定图表中可见的维度值的数量。

在论述此之前，先要描述下拉列表中的三个选项产生的的效果，这点很重要。下拉列表包含三个值：首个、最大和最小. 这些值控制计算引擎对其返回至图表引擎的值的排序方式。如果要限制维度，那么必须选择三个选项中的一个。排序只发生于第一个表达式，但当透视表中的主要排序覆盖第一维度排序时例外。

本属性页面用于定义维度限制。图表中的每个维度都是独立配置的。

### 限定

#### 使用第一个表达式限制要显示的值

根据以下做出的设置，该属性用于确定多少维度值显示在图表中。

#### 仅显示

选择此选项，如果您想要显示第一个、最大的或最小的 x 值的数量。如果该选项设置为 5，将会显示 5 个值。如果维度包括显示其他，其他分段将占据 5 个值中的 1 个。 第一个选项将根据在属性对话框排序标签内选择的选项返回行。如果是垂直表，将根据当时的主排序返回行。也就是说，用户通过双击任何列标题和设置该列为主排序便可更改值显示。最大选项根据图表的第一表达式以降序形式返回行。如果在垂直表中使用，交互式排序表达式时，维度值显示将保持一致。维度值将（可能）随着表达式的顺序变动而更改。最小选项根据图表的第一表达式以升序形式返回行。如果在垂直表中使用，交互式排序表达式时，维度值显示将保持一致。维度值将（可能）随着表达式的顺序变动而更改。输入要显示的值数量。 该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。

#### 仅显示以下值：

选择此选项，显示所有符合该选项指定条件的维度值。选择以后，可根据占总计百分比或准确数量显示值。相对合计选项启用了相对模式，其性质类似于属性对话框表达式标签上的相对选项。 该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。

#### 仅显示累计到以下的值：

当选择此选项时，当前行以下的所有行均被累计，所得结果则用于与选项设定值比较。相对合计选项启用了相对模式，其性质类似于属性对话框表达式标签上的相对选项，并可比较累计值（根据首个、最大或最小值）与全部总计。该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。 选择包括边框值，以包括含有比较值的维度值。

[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

信息注释当计算累积限制总数时，将不包含负值。我们建议您不要使用会含有负值的相关限制字段。

信息注释如果您向计算维度添加了限制，并且数据分类依据的是同一计算维度，则维度限制的应用将先于排序应用。

### 选项

#### 显示其他

启用该选项，将在图表中生成其他分段。所有不符合显示限制比较标准的维度值将分组加入其他分段。如果所选维度之后还存在维度，折叠内部维度可控制子维度/内部维度的单个值是否显示在图表上。在标签字段中，输入您希望在图表中显示的名称。如果未输入任何文本，则标签将被自动设置为表达式文本。  
该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。

#### 显示总计

启用该选项时，表格会显示选中维度的总计。其形式不同于表达式总计，但仍可以在属性对话框的。 **表达式** 标签上配置。 **标签**: 输入您希望在图表中显示的名称。如果未输入任何文本，则标签将被自动设置为表达式文本。 该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。

#### 全球分组模式

该选项仅适用于内部维度。启用该选项时，将仅在选中维度上计算限制。所有先前维度都将被忽略。如果其被禁用,限制将根据所有先前维度进行计算。

## 表达式总计与维度总计之间的比较

维度总计由计算引擎生成，并以独立行的形式（或维度值）被返回至图表引擎。这对“其他”行有影响。在以下可以看出表达式总计与维度总计之间的差异。

![Example comparison between expression totals and dimension totals, which are separated by dimension](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_Totals.png)

表达式总计与维度总计

当使用维度总计时，垂直表中可能出现子总计。

## 图表属性：表达式

要进入图表属性：表达式标签，请右键单击图表或表格，然后从对象菜单中选择属性。

当创建一个图表时，应该询问两个问题：

* 应显示什么尺寸的条形柱？这些是表达式 ( 如净销售额总和)。
* 数据应如何分组？这些是维度 ( 如每个国家/地区 )。

信息注释表达式标签不同的图表和表格类型外观不同。如果一个选项灰显，表示它对该特定图表或表格类型不可用。

### 表达式列表

左上部窗格中的表达式列表是带数字控制选项的完整的树型控制。

在每一个表达式（或表达式组）的前面有一个扩展图标（一个带 ' + '）的框。单击图标打开下面的子表达式或属性表达式。图标同时被一个折叠图标 ( ' - ' ) 取代。某些图选项使用子表达式，如一组两个或多个一起定义图符号的表达式(如以下描述的股价图或盒须图)。

表达式数据也可通过属性表达式动态地格式化。单击任何表达式前面的扩展图标显示维度属性表达式的占位符。这些是：

#### 背景颜色

编辑默认的背景颜色表达式以创建计算数据点图颜色的属性表达式。计算的颜色将会比默认的 QlikView 颜色选择更加优先，且必须为有效的颜色呈现形式，它是通过使用颜色函数取得的。如果表达式的结果并非一个有效的颜色呈现形式，则程序将会使用黑色作为默认颜色。文本颜色的辅助表达式可通过相同的方法创建。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

#### 文本颜色

文本颜色的辅助表达式可用与背景颜色相同的方法创建（见以上）。

#### 文本格式

编辑文本格式表达式以输入计算数据点相关文本的字体类型的属性表达式（对于表格：表格中的每个维度单元的表格单元格中的文本。计算文本格式优先于图表属性：样式。

用作文本格式表达式的表达式应返回一个字符串，包含粗体文本的 '&lt;B&gt;' 、斜体文本的 '&lt;I&gt;' 及/或下划线文本的 '&lt;U&gt;'。注意“ = ”是字符串前面必不可少的。

#### 饼图弹出气球

单击饼图弹出以输入属性表达式，用于计算与数据点相关的饼块是否应在抽出的“弹出”位置绘出。这种属性表达式只对饼图有影响。

#### 条形偏移

单击条形偏移，输入一个属性表达式，用于计算与数据点相关的条形或或条形片断的偏移。偏移可是正数或负数，并且将会相应地移动条形或条形片断。例如，在制作瀑布图时该功能非常有用。这种属性表达式只对条形图有影响。

#### 线类型

单击线类型输入一个属性表达式，用于计算与数据点相关的线或线段的线类型。这种属性表达式只对折线，组合以及雷达图有影响。线的相对宽度可用包含 &lt;Wn&gt; 标记来控制，在这里 n 代表一个应用于图表默认线宽的乘积因素。数字 n 必须是 0.5 至 8 范围内的实数。

示例： &lt;W2.5&gt;

线的类型可用包含 &lt;Sn&gt; 的标记控制，在这里 n 是指示使用类型的 1 至 4 的整数（1=直线，2= 虚线，3=点线， 4=虚线/点线）。示例：&lt;S3&gt;。&lt;Wn&gt; 和 &lt;Sn&gt; 标记可以自由组合，但仅限于每次计数的第一次发生次数。标签必须用单引号括起来。

#### 显示值

单击显示值，输入一个属性表达式，用于计算数据点绘制是否需应用“数据点值”补充，即使未为主表达式选择数据点上显示数值。如果数据点上显示数值已为主表达式选择，则属性表达式将被忽略。这种属性表达式只对条形图，折线图、饼图、漏斗图及组合式图表有影响。

### 添加

新表达式及子表达式是通过添加按钮创建的。选项也同时在当右键单击表达式列表时出现的上下文菜单中可用。

### 删除

删除按钮可以让您从列表中删除以前创建的表达式。当右键单击表达式列表中的表达式时，该选项也可用于上下文菜单。

### 复制

复制选项只在当右键单击表达式或表达式列表中的子/属性表达式时出现的上下文菜单中可用。在主表达式中使用该命令时，所有与表达式（包括标签）相关的数据和设置将被复制至 xml 剪贴板中。

表达式然后就可被粘贴回到同一个图表中或同个文档或其他文档中的 QlikView 图表中。如果在属性表达式上使用该命令，则只有属性表达式的定义将被复制。属性表达式然后可以粘贴至同一个或其他图表中任何一个表达式。

### 导出...

导出选项只在当右键单击表达式列表中的表达式时出现的上下文菜单中可用。在主表达式中使用该命令时，所有与表达式（包括标签）相关的数据和设置将被导出至 xml 文件中。

随后该表达式可能会导入至同一或其他文档中的同一图表或任意其他 QlikView 图表。该命令打开表达式导出为对话框，在其中您可用选择导出文件的目的地。文件将会收到一个扩展名 Ex.xml。

### 粘贴

粘贴选项只在当右键单击表达式或表达式列表中的子/属性表达式时出现的上下文菜单中可用。如果主表达式先前已复制到剪贴板，您可用以将其粘贴在表达式列表的空白处，创建与复制的表达式相同的新表达式。如果复制了一个特性表达式，您可以将其粘贴至主表达式。

### 导入

导入选项只在当右键单击表达式列表中的空白区域时出现的上下文菜单中可用。该指令会打开一个对话框，这里您可浏览至以前您导出的表达式。导入表达式将以新的表达式出现在图表中。

### 左移/右移

如果显示几个表达式，它们可以通过上移和下移按钮进行排序。这影响列等在图表中显示的顺序。

### 组

组按钮可用于将表达式合并到一个或多个循环组中，条件是两个或多个表达式可用。在 QlikView 布局中，您可以通过单击显示在图表中的循环图标（= 循环组）在属于同一组中的表达式间循环。右键单击相同的循环图标打开一个属于目前未使用的组的表达式列表弹出窗口，然后直接选择。

信息注释

不要将循环组和环形组混淆。

[非层次组（循环）](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Nonhierarchic_groups_cyclic.htm)

### 取消分组

选择属于一个组的表达式，然后单击取消分组，从组中解压表达式。如果在解压后循环组中只有一个表达式，该剩下的表达式也会解压，并且组也将被取消。

### 启用

禁用此复选框会设置图表忽略表达式。

### 相对

启用此复选框将使图表设置成以百分比的形式显示结果，而不是绝对数字形式。此选项不可用于透视表。

### 不显示

启用此复选框会防止该表达式的绘图，但仍然保留分配给它的空间。

### 有条件

启用此复选框可让您根据当前选择定义一个条件，从而决定是否显示表达式。如果条件的评估结果为“真”或 NULL，则显示表达式，如果条件的评估结果为“假”，则不显示表达式。

### 标签

在表达式标签的前面有一个或几个图标，用于表示使用的图表类型及/或为表达式选择的显示选项（见下文）。

### 定义

显示选择的表达式的组合。可以在此栏中直接编辑表达式。单击 ... 按钮，完整的编辑表达式对话框将打开。

### 注释

这是一个注释区，在这里创建者可以描述表达式的目的和功能。

### 显示选项

该组用于修改绘制点的方法或者在图表的表达式单元中输入什么内容。注意有些选项只可用于某些类型的图表，有些选项无法组合，有些选项将利用一个或多个其他表达式以创建复杂的制图。

#### 条形

将所选表达式的值显示为条形。此选项只可用于条形及组合式图表。

#### 符号

显示所选表达式的值为符号。此选项只可用于线形及组合式图表。在下拉菜单中选择几个不同的符号。

#### 线

将所选表达式的值显示为线。此选项只可用于线形及组合式图表。可在下拉菜单中的普通，圆滑及三种不同的高原线之间选择。

#### 股指线

勾选此复选框，以将表达式绘制为股价标签。在表达式列表中表达式前面是它自己的图标，以空白占位符的形式显示，有四个子表达式。

首个子表达式将用于绘制股价标签的高点。第二个子表达式将用于绘制股价标签的低点。这两个子表达式必须包括有效的定义，以用于绘制股价标签。

第三个子表达式是可选项，但可用于股价标签的近点。第四个子表达式也是可选项，但可用于股价标签的开放点。

当勾选该表达式的股价图复选框时，新的空白子表达式将自动创建。如果为表达式选择了股价图复选框，则不能为同一表达式选择条形，折线，符号，盒须图或显示错误条形。反之，如果已为表达式选择了这些选项中的任何一个，则无法为该表达式选择股价图复选框。此选项只可用于组合图。

#### 盒须图

勾选该复选框以将表达式绘制成盒须图，其经常用于显示统计数据。在表达式列表中，表达式前方是其自己的图标，以空白占位符的形式显示，并包括五个子表达式。

首个子表达式将用于绘制盒须图的盒顶点。第二个子表达式将用于绘制盒须图的盒低点。这两个表达式必须包括有效的定义，以用于绘制盒须图。

第三至第四个子表达式是可选项。如果使用它们，则这些子表达式可定义低须线，中须线和高须线。

盒须图的一般范围即所谓的极限值框架。这些可通过将表达式绘制成单独的符号获得。当勾选主表达式的盒须图时，新的空白子表达式将自动创建。如果为一个表达式选择了盒须图，您不能为同一个表达式选择条形，折线，符号，股票或有错误条形复选框。如果已为一个表达式选择了这些选项中的任何一个，则无法为该表达式选择盒须图。此选项只可用于组合图。

#### 有错误条形

勾选此复选框，利用紧随所选表达式之后的一个或两个表达式作为辅助表达式，以便在主表达式数据点上绘制错误条形。如果选择了“对称”，将会只使用一个表达式并将其在数据点周围对称绘制。如果选择了“不对称”，将会使用两个表达式并将其各自在数据点上和下绘制。

误差条形表达式应返回正数。在表达式列表中，用于错误条形的辅助表达式前方是其自己的图标（对称的），（不对称高点）或（不对称低点），且它们不能用于该图表的任何其他地方。在所选表达式后面如果没有定义表达式，新的假样本辅助表达式将自动创建。此选项只可用于条形，折线和组合图。

#### 数据点上值

标记此复选框让表达式结果作为文本在数据点顶部绘制。此选项只可用于条形，折线，组合及饼图。当应用于饼图时，值将会紧接着饼块显示。

#### 轴上的文本

勾选此复选框，将表达式结果绘制为在 x 轴的每一个值，轴以及轴标签上的文本。此选项只可用于条形，折线和组合图。

#### 以弹出框形式显示的文本

勾选此复选框让表达式的结果在弹出气球信息中显示，通常当它悬浮在布局中一个图表的点上时出现。此选项可单独使用，也可配合其他显示选项使用。因此它可以有一个不在图表本身中出现只在悬浮弹出窗口中出现的表达式。

#### 呈现形式

此选项只可用于垂直表及透视表。

#### 文本

表达式值总是以文本形式解释和显示。

#### 图片

选择此选项，QlikView 会偿试解释每一个表达式值，作为对一个图片的参考。参考可能是指向一个磁碟上的文件 (如 C:\Mypic.jpg) 或者在一个 QlikView 文档本身内部的路径 (如 qmem://&lt;Name&gt;/&lt;Peter&gt;)。如 QlikView 无法作为一个有效的图片参考解释一个表达式的值，将会显示值本身，除非勾选了当图片丢失时隐藏文本。

#### 圆形表盘，线性表盘，交通灯表盘，LED 表盘

选择其中任一个表盘选项，表盘图表都将在可用表格单元格中以图片形式写入。表盘布局可在图表属性：外观对话框中修改，该对话框可使用仪表设置按钮打开。

#### 小图表

此项选可使 QlikView 在条形或折线图中显示表达式值。图表将会记录在可用的表格单元中。图表的视觉设置可通过小图表设置按钮进行修改。此选项只可用于垂直表。

[Mini chart settings](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Sparkline_Settings.htm)

信息注释当导出至xcel 时小图表将不会显示！

#### 链接

选择此选项进入定义字段中的一个表达式，这将在表格单元格中创建一个可单击的链接。表达式应返回一个可以解释为显示文本&lt;url&gt;链接文本的文本。显示文本将在表格单元中显示， 链接文本将会是在一个新的浏览窗口中打开的链接。

如果定义了一个链接，表格单元中的值将会被添加下划线。如果未定义链接，值将不会被添加下划线。注意，不可以在一个带链接的单元格中作为显示模式作出选择。单击 ... 按钮，完整的编辑表达式对话框将打开。

信息注释由于安全限制，URL 链接只能在 Ajax 客户端中起作用。

示例：

=Name & '&lt;url&gt;' & Link

=Name & '&lt;url&gt;www.qlikview.com'

其中 Name 和 Link 是在脚本中加载的表格字段。

#### 图片格式

仅当选择了以上图片选项时才可用。此选项只可用于垂直表及透视表。该设置描述 QlikView 如何格式化图片以适应单元格。有四个替代选项：

* 没有拉伸：如果选定该选项，图片将以原样显示，不作任何伸展。这可能会导致部分图片无法显示或仅填充部分的单元格。
* 填充：如果选择该选项，在不保持固定图片纵横比的前提下图片将被拉伸以填充单元格。
* 保持长宽比：如果选择该选项，在固定图片纵横比的同时图片将被尽量拉伸填充单元格。
* 以固定长宽比填充：如果选择该选项，在固定图片纵横比的同时图片将被向两个方向拉伸填充单元格。这通常导致图片在某个方向上的多余部分被裁剪。

### 累计

通过在该组中选择设置，您可能决定图表中的值是否累计。在一个累计图表中，每一个 y 值都将被添加至之后 x 值的 y 值上。在一个累计条形图表中显示每年销售总和，如 1996 年的值被添加至 1997 年的值上。

如果图表包含几个表达式，在表达式列表中选择需要累计值的表达式。累计不可用于透视表。

#### 不累计

如果选择此选项，将不会累计所选图表表达式的 y 值。

#### 全部累计

如果选择此选项，每个 y 值将会累计该表达式以前的所有 y 值。参阅上述累计项。对于包含 NULL 值或 0 值的多维度，完全累计不起作用。

信息注释如果启用了图表网格图，则完全累计不起作用。

#### 累计 n 步长

通过在框中输入一个数字，可设定表达式中要累计的 y 值个数。参阅上述累计项。

### 合计模式

启用该组仅适用于垂直表图对象中已选的表达式。有三种可能的设置：

* 无总计：不为所选表达式计算合计。
* 表达式总计：表达式合计在下一个级别评估。例如，如果一个表达式为许多员式计算平均月工资，表达式合计将产生所有员工的合计平均数。
* 行的 F(x)：如果选定此选项，选定表达式的每个数据点的单个值（条形图的每一条，垂直表格中的每一行等）都将使用从下拉菜单中选择的聚合函数聚合中（一般称合计）。

信息注释表格中第一个字符串或最后一个字符串的值要么是最大值，要么是最小值，以字母数字顺序排序。字母数字顺序以 0 开头，直到 9，然后是 A 到 Z。

### 条形边框宽度

指定条形和组合式图中表达式绘制的条形周围边框线的宽度。值可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 表达式作为图例

当使用几个表达式时，此选项显示图例，显示表达式及其图表旁相应的色彩。

### 趋势线

在所选的 QlikView 图表中，表达式绘制可以用统计趋势线补充或取代。

趋势线只可在散点图，折线图以及条形/组合图中显示，最多作为条形显示一个维度以及一个表达式。对于其他类型的图表，趋势线组中的设置不可用并且也没有影响。在散点图中数据点以 y=f(x) 形式处理。对于条形图，线图及组合图，允许在显示选项中取消所有选项，并仍可添加趋势线，趋势线在没有基础数据点的情况下对其进行绘制。条形图，线图及组合图中的趋势线可以通过预测及/或回测间隔的方式外推（轴页面）。外推线的形式为虚线。带离散 x 轴的图表中的趋势线将显示为带符号的线。在一个连续的轴上只显示线。

* 平均值：绘制一条表示平均值的直线。
* 线性：绘制一条线性回归线。
* 二次多项式：绘制二次多项式趋势线。
* 三次多项式：绘制三次多项式趋势线。
* 四次多项式：绘制四次多项式趋势线。
* 指数：绘制指数趋势线。
* 显示公式：如果为某个具体的表达式勾选此复选框，表达式的趋势线将会由表示为图表中文本的趋势线方程式补充。
* 显示 R2：如果为特定表达式勾选此复选框，表达式趋势线将会由表达为图表文本的确定系数补充。

[表格图表中的线性回归](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/NestedAggregations/linear-regression-table-charts.htm)

## 图表属性：排序（垂直表）

![图表属性窗口的排序菜单。](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ChPs_Sort_Straight.png)

图表属性：排序（垂直表）

图表属性：排序页面的打开方式是：右键单击垂直表并选择对象菜单中的属性。

您可在其中依据众多可用排序确定图表维度的排序。

变量和定义垂直表的表达列出于列组中。

* 优先顺序：包含选为排序优先顺序列的维度/表达式。选择其中一列即可设置排序标准组内值的排序。   
  单击上移和下移按钮也可更改排序优先顺序。
* 排序方式：在此组中设置列值的排序。
  * 表达式：根据输入到此排序选项下面的文本编辑框中的表达式对列值排序。
  * 频率：依据频率（在表格中的发生次数）对列值排序。
  * 数值：依据数值对列值排序。
  * 文本：依据字母顺序排序列值。
  * 加载顺序：依据初始加载顺序对列值排序。
* 覆盖组别排序顺序：此复选框仅在属性列表中选择一个组维度时可用。通常可通过组属性来确定组内各字段的组维度排序。勾选此复选框，可以覆盖任意此类组级设置，并应用维度的单个排序，不论组内激活字段为何。

* 允许交互式排序：取消选择此选项，禁用对象 - 排序命令。

## 图表属性：外观（垂直表）

维度和定义垂直表的表达列出于列组中。选择一列可改变其属性。

* 列标签：列标签显示字段的标签，它也可以编辑。
* 显示列：通过选择此无线电按钮，当表格在布局中画出时所选列将会可见。
* 重置列顺序：单击此按钮，列将按表达式前面列出的所有维度排序。
* 隐藏列：有些情况下，您可能想要在一个用户看不见的字段内对垂直表进行排序。隐藏列选项使您可以在保证其仍然可用于排序目的的同时隐藏一个字段。排序标准在列组的优先级（位于图表属性：排序（垂直表）页面）中声明。
* 有条件：列将根据每次画出表格时都会对其进行评估的条件表达式显示或隐藏。仅当条件返回 FALSE 值时工作表才会隐藏。单击 ... 按钮，编辑表达式对话框将会完整打开，以更方便编辑长公式。
* 对齐：在此组中，可以设置维度值对齐方式，表达式值及其在垂直表中的标签。标签，数据（数字）以及数据（文本）可以单独设置为左对齐，居中或右对齐。使用多行单元格和表格时，标签（垂直）和数据（垂直）可以设置为顶部对齐，居中或底部对齐。
* 下拉选择：下拉选择选项在任何所选列中标题的左侧添加一个下拉箭头图标。单击图标从下拉数据列表中访问数据。这与在多选框中做出选择极其相似。
* 可搜索：如果为一个表达式列选定了可搜索，一个搜索图标将在列标题中的左侧显示。单击该图标，一个搜索框将会打开。然后输入一个搜索标准（如 &gt;100 000）。当您按“确定”键时，所有表达式值与搜索标准相匹配的表格列都将被选定。
* 最大数量（1 - 100）：表示要显示的最大的行数。
* 允许拖放：此选项，可通过单击并拖动标题排序表格字段的顺序。可以将维度和表达式以任何顺序混合。
* 水平：选中了此选项，垂直表转动 90 度，这样数据列就会水平显示。
* 隐藏零值：复选框禁止零值将消除仅包含表中的零或空值的表达式。
* 排序指示器：此选项在表格当前使用的排序条件字段标题列的右侧添加一个排序指示器。图标弹开反应升序或降序。
* 垂直列标签：列标题标签将旋转至垂直。
* 选择项指示器：选中了此选项，一个彩色的指示灯将显示在任何做出选择的字段列的标题中。
* 隐藏页眉行：选中了此选项，表格将会在没有标题（标签）行的情况下显示。
* 隐藏遗漏值：此选项不可用于垂直表。
* 空值符号：此处输入的符号将用来显示表格中的空值。
* 遗漏符号：此处输入的符号将用来显示表格中的遗漏值。

* 合计：表达式列的合计根据以下设置显示。
  * 第一行合计：在表格顶部附近显示合计。
  * 最后一行合计：在表格的末端显示合计。
  * 使用标签：此处您可输入总计标签。

* 多行设置：您可在此组中设置表格页眉和数据单元格，以便在多行中显示值，这对于长文本字符串极为有用。
  * 标题文本换行：定此选项，标题将在不只一行中显示其内容。
  * 标题高度\_ 行：此处您可指定对标题行数的限制。
  * 单元格文本换行：选择此选项，单元格会在多行中显示内容。
  * 单元格高度（行数）：此处您可指定对单元格行数的限制。

## 图表属性：视觉提示

图表属性: 视觉提示页面只在透视表和垂直表中可用。此页面的打开方式是：右键单击图表窗口并在浮动菜单中选择属性命令。

视觉提示用于高亮显示表达式值并通过应用不同的字形，字体颜色和/或单元格颜色显示。属于不同时间间隔的值通常有不同的提示。

使用上限 &gt;，常规和下限 &lt;选项可以指定三种不同的时间间隔值，每一个具有不同的设置。上限时间间隔值可指定输入到编辑框中大于数字值的值，下限时间间隔值可指定输入值以下的值。常规值是指在这两个范围之间的值。文本值是缺乏有效数字解释的值。

## 图表属性：样式

在此页，您可以确定图表的基本样式。并非每个图表类型均可使用列出的所有功能。

* 外观：选择其中一个可用样式。在某些实例中，这不仅会影响图表外观，而且会影响图表的功能。

* 方向：设置图表方向（垂直或水平）。

* 子类型：在此组中可以设置该模式，如条形图被设置为已分组或堆叠模式（雷达图被设置为 覆盖或堆叠模式）。仅当图表显示两个维度，或者图表显示一个维度且拥有一个以上表达式时，此项设置方可用。堆叠条形图的负值表示在 X 轴下方朝下单独堆叠。对于条形图，当使用连续轴缩放时，堆叠式布局是唯一允许的布局。  
    
  对于带有多个维度和表达式的条形图的外观，以下原则适用：

  * 两个维度的最大值显示在 X 轴上。
  * 第三维度可利用彩色堆叠条形图显示。
  * 仅表格图表可显示超过三个维度。
  * 当启用两个或更多表达式时，两个第一维度会和彩色堆叠条形图一起显示在 X 轴和表达式上。
  * 如果启用两个或多个表达式，且将子组设置为堆叠，则一个堆叠中的所有表达式都会根据一个轴进行计算（默认为左轴）。即使您将一个表达式设置为根据左轴进行计算，将另一个表达式设置为根据右轴进行计算，结果也是这样。

  下表显示了具有多个维度和表达式的子类型的呈现形式：

  * 一个维度
    * 1 个表达式：单个条形
    * 2 个以上表达式：表达式分组或堆叠
  * 两个维度
    * 1 个表达式：维度分组或堆叠
    * 2 个以上表达式：维度分组
  * 三个维度
    * 1 个表达式：第一和第二维度分组，第三维度堆叠
    * 2 个以上表达式：第一和第二维度分组，表达式堆叠
  * 四个维度
    * 1 个表达式：第一和第二维度分组，第三维度堆叠
    * 2 个以上表达式：第一和第二维度分组，表达式堆叠

* 三维视图：本组的此项设置用于定义图表在三维模式下的查看角度。

  * 顶角：定义三维视图垂直查看角度。该值必须为 5 到 45 之间的一个整数。
  * 侧面角：定义三维视图侧面查看角度。该值必须为 5 到 45 之间的一个整数。

* 绘图颜色样式：此控件可用于为图表内所有绘图色彩设置颜色样式。当在下拉式列表中选择一种样式时，色彩页面上颜色图下的所有色彩均会更改为所选样式。更改即时生效，您下次进入对话框的此页面后，设置才会保存。颜色图中的实际基本颜色不受影响。绘图颜色样式不适用于所有图表外观。以下选项可用：

  * 纯色：设置颜色图中的所有颜色为纯色。
  * 深色渐变：将颜色图中的所有颜色设置为梯度变暗式渐变。
  * 浅色渐变：将颜色图中的所有颜色设置为梯度变浅式渐变。
  * 平滑：使所有条形图具有光滑外观。

* 绘图区背景样式：此控件用于更改绘图区背景的外观。此设置仅对绘图区的图表可用。以下选项可用：

  * 框架：绘图区周围将绘制一个框架。
  * 阴影：此选项为绘图区背景添加阴影效果。
  * 极简：此项设置将移除绘图区背景。

* 预览：预览图表的基本视觉属性。

## 图表属性：数字

此属性页面应用于在用的对象，并包含以下控件，用于格式化值：

数字格式

| 格式 | 说明 |
| --- | --- |
| 默认表达式 | 使用表达式提供的数字格式显示数值。 |
| 数字 | 显示精密微调框中设置带数位数字的数值。 |
| 整数 | 显示数值为整数。 |
| 固定为 | 显示小数微调框中设置的数值为带小数位数的小数值。 |
| 货币 | 以预览文本框中显示的格式显示数值。默认格式为 Windows 货币设置。 |
| 日期 | 以格式样式编辑框设置的格式显示可被解释为日期的数值。格式示例显示在预览文本框中。 |
| 时间 | 以格式样式编辑框设置的格式显示可被解释为时间的数值。格式示例显示在预览文本框中。 |
| 时间戳 | 以格式样式编辑框设置的格式显示可被解释为日期+时间的数值。格式示例显示在预览文本框中。 |
| 时间间隔 | 显示时间为顺序时间增量（如格式 = mm 显示数值为自日历起始时间开始计算的分钟数（ 1899:12:30:24:00）。 |

显示百分比 (%) 按钮按以下格式运行：数字，整数与固定为。

小数和千分位分隔符可在分隔符组的编辑框中设置。

在符号编辑框中，可以输入单位符号，1000，1000 000 和 1000 000 000。

ISO 按钮可用于设置时间，日期和时间戳格式为 ISO 标准格式。

系统 按钮可设置系统的格式。

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。