# 列表框

![列表框示例。](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_ListBox.png)

列表框是最基本的工作表对象。其中包含特定字段所有可能值的列表。列表框中的每一行都可显示加载表格中的几条记录，全部都具有相同的值。因此，选择一个值相当于在加载的表格中选择多条记录。

列表框还可以包含一个循环组或向下钻取组。如果使用向下钻取组，在列表框中选择单个值将导致列表框向下钻取并切换到该组中下一个基础字段。单击列表框标题中的向上钻取按钮可以反向进行向上钻取。

如果循环组分配到列表框，可以单击列表框标题中的循环按钮，使其显示组中下一个字段。还可以直接使用列表框对象菜单上的循环选项直接跳到组中的任意字段。

右键单击列表框可显示对象菜单。

## 对象菜单

右键单击该对象可打开列表框对象菜单。此菜单命名包括：

对象菜单命令

| 命令 | 说明 |
| --- | --- |
| 属性... | 打开列表框属性对话框，您可在其中设置许多参数。 |
| 注 | 允许创建和共享当前对象的注释。 |
| 循环 | 只有当列表框设置为显示循环组时可用。打开一个层叠菜单，同时带有要在列表框中显示字段的直接选项的组的字段。<br><br>更多信息，请参阅[非层次组（循环）](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Nonhierarchic_groups_cyclic.htm)。 |
| 搜索 | 打开搜索框。<br><br>更多信息，请参阅[搜索](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Text_search_and_numeric_search.htm#Search) |
| 模糊搜索 | 打开模糊搜索模式的文本搜索框。<br><br>更多信息，请参阅[模糊搜索](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Text_search_and_numeric_search.htm#FuzzySearch) |
| 高级搜索 | 打开高级搜索对话框。此对话框可用于输入高级搜索表达式。该命令还可以通过以下键盘快捷方式调用： Ctrl+Shift+F。<br><br>更多信息，请参阅[高级搜索对话框](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Advanced_Search_dialog.htm) |
| 顺序 | 此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）时可用。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。<br><br><ul> <li><span>置于顶层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。 </li> <li><span>置于底层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。 </li> <li><span>上移一层</span>：以 1 为增量增加工作表对象的布局层。最大值为 127。</li> <li><span>下移一层</span>：以 1 为减量减少工作表对象的布局层。最小值为 -128。 <br></li> </ul> |
| 更改值 | 只可用于显示输入字段的列表框。在输入编辑模式设置单击单元格。相当于在单格中单击输入图标。 |
| 恢复值 | 只可用于显示输入字段的列表框。打开一个带三个选项的层叠菜单。<br><br><ul> <li> <p><span>恢复单个值</span>：在脚本中将单击的字段值中的值恢复到其默认值。 </p> </li> <li> <p><span>恢复可能值</span>：从脚本中将所有可能的字段值恢复到其默认值。 </p> </li> <li> <p><span>恢复所有值</span>：从脚本中将所有字段值恢复到其默认值。 </p> </li> </ul> |
| 选择可能值 | 选择列表框中全部非排除的数值。 |
| 选择排除项 | 选择列表框中全部排除的数值。 |
| 全选 | 选择列表框中全部值。 |
| 清除 | 在活动列表框中清除所有当前选择。 |
| 清除其他字段 | 清除所有其他工作表对象中的选择，同时保持当前列表框中的选择。 |
| 锁定 | 在活动列表框中锁定选择的值。（如果未进行选择则显示灰色）。 |
| 解锁 | 在活动列表框中解锁锁定的值。（如果已锁定选择，则“解锁”将会代替锁定出现。） |
| 创建快速图表... | 打开可帮助您快速方便地创建一个图表的快速图表。<br><br>更多信息，请参阅[快速图表向导](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Quick_Chart_Wizard.htm)。 |
| 创建时间图表... | 打开时间图表，使您可以创建一个图表，这里应有一个给定的方法（表达式）并且经常用不同的时间段进行比较。<br><br>更多信息，请参阅[时间图表向导](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Time_Chart_Wizard.htm)。 |
| 创建统计框 | 对选出的字段值（举例）执行各种统计运算并在统计框中显示结果。 |
| 打印可能值.... | 打开打印对话框，可在其中指定打印设置。 活动列表框的所在非排除值都将发送到打印机。<br><br>更多信息，请参阅[打印：一般](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Print_General.htm#Print:)。 |
| 以 PDF 文件格式打印... | 打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。 |
| 发送到 Excel | 将可能的（包括选定的）值导出到 Microsoft Excel。如果 Excel 还未运行，将会自动开启。导出的值将出现在新 Excel 工作表中。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。<br><br>信息注释当导出至 Excel 表时，最小的图表将不会显示。 |
| 导出... | 打开另存为对话框，可以指定导出数据内容的路径，文件名称和（表格）文件类型。 |
| 复制到剪贴板 | 此层叠菜单包含用于工作表对象的各种复制选项。<br><br><ul> <li> <p><span>可能值</span>：将可能值（所选及可选）复制到剪贴板上。 </p> </li> <li> <p><span>单元格值</span>：将右键单击的列表框的文本值（当调用对象菜单时）复制到剪贴板上。 </p> </li> <li> <p><span>图片</span>：将工作表对象的图片复制到剪贴板。取决于<span>用户首选项：导出</span>页面中的设置，该图片将包含或不包含工作表对象的标题和边框。 </p> </li> <li> <p><span>对象</span>：复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。 </p> </li> </ul> |
| 链接对象 | 对链接对象打开带有以下命令的菜单。<br><br><ul> <li><span>调整链接对象的位置</span>：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。 <br></li> <li><span>断开此对象/断开对象</span>：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。 </li> </ul> |
| 最小化 | 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。 |
| 最大化 | 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。 |
| 还原 | 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。 |
| 帮助 | 打开 QlikView 帮助。 |
| 移除 | 从工作表移除工作表对象。 |

## 一般

列表框属性：一般标签的打开方式是：右键单击列表框并在浮动菜单中选择属性命令。在这里，可以设置列表框的一般参数。

列表框参数

| 参数 | 说明 |
| --- | --- |
| 标题 | 显示在列表框标题区域的文本。默认文本是选中字段的名称。 标题也可以计算公式定义，以便动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。<br><br>更多信息，请参阅[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)。 |
| 字段 | 从列表中选择字段。列表框将包含选中字段的值。<br>列表框可能会显示循环或向下钻取组。虽然每次仅可显示一个字段。这些组是从文档属性：组对话框中创建的，并将与可用字段一起列出。<br>如果使用向下钻取组，在列表框中选择单个值将导致列表框向下钻取并切换到该组中下一个基础字段。点击显示在列表框标题内的向上钻取图标可以再次向上钻取。<br>如果将循环组分配给一个列表框，点击显示在列表框标题内的循环图标可以切换为显示组中的下一个字段。您还可以使用列表框对象菜单上的循环-&gt;选项，直接转至组中的任何字段。<br>此外，还可以显示列表框中的计算字段。计算字段并非来自于脚本执行，而是由表达式定义。相同的规则应用于计算维度。如果要在列表框中使用计算字段，选择下列列表中的 &lt;表达式&gt;，编辑表达式对话框随后会打开，您可在其中定义描述计算字段的表达式。<br>作为标题<br>选择此复选框后，字段名会用作标题。文本 &lt;使用字段名&gt; 会显示在标题编辑框中。<br>编辑...<br>此按钮仅在选择 &lt;表达式&gt; 作为字段名时可用。点击此按钮，打开编辑表达式对话框，您可在其中定义描述计算字段的表达式。更多信息，请参阅[已计算字段](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/List_Box.htm#Calculat)。 |
| “和”模式 | 字段中的多个选项下必须是 AND 或 OR 类型。默认选择是或类型。此指令会切换逻辑模式，多值选择借助该模式得以实现。如果字段不符合某些条件，则会禁用此菜单选项。此选项不可用于计算字段。 |
| [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/List_Box.htm)显示替代项 | 切换在用字段列表框中直接作出选择是否旨在排除其他字段值。如果显示可选项被选中，所有值（所选值除外）均将显示为可选项，但通过在其他字段中进行相关选择可能会被排除。否则，默认情况下，其他所有值均显示为被排除。此选项不可用于计算字段。 |
| 隐藏排除项 | 切换显示该字段不包含的数值。排除值也可以变成不可选。 |
| 只读 | 勾选此选项将会阻止您在列表框中进行选择。但是，它仍会反映对文档其他部分所作的选择。 |
| 总是选定一个值 | 勾选此选项可确保仅有一个值可被选定，这对于内部数据仅在已经选定一个值的文档极为有用，例如一个货币汇率。此选项会在列表框中已经选定一个值之后启用。此选项不可用于计算字段。<br><br>信息注释启用此选项可修改数据模型。因此，即使您保留相同的字段名称，现有书签也可能停止工作。 |
| 覆盖锁定字段 | 勾选该选项可以在列表框中选择对象，即使该对象已被锁定。对于在文档其他部分所作的选择，列表框将仍保持锁定。 |
| [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/List_Box.htm)显示为树形视图 | 显示列表框为树视图。仅当字段在层次结构中包含节点的路径呈现形式时，此控件方相关。此类字段可以使用层次结构前缀的路径参数生成。<br><br>更多信息，请参阅[列表框树视图](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/List_Box.htm#List)。 |
| 使用分隔符 | 设置应被解释为路径内用于树形视图的分隔符的字符。 |
| 显示频率 | 切换状态，指定是否显示字段值频率。频率是指值出现的可选组合的数量。此选项不可用于计算字段。 |
| 以百分百比表示 | 切换状态，是以绝对数显示频率，还是以总条目数的百分比显示频率。 |
| 备用状态 | 在下拉菜单中选择一个可用的状态。以下备用状态始终可用。 继承：工作表和工作表对象通常处于继承状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。 默认状态：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于默认状态。 |
| 对象 ID | 这用于宏目的。每个工作表对象均会分配一个唯一 ID。我们建议您在 ID 中只使用字母数字字符。 对于列表框，ID 以 LB01 开头。 链接对象共享相同的对象 ID。您可以稍后编辑此 ID 号。<br><br>更多信息，请参阅[内部宏解释器](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm)。 |
| 在搜索中包含“排除值” | 下拉列表可以让您在是、否或&lt;使用默认&gt;之间进行选择，&lt;使用默认&gt;将应用用户首选项：一般所指定的默认设置。 |
| 默认搜索模式 | 指定文本搜索使用的初始默认搜索模式。总是可以通过输入包含 \* 或 ~ 的搜索字符串来更改模式。以下替代选择可用：<br><br><ul><li><p><span>使用 &lt;default&gt;</span>：应用<span>用户首选项</span>下指定的默认设置。 </p></li><li><p><span>使用通配符搜索</span>：搜索字符串首字符是两个通配符，两者间有光标，这样可方便使用通配符搜索。 </p></li><li><p><span>使用模糊搜索</span>：初始搜索字符串可以是波浪号 (~)，以表示模糊搜索。 </p></li><li><p><span>使用常规搜索</span>：无需添加更多字符到搜索字符串。无通配符亦可执行常规搜索。 </p></li><li><p><span>使用关联搜索</span>：在搜索框中会使用关联搜索。 </p></li></ul><br><br>更多信息，请参阅[搜索](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Text_search_and_numeric_search.htm)。 |
| 打印设置 | 您可在此设置打印工作的打印设置。 |
| 打印所有值 | 列表框的常规打印行为是仅打印正值。勾选此复选框会打印所有制（包括排除值）。 |
| 基于布局打印 | 勾选此复选框后，当列表框依据多列，单元格的选择项颜色编码等显示在屏幕上时，列表框会被打印。当报表中包括列表框时，这可能极为有用。 |

### 已计算字段

信息注释使用计算字段时，一些列表框功能会不同于常规字段列表框。一些属性选项不能使用（见下文）。此外，无法在此类列表框中创建统计框。

信息注释计算字段必须总是一个或多个常规字段转换而来的字段。不允许通过 valuelist 和 valueloop 函数创建纯合成的计算字段。当在计算字段中进行选择时，您实际上是在基础的常规字段中进行选择。使用超过一个字段作为计算字段的基础时，基础字段或计算字段中选择项的逻辑隐义极其复杂。

信息注释在列表框中使用计算字段可能会导致超大数据集产生性能问题。

## 表达式

您可以在表达式标签上定义要在列表框中显示的表达式。每个表达式都可放置于列表框的新列中。对话框的左上角含有一列表达式。

表达式数据也可通过属性表达式动态地格式化。单击任何表达式前面的扩展图标显示表达式的属性表达式。

您可以选择性在已给出的基本表达式上使用任意数字和属性表达式组合。通过用属性表达式取代有颜色标记的数据默认格式来定义格式。

表达式命令

| 命令 | 说明 |
| --- | --- |
| 添加 | 单击此按钮，进入编辑表达式对话框，在这里可以创建新表达式。当右键单击表达式列表中的表达式时，该选项也可用于上下文菜单。 |
| 删除 | 删除选中表达式。当右键单击表达式列表中的表达式时，该选项也可用于上下文菜单。 |
| 复制 | 当右键单击表达式列表中的表达式时，该选项仅可用于上下文菜单。在主表达式中使用该命令时，所有与表达式（包括标签）相关的数据和设置将被复制至 xml 剪贴板中。随后该表达式可能会粘贴至同一或其他文档中的同一对象或任意其他 QlikView 对象。如果在属性表达式上使用该命令，则只有属性表达式的定义将被复制。一个属性表达式可能会被粘贴至同一或其他对象中的任意主表达式中。 |
| 导出... | 当右键单击表达式列表中的主表达式时，该选项仅可用于上下文菜单。在主表达式中使用该命令时，所有与表达式（包括标签）相关的数据和设置将被导出至 xml 文件中。随后该表达式可能会导入至同一或其他文档中的同一图表或任意其他 QlikView 图表。该命令打开表达式导出为对话框，在其中您可用选择导出文件的目的地。该文件将获得一个扩展插件，例如 xml。 |
| 粘贴 | 当右键单击表达式列表和仅在表达式先前已被复制到剪贴板的情况下，该选项才仅适用于上下文菜单。如果主表达式先前已复制到剪贴板，您可用以将其粘贴在表达式列表的空白处，创建与复制的表达式相同的新表达式。如果复制了一个特性表达式，您可以将其粘贴至主表达式。 |
| 导入... | 当右键单击表达式列表中的空白区域时，该选项仅可用于上下文菜单。该命令打开一个对话框，在其中您可以浏览先前导出的表达式。导入表达式将以新的主表达式出现在图表中。 |
| 上移 | 将选中表达式在列表中向上提升一位。当您想更改表达式顺序时使用该按钮。 |
| 下移 | 将选中表达式在列表中向下下移一位。当您想更改表达式顺序时使用该按钮。 |
| 空值符号 | 此处输入的符号将用来显示表格中的空值。 |
| 遗漏符号 | 此处输入的符号将用来显示表格中的遗漏值。 |
| 启用 | 标记复选框将启用选中表达式。如果此框被标记，则表达式将完全不被使用。 |
| 定义 | 显示选择的表达式的组合。可以在此栏中直接编辑表达式。单击 ... 按钮，完整的编辑表达式对话框将打开。 |
| 显示 | 如果选择总是，表达式将总是显示在列表框的额外列中。如果选择有条件，表达式将根据输入在编辑框右侧的条件表达式的值来决定动态显示或隐藏。 |
| 对齐 | 在这一组中，您可以将表达式设置成默认对齐。文本和数字可以单独设置成左对齐，中间对齐或右对齐。 |
| 显示选项 | 此组将定义写入列表框表达式单元格的表达式。 |
| 呈现形式 | 提供了以下替代选择：<br>文本：一旦选择此选项，将总是解释表达式值并将其显示为文本。<br>图片：当选择此选项时，QlikView 尝试将每个表达式值解释为图片的参考。该参考可能是磁盘上图片文件的路径（例如，C:\Mypic.jpg）或在 QlikView 文档内部（例如，qmem://&lt;Name&gt;/&lt;Peter&gt;）。如果 QlikView 不能将表达式值解释成有效的图片参考，则将显示它本身的值。<br>圆形仪表：当选择此选项时，QlikView 将在圆形样式仪表中显示表达式值。仪表盘图表将被刻入一个可用的表格单元格。可以通过仪表设置...按钮为仪表修改视觉设置。<br>线性仪表盘：当选择此选项时，QlikView 将在水平线性样式仪表中显示表达式值。仪表盘图表将被刻入一个可用的表格单元格。可以通过仪表设置...按钮为仪表修改视觉设置。<br>交通灯仪表盘：当选择此选项时，QlikView 将在水平交通灯样式仪表中显示表达式值。仪表盘图表将被刻入一个可用的表格单元格。可以通过仪表设置...按钮为仪表修改视觉设置。<br>LED 仪表盘：当选择此选项时，QlikView 将在 LED 样式仪表中显示表达式值。仪表盘图表将被刻入一个可用的表格单元格。可以通过仪表设置...按钮为仪表修改视觉设置。<br>小图表：当选择此选项时，QlikView 将在微型图表和从其他维度中聚合起来的表达式中显示表达式值。图表将会记录在可用的表格单元中。能为图表进行定义和视觉设置的小图表维度可以通过小图表设置按钮（如下所示）修改。<br><br>信息注释当导出至 Excel 时小图表将不会显示。 |
| 仪表设置... | 仅当选择以上某个仪表选项时才可用。为设置仪表属性打开对话框。此对话框基本等同于仪表盘图表的图表属性：外观对话框。 |
| 小图表设置 | 只有当小图表被选中为表格中某一表达式的显示选项时才可用。打开对话框，以设置小图表的属性。 |
| 图片格式 | 仅当选择了以上图片选项时才可用。该设置描述 QlikView 如何格式化图片以适应单元格。有四种替代方案。<br>没有拉伸：如果选定该选项，图片将以原样显示，不作任何伸展。这可能会导致部分图片无法显示或仅填充部分的单元格。<br>填充：如果选择该选项，在不影响固定图片纵横比的前提下图片将被拉伸填充单元格。<br>固定纵横比：如果选择该选项，在固定图片纵横比的同时图片将被尽量拉伸填充单元格。这通常导致产生区域，要么在两侧，要么在图片未填充的上部和下部。<br>以固定纵横比填充：如果选择该选项，在固定图片纵横比的同时图片将被向两个方向拉伸填充单元格。这通常导致图片在某个方向上的多余部分被裁剪。<br>图片丢失时隐藏文本：如果选择该选项，而因为某些原因字段值文本没有解释成图片参考，那么 QlikView 将不会显示该字段值文本。单元格将会留空。 |

### 小图表设置

仅当小图表选项在垂直表属性对话框的表达式页面中选定后可用。打开对话框，以设置小图表的属性。

小图表属性

| 属性 | 说明 |
| --- | --- |
| 维度 | 选择绘制表达式所需的维度。 |

### 外观

外观属性

| 属性 | 说明 |
| --- | --- |
| 模式 | 设置小图表为迷你图，点线，点，条形或须线。 |
| 颜色 | 打开颜色区域对话框，您可在其中设置小图表的颜色。 |
| 用颜色高亮显示最大值 | 勾选此复选框并单击颜色按钮，打开颜色区域，在其中可以设置最大值的颜色。 |
| 用颜色高亮显示最小值 | 勾选此复选框并单击颜色按钮，打开颜色区域，在其中可以设置最小值的颜色。 |
| 用颜色高亮显示最初值 | 勾选此复选框并单击颜色按钮，打开颜色区域，在其中可以设置开始值的颜色。不可用于条形和须线。 |
| 用颜色高亮显示最终值 | 勾选此复选框并单击颜色按钮，打开颜色区域，在其中可以设置结束值的颜色。不可用于条形和须线。 |
| 设置默认颜色 | 将高亮设置颜色设置为 QlikView 默认颜色。 |
| 强制零基刻度调整 | 固定图表下限边至轴上的零点。不可用于须线。 |
| 对 Y 轴强制共享刻度 | 强制列内全部单元格使用相同的 Y 轴刻度。 |

## 排序

右键单击工作表对象（列表框，多选框，表格框，图表或滑块/日历标签），然后从浮动菜单选择属性（或主工作表菜单中的对象：属性），可以打开排序标签。在这里，可以设置工作表对象中的值排序。对于某些工作表对象可能部分排序选项不可用。

排序选项

| 排序方式： | 结果 |
| --- | --- |
| 州 | 字段值根据其逻辑状态（选中，可选或排除）排序。<br>自动升序设置可以根据状态排列列表框（或多选框中包含字段值的下拉列表）顺序（只有当列表框包含垂直滚动条的时候）。但是，如果扩大列表框以显示所有值，将完全关闭排序状态。<br><br>信息注释 请勿在容器对象的列表框中使用自动升序顺序。 |
| 表达式 | 根据输入到此排序选项下面的文本编辑框中的表达式排列字段值。如果使用表达式排序，则必须通过集合表达式来定义替代记录集，因为将针对列表中的所选/可能值来计算该表达式，并且排序仅应用于列表中的所选/可能值。<br><br>信息注释 表达式排序仅适用于数值字段而不适用于文本字段。<br><br>[集合分析和集合表达式](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/SetAnalysis/set-analysis-expressions.htm) |
| 频率 | 按频率（表格中的数字发生次数）排列字段值。 |
| 数值 | 按数值排列字段值。 |
| 文本 | 按字母顺序排列字段值。 |
| 加载顺序 | 按首次加载顺序排列字段值。 |

默认按钮排序可以设置默认排序。

优先顺序依次为状态，表达式，频率，数值，文本，加载属性。每一个排序标准都可以设置为升序或降序。

## 外观

列表框属性：外观标签的打开方式是：右键单击列表框并在浮动菜单中选择属性命令。在这里可以调整列表框单元格的布局

在图片选择组中，您可让一个字段值包括一个参考至存储中的图片或一个解释为该图片的光碟上：

在呈现形式项下，您可以在文本 (默认)，图片及图片信息之间进行选择。

当您选择了图片时，QlikView 将偿试将每一个字段值解释为至一个图片的参考。参考可能是指向一个磁碟上的文件 (如 C:\Mypic.jpg) 或者在一个qvw 文档本身内部的路径 (如 qmem://&lt;Name&gt;/&lt;Peter&gt;)。如 QlikView 无法作为一个有效的图片参考解释一个字段的值，将会显示值本身，除非选中了当图片丢失时隐藏文本。

当您选择了作为图片的信息时，QlikView 将通过脚本中信息加载/信息选择显示链接至字段值的图片信息。当字段值无可用的图片信息时，除非选中图片丢失时隐藏文本框，否则字段值不会显示。

在已选择图片选项的前提下，图片格式中的设置可用于使图片以合适尺寸插入单元格。

图片格式设定选项

| 选项 | 说明 |
| --- | --- |
| 没有拉伸 | 图片未经任何处理即显示，可能会造成屏蔽问题。 |
| 填充 | 拉伸图片以填充单元格，无需考虑长宽比。 |
| 保持长宽比 | 尽量拉伸图片，同时保持图片正确的的长宽比。 |
| 以固定长宽比填充 | 尽量拉伸图片，同时保持图片正确的的长宽比。未覆盖的区域随后可通过裁剪图片进行填充。 |

如果显示样式为图片，而非文本，则有必要换用选择项样式（而非选择文档默认设置），以确保字段值的逻辑状态清晰可见。使用选择项样式覆盖中的下拉式列表，在其中选择合适的选择项样式，例如圆角标记。

列表框外观选项

| 选项 | 说明 |
| --- | --- |
| 单列 | 如果选中此选项，列表框字段值将总是显示在单列中。 |
| 隐藏水平滚动条 | 选中此选项以隐藏水平滚动条（通常当字段值太长，超过列表框指定的宽度时会显示该滚动条）。此时，将根据需要截短字段值。 |
| 列固定数值 | 选中此选项为列表框设置列的固定数值。当选择了单列时，选项不可用。 |
| 根据列排序 | 在超过一列的列表中，按指定的排序顺序逐行显示值。根据列排序选项用于切换为逐列显示。 |
| 单元格边框 | 字段值由水平线分隔，类似于表格的行。当选中了单元格文本换行选项时，单元格边框自动激活，但可能随后关闭。 |
| 高亮显示内容搜索<br>子字符串 | 在一个搜索对象中输入的搜索字符串现在将会在匹配中高亮显示。 |
| 背景... | 打开背景设置对话框。 |
| 对齐 | 您在这里设置字段值在列表框中的对齐方式。文本和数值的对齐可单独设置。 |
| 多行设置 | 在此组中，列表框单元格可以设置为显示多行的值，这在长文本字符串中很有用。<br>单元格文本换行<br>选择此选项，单元格会在多行中显示内容。<br>高度 n 行数<br>在这里指定单元格行数的限值。 |

### 背景设置

背景设置

| 设置 | 说明 |
| --- | --- |
| 颜色 | 如果启用了此设置，则对象的背景将会加上颜色。通过单击颜色按钮选择颜色。 |
| 颜色透明度 | 仅当启用了颜色选项时才可用。设置背景颜色的透明度。 |
| 图片 | 如果启用了此设置，则对象的背景将会是图片。单击浏览选择图片。单击移除移除背景图片。 |
| 图片拉伸 | 仅当图片选项启用后才可用。该设置描述 QlikView 如何格式化图片。<br>没有拉伸：图片将以原样显示，不作任何伸展。这可能会导致部分图片无法显示或仅填充部分背景。<br>填充：伸展图片以适应背景，不固定图片的纵横比。<br>固定纵横比：尽量伸展图片以填充背景，同时固定图片的纵横比。<br>以固定纵横比填充：如果选中此选项，拉伸图片以填充背景长宽，同时固定图片的纵横比。这通常导致图片在某个方向上的多余部分被裁剪。 |
| 水平对齐 | 仅当图片选项启用后才可用。将图片左对齐，居中对齐或右对齐。 |
| 垂直对齐 | 仅当图片选项启用后才可用。将图片上对齐，居中对齐或下对齐。 |
| 图片透明度 | 仅当图片选项启用后才可用。设置背景图片的透明度。 |

## 数字

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/List_Box.htm)属性：数字页面的打开方式是：右键单击工作表对象并在浮动菜单中选择属性命令。

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/List_Box.htm)每个字段都有默认数字格式，此数字格式可在 文档属性：数字页面中进行设置。不过，可以使用单个工作表对象的分隔数字格式。要做到此点，选中替代的覆盖文档设置并在以下组控件中指定一个数字格式。此属性页面应用于在用的对象，并包含以下控制，用于格式化值：

数字格式

| 格式 | 说明 |
| --- | --- |
| 混合 | 数值和文本。原始格式显示的数值 |
| 数字 | 显示精密微调框中设置带数位数字的数值。 |
| 整数 | 显示数值为整数。 |
| 固定为 | 显示小数微调框中设置的数值为带小数位数的小数值。 |
| 货币 | 以格式样式编辑框设置的格式显示数值。格式示例显示在预览文本框中。默认格式为 Windows 货币设置。 |
| 日期 | 以格式样式编辑框设置的格式显示可被解释为日期的数值。格式示例显示在预览文本框中。 |
| 时间 | 以格式样式编辑框设置的格式显示可被解释为时间的数值。格式示例显示在预览文本框中。 |
| 时间戳 | 以格式样式编辑框设置的格式显示可被解释为日期+时间的数值。格式示例显示在预览文本框中。 |
| 时间间隔 | 显示时间为顺序时间增量（如格式 = mm 显示数值为自日历起始时间开始计算的分钟数（ 1899:12:30:24:00）。 |
| 显示百分比(%) | 此复选框会对以下格式造成影响：数字，整数和固定。 |

小数和千分位分隔符可在分隔符组的编辑框中设置。

ISO 按钮使用 ISO 标准设定日期，时间和时间戳的格式。

系统按钮应用系统设置到格式。

更改文档格式按钮可用于打开文档属性：数字页面，在该页面上可编辑任何字段的默认数字格式。

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。

## 标题和边框属性

在标题和边框属性对话框中，设置应将标题和边框属性应用到文档中的哪些对象。

* 将属性应用到...：勾选此复选框将设置应用到当前对象之外的其他对象。
  1. 选择以下选项之一：
     * 此工作表上的对象：将设置仅应用到当前工作表上的对象。只有当此对话框从工作表对象的布局页面打开时才可用。
     * 此文档中的对象：将设置应用到整个文档的对象。
  2. 选择以下选项之一：
     * 仅限此对象类型：将设置应用到所有此类型对象。只有当此对话框从工作表对象的布局页面打开时才可用。
     * 所有对象类型：将设置应用到所有对象。
* 设置为此文档中的新对象默认设置：勾选此复选框，使用此设置作为当前文档中的所有新对象的默认设置。只有当此对话框从工作表对象的布局页面打开时才可用。

## 列表框树视图

如果字段包含层次结构节点路径，例如 World/North America/USA/California/NapaValley，则列表框可以树视图形式显示。树视图将显示节点缩进以便于导航，并且允许用户折叠节点以便列表框其中一行呈现层次结构分支，而不只是单个节点。

将使用通常方式进行选择，当然也支持在层次结构中跨不同级别进行多项选择。

![树视图中的列表框。](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_TreeView1.png) ![树视图中的列表框，具有跨多个层次结构的选择项。](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_TreeView2.png)

若要展开节点和叶片（底部节点），可以使用 QlikView 标准的颜色代码。但是，折叠节点可能包含不同的状态组合。在这种情况下，如果已选中全部值节点将变为绿色，如果已排除全部值节点将以灰色显示，白色表示其他情况。此外，还将显示一个小信号灯，指示隐藏节点的状态。