# 输入框

![](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/Resources/Images/ui_gen_Input.png)

输入框是用于输入数据到 QlikView 变量值和显示其数值的工作表对象。

右键单击输入框以显示对象菜单。当输入框为活动对象时，其还可从对象菜单存取。

## 使用输入框

输入框由类似布局的多选框中的三列构成。第一列显示变量列表。第二列为等号“=”，第三列为变量值。输入框包含一个或多个变量，每个单独行上有一个变量。

QlikView 中的变量为包含单个数据值的已命名实体，不同于（通常）包含多个值的字段。此外，字段从脚本中的 load 和 select 语句获取值，变量从脚本中的 let 和 set 语句获取值，获取方法包括自动调用或借助布局中输入框的帮助。

变量可以包含数字或字母数据。如果变量值的第一个字符为等于符号“=”，QlikView 将尝试以公式（QlikView 表达式）评估该值，然后显示或返回结果而不是实际公式文本。

输入框中会显示变量的当前值。单击输入框中的值，单元格会转变为编辑模式，因此可以输入新值，或者修改旧值。如果变量包含公式，则其会即时显示，而不是显示其结果。编辑模式下的单元格通常包含 ... 按钮，此按钮用于打开整个编辑窗口，便于高级公式的创建。输入框中的变量值单元格函数可以和电子表格中的单元格函数详加比较。

输入框变量值单元格有时可能包含一个钻取图标，其可用于快速存取最近使用的值或预定值。变量可能包含输入约束，防止输入所有不符合某些标准的值。在某些情况下，输入框中的变量为只读变量，此时无法进入编辑模式。

## 了解详情

* [脚本变量](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptVariables.htm)
* [字段](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/Fields.htm)

## 对象菜单

右键单击该对象可打开输入框对象菜单。此菜单命名包括：

对象菜单命令

| 命令 | 说明 |
| --- | --- |
| 属性... | 打开 输入框属性 页面，您可在其中设置参数。 |
| 注 | 允许创建和共享当前对象的注释。 |
| 顺序 | 此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）时可用。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。<br><br><ul> <li><span>置于顶层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。 </li> <li><span>置于底层</span>：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。 </li> <li><span>上移一层</span>：以 1 为增量增加工作表对象的布局层。最大值为 127。</li> <li><span>下移一层</span>：以 1 为减量减少工作表对象的布局层。最小值为 -128。 <br></li> </ul> |
| 打印... | 打开打印对话框，可在其中指定打印设置。 |
| 以 PDF 打印... | 打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。 |
| 发送到 Excel | 将输入框中的值导出至 Microsoft Excel，如果 Excel 未运行，则会自动开启。导出的值将保存在新的 Excel 工作表中。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。 |
| 导出... | 打开对话框，您可在其中导出输入框的内容到选择的文件。该文件可以保存为以下任意格式：逗号分隔，分号分隔，制表符分隔，超文本 (HTML)，XML 和 Excel（xls 或 xlsx）。默认格式为 \*.qvo (QlikViewOutput)，是一个制表符分隔文件。 |
| 复制到剪贴板 | 此层叠菜单包含用于工作表对象的各种复制选项。<br>数据<br>复制输入框的数据行到剪贴板。<br>单元格值<br>将右键单击的输入框的文本值（当调用对象菜单时）复制到剪贴板上。<br>图片<br>将工作表对象的图片复制到剪贴板。图像将包括或不包括工作表对象标题和边框，具体取决于用户首选项：导出页面中的设置。<br>对象<br>复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。 |
| 链接对象 | 对链接对象打开带有以下命令的菜单。<br><br><ul> <li><span>调整链接对象的位置</span>：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。 <br></li> <li><span>断开此对象/断开对象</span>：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。 </li> </ul> |
| 最小化 | 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。 |
| 最大化 | 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。 |
| 还原 | 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。 |
| 帮助 | 打开 QlikView 帮助。 |
| 移除 | 从工作表移除工作表对象。 |

## 一般

输入框属性：一般页面的打开方式是：右键单击输入框并在浮动菜单中选择属性命令。在这里，可以设置输入框的一般参数。

一般属性

| 属性 | 说明 |
| --- | --- |
| 标题 | 显示在输入框标题区域的文本。标题可定义为表达式，以动态更新标签文本。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 可用变量 | 全部可用字段详列于此列中。要包括系统变量，请勾选显示系统变量复选框。 通过单击可以选择要使用/移除的项目。使用添加 &gt;或&lt; 移除按钮将其移动至所需列。 |
| 显示系统变量 | 使系统变量显示在可用变量列表中。 |
| 新变量 | 打开新变量对话框，可在其中定义一个自定义变量。 |
| 显示变量 | 要显示在输入框中的变量会详列在此列中。起初，该列空白。 |
| 上移 | 在显示顺序中向上移动变量。 |
| 下移 | 在显示顺序中向下移动变量。 |
| 标签 | 用作输入框中变量标题的替代名称，可在此输入。该标签可定义为计算表达式，以便动态更新。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |
| 备用状态 | 在下拉菜单中选择一个可用的状态。以下备用状态始终可用。 继承：工作表和工作表对象通常处于继承状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。 默认状态：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于默认状态。 |
| 对象 ID | 这用于宏目的。每个工作表对象均会分配一个唯一 ID，输入框的 ID 以 IB01 开头。链接工作表对象共享相同的对象 ID。您可以稍后编辑此 ID 号。<br><br>[内部宏解释器](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Internal_Macro_Interpreter.htm) |

## 外观

外观选项

| 选项 | 说明 |
| --- | --- |
| 变量 | 在当前输入框中显示全部变量列表。当在此列表中选中变量名后，可以修改该变量的属性。 |
| 显示等号 | 如果不想在输入框中显示等号，可以取消选中此框。此设置对全部变量通用。 |
| 背景... | 打开背景设置对话框。 |
| 对齐 | 可以设置变量对齐。变量可以单个设置为左对齐，居中对齐或右对齐。 |
| 行的颜色 | 在此组中，可以对变量列表左边选中的行进行单个颜色设置。<br>背景<br>指定选中行的背景颜色。单击此按钮可打开颜色区域对话框，在当中可将颜色定义为纯色或渐变色。<br>文本<br>指定选中行的文本颜色。<br>应用于所有行<br>单击应用或确定之前，通过选择此复选框可以将所选颜色应用到输入框的全部行。 |

## 约束

输入框属性：约束页面的打开方式是：右键单击输入框并在浮动菜单中选择属性命令。添加到输入框属性的显示变量中的脚本变量列在约束标签上的变量列表中，这里可以对其进行修改。

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Input_Box.htm)文档属性 ：变量页可通过设置文档属性：新变量对话框。变量列表可以通过显示变量选项修改。[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Input_Box.htm)新建...按钮可在文档中添加一个新变量。按删除按钮移除所选变量。

在设置所选变量组中，编辑框显示所选变量的当前值。 该值可以作为计算公式输入。单击 ... 按钮打开编辑表达式对话框。

变量通常不包括在书签中，但在这里可以选中选项 在标签中包括。

在输入约束组中指定所有由用户输入一个输入框变量的值都将根据其进行检测的约束。如果一个值不满足指定的约束的要求，它将被拒绝，同时可能显示一个错误信息。以下替代选择可用：

输入约束条件设置

| 设置 | 说明 |
| --- | --- |
| 无约束 | 输入值未根据任何指定的约束进行检查。 |
| 标准 | 输入的值将会根据从下拉框中选择的许多普通标准约束之一进行检查。由于默认情况下根本未选择任何约束，变量中可能输入任何值。只以下选项之一：标准，自定义，只限预定值及只读可以被检查。 |
| 自定义 | 输入值将会根据客户指定的约束进行检查。约束被输入编辑框中，如果输入值可接受它必须被表达为返回真值（非零值）的 QlikView 表达式。输入值在表达式中作为美元符号 ($) 引用。<br><br>示例：<br><br>$&gt;0 将会导致输入框在所选变量中只接受负数。<br><br>变量的以前的值可以由变量名称引用。<br><br>示例：<br><br>$&gt;=abc+1 作为一个变量中被称为 abc 的约束将导致输入框只接受数字条目，值为旧值加 1。 |
| 只限预定义值 | 输入值将根据在 预定值组中定义的值列表检查。只在列表中出现的输入值会被接受。 |
| 只读 | 将变量标记为只读。不可输入值。 |
| 启用编辑表达式对话框 | 选中此选项，启用编辑表达式对话框中的变量值编辑，可通过单击值本身时出现的 ... 按钮打开该对话框。 |

约束监视

| 选项 | 说明 |
| --- | --- |
| 非法输入时发出声音警报 | 选中此选项当用户试图输入一个约束以外的值时让 QlikView 发出一个警报声。 |
| 错误信息 | 通常如果用户偿试输入一个约束以外的值，它将会被拒绝，使当前的变量值保持不变。通过选中此选项，您可以指定自定义错误消息，它将在条目不正确的情况下展示给用户。错误信息在编辑框中输入。它可能定义为表达式，以便动态更新。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。<br><br>[自定义错误信息](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Custom_Error_Messages.htm)<br><br>[用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm) |

在值列表组中指定是否且如何为一个输入框展示一个值列表。

值列表选项

| 选项 | 说明 |
| --- | --- |
| 无列表 | 变量中无以前使用的值列表保持不变。 |
| 列表 \_ 最近使用的值 | 一个最近使用的值的下拉列表 (MRU) 将会对用户在输入框中所选择的值可用。要保存的以前值的个数可以在该框中设置。 |
| 下拉菜单中的预定义值 | 一个带预定值的下拉菜单将会对在输入框的所选值的用户可用。 |
| 预定义值（带滚动条） | 一个滚动条将会对输入框中所选值的用户可用。滚动条将会在预定值之间做出。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Input_Box.htm)[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Input_Box.htm)在预定值组中指定了一个预定值的列表，可以将它提供给下拉菜单中的用户及\或定义可接受的变量值。

值字段选项

| 选项 | 说明 |
| --- | --- |
| 数字系列 | 选中此选项根据一个下限值（从），一个上限值（至）及一个步骤值生成一个预定数值的列表。此选项可独自使用或与所列值联合使用。 |
| 所列值 | 选中引选项指定一个任意值的列表。值可以是数字的，也可以是数字和字母结合的。数字和字母结合的值必须用引号括起（如'abc'）。每个值用分号 (; )（如'abc';45;14.3;'xyz' ). 此选项可独自使用或与 数字系列联合使用。 |
| 注释 | 这是一个注释区，在这里变量的创建者可以描述其目的和功能。 |

## 了解详情

* [脚本变量](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptVariables.htm)

## 数字

输入框属性：数字页面的打开方式是：右键单击输入框并在浮动菜单中选择属性命令。

此属性页面提供输入框的所有变量的格式设置。选择变量文本框中的一个或多个变量（单击，Shift-单击或 Ctrl-单击），可单独为变量设置数字格式。

每个变量都有默认数字格式，可在文档属性中设置。

[文档属性：数字](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Number.htm)

不过，可以使用单个工作表对象的分隔数字格式。要做到此点，选中替代的覆盖文档设置并在以下组控件中指定一个数字格式。此属性页面应用于活动对象，并包含以下控件，用于格式化变量值：

编号属性

| 属性 | 说明 |
| --- | --- |
| 混合 | 数值和文本。原始格式显示的数值 |
| 数字 | 显示精密微调框中设置带数位数字的数值。 |
| 整数 | 显示数值为整数。 |
| 固定为 \_ 位小数 | 显示小数微调框中设置的数值为带小数位数的小数值。 |
| 货币 | 以格式样式编辑框设置的格式显示数值。格式示例显示在预览文本框中。默认格式为 Windows 货币设置。 |
| 日期 | 以格式样式编辑框设置的格式显示可被解释为日期的数值。格式示例显示在预览文本框中。 |
| 时间 | 以格式样式编辑框设置的格式显示可被解释为时间的数值。格式示例显示在预览文本框中。 |
| 时间戳 | 以格式样式编辑框设置的格式显示可被解释为日期+时间的数值。格式示例显示在预览文本框中。 |
| 时间间隔 | 显示时间为顺序时间增量（如格式 = mm 显示数值为自日历起始时间开始计算的分钟数 (1899:12:30:24:00)。 |

显示百分比 (%) 按钮按以下格式运行：数字，整数与固定为。

小数和千分位分隔符可在分隔符组的编辑框中设置。

ISO 按钮使用 ISO 标准设定日期、时间和时间戳的格式。

系统按钮应用系统设置到格式。

## 了解详情

* [文档属性：数字](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Number.htm)

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。