# 编辑脚本对话框

编辑脚本对话框可从文件中打开或通过单击工具栏中的编辑脚本符号 the edit script icon 打开。

在这里可以输入和执行连接文档至 ODBC 数据源的脚本，或者连接至不同类型的数据文件并获取所需的信息。

脚本可以手动输入或自动生成。复杂的脚本语句必须，或至少部分由手动输入。

编辑脚本对话框使用自动完成程序，所以当输入时，程序会预测需要输入的语句而不需要完全输入。预测包括构成脚本语法的词语。该脚本同样由语法部件进行颜色标记。它可以通过选择工具 和编辑器首选项进行自定义。

在对话框顶部有菜单栏，其中有各种与脚本相关的命令。最常用的命令也在工具栏内。在工具栏内也有脚本标签的下拉列表。

## 编辑脚本对话框中的菜单

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 文件菜单

文件菜单选项

| 选项 | 说明 |
| --- | --- |
| 重新加载 | 执行脚本，关闭对话框并在工作表属性对话框中打开字段 页面。此命令同样可用于编辑脚本对话工具栏。 |
| 调试... | 在调试器中开启脚本执行。调试器在脚本中搜索错误。执行脚本时，可监控每一条脚本语句，检查各变量值。此命令同样可用于编辑脚本对话工具栏。 |
| 编辑隐藏脚本... | 为隐藏脚本打开脚本标签。在这里可以定义隐藏脚本的一部分，该操作必须在每次重新加载一般脚本前执行。隐藏脚本标签通常显示在打开脚本标签的左侧。创建或存取隐藏脚本都需要密码。 |
| 更改隐藏脚本密码... | 打开新隐藏脚本密码对话框，在这里可以设置存取隐藏脚本的新密码。 |
| 创建隐藏脚本 | 打开新隐藏脚本密码对话框，在这里必须先为隐藏脚本设置一个新密码，然后在脚本窗口中打开名为隐藏脚本的新脚本标签。在这里可以定义隐藏脚本的一部分，该操作必须在每次重新加载一般脚本前执行。隐藏脚本标签通常显示在打开脚本标签的左侧。 |
| 移除隐藏脚本 | 从编辑脚本对话框中移除隐藏脚本。 |
| 保存整个文档 | 保存活动文档在文件中。数据、脚本和布局均已保存。该命令还可以通过以下键盘快捷方式调用： Ctrl+S。此命令同样可用于编辑脚本对话工具栏。 |
| 保存整个文档为... | 保存活动文档于一个拥有新名称的新文件中。 |
| 打开外部脚本文件 | 可以浏览包含脚本的文件并可以在脚本窗格的新标签中打开文件，在这里通过使用 QlikView 的颜色编码实现编辑。 |
| 保存外部文件 | 保存外部脚本文件。 |
| 导出至脚本文件... | 保存整个脚本于保存脚本对话框所指定的文本文件中。该文件将包含扩展插件 .qvs。 |
| 打印标签... | 允许在可选打印机上打印活动脚本标签。该命令还可以通过以下键盘快捷方式调用： Ctrl+P。此命令同样可用于编辑脚本对话工具栏。 |
| 打印所有标签... | 允许在可选打印机上打印整个脚本。隐藏脚本将不会通过该命令打印。 |
| 表视图 | 打开表格查看器对话框，这里的加载数据结构可在表格，字段以及关联图形中进行研究。该命令还可以通过以下键盘快捷方式调用： Ctrl+T。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 编辑菜单

编辑菜单选项

| 选项 | 说明 |
| --- | --- |
| 撤消 | 撤销上一次更改（可以撤销多个步骤）。等同于按 Ctrl+Z。 |
| 重做 | 重做最新的撤消。等同于按 Ctrl+Y。 |
| 剪切 | 导出选中文本至剪贴板。此命令同样可用于编辑脚本对话工具栏。等同于按 Ctrl+X。 |
| 复制 | 复制选中文本至剪贴板。此命令同样可用于编辑脚本对话工具栏。相当于按 Ctrl+C。 |
| 粘贴 | 将剪切板上的内容粘贴到对话框中的光标位置。此命令同样可用于编辑脚本对话工具栏。等同于按 Ctrl+V。 |
| 删除 | 删除选中的脚本文本。等同于按 Del。 |
| 清除整个脚本 | 清除脚本，即移除所有除初始自动生成的设置语句之外的文本。 |
| 全选 | 选择整个脚本文本。等同于按 Ctrl+A。 |
| 查找/替换... | 打开对话框可以在脚本中查找和替换数字或字符。此命令同样可用于编辑脚本对话工具栏。等同于按 Ctrl+F。 |
| 跳转到... | 打开对话框可以在脚本中跳转至特定行数。等同于按 Ctrl+G。 |
| 大写 | 选中脚本文本用大写表示。 |
| 小写 | 选中脚本文本用小写表示。 |
| 大小写互换 | 互换选中的脚本文本的大小写。 |
| Capitalize | 选中的脚本文本首字母大写。 |
| 注释 | 在脚本内转换文本行为注释。<br><br>[Rem](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptRegularStatements/Rem.htm) |
| 取消注释 | 将文本行转换回原始脚本文本。 |
| 缩进 | 在脚本中缩进高亮行。 |
| 减少缩进 | 在脚本中减少缩进高亮行。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 插入菜单

插入菜单选项

| 选项 | 说明 |
| --- | --- |
| Set 语句 | 打开设置语句向导，在这里您可以进入新设置语句向导并选择预定义语句。 |
| 环境变量 | 在基于操作系统默认设置的脚本内插入数字解释变量。 |
| 脚本文件 | 您可以浏览包含脚本或部分脚本的文件并在光标位置插入其内容。 |
| 包括语句 | 打开包括脚本文件对话框，您可以用以下几种格式浏览脚本文件： qvs （先前保存的 QlikView 脚本文件）， txt 或sql。 |
| 域 SID | 检索 NT 域安全性 ID 以便于在脚本中使用。NTDOMAINSID 在区域权限内作为控制 NT 安全性的保留字段使用。 |
| 测试脚本 | 插入一个自动生成的测试脚本。 |
| LOAD 语句 | 插入一个加载语句，From File或内嵌。选择内嵌打开内联数据向导，借助它可以从电子表格样式控制中创建加载内嵌语句。 |
| 区域权限 | 从发布商授权表格或内嵌中插入区域权限语句。<br>选择发布商授权可打开文件向导。<br>选择内联可打开访问限制表格向导。 |
| Connect 语句 | 在脚本中插入一个连接语句。 |
| Disconnect 语句 | 在脚本中插入一个 Disconnect 语句。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 标签菜单

标签菜单帮助组织脚本结构。

标签菜单选项

| 选项 | 说明 |
| --- | --- |
| 添加标签... | 添加一个新的脚本标签。从左到右，通过一个个标签执行脚本。如果当前脚本是隐藏脚本的一部分，新标签也将创建于隐藏脚本内。 |
| 在光标除插入标签... | 在活动标签后插入新标签。光标后的活动标签上的任何文本将移动至新标签。 |
| 重命名... | 打开对话框重命名活动标签。 |
| 上移 | 将活动书签向左移一位。标签不能上移至隐藏脚本标签左侧。 |
| 下移 | 将活动书签向右移一位。 |
| 与上一个合并... | 将活动标签上的所有文本移动至上一标签末尾，则活动标签被删除。 |
| 移除... | 移除活动标签。剩下最后一个脚本标签不能移除。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 工具菜单

工具菜单选项

| 选项 | 说明 |
| --- | --- |
| ODBC管理员 64位... | 为 64 位 ODBC 驱动程序打开 ODBC 数据源管理器。 |
| ODBC管理员 32位... | 为 32 位 ODBC 驱动程序打开 ODBC 数据源管理器。 |
| 编辑器首选项 | 打开用户首选项对话框，在这里可以设置显示在脚本中的不同文本类型的字体和颜色。 |
| 语法检查 | 检查脚本语法并停止第一错误。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 帮助菜单

帮助可打开 QlikView 的在线帮助。

## 编辑脚本对话框中的窗格

在编辑脚本对话框中有两个面板：位于顶部的脚本窗格和位于底部的工具窗格。

### 脚本窗格

脚本窗格包括实际脚本。每个脚本行都有编号。脚本可能被分为几个部分显示在独立标签页面，它是按从左至右的顺序执行的。

如果使用了隐藏脚本，它可能在独立标签的左端查看（前提是已有密码）。

该脚本由语法部件进行颜色标记。通过从工具菜单中选择编辑器首选项可以自定义颜色编码。

### 工具窗格

工具窗格由四个标签页面组成，该页面包含用于脚本生成的函数。

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 数据页面

数据页面包含从 QlikView 获取数据的基本命令：

数据库分组命令用于创建连接到数据库和从数据源中选择字段。如果使用商业 DBMS，则可以将 ODBC 或 OLE DB 作为 QlikView 和数据库直接的界面使用。支持 DBMS 的 ODBC 或 OLE DB 驱动程序必须在可以使用 ODBC 或 OLE DB 界面检索数据前安装于电脑之上。一旦在电脑上安装了合适的 ODBC 或 OLE DB 驱动程序，数据库必须配置成 ODBC 数据源。

数据页命令

| 命令 | 说明 |
| --- | --- |
| OLE DB | 使用 OLE DB 建立与数据源的连接。 |
| ODBC | 使用 ODBC 建立与数据源的连接。 |
| QVSAdminDataProvider.dll | 自定义连接器可以连接 QlikView 服务器并从 DMS 和协作对象中加载信息。 |
| 自定义... | 任何自定义数据源将会显示在选择下拉框内。QlikView 具备开源插件接口，这使对自定义界面进行编程成为可能，由此实现对传统文件，ODBC 或 OLE DB 界面所不包括的各类数据源的处理。典型实例是通过网络服务可得的数据。应依据模板代码显示的规格对插件进行编程并将其编译为 dll，此模板代码是作为 Qlik 的开源提供的（按请求）。随后将 dll 文件置于 QV.EXE 文件旁，确保自定义数据源随时可用。 |
| 强制为 32 位 | 通常，QlikView 使用 64 位提供程序。在数据源使用 32-位驱动程序的情况下，选择这一选项强制 ODBC/OLEDB 连接语句至 32-位提供者。 |
| 连接... | 打开数据链接属性对话框，在这里可以选择数据源，或连接到数据源对话框，在这里可以选择 ODBC 数据源。 |
| 选择... | 打开创建选择语句对话框。 |

来源于文件的数据组可以实现从其他数据源检索数据。

来自文件选项的数据

| 选项 | 说明 |
| --- | --- |
| 相对路径 | 如果该设置已启用，QlikView 将在脚本中使用相对路径而不是绝对路径。当文档移动至其他电脑时，通常需要使用相对路径。该设置在用户首选项对话框中同样可用。如果更改此处，也将更改编辑脚本和编辑隐藏脚本对话框。 |
| 使用 FTP | 要从 FTP 服务器中选择文件，单击表格文件，QlikView 文件或包括启用该设置。 |
| 表格文件... | 打开打开本地文件对话框列表表格文件。选择一个或多个文件并按确定将生成一个或多个加载语句。当执行时，脚本从相应文件中加载数据。如果使用 FTP选项已勾选（如上所见），则从列表中选择一个服务器（或输入要使用的服务器，然后单击连接）。完成这些后，选择一个文本文件。 |
| QlikView 文件... | 打开打开 QlikView 文件对话框。当选中一个文件后，二进制语句会生成于脚本的第一行。这些语句从 QlikView 文件中加载数据，但是不会使用布局设置。 |
| 网络文件... | 打开文件向导，在这里可以将 URL 作为源输入数据库表格。 |
| 字段数据 | 打开文件向导，其中可加载已加载字段的内容。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 变量页面

在变量页面上，查找到粘贴与 QlikView 各变量相关的语法的控件。

变量选项

| 选项 | 说明 |
| --- | --- |
| 粘贴 | 粘贴选中函数至脚本。 |
| 显示系统变量 | 如果已标记这个复选框，那么变量下拉菜单中的列表将包括系统变量。 |

QlikView 具备开源插件接口，这使对自定义界面进行编程成为可能，由此实现对传统文件、ODBC 或 OLEDB 界面所不包括的各类数据源的处理。典型实例是通过网络服务可得的数据。应依据模板代码显示的规格对插件进行编程并将其编译为 dll，此模板代码是作为 Qlik 的开源提供的（按请求）。随后将 dll 文件置于 QV.EXE 文件旁，确保自定义数据源随时可用。它会显示在选择下拉框内。

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 函数页面

函数页面包含导航和粘贴 QlikView 标准函数的工具。

函数页面选项

| 选项 | 说明 |
| --- | --- |
| 函数类别 | 在下拉列表中选择一个类别，查看函数名称列表下的相关函数。 |
| 函数名称 | 下拉列表包括标准 QlikView 脚本函数。 |
| 粘贴 | 在函数名称列表中选择一个函数并将其粘贴至脚本中光标所在的位置。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 变量页面

在变量页面上，您将查找到粘贴与 QlikView 变量相关的语法的控件。

变量页面选项

| 选项 | 说明 |
| --- | --- |
| 粘贴 | 粘贴选中变量至脚本。 |
| 显示系统变量 | 如果已标记这个复选框，那么变量下拉菜单中的列表将包括系统变量。 |

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Edit_Script_dialog_box.htm)

#### 设置页面

设置页面包括 QlikView 脚本的安全性设置。

设置页面选项

| 选项 | 说明 |
| --- | --- |
| 脚本权限 | 在读写模式下打开数据库<br><br>如果该选项已选中，在选择语句中写入模式识别符将被启用。<br>可运行外部程序<br>如果选中该选项，则可以在脚本中执行语句。 |
| 设置 | 加密连接用户凭据<br><br>如果该复选框被标记，在 connect 语句中的 USERID 和 PASSWORD 将在脚本中随机选取。 |

## 了解详情

* [从文件中加载数据](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Loading_data_from_files.htm)
* [从数据库中加载数据](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Loading_data_from_databases.htm)
* [脚本语法和图表函数](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Scripting/script-syntax.htm)