# 编辑表达式对话框

选择图表属性：表达式中表达式列表下方的添加按钮，或右键单击现有表达式并选择添加表达式或编辑表达式，即可打开“编辑表达式”对话框。

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Define_Expression.htm)尽管它主要在图表表达式中使用，但只要需要表达式，同样的对话框还用于创建或编辑其他表达式。它通常可以通过单击带三个点符号的按钮进入，这个符号在整个程序中都可以在文本编辑框旁边看到。

对话框的主要部分由可以调整大小以适应大表达式的表达式编辑区组成，在它下面，标签区域包括四个标签 字段，函数，变量及图片。

## 编写表达式

在所选表达式的编辑区输入完整的表达式，但是通常使用以下所述的标签创建大多数表达式比较方便。表达式需要以 = 开头。

标签表达式正确只有在程序接受了表达式语法它才会显示，即当表达式有效时。否则标签将显示以下几个错误信息之一（不当字段名称，表达式错误，表达式后删除数据）。很少有时需要单击确认按钮离开对话框，除非表达式有效。

## 表达式标签选项

编辑表达式对话框选项卡包含以下用于构建表达式的选项。

### 字段

字段标签拥有可在字段数据基础上创建统计聚合函数的控件。

字段选项

| 选项 | 说明 |
| --- | --- |
| 聚合 | 第一个下拉菜单包括一个可用的统计聚合函数的列表。（函数第一个字符串及最后一个字符串可以用于显示透视表中的文本） |
| 表格 | 此下拉列表使您可以将以下字段列表中显示的字段限制在特定的内部表格中。 |
| 字段 | 此下拉菜单包括一个可用字段名称的列表。<br><br>MEASURE 字段值只能与基本聚合函数 Sum、Avg、Count、Min 和 Max 一起使用。 |
| 显示系统字段 | 选中此选项以在字段列表中包括系统字段。 |
| 区别 | 统计函数默认情况下根据发生次数计算。通过选中特殊选项，表达式将在没有重复值的情况下计算。 |
| 粘贴 | 单击此按钮以输入您的选择作为表达式的组成部分。 |

### 函数

函数标签拥有可在表达式中输入通用 QlikView 函数的控件。

函数选项

| 选项 | 说明 |
| --- | --- |
| 函数类别 | 此下拉列表使您可以将以下函数名称列表中显示的函数一次限制在一个类别中。 |
| 函数名称 | 此下拉菜单包括所有可用 QlikView 函数的列表（除了有限的几个专用脚本函数外）。<br>函数标签底部的窗格可显示所选函数的自变量语法。 |
| 粘贴 | 单击此按钮以输入您的选择作为表达式的组成部分。 |

### 变量

变量标签拥有可在表达式中输入 QlikView 变量的控件。

变量选项

| 选项 | 说明 |
| --- | --- |
| 变量 | 此下拉菜单包括所有当前为文档定义的变量列表。 |
| 显示系统变量 | 选中此选项以在变量列表中包括系统变量。 |
| 粘贴 | 单击此按钮以输入您的选择作为表达式的组成部分。 |

在变量标签的底部有一栏显示在变量下拉菜单中所选择的任何变量的当前值。

### 图片

图片标签拥有可访问 QlikView 可用内部文件的控件。也可进入其他相关的图片文件。注意此功能只限于布局的某些部分。在图片标签的右侧是一个显示当前所选图片的窗格。

图像选项

| 选项 | 说明 |
| --- | --- |
| 图片文件夹 | 此下拉菜单包括一个可用图片文件夹的列表。 |
| 图片 | 此下拉菜单包括一个所选文件夹中的可用图片列表。 |
| 高级... | 单击此按钮从图片选择器对话框中直接选择。 |
| 粘贴 | 单击此按钮以输入您的选择作为表达式的组成部分。 |

## 编辑表达式菜单选项

另外，编辑表达式对话框包括以下菜单命令和按钮。

### 文件菜单

文件菜单选项

| 选项 | 说明 |
| --- | --- |
| 导出至表达式文件.... | 可以通过导出至表达式文件命令作为表格文件保存表达编辑框内容。文件以扩展名为 .qve 的形式保存。 |
| 插入文件... | 可以通过插入文件...将以前创建的表达式文件插入脚本。 |
| 混合色向导... | 可使用混合色向导创建颜色混合表达式。 |
| 打印 | 打开 Windows 标准打邼对话框打印表达式。该命令还可以通过以下键盘快捷方式调用： Ctrl+P。 |

### 编辑菜单

编辑菜单选项

| 选项 | 说明 |
| --- | --- |
| 撤消 | 撤消最近改变。该命令还可以通过以下键盘快捷方式调用： Ctrl+Z。 |
| 重做 | 重做最新的撤消。该命令还可以通过以下键盘快捷方式调用： Ctrl+Y。 |
| 剪切 | 将亮显的文本导出至剪切板。该命令还可以通过以下键盘快捷方式调用： Ctrl+X。 |
| 复制 | 将亮显文本复制到剪切板上。该命令还可以通过以下键盘快捷方式调用： Ctrl+C。 |
| 粘贴 | 将剪切板上的内容粘贴到对话框中的光标位置。该命令还可以通过以下键盘快捷方式调用： Ctrl+V。 |
| 清除 | 清除整个表达式。 |
| 全选 | 选择整个表达式。 |
| 查找/替换... | 打开可查找和替换表达式中数字和字符的对话框。该命令还可以通过以下键盘快捷方式调用： Ctrl+F。 |

### 设置菜单

设置菜单选项

| 选项 | 说明 |
| --- | --- |
| 配置... | 打开用户首选项：编辑器。 |

## 了解详情

* [图表表达式](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/ChartFunctions/chart-expressions.htm)
* [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2025/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)