支持的配置以及不支持的配置

该部分概述支持和不支持的 Qlik NPrinting 安装配置。

支持的配置

  • 可以将所有 Qlik NPrinting 组件安装在同一计算机上。也可以将 Qlik NPrinting ServerQlik NPrinting EngineQlik NPrinting Designer 安装在不同计算机上
  • 您不能将 Qlik NPrinting 16 报表导入 Qlik NPrinting 17 或更高的环境。您无法导入全部项目(.nsq 文件)。请参阅:从较旧版本的 Qlik NPrinting 迁移报表模板
  • 报表功能在物理机和虚拟机上都可以正常工作。在两种配置中都不支持虚拟化应用程序。例如,如果将 Qlik NPrinting Engine 安装在已具有从其他计算机上分发的虚拟 QlikView Desktop 12.00 的计算机上,则它不会工作。
  • 可以从同一 Qlik NPrinting Engine 同时连接到 QlikView ClusterQlik Sense 群集。
  • 所有受支持的配置必须在单个 Active Directory 域中实施,除非实施了 JWT 和/或 SAML。在该情况下,列出映射到其他可信域(Qlik NPrinting 可在相同 Active Directory Forest 中验证的域)中的域帐户的对于 Qlik NPrinting web console 用户的限制。请参阅:JWT 身份验证Security Assertion Markup Language (SAML) single sign-on (SSO)

不支持的配置

  • Qlik NPrinting 16 和 Qlik NPrinting Designer June 2017 或更新的版本不能安装在同一计算机上。
  • Qlik NPrinting Designer June 2017 不能管理 Qlik NPrinting 16 项目(.nsq 文件),但是您可导入各个 Qlik NPrinting 16 报表。请参阅:从较旧版本的 Qlik NPrinting 迁移报表模板
  • Qlik NPrinting Server 16 和 Qlik NPrinting June 2017(或更高版本)Server 或 Engine 不能安装在同一计算机上。
  • Qlik NPrinting Engine、Server 和 Qlik Sense Server 不应安装在同一计算机上。

    在这两种产品之间不存在已知的不兼容,但是在生产环境中,Qlik NPrinting 应当安装在和 Qlik Sense 不同的计算机上(虚拟或物理计算机),因为 Qlik NPrinting Engine 和 Server 将使用安装它们的计算机上所有可用的资源。这可能导致 Qlik Sense 因资源不足而崩溃。

  • Qlik NPrinting 引擎和服务不应当安装在安装有 QlikView ServerQlikView Publisher 的同一计算机上。

    在这两种产品之间不存在已知的不兼容,但是在生产环境中,Qlik NPrinting 应当安装在和 QlikView ServerQlikView Publisher 不同的计算机上(虚拟或物理计算机),因为 Qlik NPrinting Engine 和 Server 将使用安装它们的计算机上所有可用的资源。这可能导致 QlikView ServerQlikView Publisher 因资源不足而崩溃。

  • 不支持以上列出的版本之前的 QlikView Desktop 版本。
  • QlikView DesktopMicrosoft Office 无法作为虚拟化应用程序分发。这些应用程序必须本地安装在您安装 Qlik NPrinting 组件的同一物理或虚拟机上。
  • 不支持除了 Microsoft Windows 之外的操作系统。例如,您不能在 Linux 计算机上安装 Qlik NPrinting Server
  • 您只能在计算机上安装 Qlik NPrinting Server、Engine 或 Designer 的一个实例。
  • 您只能从 Qlik NPrinting Engine 连接至一个 Qlik Sense 群集。
  • 不支持域信任、多个域和跨域实施。例如在 Qlik NPrinting Server 部署于一个域上的情况下,映射至 Qlik NPrinting 用户的Windows 用户帐户不能为来自不同域(Qlik NPrinting Server 并非为其成员)的域帐户。

  • Qlik NPrinting June 2018 起,Qlik NPrinting 不再兼容 Qlik Sense 2.2。如果您使用支持的 Qlik Sense 版本,应当更新自己的安装,即使看上去它可以工作。