# 创建 Excel 透视表

您可使用 Excel 表列或层级创建 Excel 透视表。

Qlik Sense 透视表只能作为 Qlik NPrinting 中的图像添加。QlikView 透视表可以作为图像和垂直表添加。都不能在报告中转换成 Excel 透视表。如果您有要在 Excel 报表中复现的透视表，可进行以下两个操作之一：

* 将初始透视表转换为垂直表。
* 克隆透视表并将克隆的表转换为垂直表。

信息注释本帮助主题概述了创建原生 Excel 透视表的唯一受支持方法。

## 使用 Excel 表格列创建透视表

我们建议在Excel 报告中使用 Excel 表列来创建透视表。这比使用级别更简单，也不会降低报告生成速度。

信息注释

透视表不能放在源数据表侧。请将它们放在数据表的上方、下方或单独的工作表中。

### 要求

要在 Qlik NPrinting Designer 中创建透视表，您需要：

* Excel 2007 或更高版本
* Qlik Sense 或 QlikView 垂直表

### 你将进行什么操作

您将进行以下操作：

1. 将 QlikView 垂直表作为表格对象添加到 Excel 报告中。
2. 逐列构建表格。
3. 将该表转换为透视表。

本教程使用 QlikView 数据，该数据可在 [示例文件](https://help.qlik.com/zh-CN/nprinting/February2025/Content/NPrinting/Examples/Examples.htm) （仅提供英文版本） 上找到。您也可以使用自己的 Qlik Sense 或 QlikView 数据。

### 新建 Excel 报告

进行以下操作：

1. 在 Qlik NPrinting 主菜单中选择报表，然后单击创建报表。
2. 为报表输入标题。
3. 在类型下拉列表中选择 Excel。
4. 从应用程序下拉列表选择应用程序。
5. 单击创建来创建报表。
6. 单击编辑模板打开模板编辑器。

### 将图表对象作为表格逐列添加

进行以下操作：

1. 右键单击表格节点，然后选择添加对象。

2. 选择包含垂直表的连接。

3. 选择一个表格对象。例如：Straight Country - Salesman - Year。单击确定。

4. 在表节点中，选择Straight Country - Salesman - Year。

5. 在属性窗格中，清除Keep Source Formats。

6. 单击 Straight Country - Salesman - Year 旁边的 +。

   这将展开表格节点，并显示所有表格列。

7. 按住 Shift 或 CTRL 键，选择要添加的列。在本例中，选择所有四个表字段。

8. 将列拖动到模板上。

   ![Excel 报告管理模板，以表格形式添加各级别。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_1AddTable.png)

9. 突出显示列标题、表格标记和下面的空行。

10. 在 Excel 功能区中，单击插入选项卡。

11. 在表格组中，单击表格。

12. 确保选中我的表格标题框。单击确定。

    ![Excel 报告管理模板，以表格形式添加各级别。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_2ConTable.png)

13. 在左窗格中单击额外。将 deleterow 标记拖动到表格下方空行中的单元格上。

    由此将从最终报表删除空行。

    ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_3DeleteRow.png)

### 转换为透视表

进行以下操作：

1. 突出显示标题和表格字段单元格。

2. 在 Excel 功能区的表格工具下，单击设计选项卡。

3. 在工具组中，单击使用透视表汇总。

4. 在创建透视表窗口中，单击确定。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot1.png)

   会在新工作表中创建透视表。您还可以将透视表添加到同一工作表中，并隐藏包含数据的列。

5. 将Year字段拖动至列框中。

6. 将Salesman和Country字段拖动至行标签框中。

7. 将Sales字段拖动至值框中。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot2.png)

8. 单击计数Total sales以打开下拉菜单。选择值字段设置。

   ![Excel 报告管理模板，以表格形式添加各级别。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot3.png)

9. 在值汇总方式选项卡上，选择总和。单击确定。

10. 选择表中包含销售额值的单元格。将它们格式化为货币。

    ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_6FormatCurren.png)

### 确保在打开报告时刷新数据

如果您不执行这些步骤，将会在生成的报表中看到空的数据透视表。

进行以下操作：

1. 在透视表工具 - 分析选项卡下。点击左侧的选项下拉菜单 。

2. 选择数据选项卡。

3. 选中打开文件时刷新数据复选框。

4. 将每个字段保留的项数设置为None。

5. 单击确定。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot4.png)

### 预览报表

进行以下操作：

1. 单击预览。

   Excel 启动并显示您的报告。

2. 您将得到一份带有透视表的报告。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_5Preview.png)

3. 单击保存并关闭以保存模板并关闭模板编辑器。

## 使用层级创建透视表

您可以使用级别来制作透视表，但这会减慢报告生成时间。只有当 Excel的版本（2003 及更早版本）不支持添加表列时，才应使用此方法。

### 你将进行什么操作

1. 将 QlikView 垂直表作为层级对象添加到 Excel 报告中。
2. 使用层级构建表。
3. 将该表转换为透视表。

本教程使用 QlikView 数据，该数据可在 [示例文件](https://help.qlik.com/zh-CN/nprinting/February2025/Content/NPrinting/Examples/Examples.htm) （仅提供英文版本） 上找到。您也可以使用自己的 Qlik Sense 或 QlikView 数据。

### 将层级添加至模板

进行以下操作：

1. 打开现有的 Excel 报告，或创建新报告。

   参见：[创建](https://help.qlik.com/zh-CN/nprinting/February2025/Content/NPrinting/ExcelReports/Pivot-table-Excel.htm#Creating)

2. 右键单击层级节点，然后选择添加层级。

3. 在层级列表中选择Straight Country - Salesman - Year。单击确定。

4. 将 CH205\_Level - Straight Country-Salesman-Year节点拖动到空模板单元上。这样将创建层级的打开和关闭标签。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_7AddLev.png)

5. 单击 CH205\_Level - Straight Country-Salesman-Year 节点旁边的 +。

6. 将 Country、Salesman、Year 和 Sales 节点拖动到 &lt;CH205\_Level&gt; 和 &lt;/CH205\_Level&gt;标记之间的行上的空单元格上。

   在属性窗格中，确保为所有这四个对象取消选中了保留源格式。

   ![](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_7AddLev2.png)

7. 在 &lt;CH205\_Level&gt; 标签上方的行中输入各栏的标题。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_7AddLev3.png)

信息注释

您可将具有计算维度的 QlikView 对象或空值用作层级。但是您不能在它们内部嵌套其他对象，但不包括来自该工作表对象的字段。Qlik Sense 具有计算维度的可视化无法用作层级。

### 创建透视表

进行以下操作：

1. 选择单元格范围，包括：

   * 标题
   * &lt;CH205\_Level&gt; 打开标记
   * 列标记
   * &lt;/CH205\_Level&gt; 关闭标记

2. 在 Excel 功能区中，选择插入选项卡。在表格组中选择透视表。

3. 在创建透视表窗口中，单击确定。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_8CreatePivot1.png)

   会在新工作表中创建透视表。您还可以将透视表添加到同一工作表中，并隐藏包含数据的列。

4. 将Country和Salesman字段拖动至行标签框中。

5. 将Year字段拖动至列标签框中。

6. 将Sales字段拖动至值框中。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot2.png)

7. 在活动字段组中单击字段设置按钮。

8. 将值汇总方式选项卡中的值更改为总计。单击确定。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_8CreatePivot2.png)

9. 选择表中包含销售额值的单元格。将它们格式化为货币。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_8CreatePivot3.png)

### 确保在打开报告时刷新数据

如果您不执行这些步骤，将会在生成的报表中看到空的数据透视表。

进行以下操作：

1. 在透视表工具 - 分析选项卡下。点击左侧的选项下拉菜单 。

2. 选择数据选项卡。

3. 选中打开文件时刷新数据复选框。

4. 将每个字段保留的项数设置为None。

5. 单击确定。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_4CreatePivot4.png)

### 预览报表

进行以下操作：

1. 单击预览。

   Excel 启动并显示您的报告。

2. 您将得到一份带有透视表的报告。

   ![用透视表创建 Excel 报告模板。](https://help.qlik.com/zh-CN/nprinting/February2025/Content/Resources/Images/NPTutorial/ExcelPivot/ex_NPEX_5Preview.png)

3. 单击保存并关闭以保存模板并关闭模板编辑器。