Satır İçi Veri Sihirbazı

Satır İçi Veri Sihirbazı diyalog penceresi, Ekle menüsü, Yükle Deyimi, Satır İçini Yükle öğesinden açılır. Kodda load inline deyimleri oluşturmak için kullanılır.

Diyalog penceresi, çalışma sayfasına benzer bir görünüm içerir ve aslında birçok açıdan çalışma sayfası gibi çalışır. Ancak, hesaplama formüllerinin bu çalışma sayfasında örneğin Microsoft Excel'de olduğu gibi değerlendirilmeyeceğini unutmayın.

Her sütun, bir satır içi tablo aracılığıyla QlikView'a yüklenecek bir alanı temsil eder. Her satır tablodaki bir kayıttır. Veri hücresi, üzerine tıklanarak seçilir. Ardından değer yazılabilir ya da panodan yapıştırılabilir. Değeri kabul etmek ve başka bir hücreye geçmek için Enter tuşuna veya bir ok tuşuna basın.

Üst (etiket) satır, alan etiketleri için ayrılmıştır. Düzenlemek için etiket hücresine çift tıklayın. Etiket satırında herhangi bir değer girilmemişse, alan adları F1, F2 vb şekilde kullanılır.

Düzenle Menüsü

Düzenle menüsü, bazı temel düzenleme komutları içerir.

Sütun Ekle Bir veya daha fazla sütun seçiliyse, yeni boş bir sütun ekler.
Sütun Sil Seçilen sütunları siler.
Satır Ekle Bir veya daha fazla satır seçiliyse, yeni boş bir satır ekler.
Satır Sil Seçilen satırları siler.

Araçlar Menüsü

Araçlar menüsü, belgedeki mevcut herhangi bir alandan alan değerlerinin yapıştırılabildiği Belge Verilerini İçeri Aktarma Sihirbazı'nı açan Belge Verileri komutunu içerir. Diyalog penceresinde, seçilen herhangi bir alanda bulunan alan değerleri sayısını görülebilir. Ayrıca, tüm değerleri, seçilen değerleri veya hariç değerleri satır içi sihirbazına eklemek için seçmek de mümkündür.

Diyalog penceresini kapatmak ve diyalog penceresinin tablo kılavuz çizgisinin içeriğini yansıtan bir Satır İçini Yükle deyimi oluşturmak için TAMAM öğesine tıklayın.