# 外部モジュールをインストールするタイミング

Talend Studioに、外部モジュールのインストールが必要なタイミングとインストールする外部モジュールが表示されます。

Talend Studioが、必要な外部モジュールを複数の方法で通知します。

* デザインワークスペースでは、コンポーネントを正常に動作させる前に外部モジュールのインストールが必要な場合、そのコンポーネントに赤いエラーインジケーターが表示されます。エラーインジケーターにポインターを合わせると、そのコンポーネントを動作させるために必要な外部モジュールを示すツールチップメッセージが表示されます。

* 1つまたは複数の外部モジュールが必要なコンポーネントの[Basic settings] (基本設定)ビューまたは[Advanced settings] (詳細設定)ビューを開くと、外部モジュールに関する主要情報が表示され、そのとなりに[Install] (インストール)ボタンが表示されます。[Install] (インストール)ボタンをクリックすると、ウィザードが開き、インストール対象の外部モジュールが示されます。

* [Modules] (モジュール)ビューには、インストールが必要なJavaライブラリーとドライバーを含め、Talend Studioが正しく動作するために必要なすべてのモジュールがリスト表示されます。

  デザインワークスペースに[Modules](モジュール)ビューが表示されていない場合は、[Window] (ウィンドウ) &gt; [Show View...] (ビューを表示...) &gt; [Talend]と選択し、リストで[Modules] (モジュール)を選択します。

  ![\[モジュール\]ビュー。](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/tos_install-missing_modules-modules_view.png)

  このビューには次の項目が含まれています:

  | 項目 | 説明 |
  | --- | --- |
  | [Filter text] (フィルターテキスト)フィールド | ステータスに基づいた外部モジュール、コンテキスト、モジュールファイル名、Maven URIを検索できます。 |
  | [Status] (ステータス) | モジュールがシステムにインストールされているかどうかを示します。<br><br>![\[Warning\] (警告)](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/icon-warning_triangle.png)アイコンは、対応するコンポーネントやメタデータ接続に対してこのモジュールが必ずしも必要ではないことを示しています。<br><br>![\[Red cross warning\] (赤い十字)](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/icon-warning_circle.png)アイコンは、対応するコンポーネントやメタデータ接続に対してこのモジュールが絶対に必要であることを示しています。<br><br>右上の小さな緑の点は、モジュールのMaven URIがカスタマイズされていることを表します。詳細は、[Maven URIをカスタマイズしてデータベースドライバーをオーバーライド](https://help.qlik.com/talend/ja-JP/studio-user-guide/8.0-R2024-04-and-earlier/upgrading-database-jdbc-driver-by-customizing-mvn-uri "データベースドライバーのバージョンが異なる場合、そのMaven URIをカスタマイズすれば現在のバージョンをオーバーライドできます。つまり、最新バージョンへのアップグレードや前のバージョンへのロールバックが可能です。ドライバーをオーバーライドすれば、ジョブは利用可能なドライバーをどのバージョンでも使用できるようになります。")をご覧ください。 |
  | [Context] (コンテキスト) | モジュールを使用するコンポーネントやメタデータ接続の名前を示します。このカラムが空の場合は、そのモジュールがTalend Studioの使用全般に必要であることを意味します。 |
  | [Module] (モジュール) | モジュールの正確な名前を示します。 |
  | Maven URI | Mavenでのモジュールのデプロイを一意識別します。<br><br>Maven URIフィールドをクリックし、表示される[...]をクリックすれば、モジュールのMaven URIをカスタマイズできます。詳細は、[外部モジュールのデプロイメント用にMaven URIをカスタマイズ](https://help.qlik.com/talend/ja-JP/studio-user-guide/8.0-R2024-04-and-earlier/customizing-maven-uri-for-external-module-deployment "Talend Studioでは、Mavenでデプロイを識別できるよう、各外部モジュールにデフォルトのURIが与えられます。Maven URIは必要であれば変更することもできます。")をご覧ください。 |
  | ![\[更新\]アイコン](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button_refresh.png) | このビューを更新し、モジュールインストールの最新ステータスが反映されるようにします。<br><br>共同作業の場合、1人のユーザーのTalend Studioに必要なモジュールがインストールされると、他のユーザーは[Modules] (モジュール)ビューを更新してこのモジュールを自分のTalend Studioに追加できるようになります。 |
  | ![\[インポート\]アイコン](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button_import.png) | ローカルファイルからMaven設定をインポートします。 |
  | ![\[エクスポート\]アイコン](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button_export.png) | ローカルファイルにMaven設定をエクスポートします。 |
  | ![Jarアイコン](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button_jar.png) | ダウンロード済みの外部モジュールをTalend Studioにインストールできます。詳細は、[\[Modules\] (モジュール)ビューを使用して外部モジュールを手動でインストール](https://help.qlik.com/talend/ja-JP/studio-user-guide/8.0-R2024-04-and-earlier/installing-external-modules-manually-using-modules-view "外部モジュールがダウンロード済みの場合は、Talend Studioに手動でインストールできます。")をご覧ください。 |
  | ![\[ライブラリーを共有\]アイコン](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button_studio_share_libraries.png) | ライブラリーをローカルライブラリーリポジトリーに共有します。<br><br>このボタンは、ローカルライブラリーリポジトリーへの接続が正しくされた場合のみ使用できます。<br><br>Talend Studioの起動時にライブラリーを共有するかどうかを設定できます。詳細は、[ライブラリーの環境設定のためのアーティファクトリポジトリー](https://help.qlik.com/talend/r/ja-JP/8.0/studio-user-guide/artifact-repository-for-libraries-preferences)をご覧ください。<br><br>プロキシで設定されたローカルライブラリーリポジトリーを使用している場合、このボタンをクリックしてもライブラリーは共有されません。プロキシライブラリーリポジトリーのプロキシ設定に関する詳細は、[Talend Studioでライブラリー用にプロキシリポジトリーを設定](https://help.qlik.com/talend/ja-JP/studio-user-guide/8.0-R2024-04-and-earlier/configure-proxy-for-local-libraries-repository "Talendが提供する8.0 R2022-12以降のTalend Studioマンスリーアップデートをインストール済みであれば、Talend Studioで必要となるライブラリーはTalendの公式リポジトリーグループ(https://talend-update.talend.com/nexus/content/groups/studio-libraries)からデフォルトでダウンロードされます。インストール済みでない場合、ライブラリーはTalendの公式リポジトリー(https://talend-update.talend.com/nexus/content/repositories/libraries)からダウンロードされます。")をご覧ください。 |
  | ![\[サードパーティライブラリーをインストール\]アイコン](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button-install-third-party-libraries.png) | サードパーティライブラリーウィザードが開きます。このウィザードによって、必要なライブラリーやオプションのライブラリを一括してインストールできます。詳細は、[外部モジュールをすべて一括インストール](https://help.qlik.com/talend/ja-JP/studio-user-guide/8.0-R2024-04-and-earlier/installing-all-external-modules-in-one-go "必要な外部モジュールやオプションの外部モジュールをすべて一括してダウンロードし、自動的にインストールできます。")をご覧ください。 |

* Jarインストールウィザードは、以下の場合に表示されます。

  * [Palette] (パレット)からコンポーネントをドロップした際に、そのコンポーネントを動作させるために必要な1つまたは複数の外部モジュールがTalend Studioに存在しない場合。
  * Talend Studioのメタデータ接続セットアップウィザードの[Test connection] (テスト接続)ボタンをクリックした際に、接続に必要な1つまたは複数の外部モジュールがTalend Studioに存在しない場合。
  * コンポーネントのComponent (コンポーネント)ビューで[Guess schema] (推測スキーマ)ボタンをクリックした際に、そのコンポーネントを動作させるために必要な1つまたは複数の外部モジュールがTalend Studioに存在しない場合
  * 1つまたは複数の必須外部モジュールが不足しているコンポーネントの[Basic settings] (基本設定)または[Advanced settings] (詳細設定)ビューの上部で [Install] (インストール)をクリックした場合。
  * 1つまたは複数の必須外部モジュールが不足しているコンポーネントまたはメタデータ接続が関連するジョブを実行した場合。
  * Talend Studioで統合されていないモジュールを1つまたは複数選択し、[Modules] (モジュール)ビューで![\[Download\] (ダウンロード)](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/button_download.png)ボタンをクリックした場合。

  ![\[モジュール\]ビュー。](https://help.qlik.com/talend/ja-JP/studio-user-guide/Resources/images/tos_install-missing_modules-wizard.png)

  このウィザードによって、さまざまな種類の情報と機能が提供されます:

  * インストールが必要な外部モジュールと、その使用を許可するライセンスがリスト表示されます。
  * モジュールのデプロイを識別するデフォルトのMaven URIを利用できます。
  * モジュールの詳細が記載されている公式サイトを利用できます。
  * Talendリポジトリーで利用可能なモジュールをすべて自動的にダウンロードしてインストールできます。
  * Talendリポジトリーで利用できないモジュールを手動でインストールできます。

  外部モジュールを必要とするコンポーネントのドロップ、接続の設定、またはデータベースのスキーマの推測を行う際に、TalendのWebサイトでJarファイルとダウンロードURLのどちらも利用できない場合は、Jarインストールウィザードは表示されません。ただし、Error Log (エラーログ)ビューに、該当するモジュールのダウンロードURLが利用できなかったことを示すエラーメッセージが表示されます。この場合は、ユーザー自身でURLを探してダウンロードし、手動でTalend Studioにインストールできます。

  情報メモヒント: タブシステムに[Error Log] (エラーログ)ビューを表示させるには、[Window] (ウィンドウ) &gt; [Show views...] (ビューの表示...)を選択し、[General] (一般)を展開して[Error Log] (エラーログ)を選択します。