Inline-dataguiden

Dialogen Inline-dataguiden öppnas från menyn Infoga, Load-sats, Inline. Den används för att skapa load inline-satser i skriptet.

Dialogen påminner om ett kalkylblad - och fungerar som ett sådant på många sätt. Dock beräknas formlerna inte i detta kalkylblad såsom i exempelvis Microsoft Excel.

Varje kolumn motsvarar ett fält som ska läsas in i QlikView med hjälp av en inline-tabell. Varje rad är en post i den tabell som ska läsas in. Klicka på en datacell för att markera den. Ett värde kan sedan skrivas in eller klistras in från Urklipp. Tryck på returtangenten eller en piltangent för att godkänna värdet och gå vidare till en annan cell.

Den översta (etikett-)raden är reserverad för fältetiketter. Dubbelklicka i en etikettcell för att redigera den. Om inga värden anges i etikettraden kommer fältnamnen F1, F2 osv att användas.

Redigera-menyn

Menyn Redigera innehåller följande grundläggande kommandon:

Infoga kolumn Infogar en ny tom kolumn om en eller flera kolumner är markerade.
Radera kolumn Tar bort markerade kolumner.
Infoga rad Infogar en ny tom rad om en eller flera rader är markerade.
Radera rad Raderar de markerade raderna.

Verktyg-menyn

Menyn Verktyg innehåller kommandot Dokumentdata som öppnar Guide för import av dokumentdata. Härifrån kan man klistra in fältvärden från befintliga fält i dokumentet. I dialogen kan man även se hur många fältvärden som finns i markerade fält. Man kan även välja att infoga alla värden, möjliga värden eller uteslutna värden i inline-guiden.

Klicka på OK för att stänga dialogen och skapa en Load inline-sats som motsvarar dialogens tabellinnehåll.

Hjälpte den här informationen?

Varför var informationen inte till hjälp och hur kan vi förbättra den?