Arkiv-meny

Arkiv-menyn hittar man överst i fönstret. Den innehåller följande kommandon:

Ny Öppnar ett nytt QlikView-fönster där man kan skapa en ny QlikView-fil.
Öppna... Öppnar ett nytt QlikView-fönster där man kan öppna en QlikView-fil eller tabellfil. När man öppnar en tabellfil öppnas Filguiden automatiskt. Motsvaras av kortkommandot: Ctrl+O.
Öppna i server... Öppnar en dialog där du kan ansluta till en QlikView Server och söka efter dokument som kan öppnas i klientläge.
Motsvaras av kortkommandot: Ctrl+Skift+O.
Observera: När man öppnar dokument som klient till QlikView Server har man inte samma rättigheter som när man öppnar lokala dokument. Som klient kan man kanske inte lägga till eller ta bort arkobjekt, beroende på om dokumentet tillåter samverkan. Man kan inte lägga till eller ta bort ark. Det är inte heller möjligt att komma åt alla egenskapsdialoger, ändra makron, nå skriptet, ladda data eller spara dokumentet.
Uppdatera dokument Detta kommando är endast tillgängligt för dokument som har öppnats på QlikView Server och då endast när det finns en nyare version av dokument på servern. När man begär en uppdatering får man tillgång till de senaste uppgifterna samtidigt som den pågående sessionens val och layoutstatus bibehålls.
Öppna URL... Öppnar dialogen Öppna URL. Här anger man en giltig URL-adress till en valfri webbsida. Webbsidan kommer att öppnas i ett separat fönster inuti QlikView. Denna funktion kan exempelvis användas för QlikView Publisher Accesspoint eller sidor som visar QlikView Server-dokument via AJAX-klienter. Webbsidor som har öppnats kan man nå på samma sätt som QlikViews standarddokument - via Windows-menyn.
Öppna ftp... Öppnar ett nytt QlikView-fönster där du kan öppna en QlikView-fil eller tabellfil från en FTP-server. När man öppnar en tabellfil öppnas Filguiden automatiskt.
Stäng Stänger den aktiva QlikView-filen.
Favoriter Menyn och dess undermenyer kontrollerar en lista över användardefinierade dokument som hanteras oberoende av listan Senast öppnade dokument (se nedan).
Spara

Sparar det aktuella dokumentet som en QlikView-fil. Data, skript och layout sparas. Motsvaras av kortkommandot: Ctrl+S.

Om du vill dela ett QlikView-dokument med hjälp av AJAX-klienter får filnamnet inte innehålla tecknet brädgård (#).

Spara som...

Sparar det aktiva dokumentet i en ny QlikView-fil, under ett nytt namn. Motsvaras av kortkommandot: F12.

Om du vill dela ett QlikView-dokument med hjälp av AJAX-klienter får filnamnet inte innehålla tecknet brädgård (#).

Spara länk... Sparar en länk till dokument som har öppnats på en QlikView Server som en textfil på den lokala maskinen. Filen kommer att ha filtillägget .qvw men innehåller varken data eller layout. När man öppnar ett sådant länkat dokument kommer QlikView att försöka att koppla upp och öppna dokumentet på QlikView Server. Detta kommando är inte tillgängligt för lokala dokument.
Skicka som bifogad fil… Endast tillgängligt när man arbetar med ett lokalt dokument. Skapar ett e-postmeddelande där en kopia av det aktuella qvw-dokumentet bifogas som fil. E-postmottagaren kan öppna qvw-dokumentet om han eller hon har tillgång till QlikView och behörighet för dokumentet (om section access-säkerhet tillämpas). För att detta kommando ska fungera måste en e-postklient vara konfigurerad på datorn.
Skicka med bokmärke som länk… Endast tillgängligt när man arbetar med ett QlikView Server-dokument. Skapar ett e-postmeddelande med en länk till det aktuella serverdokumentet. Ett tillfälligt serverbokmärke (med information om layout-status) skapas och kodas i URL:en. E-postmottagaren kan använda URL-länken för att öppna serverdokumentet och se det du ser – under förutsättning att mottagaren har behörighet för dokumentet och dess information. En e-postklient måste konfigureras på datorn för att detta kommando ska fungera. QlikView Server måste vara konfigurerad så att serverbokmärken är tillåtna.
Skriv ut... Öppnar standarddialogen Skriv ut för utskrift av det aktuella arkobjektet. Kommandot är inte tillgängligt för listboxar. Motsvaras av kortkommandot: Ctrl+P.
Skriv ut som PDF... Öppnar dialogen Skriv ut med PDF-XChange 3.0-skrivaren förvald. Motsvaras av kortkommandot: Ctrl+Skift+P.
Skriv ut möjliga... Öppnar standarddialogen Skriv ut varifrån man kan skriva ut möjliga (valda och valbara) värden i den aktiva listboxen. Kommandot är endast tillgängligt för listboxar.
Skriv ut möjliga som PDF... Detta kommando måste användas när man skriver ut listboxar och multiboxar som PDF.
Skriv ut ark... Öppnar dialogen Skriv ut för utskrift av en bild av det aktuella arket.
Granska... Ger en förhandsgranskning av arkobjekt som kan skrivas ut.
Versionshantering Inställningar
Ange vilken MSSCCI Provider-dll (Microsoft Source Control Interface) som ska användas när ett projekt läggs till eller hämtas från versionshanteringen.

Lägg till projekt i versionshantering
Sparar det öppnade QlikView-dokumentet och skapar automatiskt en projektmapp och projektfiler. Gör så att versionshanteringssystemet lägger till projektet i versionshantering.

Hämta projekt från versionshantering
Hämtar ett projekt från versionshantering och bygger QlikView-dokumentet på nytt från projektfilerna. QlikView-data sparas inte i versionshanteringen. För att fylla dokumentet med data måste kommandot Ladda användas på det byggda dokumentet.

Hämta senaste versionen
Hämtar den senaste versionen av dokumentet från versionshanteringssystemet och bygger QlikView-dokumentet på nytt.

Checka in väntande ändringar
Sparar QlikView-dokumentet och checkar in det i versionshanteringssystemet. Fyra olika versionshanteringsmöjligheter med egna dialoger finns:
  • Lägg till nya filer.
  • Ångra utcheckningen för de filer som ska raderas från versionshanteringen.
  • Ta bort de filer som motsvarar borttagna ark eller arkobjekt som ingår i det versionshanterade materialet.
  • Checka in ändrade filer.

Om dokumentet inte var i den senaste versionen innan incheckningen gjordes öppnar du dokumentet på nytt för att ladda projektändringar som kan ha introducerats medan konflikterna löstes.

 

Ångra väntande ändringar
Ångrar ändringarna. Om det finns filer som har ändrats lokalt men inte checkats ut i versionshanteringssystemet, checkas dessa filer ut innan Ångra väntande ändringar genomförs. QlikView-dokumentet byggs på nytt enligt följande: De filer som har lagts till men inte checkats in tas bort. De filer som väntar på att raderas återställs.
Exportera Exportera innehåll...
Detta alternativ är endast tillgängligt om ett arkobjekt som kan exporteras är aktivt. Då exporteras innehållet på det sätt som beskrivs på arkobjektets Objekt-meny.

Exportera arkbild...
Öppnar en dialog där man kan spara en bild av det aktiva arket i en fil.

Exportera dokumentlayout
Öppnar en dialog för att spara dokumentlayouten som XML-fil. Inga data från dokumentet sparas i XML-filen.
Redigera skript... Öppnar dialogen Redigera skript. Här kan man skriva och exekvera skript som öppnar och läser databaser.
Ladda data Exekverar det aktuella skriptet och laddar nya data till det aktiva QlikView-dokumentet. Ändringar i databasen som inträffat sedan föregående exekvering laddas på så sätt in i dokumentet. Motsvaras av kortkommandot: Ctrl+R.
Partiell laddning Exekverar det aktuella skriptet, inklusive alla skriptkommandon, som Drop table, och laddar data till det aktiva QlikView-dokumentet. Enbart de tabeller vars load- och select-satser föregås av prefixet Replace eller Add laddas dock igen. Datatabeller som inte påverkas av denna typ av load- eller select-satser kommer heller inte att påverkas av den partiella laddningen. Motsvaras av kortkommandot: Ctrl+Skift+R.
Reducera data Öppnar en meny som innehåller följande två kommandon:

Spara möjliga värden
Reducerar QlikView-databasen genom att ta bort alla uteslutna värden.

Ta bort alla värden
Skapar en mall genom att ta bort alla värden från QlikView-databasen, men behålla databasstrukturen och layouten.
Tabellvy... Öppnar dialogen Tabellvy där den laddade informationsstrukturen visas grafiskt i tabeller, fält och associationer. Motsvaras av kortkommandot: Ctrl+T.
Senaste dokument (lista) En lista över de senast använda QlikView-dokumenten. Antalet dokument som ska visas här anges i dialogen Inställningar: Användarinställningar. Standard är 8. Välj ett av dem. Detta motsvaras av kommandot Öppna.
Avsluta Stänger de öppna dokumenten och avslutar QlikView.