Перейти к основному содержимому

Sankey chart

Диаграмма Сэнки (Sankey chart) позволяет пользователям добавлять на редактируемый лист блок-схему определенного типа. Диаграмма служит для визуального представления основных потоков в заданных границах системы. Ширина стрелки диаграммы пропорциональна объему потока. Диаграмма Сэнки входит в пакет Visualization Bundle.

  • Для создания диаграммы необходимо использовать не менее двух измерений и одну меру. Можно указать до пяти измерений, но только одну меру.
  • Измерения с каждой стороны диаграммы необязательно должны иметь одинаковый размер.

  • Значения измерений определяют цвет потоков диаграммы.
  • Цвета связей можно выбрать в соответствии с начальными или конечными точками привязки.
Диаграмма с исходным измерением (Quarter) и целевым измерением (Year).

A Sankey chart with a source and target dimension

Когда это следует использовать

Диаграмму Сэнки удобно использовать для выявления наиболее важных вкладов в общий поток. Диаграмма также позволяет представить определенные количественные показатели в пределах заданных границ системы.

Создание диаграммы Сэнки

На редактируемом листе можно создать диаграмму Сэнки.

Выполните следующие действия.

  1. На панели ресурсов откройте Пользовательские объекты > Visualization bundle и перетащите объект Sankey chart на лист.
  2. Нажмите верхнюю кнопку Добавить измерение и выберите исходное измерение для потока диаграммы (отображается слева).
  3. Нажмите вторую кнопку Добавить измерение и выберите целевое измерение для потока диаграммы (отображается справа).
  4. Нажмите кнопку Добавить меру и выберите меру диаграммы.

После выбора измерений и меры раскрашенная диаграмма Сэнки автоматически отобразится в поле диаграммы.

Добавление дополнительных измерений

В разделе панели свойств Данные > Измерения в диаграмму можно добавить до пяти измерений. Диаграмма обновится и отобразит добавленные измерения. Измерения отображаются слева направо. В роли исходного всегда выступает первое введенное измерение. Целевое измерение всегда отображается справа. При вводе дополнительных измерений они добавляются справа в порядке ввода.


Диаграмма с тремя измерениями: исходное измерение (Origin), целевое измерение (Decision) и дополнительное измерение (Destination).

Sankey chart with three dimensions.

Сортировка

Элементы диаграммы Сэнки автоматически сортируются от самого большого до самого маленького. Порядок сортировки можно изменить на панели свойств.

Выполните следующие действия.

  1. Щелкните Сортировка в разделе Вид на панели свойств.
  2. Переключите параметр Сортировка с Авто на Пользовательский.
  3. Можно переключить параметр Сортировка по численным значениям:
    • Включение: Сортировка по численным значениям: По возрастанию или По убыванию.
    • Выключение: Расположите свои измерения и меры в нужном порядке путем перетаскивания.

Изменение вида диаграммы

Для настройки диаграммы можно использовать одну или несколько функций. Диаграмма будет автоматически обновлена.

Цвета связей

Цвета связей диаграммы выбираются в соответствии с начальными или конечными точками привязки. Чтобы применить к связям диаграммы цвет начальной или конечной точки привязки, используйте строку ='SOURCE' или ='TARGET'. Также можно выбрать другой цвет путем ввода строки цветового кода. Следует использовать допустимые CSS-цвета.

Выполните следующие действия.

  1. Щелкните Представление в разделе Вид на панели свойств.
  2. Введите соответствующую строку в поле Link color.
  3. Нажмите «Ввод». Диаграмма будет обновлена.

Также изменить цвет связи можно с помощью выражения в редакторе выражения (Expression). Кроме того, можно раскрасить связь, интенсивность которой основана на значении Margin % представленных этой связью значений измерения.

Example:  

Введите строку =rgb(round(Avg ([Margin %])*255), 100, 100) где Margin % представляет собой значение от 0 до 1. Связь диаграммы отобразится красным цветом.

Непрозрачность связи

Для регулировки непрозрачности связи переместите кнопку ползунка непрозрачности связи в разделе Вид > Link opacity на панели свойств. Если для параметра непрозрачности задать значение 1 (крайнее правое), отобразится тень, что подчеркнет различия связей.

Цвета узлов

Можно изменить цвет узла каждого значения измерения. Следует использовать допустимые CSS-цвета.

Выполните следующие действия.

  1. Выберите соответствующее измерение в разделе Данные > Измерения на панели свойств.
  2. Введите строку цветового кода в поле Node color и нажмите «Ввод». Диаграмма будет обновлена.

    Пример. Для использования бирюзового цвета (#00ffff) задайте ='#00ffff' для строки кода цвета. Настроить цвет узла можно также с помощью выражения в редакторе выражения (Expression).

    Region dimension values colored by an expression.

Интервал и ширина узлов

Можно настроить как расстояние между узлами по вертикали («node padding»), так и ширину узлов диаграммы по горизонтали («node width»).

Выполните следующие действия.

  1. Щелкните Представление в разделе Вид на панели свойств.
  2. Переместите соответствующие кнопки ползунков Node padding и/или Node width, чтобы настроить параметры узла.

Ограничения

Для получения сведений об ограничениях общего характера см. Ограничения.