# Настройка ключевых показателей эффективности

Значения и меры диаграммы мульти-КПЭ (Мульти-КПЭ) можно настроить при помощи одного или нескольких условных параметров. Можно одновременно добавить несколько ключевых показателей эффективности, сгруппировать их и связать с разными листами. Ключевые показатели эффективности можно настроить независимо друг от друга, например, изменив соответствующие CSS-свойства, таких как цвет текста, шрифт, размер, значки, метки, графические элементы.

Примечание к информации

Функция «Мульти-КПЭ» больше не будет доступна в панели ресурсов для создания новых диаграмм с 5 апреля 2025 года в Qlik Cloud и в версии Qlik Sense под управлением клиента, которая ожидается в мае 2025 года. Она по-прежнему будет работать на тех информационных панелях, куда она была добавлена ранее, но будет полностью удалена в мае 2026 года в Qlik Cloud и в версии Qlik Sense под управлением клиента, выпуск которой запланирован на май 2026 года.

Рекомендации по замене функциональности см. на сайте [Диаграмма мульти-КПЭ](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/multi-KPI.htm).

Ключевые показатели эффективности можно настроить независимо друг от друга, например, изменив соответствующие CSS-свойства, таких как цвет текста, шрифт, размер, значки, метки, графические элементы.

Настройка значений ключевых показателей эффективности с использованием значков, разных цветов, шрифтов, основных визуализаций

Настройка значений ключевых показателей эффективности с использованием значков, разных цветов, шрифтов, основных визуализаций

Настройка значений ключевых показателей эффективности с использованием значков, разных цветов, шрифтов, основных визуализаций ![Настройка значений ключевых показателей эффективности с использованием значков, разных цветов, шрифтов, основных визуализаций](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/info1_701x117.png)

## Раскрашивание мульти-КПЭ

Благодаря функции раскрашивания значения ключевых показателей эффективности (меры и метки) можно различать по цветам. Можно изменить цвет текста, значков и фона. Следует использовать допустимые CSS-цвета.

Можно выбрать следующие параметры:

* Палитра цветов с набором предопределенных цветов.
* Цветовой круг (щелкните символ мольберта на палитре цветов и выберите отдельный цвет).
* Введите строку кода цвета в поле рядом с символом мольберта.

### Изменение цвета меры/метки

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств.

2. Щелкните соответствующую меру и выберите параметр раскрашивания значения (Цвет значения) или метки (Цвет метки).

3. Выберите цвет с помощью отобразившейся палитры цветов.

   ![Панель выбора цвета ключевого показателя эффективности](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/color50_680x243.png)

### Изменение цвета фона

Выполните следующие действия.

1. Также можно настроить собственный цвет. Для этого щелкните символ мольберта на палитре цветов и выберите цвет либо введите строку кода цвета в поле рядом с символом мольберта. Следует использовать допустимые CSS-цвета.

2. Щелкните Вид &gt; Стили на панели свойств.

3. Щелкните поле Цвет фона.

4. Выберите цвет с помощью отобразившейся палитры цветов. Диаграмма будет обновлена.

## Изменение размера мульти-КПЭ

Для настройки размера измерений, мер, меток и значков можно использовать предопределенные размеры в раскрывающемся меню:

* Метки измерений: выберите размер метки в раскрывающемся меню в разделе Вид &gt; Измерения &gt; Размер на панели свойств.
* Метки мер: у всех мер размер меток может быть разным.

Выполните следующие действия.

1. Выберите размер меры в разделе Данные &gt; Меры на панели свойств.
2. Выберите меру и щелкните поле Переопределить параметры.
3. Введите тип метки в качестве строки или выражения в поле Метка и выберите размер из числа параметров в раскрывающемся меню Размер.

Значки: можно раскрасить значки разными цветами, чтобы с легкостью различать их.

Выполните следующие действия.

1. Перейдите в раздел Данные &gt; Меры на панели свойств.
2. Укажите меру и выберите значок с помощью параметра значка.
3. Выберите размер значка в раскрывающемся меню раздела Значок.

## Изменение шрифта мульти-КПЭ

Для изменения шрифта меток перейдите в раздел Данные &gt; Меры на панели свойств и выберите соответствующую меру. В поле Стиль шрифта введите строку метки и нажмите клавишу «Ввод».

Также изменить шрифт можно с помощью выражения в редакторе выражения (the Выражение icon) либо применить CSS-свойства шрифта, указанные в разделе Вид &gt; Стили &gt; Стили (CSS) на панели свойств.

## Изменение значков

Можно настроить предопределенный значок для представления значения и/или метки. Для этого выберите значок из набора значков. Значки можно настраивать, изменяя цвета, шрифты, метки и размер.

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств.

2. Установите флажок Выбрать значок и щелкните соответствующий значок в отобразившемся наборе значков.

   ![Панель набора значков](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/icon3_665x258.png)

3. Щелкните ОК. Всплывающее окно будет закрыто, а диаграмма обновится.

4. Для настройки метки или значения выберите Метка или Значение в разделе Положение значка.

Доступен другой способ изменения значения/метки значка. Для этого введите строку значка в разделе Значок (Данные &gt; Меры &gt; соответствующая мера на панели свойств) и нажмите клавишу «Ввод». Затем в зависимости от того, какой элемент необходимо настроить, щелкните Метка или Значение в разделе Положение значка. Также изменить значок можно с помощью выражения в редакторе выражения (the Выражение icon). Следует использовать допустимые CSS-значки.

## Использование режима инфографики

С помощью режима инфографики можно графически отобразить каждую меру в виде набора значков.

Выполните следующие действия.

1. Щелкните соответствующую меру в разделе Данные &gt; Меры на панели свойств, затем нажмите кнопку Значок.

2. В отобразившемся наборе предопределенных значков (Значки) выберите значок, представляющий меру.

3. Нажмите кнопку Режим инфографики. Созданная диаграмма ключевого показателя эффективности будет обновлена. На ней будут графически отображены меры с соответствующим количеством значков (не более 100 значков на меру).

   Также выбрать значок можно с помощью выражения в редакторе выражения (the Выражение icon).

   ![диаграммы ключевого показателя эффективности, для отображения которых использованы разные типы инфографики.](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/info2_715x163.png)

## Встраивание основной визуализации

Для наглядного представления объекта ключевого показателя эффективности можно использовать встроенную основную визуализацию.

Выполните следующие действия.

1. Перейдите в раздел Данные &gt; Меры на панели свойств и щелкните Добавить.
2. Нажмите кнопку Редактор выражения (the Выражение icon).
3. Введите строку ='Перетащите сюда' в Редактор выражения и щелкните Применить.
4. Перетащите объект основной визуализации в область значения заполнителя каждой меры.

Также можно вставить строку идентификатора объекта в выражение в редакторе выражения (the Выражение icon) в разделе Визуализация для каждой меры (Данные &gt; Меры &gt; соответствующая мера на панели свойств)

![Меры ключевых показателей эффективности, где каждый ключевой показатель эффективности отображается с соответствующей основной визуализацией.](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/info_684x157.png)

## Использование свойств стилей (CSS)

Для дальнейшей настройки каждой меры можно использовать непредопределенные свойства стилей (CSS). Можно изменить значки, цвет текста/значков, метки, шрифт, цвет фона, размер и т. д. Скопируйте и вставьте стили в поле Стили (CSS) (раздел Вид &gt; Стили на панели свойств).

Для настройки значков укажите соответствующие классы в поле Значок выбранной меры в разделе Данные &gt; Меры на панели свойств. Также для ввода строки значка можно использовать выражение в редакторе выражения (the Выражение icon).

![Окно стилей CSS на панели свойств.](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/css502_639x203.png)

## Форматирование ключевых показателей эффективности

Макет диаграммы можно представлять разными способами при помощи форматирования.

### Выравнивание

Чтобы настроить выравнивание основного текста диаграммы, установите соответствующий флажок в поле Выравнивание выбранной меры в разделе Данные &gt; Меры на панели свойств.

Также можно выровнять все ключевые показатели эффективности по вертикали. Можно настроить выравнивание по верхнему, нижнему краю или по центру, а также растягивание. Выберите соответствующий параметр выравнивания в меню Выравнивание по вертикали раздела Вид &gt; Стили на панели свойств. Чтобы выровнять метки по центру, установите флажок Выровнять метки по центру в разделе Вид &gt; Измерения на панели свойств.

### Формат чисел

Также можно настроить формат числовых значений ключевых показателей эффективности. К одним и тем же значениям можно применить разное форматирование. Диаграмма обновляется в соответствии с выбранным форматом чисел.

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств и выберите соответствующую меру.

2. Выберите соответствующий формат чисел в меню Формат чисел.

   ![Объект ключевого показателя эффективности, для которого используются два разных типа форматирования чисел («Авто», «Денежный»).](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/number3_600x347.png)

### Образец формата

Текст определенной меры можно изменить или удалить.

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств.
2. Щелкните соответствующую меру, введите/удалите строку формата в поле Образец формата и нажмите клавишу «Ввод».

### Сегмент/карта

Также макет диаграммы ключевого показателя эффективности можно настроить таким образом, чтобы измерения и значения отображались в виде сегментов или карт.

Выполните следующие действия.

1. Щелкните Вид &gt; Измерения на панели свойств.

2. Выберите макет Сегмент или Карта в меню Показать в виде. Диаграмма будет обновлена.

   ![Объект ключевого показателя эффективности с выбранным макетом сегмента (сверху) и карты (снизу).](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/seg3_641x413.png)

Можно настроить отображение макета сегмента по горизонтали или по вертикали в разделе Вид &gt; Измерения &gt; Ориентация на панели свойств. Нажмите кнопку Горизонтальная или Вертикальная.

### Элементы в строке

В разделе Вид &gt; Меры на панели свойств также можно настроить количество элементов (ключевых показателей эффективности) на строку диаграммы. Используйте параметр по умолчанию «Авто» или выберите соответствующее значение в меню Элементы в строке (от 1 до 8 элементов).

### Границы

Внешние и внутренние границы диаграммы можно скрыть. По умолчанию видны все границы. Чтобы настроить границы, перейдите в раздел Вид &gt; Измерения на панели свойств и установите соответствующий флажок: Скрыть внешние границы и/или Скрыть внутренние границы.

### Макет и форматирование значения/метки

Положение и порядок отображения меток значений измерений и мер можно изменять. Метки можно скрыть либо отобразить по горизонтали или по вертикали. По умолчанию выбран параметр Горизонтальный.

#### Макет метки измерения

Выполните следующие действия.

1. Щелкните Вид &gt; Меры на панели свойств.
2. Щелкните Горизонтальная или Вертикальная в разделе Ориентация меток для настройки отображения меток.

#### Макет значения меры

Макет значения меры можно настроить двумя разными способами.

Выполните следующие действия.

1. Существующие параметры:
   1. Щелкните Вид &gt; Меры на панели свойств.
   2. Щелкните Горизонтальная или Вертикальная в разделе Ориентация меток для настройки отображения меток.
2. Новые параметры:
   1. Щелкните Данные &gt; Меры на панели свойств.
   2. Щелкните соответствующую меру и установите флажок Переопределить параметры.
   3. Введите строку метки в поле Метка и нажмите клавишу «Ввод».

#### Порядок меток

Также можно настроить порядок отображения меток значений меры.

Выполните следующие действия.

1. Щелкните Вид &gt; Меры на панели свойств.
2. Щелкните Метка, значение или Значение, метка в разделе Ориентация меток для настройки порядка отображения меток.

#### Порядок значков

Можно настроить отображение значков перед значением или после него. В разделе Вид &gt; Меры на панели свойств перейдите в раздел Порядок значков и нажмите кнопку Значок, значение или Значение, значок для настройки порядка отображения элементов на диаграмме.

#### Скрыть метки

* Метки мер: выберите этот параметр, чтобы скрыть метку меры каждого ключевого показателя эффективности. Чтобы скрыть метки, щелкните Данные &gt; Меры на панели свойств и выберите соответствующую меру. Затем установите флажок Скрыть метки.
* Метки измерений: выберите этот параметр, чтобы скрыть метку измерения каждого ключевого показателя эффективности. Чтобы скрыть метки, щелкните Вид &gt; Измерения на панели свойств. Затем установите флажок Скрыть метки.

#### Скрыть значения

Выберите этот параметр, чтобы скрыть значение каждого ключевого показателя эффективности. Чтобы скрыть значение, щелкните Данные &gt; Меры на панели свойств. Затем установите флажок Скрыть значения.

#### Группировать значения ключевых показателей эффективности

Значения ключевых показателей эффективности можно сгруппировать или отображать для каждой меры по отдельности. Перейдите в раздел Данные &gt; Меры на панели свойств. Выберите соответствующую меру и установите флажок Группировать по измерению.

Также можно ввести строку значения измерения в поле Значение измерения и нажать клавишу «Ввод». Диаграмма будет обновлена. Также для ввода значения измерения можно использовать выражение в редакторе выражения (the Выражение icon). Следует использовать допустимые CSS-значения.

#### Связать с отдельным листом

Меры можно связывать с разными листами.

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств и выберите соответствующую меру.

2. Чтобы включить параметр, переместите ползунок Ссылка на лист вправо.

3. Нажмите кнопку Выбрать лист и во всплывающем окне Выбрать лист щелкните страницу для связывания. Лист будет закрыт, между страницами установится связь.

   ![Связывание с отдельным листом на панели свойств.](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Resources/Images/sheet2_662x302.png)

## Ограничения

Для получения сведений об ограничениях общего характера см. [Ограничения](https://help.qlik.com/ru-RU/sense/November2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati).

СОПУТСТВУЮЩИЕ УЧЕБНЫЕ МАТЕРИАЛЫ:

* [Настройка диаграммы «Мульти-КПЭ» в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)

## Подробнее

* [Настройка диаграммы «Мульти-КПЭ» в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)