# Диаграмма Сэнки

Диаграмма Сэнки (Диаграмма Сэнки) позволяет пользователям добавлять на редактируемый лист блок-схему определенного типа. Диаграмма служит для визуального представления основных потоков в заданных границах системы. Ширина стрелки диаграммы пропорциональна объему потока. Диаграмма Сэнки входит в пакет Visualization Bundle.

* Для создания диаграммы необходимо использовать не менее двух измерений и одну меру. Можно указать до пяти измерений, но только одну меру.

* Измерения с каждой стороны диаграммы необязательно должны иметь одинаковый размер.

* Значения измерений определяют цвет потоков диаграммы.

* Цвета связей можно выбрать в соответствии с начальными или конечными точками привязки.

Диаграмма с исходным измерением (Quarter) и целевым измерением (Year).

Диаграмма с исходным измерением (Quarter) и целевым измерением (Year).

Диаграмма с исходным измерением (Quarter) и целевым измерением (Year). ![Диаграмма Сэнки с исходным и целевым измерением](<https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/2018-11-23 09_04_58-Qlik Sense Desktop 2_690x421.png>) [Sankey Chart](https://play.vidyard.com/4wj7qQHGuJS3KUJYkzALEq)

## Когда это следует использовать

Диаграмму Сэнки удобно использовать для выявления наиболее важных вкладов в общий поток. Диаграмма также позволяет представить определенные количественные показатели в пределах заданных границ системы.

## Создание диаграммы Сэнки

На редактируемом листе можно создать диаграмму Сэнки.

Выполните следующие действия.

1. На панели ресурсов откройте Пользовательские объекты &gt; Visualization bundle и перетащите объект Диаграмма Сэнки на лист.
2. Нажмите верхнюю кнопку Добавить измерение и выберите исходное измерение для потока диаграммы (отображается слева).
3. Нажмите вторую кнопку Добавить измерение и выберите целевое измерение для потока диаграммы (отображается справа).
4. Нажмите кнопку Добавить меру и выберите меру диаграммы.

После выбора измерений и меры раскрашенная диаграмма Сэнки автоматически отобразится в поле диаграммы.

## Добавление дополнительных измерений

В разделе панели свойств Данные &gt; Измерения в диаграмму можно добавить до пяти измерений. Диаграмма обновится и отобразит добавленные измерения. Измерения отображаются слева направо. В роли исходного всегда выступает первое введенное измерение. Целевое измерение всегда отображается справа. При вводе дополнительных измерений они добавляются справа в порядке ввода.

Диаграмма с тремя измерениями: исходное измерение (Origin), целевое измерение (Decision) и дополнительное измерение (Destination).

Диаграмма с тремя измерениями: исходное измерение (Origin), целевое измерение (Decision) и дополнительное измерение (Destination).

Диаграмма с тремя измерениями: исходное измерение (Origin), целевое измерение (Decision) и дополнительное измерение (Destination). ![Диаграмма Сэнки с тремя измерениями.](<https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/2018-11-20 11_33_01-Microsoft Edge_691x383.png>)

## Сортировка

Элементы диаграммы Сэнки автоматически сортируются от самого большого до самого маленького. Порядок сортировки можно изменить на панели свойств.

Выполните следующие действия.

1. Щелкните Сортировка в разделе Вид на панели свойств.
2. Переключите параметр Сортировка с Авто на Пользовательский.
3. Можно переключить параметр Сортировка по численным значениям:
   * Включение: сортировка по численным значениям: По возрастанию или По убыванию.
   * Выключение: расположите свои измерения и меры в нужном порядке путем перетаскивания.

## Изменение стиля и вида

Для настройки диаграммы можно использовать одну или несколько функций. Диаграмма будет автоматически обновлена.

### Цвета связей

Цвета связей диаграммы выбираются в соответствии с начальными или конечными точками привязки. Чтобы применить к связям диаграммы цвет начальной или конечной точки привязки, используйте строку ='SOURCE' или ='TARGET'. Также можно выбрать другой цвет путем ввода строки цветового кода. Следует использовать допустимые CSS-цвета.

Выполните следующие действия.

1. Щелкните Представление в разделе Вид на панели свойств.
2. Введите соответствующую строку в поле Цвет связи.
3. Нажмите «Ввод». Диаграмма будет обновлена.

Также изменить цвет связи можно с помощью выражения в редакторе выражения (the Выражение icon). Кроме того, можно раскрасить связь, интенсивность которой основана на значении Margin % представленных этой связью значений измерения.

Пример:

Введите строку `=rgb(round(Avg ([Margin %])*255), 100, 100)`, где Margin % представляет собой значение от 0 до 1. Связь диаграммы отобразится красным цветом.

### Непрозрачность связи

Для регулировки непрозрачности связи переместите кнопку ползунка непрозрачности связи в разделе Вид &gt; Link opacity на панели свойств. Если для параметра непрозрачности задать значение 1 (крайнее правое), отобразится тень, что подчеркнет различия связей.

### Цвета узлов

Можно изменить цвет узла каждого значения измерения. Следует использовать допустимые CSS-цвета.

Выполните следующие действия.

1. Выберите соответствующее измерение в разделе Данные &gt; Измерения на панели свойств.

2. Введите строку цветового кода в поле Node color и нажмите «Ввод». Диаграмма будет обновлена.

   Например, для использования бирюзового цвета (`#00ffff`) задайте `='#00ffff'` для строки кода цвета. Настроить цвет узла можно также с помощью выражения в редакторе выражения (the Выражение icon).

   ![Раскрашивание значений измерения региона выполняется по выражению.](<https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/2018-11-20 11_39_03-Microsoft Edge_651x328.png>)

### Интервал и ширина узлов

Можно настроить как расстояние между узлами по вертикали («node padding»), так и ширину узлов диаграммы по горизонтали («node width»).

Выполните следующие действия.

1. Щелкните Представление в разделе Вид на панели свойств.
2. Переместите соответствующие кнопки ползунков Node padding и/или Node width, чтобы настроить параметры узла.

## Использование панели стиля для дополнительной настройки внешнего вида

В области Вид на панели свойств доступен ряд параметров для настройки стилей.

Щелкните the Стиль icon в области Вид &gt; Представление для дополнительной настройки стиля диаграммы. Панель стиля содержит несколько разделов на вкладках Общие и Диаграмма.

Чтобы сбросить стили, щелкните ![](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) рядом с каждым разделом. Нажмите кнопку ![](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg)Сбросить все, чтобы сбросить стили для всех доступных вкладок на панели стиля.

Для получения общих сведений о настройке стиля отдельной визуализации см. раздел [Применение пользовательского стиля к визуализации](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm).

### Настройка текста

Можно настроить текст для заголовка, подзаголовка и сноски на вкладке Вид &gt; Общие. Чтобы скрыть эти элементы, выключите параметр Показать заголовки.

Видимость различных меток на диаграмме зависит от настроек конкретной диаграммы и от параметров отображения меток. Их можно задать на панели свойств.

Можно настроить стиль текста, который отображается на диаграмме.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon.

3. На вкладке Общие настройте шрифт, стиль начертания, размер шрифта и цвет для следующих элементов:

   * Заголовок

   * Подзаголовок

   * Сноска

4. На вкладке Диаграмма настройте шрифт, размер шрифта и цвет для следующих текстовых элементов.

   * Заголовок узла: настройте стиль текста заголовка для каждого узла в диаграмме.

   * Метка узла: настройте стиль текста меток для отдельных значений узлов.

### Настройка фона

Можно настроить фон диаграммы. В качестве фона можно использовать цвет или изображение.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon .

3. На вкладке Общие панели стиля выберите цвет фона (основной цвет или выражение). Также можно выбрать фоновое изображение из библиотеки медиафайлов или указать URL-адрес изображения.

   При использовании цвета фона настройте непрозрачность фона с помощью ползунка.

   При использовании фонового изображения можно настроить размер и расположение изображения.

### Пользовательская настройка границы и тени

Можно настроить границу и тень диаграммы.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon.

3. На вкладке Общие панели стилей в области Граница настройте значение параметра Контур, чтобы сделать линию вокруг диаграммы более широкой или узкой.

4. Выберите цвет границы.

5. Настройте параметр Радиус закругления, чтобы управлять скруглением рамки.

6. В области Тень на вкладке Общие выберите размер и цвет тени. Выберите Нет, чтобы убрать тень.

## Ограничения

Для получения сведений об ограничениях общего характера см. [Ограничения](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati).

СОПУТСТВУЮЩИЕ УЧЕБНЫЕ МАТЕРИАЛЫ:

* [Настройка диаграммы Сэнки в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Sankey_chart)

## Подробнее

* [Настройка диаграммы Сэнки в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Sankey_chart)