# Сетевая диаграмма

С помощью сетевой диаграммы (Сетевая диаграмма) можно перенести сеть связанных узлов и контуров из набора данных на лист. Сетевая диаграмма служит для представления потоков информации, взаимодействия компонентов и их местоположения в сети. Сетевая диаграмма входит в пакет Visualization Bundle.

Сетевая диаграмма поддерживает как общий, так и детализированный обзор. Узлы соответствуют сетевым компонентам, а контуры представляют движение информации от одного компонента к другому. Сетевые узлы связаны с теми узлами, с которыми они активнее всего взаимодействуют. Для представления разных уровней сети в данной визуализации используются различные параметры стиля, цвета и размера, а также изображения.

[Network Chart](https://play.vidyard.com/eB5dYhHpX6d2ZUcWQnq6kK)

## Содержимое

Необходимо определить три измерения с четвертым оптимальным измерением:

* Идентификатор узла: данное измерение определяет, какие узлы представлены на диаграмме.
* Метка узла: данное измерение устанавливает метку каждого узла.
* Родительский элемент узла: данное измерение устанавливает родительский элемент узла, а также управляет связью между узлами. Оно должно содержать значение идентификатора узла родительского элемента для подключения.
* Группа узлов (дополнительно): данное измерение используется для группирования узлов. Все узлы в одной и той же группе будут выделены одинаковым цветом.

Для расширения диаграммы можно использовать до трех мер. Все меры не являются обязательными, но при их добавлении необходимо соблюдать следующий порядок.

1. Подсказка: можно установить значение меры, которое отображается в подсказке при наведении курсора на узел.
2. Размер узла: можно установить размер узла в соответствии с мерой.
3. Размер контура: можно установить ширину линий между узлами в соответствии с мерой.

Примечание к информацииПеред установкой размера узла необходимо добавить подсказку. Размер контура можно установить после добавления подсказки и размера узла.

## Когда это следует использовать

Сетевые диаграммы можно использовать для наглядного представления компьютерных или телекоммуникационных сетей. Они служат для отображения компонентов сети и их взаимодействия. К примеру, на диаграмме может быть представлена группа связанных компьютеров, принтеров, модемов, хабов и маршрутизаторов. Эту диаграмму удобно использовать для следующих целей:

* Планирование структуры сети.
* Согласование обновлений существующей сети.
* Составление отчетов и устранение проблем сети.
* Отслеживание поведения компонентов.
* Составление подробной документации сети.

## Форматирование данных

Для сетевой диаграммы требуются данные, структурированные последовательно в соответствии с моделью сетевых данных, где каждая запись может содержать несколько родительских и дочерних элементов. Каждая запись должна содержать по крайне мере:

* поле, идентифицирующее узел — идентификатор узла. Значения идентификатора узла должны быть выражены целыми числами, начиная от 0 и в последовательном порядке;
* поле с названием узла;
* поле, определяющее родительский узел. Данное значение должно быть выражено идентификатором узла другого узла. Если данное поле пустое и любая другая запись не относится к данному узлу, будет создан отключенный узел.

Примечание к подсказкеТакже возможно использование иерархической модели данных, в которой каждый узел имеет один родительский элемент. В результате будет создана древовидная диаграмма.

Далее указаны примеры данных, которые можно сохранить в текстовом редакторе и загрузить в новое приложение. Необходимо загрузить оба примера файлов. В этом примере показан поток пассажиров между разными аэропортами.

* ID — это идентификатор узла аэропорта.
* Name — это имя узла аэропорта. Используется в качестве метки узла.
* LinkTo содержит идентификатор родительского узла.
* Group указывает на группу узла. Может использоваться для установки цвета узлов в соответствии с группой.
* Volume — объем потока пассажиров между ID и LinkTo. Может использоваться в качестве меры для размера контура.
* NodeVolume — общий объем потока пассажиров для узла. Загружается в отдельную таблицу, так как диаграмма не может автоматически агрегировать объемы.

Пример 1: Airports1.csv

```
ID;Name;LinkTo;Group;Volume
0;Frankfurt;;0;
1;London;0;1;5
2;Madrid;0;1;4
2;Madrid;1;1;8
3;Warsaw;0;1;7
4;Arlanda;0;1;1
3;Warsaw;1;1;5
4;Arlanda;1;1;6
5;Tunis;0;2;8
5;Tunis;2;2;4
6;Berlin;0;1;6
6;Berlin;4;1;4
7;Rome;0;1;6
7;Rome;6;1;3
8;San Francisco;0;3;2
9;New York;0;3;9
```

Пример 2: Airports2.csv

```

ID,NodeVolume
0,48
1,24
2,16
3,12
4,11
5,12
6,13
7,9
8,2
9,9
```

## Создание сетевой диаграммы

На примере сетевой диаграммы, созданной на основе набора данных, показана связь разных аэропортов по всему миру. Диаграмма использует набор данных образца из раздела [Форматирование данных.](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/network-diagram.htm#Formatti) Для начала необходимо сохранить набор данных образца в текстовый файл, создать новое приложение и загрузить набор данных образца.

Выполните следующие действия.

1. На панели ресурсов откройте Пользовательские объекты &gt; Visualization bundle и перетащите объект Сетевая диаграмма на лист.

2. Нажмите верхнюю кнопку Добавить измерение и выберите Идентификатор в качестве идентификатора узла.

3. Нажмите вторую кнопку Добавить измерение и выберите Имя в качестве метки узла.

4. Нажмите третью кнопку Добавить измерение и выберите LinkTo (Связать с) в качестве родительского узла.

5. На панели свойств щелкните Данные. Нажмите кнопку Добавить в разделе Группа узла (Node group) и выберите Группа (Group) в качестве измерения группы.

6. В меню мер в разделе Подсказка нажмите кнопку Добавить и выберите Volume &gt; Sum(NodeVolume).

7. В разделе Размер узла (Node size) нажмите кнопку Добавить и выберите Volume &gt; Sum(NodeVolume).

8. В разделе Размер контура нажмите кнопку Добавить и выберите Volume &gt; Sum(Volume).

   Диаграмма примет следующий вид:

   ![Диаграмма с четырьмя измерениями и тремя мерами, динамическими контурами, узлами, представленными в виде точек, и значениями кривых.](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/ex_gen_networkchart.png)

## Изменение вида диаграммы

Для настройки диаграммы можно использовать одну или несколько функций.

### Настройка типа контура

Настроить форму кривой, соединяющей узлы диаграммы, можно на панели свойств Параметры &gt; Edge Type (Тип контура). Выберите в меню параметр формы кривых диаграммы.

Примеры:

Диаграмма с динамическими контурами (кривыми).

Диаграмма с динамическими контурами (кривыми).

Диаграмма с динамическими контурами (кривыми).   
![Диаграмма с динамическими контурами (кривыми).](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/b2_335x227.png)

Та же диаграмма с контурами, загнутыми по часовой стрелке.

Та же диаграмма с контурами, загнутыми по часовой стрелке.

Та же диаграмма с контурами, загнутыми по часовой стрелке. ![Та же диаграмма с контурами, загнутыми по часовой стрелке.](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/bild7_337x292.png)

### Переключение значения контура

Значение контура представляет собой значение кривых, соединяющих узлы диаграммы, и их ширины. Выберите этот параметр, чтобы скрыть числовое значение каждой кривой. Чтобы скрыть значение, переместите влево кнопку ползунка в разделе Параметры &gt; Display edge value на панели свойств для выключения параметра.

### Настройка метки контура

Значение метки контура представляет собой числовое значение каждой кривой диаграммы. Можно изменить положение метки или скрыть ее.

* Скрыть значение метки контура: выберите этот параметр, чтобы скрыть метку контура в сетевой диаграмме. Переместите кнопку ползунка в разделе Параметры &gt; Display edge value на панели инструментов.

* Положение метки контура: данный параметр определяет местоположение для отображения значения контура на каждой кривой диаграммы, к примеру, сверху или снизу. Выберите соответствующий параметр меню.

### Настройка формы узла

Можно выбрать один из следующих вариантов формы узла: точка, квадрат, ромб или треугольник. Перейдите в раздел Параметры &gt; Node shape на панели свойств и выберите форму узла в меню.

### Переключение параметра отображения тени

С помощью данного параметра можно выключить отображение тени кривых и узлов диаграммы (служит для привлечения внимания к фону). Переместите кнопку ползунка в разделе Параметры &gt; Display shadow на панели инструментов.

### Сортировка

Если для сортировки установлен параметр «Авто», система применяет порядок сортировки по умолчанию (раздел панели свойств Сортировка &gt; выбранное измерение или мера) для всех измерений и мер. Для каждого измерения и меры по отдельности можно настроить порядок сортировки по выражению:

Выполните следующие действия.

1. Откройте меню измерения или меры в разделе Сортировка на панели свойств.
2. Переместите влево кнопку ползунка Сортировка для изменения параметра с «Авто» на «Пользовательский».
3. Установите флажок Сортировка по выражению.
4. Введите строку порядка в поле Выражение и нажмите «Ввод». Также изменить цвет можно с помощью выражения в редакторе выражения (the Выражение icon).
5. Для настройки порядка сортировки в меню ниже выберите параметр По возрастанию или По убыванию.

### Форматирование чисел

Значение меры можно форматировать. К одному и тому же значению можно применить разные параметры форматирования, к примеру, «Денежный», «Дата», «Длительность». Диаграмма обновляется в соответствии с выбранным форматом чисел.

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств и щелкните выбранную меру.
2. Выберите соответствующий формат чисел в меню Формат чисел.
3. Введите сведения в поля панели. Для отображения этих полей в ходе настройки диаграммы следует выбрать параметр, отличный от «Авто».

## Использование панели стиля для дополнительной настройки внешнего вида

В области Вид на панели свойств доступен ряд параметров для настройки стилей.

Щелкните the Стиль icon в области Вид &gt; Представление для дополнительной настройки стиля диаграммы. Чтобы сбросить стили, щелкните ![](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) рядом с каждым разделом. Нажмите кнопку ![](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg)Сбросить все, чтобы сбросить стили для всех доступных вкладок на панели стиля.

Для получения общих сведений о настройке стиля отдельной визуализации см. раздел [Применение пользовательского стиля к визуализации](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm).

### Настройка текста

Можно настроить текст для заголовка, подзаголовка и сноски на вкладке Вид &gt; Общие. Чтобы скрыть эти элементы, выключите параметр Показать заголовки.

Видимость различных меток на диаграмме зависит от настроек конкретной диаграммы и от параметров отображения меток. Их можно задать на панели свойств.

Можно настроить стиль текста, который отображается на диаграмме.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon.

3. На вкладке Общие настройте шрифт, стиль начертания, размер шрифта и цвет для следующих элементов:

   * Заголовок

   * Подзаголовок

   * Сноска

### Настройка фона

Можно настроить фон диаграммы. В качестве фона можно использовать цвет или изображение.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon .

3. На вкладке Общие панели стиля выберите цвет фона (основной цвет или выражение). Также можно выбрать фоновое изображение из библиотеки медиафайлов или указать URL-адрес изображения.

   При использовании цвета фона настройте непрозрачность фона с помощью ползунка.

   При использовании фонового изображения можно настроить размер и расположение изображения.

### Пользовательская настройка границы и тени

Можно настроить границу и тень диаграммы.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon.

3. На вкладке Общие панели стилей в области Граница настройте значение параметра Контур, чтобы сделать линию вокруг диаграммы более широкой или узкой.

4. Выберите цвет границы.

5. Настройте параметр Радиус закругления, чтобы управлять скруглением рамки.

6. В области Тень на вкладке Общие выберите размер и цвет тени. Выберите Нет, чтобы убрать тень.

## Ограничения

Для получения сведений об ограничениях общего характера см. [Ограничения](https://help.qlik.com/ru-RU/sense/November2024/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati).

* Отчеты Qlik NPrinting не поддерживают визуализации сетевых диаграмм.

* Максимальный размер набора данных, отображаемого в сетевой диаграмме, составляет 1400 строк. Если выбранный набор данных больше, узлы и ссылки могут быть опущены в диаграмме.

  Используйте меньший набор данных или используйте выборки, чтобы ограничить его объем.

СОПУТСТВУЮЩИЕ УЧЕБНЫЕ МАТЕРИАЛЫ:

* [Настройка сетевой диаграммы в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Network_chart)

## Подробнее

* [Настройка сетевой диаграммы в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Network_chart)