Расширение Trellis container

Расширение Trellis container (Матричный контейнер) можно использовать для отображения матричной диаграммы, созданной на базе основной визуализации. Матричная диаграмма отображает сетку одной и той же диаграммы для разных значений измерения. Матричную диаграмму можно использовать для сравнения показателей по разным группам данных.

A trellis chart container showing charts for retail sales for 8 different dimension values.

Матричная диаграмма, созданная на базе линейчатой диаграммы данных о продажах, представленных по разным категориям продуктов

Порядок создания матричной диаграммы

На редактируемом листе можно создать матричную диаграмму. Диаграмма, которую необходимо повторить с разными значениями измерения, должна быть основной визуализацией.

Выполните следующие действия.

  1. На панели ресурсов откройте Пользовательские объекты >Visualization bundle и перетащите объект Trellis container (Матричный контейнер) на лист.
  2. В меню Appearance (Вид) > Trellis options (Параметры матрицы) > Base visualization (Основная визуализация) на панели свойств выберите основную визуализацию для отображения.
  3. В меню Data (Данные) > Dimensions (Измерения) выберите измерение, которое необходимо использовать в качестве измерения сетки.

Отобразится сетка диаграмм, созданных на основе выбранного измерения сетки.

Поиск и устранение неисправностей

Сетка диаграмм не отображается, получено сообщение следующего содержания: Too many dimension values!

Possible cause  

Количество значений измерения превосходит максимальное допустимое количество диаграмм в сетке.

Proposed action  

В меню Appearance (Вид) > Trellis options (Параметры матрицы) > Maximum number of charts (Максимальное количество диаграмм) можно увеличить допустимое количество диаграмм.

Изменение вида диаграммы

Для настройки диаграммы можно использовать одну или несколько функций.

Настройка количества столбцов

В меню Appearance (Вид) > Trellis options (Параметры матрицы) > Number of columns (Количество столбцов) можно настроить количество столбцов сетки диаграммы.

Настройка диапазона оси Y для диаграмм

В меню Appearance (Вид) > Trellis options (Параметры матрицы) > Auto range (Автоматический диапазон) можно выбрать диапазон оси Y для диаграмм в составе матричной диаграммы.

  • Параметр On (Вкл.) служит для отображения одного и того же диапазона для всех диаграмм. Выберите его, если необходимо сравнить значения разных диаграмм.
  • Параметр Off (Выкл.) служит для отображения диапазона, оптимизированного для каждой диаграммы.

Режим слайда

Диаграммы можно просматривать в режиме не только сетки, но и слайда. Для этого в меню Appearance (Вид) > Trellis options (Параметры матрицы) > Slide mode (Режим слайда) выберите On (Вкл.). В режиме слайда одновременно можно просматривать только одну диаграмму. Между диаграммами можно переключаться.

Рекомендации по созданию основной визуализации

Ниже приведены советы по созданию эффективной основной визуализации для матричной диаграммы.

  • Отобразите заголовок основной визуализации. В матричной диаграмме заголовок заменяется значением измерения сетки каждой диаграммы.
  • В случае использования выражений: создайте метку, чтобы скрыть выражение множества.
  • В случае использования комбинированной диаграммы: используйте только одну ось и задайте минимальное и максимальное значения оси Y.
  • В случае использования блочной диаграммы: задайте минимальное и максимальное значения оси Y.
  • В случае использования точечной диаграммы: настройте ось X.
  • В случае использования карты: используйте расширенный режим, настройте цвет и заголовок слоя.

Использование расширенного режима

В расширенном режиме можно указать места для вставки анализа множеств и значений измерения в основную визуализацию. Для активации режима в меню Appearance (Вид) > Trellis options (Параметры матрицы) > Advanced mode (Расширенный режим) выберите параметр On (Вкл.).

В формулах основной визуализации можно использовать следующие заполнители. В матричной диаграмме они будут заменены соответствующими значениями:

Замена значений матричной диаграммы в расширенном режиме
Заполнитель Заменено значением
$(vDim) Dimension Name
$(vDimValue) Dimension Value
$(vDimSet) [Dimension Name]={'Dimension Value'}
$(vDimSetFull) {<[Dimension Name]={'Dimension Value'}>}

Ограничения

Для получения сведений об ограничениях общего характера см. Ограничения пакетов расширений, поставляемых Qlik.

Неподдерживаемые визуализации

Использование следующих визуализаций в матричной диаграмме не поддерживается:

  • Фильтр
  • Гистограмма

Визуализации мульти-КПЭ со встроенными основными визуализациями

Использование диаграмм мульти-КПЭ, содержащих встроенные основные визуализации, не поддерживается.