Расширение Heatmap chart

Тепловая диаграмма (Heatmap chart) служит для отображения сравнительных данных с представлением значений в виде цветовых шаблонов. Тепловая диаграмма позволяет наглядно представлять информацию путем объединения элементов из нескольких источников. Диаграмма входит в пакет Visualization Bundle.

Тепловая диаграмма поддерживает отображение больших объемов данных за счет замены значений цветными областями. Сжатый формат представления с цветовой маркировкой обеспечивает удобство восприятия данных.

Для тепловых диаграмм необходимо использовать два измерения и одну меру. Вторую меру использовать необязательно. Диаграмма отображается в табличной форме с маркированными цветом плитками. В столбце каждого измерения отображаются самое низкое и самое высокое значения. Находящиеся между ними значения раскрашены с использованием градиента цвета. Центральным является среднее значение.

Когда это следует использовать

Тепловую диаграмму рекомендуется использовать для сжатого визуального представления больших объемов сравнительных данных. Данные отображаются в виде удобных для восприятия цветовых шаблонов, за счет чего для их представления достаточно использовать одну диаграмму. Тепловую диаграмму также удобно использовать для следующих целей:

  • Сравнение показателей результативности деятельности компаний, рыночной конъюнктуры и эффективности инвестирования.
  • Сравнение разных подразделений компании с точки зрения эффективности.
  • Определение приоритетных направлений инвестирования и выявление проблемных областей.
  • Представление больших объемов статистических данных и наборов данных.
  • Исследование поведения пользователей на веб-сайтах.
  • Оценка и классификация местоположений, людей, показателей и должностей.

Создание тепловой диаграммы

На редактируемом листе можно создать тепловую диаграмму.

Выполните следующие действия.

  1. Из раздела панели ресурсов Пользовательские объекты > Visualization bundle перетащите объект Heatmap chart на лист.
  2. Нажмите верхнюю кнопку Добавить измерение и выберите измерение.
  3. Нажмите нижнюю кнопку Добавить измерение и выберите переменную второго измерения.
  4. Нажмите кнопку Добавить меру и выберите меру диаграммы.

После выбора измерений и меры отобразится тепловая диаграмма.

Examples:

A heatmap displaying results using colors only.

Тепловая диаграмма с цветовым представлением результатов.

A heatmap with grid layout, data, and labels.

Та же тепловая диаграмма выше с макетом сетки, данными и метками.

Изменение вида диаграммы

Использование инструмента выбора лассо

С помощью инструмента выбора лассо можно выполнить двухмерную выборку интересующей вас области. Для этого следует обвести область.

Контур исчезнет, и в выбранной области можно повторно провести контур.

Выполните следующие действия.

  1. Откройте тепловую диаграмму в основной области отображения. Если вы работаете в режиме изменения, щелкните Готово.
  2. Наведите курсор на плитку, щелкните и, удерживая кнопку мыши нажатой, обведите интересующую вас область диаграммы.
  3. Конечная точка контура должна совпадать с начальной. Диаграмма будет автоматически увеличена, отобразится только обведенная контуром область.

Examples:

Heatmap with border traced out with the lasso tool.

При помощи инструмента лассо область выделяется контуром зеленого цвета.

Heatmap showing a selection picked using lasso tool.

По завершении выборки в диаграмме будет отображена только увеличенная и обведенная контуром область.

Использование параметра выбора измерения

Для обоих измерений можно выбрать столбец или строку плиток. Для этого щелкните метку измерения или плитку для выбора двух измерений. По завершении выборки в диаграмме будет отображена только выбранная строка, столбец или плитка.

Изменение цветовой схемы

Цветовую схему диаграммы можно изменить путем выбора одного из четырех предопределенных параметров.

Выполните следующие действия.

  1. Щелкните Вид > Design на панели свойств.
  2. В разделе Цветовая схема выберите цветовую схему.

    The different colour gradients that can be used in heatmaps.
Тепловые диаграммы поддерживают использование градиентов цвета.

Изменение цвета метки

Метки представляют собой элементы текста или изображения, которые можно расположить в любом месте любой диаграммы. Настроить цвет метки можно в разделе Вид > Label color на панели свойств. Щелкните поле цвета метки и выберите цвет с помощью цветового круга с градиентом. Или щелкните символ мольберта под цветовым кругом и выберите цвет либо введите строку кода цвета в поле рядом с символом мольберта. Следует использовать допустимые CSS-цвета.

Переключение легенды

Легенда — это тонкая градиентная линия вверху диаграммы, представляющая собой расшифровку цветов. Чтобы скрыть легенду, переместите влево кнопку ползунка в разделе Вид > Design > Легенда на панели свойств для выключения параметра.

Настройка непрозрачности плитки

Для регулировки непрозрачности переместите кнопку ползунка непрозрачности плитки в разделе Вид > Design > Tile opacity на панели свойств. Если для параметра непрозрачности установлено значение 1, цвета отображаются без искажения, что упрощает различение плиток.

Использование среднего значения в шкале

Тепловая диаграмма поддерживает вычисление и отображение среднего значения набора данных. Это значение используется в качестве центрального значения цветовой шкалы. Эту функцию можно включить или выключить в разделе Вид > Параметры > Use mean in scale на панели свойств.

В поле среднего значения укажите значение шкалы по выражению. На основе этого значения система выбирает цветовой диапазон, соответствующий медианной цветовой шкале. Также можно вставить строку шкалы в выражение в редакторе выражения (Expression) в разделе Вид > Параметры > Mean scale value на панели свойств. Если среднее значение не используется, для параметра среднего значения шкалы следует установить значение 0.

Настройка фиксированной шкалы

Можно настроить определение фиксированной цветовой шкалы независимо от набора данных путем указания минимального, максимального и среднего значений. Для этого переместите вправо кнопку ползунка Fixed scales в разделе Вид > Параметры > Fixed scale на панели свойств. Затем укажите минимальное значение в поле Min scale value, максимальное значение в поле Max scale value и среднее значение в поле Mean scale value. Также можно вставить строку шкалы в выражение в редакторе выражения (Expression).

Переключение заголовков

Выберите этот параметр, чтобы скрыть имя тепловой диаграммы. Щелкните Вид > Общее на панели свойств и переместите кнопку ползунка Показать заголовки.

Изменение размера меток на осях диаграммы

Также можно настроить размер меток на осях X и Y диаграммы. Щелкните Вид на панели свойств и в полях Y-axis label size и X-axis label size укажите желаемые значения размера метки.

Ограничение значений измерения

Значения измерения можно ограничить. Перейдите в раздел Данные > Измерения на панели свойств. Щелкните измерение и в меню раздела Ограничение выберите ограничение.

Настройка минимального размера по горизонтали

Для тепловой диаграммы можно настроить минимальный размер отображения по горизонтали. Укажите желаемое значение размера в поле Вид > Параметры > Minimum horizontal size на панели свойств. Также можно вставить строку в выражение в редакторе выражения (Expression).

Форматирование чисел

Значение меры можно форматировать. К одному и тому же значению можно применить разные параметры форматирования, к примеру, «Денежный», «Дата», «Длительность». Диаграмма обновляется в соответствии с выбранным форматом чисел.

Выполните следующие действия.

  1. Щелкните Данные > Меры на панели свойств и щелкните меру.
  2.  Выберите соответствующий формат чисел в меню Формат чисел.
  3. Введите сведения в поля панели. Для отображения этих полей в ходе настройки диаграммы следует выбрать параметр, отличный от «Авто».

Ограничения

Для получения сведений об ограничениях общего характера см. Ограничения пакетов расширений, поставляемых Qlik.