Upgrade fails with message "Qlik Sense Superuser password validation failure"

When upgrading Qlik Sense 3.2 or earlier to June 2017 or later, the installation fails and you get the following error message: "Qlik Sense Superuser password validation failure". Despite using the correct password, you get the same error every time you attempt the upgrade.

Possible cause  

The upgrade failed because you entered an incorrect superuser or repository password during the first upgrade attempt.

Although you inserted an incorrect password, you were still able to create the PostgreSQL 9.6 version of the database, and the wrong password was registered in the settings. Therefore, later upgrade attempts will fail because the passwords in PostgreSQL 9.6 no longer match.

Proposed action  

Delete the c:\ProgramData\Qlik\Sense\Repository\PostgreSQL\9.6 folder and try running the upgrade procedure again. Make sure you enter the correct password.