Перейти к основному содержимому

Первый лист: Dashboard

Щелкните правой кнопкой мыши Dashboard, а затем выберите Открыть и редактировать, чтобы открыть первый лист. Лист пустой, но он будет оставаться таким недолго. Панель ресурсов, расположенная слева, содержит доступные диаграммы и поля. Щелкните Sheet (Диаграммы), чтобы приступить к добавлению диаграмм на лист. Справа расположена панель свойств.

Примечание: У панели ресурсов и панели свойств есть функция отображения/скрытия. Щелкните open right panel в правом нижнем углу для переключения между режимами отображения и скрытия панели свойств.

Создание визуализаций

Цель информационной панели — быстрый обзор текущего состояния дел. В центре внимания тренды продаж и цифры. Информационная панель не предназначена именно для исследования данных, но в ней, конечно, можно делать выборки и анализировать результаты.

Снимок для листа Dashboard показывает лист при редактировании. Перетащите диаграммы в центр области, где необходимо их разместить.

Слева находятся два фильтра: фильтр времени без имени и Region. Начните с этого.

Лист Dashboard во время редактирования
Dashboard sheet when editing

Добавление фильтров

Назначение фильтров — получить ограниченный набор данных, который можно анализировать и исследовать.

Выполните следующие действия.

  1. Перетащите фильтр на лист.

  2. На панели ресурсов слева щелкните open right panel для открытия раздела Поля.

  3. Для развертывания щелкните элемент Date в списке.

  4. Перетащите поле Year в центр фильтра, затем на панели свойств, расположенной справа, щелкните Arrow right , чтобы развернуть измерение и изменить его Заголовок на Year.
  5. Перетащите поле Quarter на фильтр, затем на панели свойств, расположенной справа, щелкните Arrow right , чтобы развернуть измерение и изменить его Заголовок на Quarter.
  6. Перетащите поле Month на фильтр, затем на панели свойств, расположенной справа, щелкните Arrow right , чтобы развернуть измерение и изменить его Заголовок на Month.
  7. Перетащите поле Week на фильтр, затем на панели свойств, расположенной справа, щелкните Arrow right , чтобы развернуть измерение и изменить его Заголовок на Week.
  8. Используйте метки-манипуляторы, чтобы изменить размер фильтра согласно снимку.

  9. Щелкните правой кнопкой мыши фильтр и выберите параметр Добавить к основным элементам.

  10. Введите имя Period и щелкните команду Добавить.

Вы создали фильтр и сохранили его как основной элемент. Это облегчит вам дальнейшее использование элементов.

Второй фильтр содержит только одно измерение Region.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы и перетащите фильтр на лист.

  2. Щелкните параметр Добавить измерение, прокрутите экран вниз и выберите поле Region.

  3. Используйте метки-манипуляторы, чтобы изменить размер фильтра согласно снимку.

  4. Щелкните правой кнопкой мыши фильтр и выберите параметр Добавить к основным элементам.

  5. Введите имя Region и щелкните команду Добавить.

Два фильтра завершены.

Добавление круговой диаграммы

Далее необходимо добавить круговую диаграмму.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы и перетащите круговую диаграмму на лист.

  2. Щелкните параметр Добавить измерение и добавьте поле Region.

  3. На панели ресурсов слева щелкните open right panel для открытия раздела Поля.

  4. Найдите поле Sales, щелкните его правой кнопкой мыши и выберите Создать меру.

  5. В диалоговом окне Создать новую меру в окне Выражение добавьте элемент Sum перед (Sales), чтобы создать меру Sum(Sales).

  6. Щелкните команду Создать.

    Мера будет добавлена как основной элемент.

  7. Перетащите новую меру Sales в центр круговой диаграммы.

  8. Справа на панели свойств щелкните Вид > Представление и выберите Круг.

  9. На панели свойств щелкните параметр Цвета и легенда.

  10. Для параметра Цвета установите значение Пользовательский и выберите в списке параметр По мере.

  11. В верхней части визуализации введите заголовок Sales per Region.

  12. Используйте метки-манипуляторы, чтобы изменить размер круговой диаграммы согласно снимку.

Круговая диаграмма кольца завершена. Цвета в круговой диаграмме представлены по мере, что означает, что чем выше значение, тем темнее цвет.

При раскрашивании значений существует много вариантов. Просто помните, что цвета должны служить определенной цели, а не просто вносить разнообразие в визуализацию.

Добавление линейчатой диаграммы

Следующая визуализация представляет собой линейчатую диаграмму с пятью главными клиентами.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы.

  2. Перетащите линейчатую диаграмму на лист. Поместите ее под круговой диаграммой.
  3. Щелкните параметр Добавить измерение, прокрутите экран вниз и выберите поле Customer.

  4. Щелкните параметр Добавить меру и в разделе Меры выберите элемент Sales.

  5. Справа на панели свойств в разделе Вид > Представление выберите Горизонт..

    Полоски отобразятся в горизонтальном направлении.

  6. На панели свойств в разделе Данные щелкните Customer, чтобы открыть измерение.

  7. В списке Ограничение выберите элемент Фиксированное число.

  8. По умолчанию отображается 10 верхних значений. Измените число на 5.

  9. Очистите выборку Показать другие.

  10. На панели свойств щелкните Вид > Представление и в поле Метки значений выберите Авто.
  11. На панели свойств щелкните элемент Вид > Ось Y: Customer.

  12. В разделе Метки и заголовок выберите параметр Только метки.

  13. Щелкните элемент Ось X: Sales.

  14. В разделе Метки и заголовок выберите параметр Только метки.

  15. В верхней части визуализации введите заголовок Top 5 Customers.

  16. Измените размер линейчатой диаграммы согласно снимку экрана.

Линейчатая диаграмма завершена. Вы создали линейчатую диаграмму с пятью главными клиентами. В случае выборок в других визуализациях эти клиенты изменятся соответственно.

Если бы выборка параметра Показать другие не была очищена, пятая полоска стала бы серой, суммируя все значения продаж, где отсутствует имя компании. Это значение может помочь понять количество продаж, которые нельзя отнести к определенной компании.

Добавление комбинированной диаграммы

Комбинированная диаграмма объединяет линейчатую диаграмму и линейный график. Она особенно полезна, если необходимо объединить значения, которые обычно трудно сочетать из-за различий в масштабе.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы.

  2. Перетащите комбинированную диаграмму на лист. Поместите ее под линейчатой диаграммой.
  3. На панели ресурсов слева щелкните open right panel для открытия раздела Поля.

  4. Щелкните Date.

  5. Перетащите поле YearMonth в комбинированную диаграмму и щелкните Добавить в верхней части.
  6. Щелкните параметр Добавить меру и в разделе Меры выберите элемент Sales.

  7. На панели ресурсов слева щелкните Linked Object , чтобы открыть Основные элементы.

  8. В разделе Меры щелкните параметр Создать.

  9. Скопируйте и вставьте следующую строку в окно Выражение

    (Sum(Sales) - Sum(Cost)) / Sum(Sales)

  10. Введите имя Margin Percent и щелкните команду Создать.

    Новая мера будет добавлена в список мер основных элементов.

  11. Перетащите меру Margin Percent в комбинированную диаграмму.

  12. Выберите Добавить Margin Percent > В виде линии.

  13. В верхней части визуализации введите заголовок Sales Trend.

  14. Измените размер комбинированной диаграммы согласно снимку экрана.

Комбинированная диаграмма готова. Две меры Sales и Margin Percent имеют по одной оси, что позволяет объединять два совершенно разных масштаба.

Первичная ось слева используется для меры Sales, а вторичная ось справа используется для меры Margin Percent.

Добавление ключевого показателя эффективности

Визуализация ключевого показателя эффективности показывает одно-два значения меры и используется для отслеживания выполнения работы. Цветовая кодировка и символы отображают отношение цифр к ожидаемым результатам.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы.

  2. Перетащите диаграмму ключевого показателя эффективности на лист. Поместите ее справа от круговой диаграммы.
  3. Щелкните параметр Добавить меру и в разделе Меры выберите элемент Sales.

    Сумма продаж будет добавлена к ключевому показателю эффективности.

  4. На панели свойств справа в разделе Вид > Цвет для параметра Условные цвета установите значение Вкл и щелкните Добавить предел.

  5. Щелкните левую часть полосы Значение и выберите красный Цвет и Символ Arrow down в диалоговом окне.

  6. Щелкните правую часть полосы Значение и выберите зеленый Цвет и Символ Arrow up в диалоговом окне.
  7. Перетащите предел значений вправо, чтобы в ключевом показателе эффективности отобразить значение продаж красным.
  8. На панели ресурсов слева щелкните Linked Object , чтобы открыть Основные элементы.

  9. Щелкните параметр Меры.
  10. Щелкните команду Создать и введите Sum(Margin) в окно Выражение.
  11. Введите имя Margin и щелкните команду Создать.

    Элемент Margin добавляется к мерам основного элемента.

  12. На панели свойств в разделе Данные > Меры щелкните Добавить и выберите Прибыль.

    Сумма прибыли будет добавлена к ключевому показателю эффективности.

  13. На панели свойств справа в разделе Вид > Цвет щелкните Второй.

  14. Установите предельное значение для параметра Прибыль, как это делали для параметра Продажи, но в этот раз перетащите предел значений влево, чтобы в ключевом показателе эффективности отобразить значение продаж зеленым.
  15. На панели свойств в разделе Вид > Представление в раскрывающемся списке выберите Выравнивание по левому краю.
  16. На панели свойств в разделе Вид > Представление установите для параметра Показать заголовок значение Вкл.
  17. В текстовом поле Заголовок введите следующее. 

    Всего продаж и прибыли

  18. Измените размер объекта ключевого показателя эффективности согласно снимку экрана.

При использовании Qlik Sense Desktop щелкните Сохранить.

Добавление ключевого показателя эффективности выполнено. Он показывает, что общий объем продаж ниже ожидаемого, но значение прибыли пока удовлетворительное.

Различные цвета и символы помогают интерпретировать значение. Красный предупреждает, а зеленый свидетельствует о том, что все в порядке.

Добавление датчика

Датчик используется для визуализации одиночной меры. Так же как в диаграмме текста и изображения, в датчике выборки не выполняются.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы.
  2. Перетащите диаграмму датчика на лист и поместите ее справа от визуализации ключевого показателя эффективности.

  3. Щелкните команду Добавить меру.

  4. Выберите меру Margin Percent.

  5. На панели свойств справа в разделе Данные > Измерения > Процент маржи > Форматирование числа выберите Число, а в появившемся списке Форматирование выберите значение 12%

  6. В разделе Вид > Представление выберите параметр Полоска, чтобы представить датчик в виде полосы.

  7. Для параметра Ориентация установите значение Пользовательский и выберите Горизонтальная.

  8. В разделе Пределы диапазона выше установите значение Мин на –0,5, а Макс на 0,5.

  9. В разделе Представление выберите параметр Использовать сегменты.

  10. Щелкните команду Добавить предел.

  11. В отображаемом текстовом поле введите значение 0,12, которое задает ограничение между левым и правым сегментами до 12%.

  12. Нажмите клавишу Enter.

  13. Щелкните левый сегмент и выберите красный цвет.

  14. Щелкните правый сегмент и выберите зеленый цвет.

  15. В самом низу панели свойств откройте параметр Ось меры.

  16. В разделе Метки и заголовок выберите параметр Только метки.

  17. В верхней части визуализации введите заголовок Profit Margin.

  18. Измените размер датчика согласно снимку экрана.

Создание датчика теперь завершено. Он должен отображать большую удельную прибыль.

Различные цвета датчика помогают интерпретировать значение. Красный предупреждает, а зеленый свидетельствует о том, что все в порядке.

Добавление линейного графика

Линейный график будет использоваться для отображения тренда квартальных продаж за период 2012–2014 гг. Цифры для 2014 года представлены за первую половину года.

Выполните следующие действия.

  1. На панели ресурсов слева щелкните Sheet , чтобы открыть Диаграммы.
  2. Перетащите линейный график на лист.
  3. На панели ресурсов слева щелкните open right panel для открытия раздела Поля.

  4. Щелкните Date.

  5. Перетащите поле Quarter в окно линейного графика и щелкните Добавить в верхней части.
  6. Щелкните Arrow right на панели свойств, расположенной справа, чтобы развернуть измерение Date.Quarter, и измените его Метку на Quarter.
  7. Щелкните параметр Добавить меру и выберите параметр Sales из списка Меры.
  8. На панели ресурсов слева щелкните open right panel для открытия раздела Поля.
  9. Щелкните Date.

  10. Перетащите поле Year в окно линейного графика и щелкните Добавить в верхней части.
  11. Щелкните Arrow right на панели свойств, расположенной справа, чтобы развернуть измерение Date.Year, и измените его Метку на Year.
  12. На панели свойств щелкните Вид > Представление и установите флажок Показать точки диаграммы.

  13. В верхней части визуализации введите заголовок Quarterly Trend.

Первый лист завершен. В правом верхнем углу щелкните Next , чтобы перейти к листу Product Details.