# Мастер встроенных данных

Диалоговое окно Мастер встроенных данных открывается следующим образом: меню Вставить, Оператор load, Load Inline. Он используется для создания операторов load inline в скрипте.

Содержимое этого диалогового окна напоминает таблицу и в большинстве случаев так же работает. Тем не менее, обратите внимание на то, что для вычисляемых формул в этой таблице не будут искаться численные выражения, как это делается, например, в Microsoft Excel.

Каждый столбец представляет поле, которое должно быть загружено в QlikView с помощью встроенной таблицы. Каждая строка является записью этой таблицы. Чтобы выбрать ячейку с данными, щелкните по ней. Затем в нее можно ввести или вставить значение из буфера обмена. Нажмите Enter или клавишу со стрелкой, чтобы принять значение и перейти в другую ячейку.

Верхняя строка (метка) оставляется для меток полей. Дважды щелкните ячейку метки, чтобы изменить ее. Если в строку метки не введено ни одно значение, будут использоваться имена полей F1, F2 и т. д.

## Меню «Изменить»

Меню Изменить содержит некоторые основные команды редактирования.

Команды в меню «Правка»

| Команда | Описание |
| --- | --- |
| Вставить столбец | Вставляет новый пустой столбец, если выбран один ли несколько столбцов. |
| Удалить столбец | Удаляет выбранные столбцы. |
| Вставить строку | Вставляет новую пустую строку, если выбрана одна или несколько строк. |
| Удалить строку | Удаляет выбранные строки. |

## Меню «Инструменты»

Меню Инструменты содержит команду Данные документа, которая открывает Мастер импорта данных документа, в котором можно вставить значения из любого существующего поля в документе. В этом диалоговом окне можно просмотреть число существующих в любом выбранном поле значений. Здесь также можно вставить все значения, выбранные значения или исключенные значения в мастер встроенных данных.

Нажмите ОК, чтобы закрыть диалоговое окно и создать оператор Load inline, отображающий содержимое сетки таблицы диалогового окна.