# Создание сетевых диаграмм

С помощью сетевой диаграммы (Сетевая диаграмма) можно перенести сеть связанных узлов и контуров из набора данных на лист. Сетевая диаграмма служит для представления потоков информации, взаимодействия компонентов и их местоположения в сети. Сетевая диаграмма входит в пакет Visualization Bundle. Для получения дополнительной информации см. раздел [Visualization bundle](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm).

На примере сетевой диаграммы, созданной на основе набора данных, показана связь разных аэропортов по всему миру. Диаграмма использует набор данных образца из раздела [Форматирование данных.](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/creating-network-diagram.htm#Formatti) Для начала необходимо сохранить набор данных образца в текстовый файл, создать новое приложение и загрузить набор данных образца.

Выполните следующие действия.

1. На панели ресурсов откройте Диаграммы.

2. В разделе Legacy перетащите объект Network chart на лист.

3. Нажмите верхнюю кнопку Добавить измерение и выберите Идентификатор в качестве идентификатора узла.

4. Нажмите вторую кнопку Добавить измерение и выберите Имя в качестве метки узла.

5. Нажмите третью кнопку Добавить измерение и выберите LinkTo (Связать с) в качестве родительского узла.

6. На панели свойств щелкните Данные. Нажмите кнопку Добавить в разделе Группа узла (Node group) и выберите Группа (Group) в качестве измерения группы.

7. В меню мер в разделе Подсказка нажмите кнопку Добавить и выберите Volume &gt; Sum(NodeVolume).

8. В разделе Размер узла (Node size) нажмите кнопку Добавить и выберите Volume &gt; Sum(NodeVolume).

9. В разделе Размер контура нажмите кнопку Добавить и выберите Volume &gt; Sum(Volume).

   Диаграмма примет следующий вид:

   ![Диаграмма с четырьмя измерениями и тремя мерами, динамическими контурами, узлами, представленными в виде точек, и значениями кривых.](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/ex_gen_networkchart.png)

## Изменение вида диаграммы

Для настройки диаграммы можно использовать одну или несколько функций.

### Настройка типа контура

Настроить форму кривой, соединяющей узлы диаграммы, можно на панели свойств Параметры &gt; Edge Type (Тип контура). Выберите в меню параметр формы кривых диаграммы.

Примеры:

Диаграмма с динамическими контурами (кривыми).

Диаграмма с динамическими контурами (кривыми).

Диаграмма с динамическими контурами (кривыми).   
![Диаграмма с динамическими контурами (кривыми).](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/b2_335x227.png)

Та же диаграмма с контурами, загнутыми по часовой стрелке.

Та же диаграмма с контурами, загнутыми по часовой стрелке.

Та же диаграмма с контурами, загнутыми по часовой стрелке. ![Та же диаграмма с контурами, загнутыми по часовой стрелке.](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/bild7_337x292.png)

### Переключение значения контура

Значение контура представляет собой значение кривых, соединяющих узлы диаграммы, и их ширины. Выберите этот параметр, чтобы скрыть числовое значение каждой кривой. Чтобы скрыть значение, переместите влево кнопку ползунка в разделе Параметры &gt; Display edge value на панели свойств для выключения параметра.

### Настройка метки контура

Значение метки контура представляет собой числовое значение каждой кривой диаграммы. Можно изменить положение метки или скрыть ее.

* Скрыть значение метки контура: выберите этот параметр, чтобы скрыть метку контура в сетевой диаграмме. Переместите кнопку ползунка в разделе Параметры &gt; Display edge value на панели инструментов.

* Положение метки контура: данный параметр определяет местоположение для отображения значения контура на каждой кривой диаграммы, к примеру, сверху или снизу. Выберите соответствующий параметр меню.

### Настройка формы узла

Можно выбрать один из следующих вариантов формы узла: точка, квадрат, ромб или треугольник. Перейдите в раздел Параметры &gt; Node shape на панели свойств и выберите форму узла в меню.

### Переключение параметра отображения тени

С помощью данного параметра можно выключить отображение тени кривых и узлов диаграммы (служит для привлечения внимания к фону). Переместите кнопку ползунка в разделе Параметры &gt; Display shadow на панели инструментов.

### Сортировка

Если для сортировки установлен параметр «Авто», система применяет порядок сортировки по умолчанию (раздел панели свойств Сортировка &gt; выбранное измерение или мера) для всех измерений и мер. Для каждого измерения и меры по отдельности можно настроить порядок сортировки по выражению:

Выполните следующие действия.

1. Откройте меню измерения или меры в разделе Сортировка на панели свойств.
2. Переместите влево кнопку ползунка Сортировка для изменения параметра с «Авто» на «Пользовательский».
3. Установите флажок Сортировка по выражению.
4. Введите строку порядка в поле Выражение и нажмите «Ввод». Также изменить цвет можно с помощью выражения в редакторе выражения (the Открыть редактор выражения icon).
5. Для настройки порядка сортировки в меню ниже выберите параметр По возрастанию или По убыванию.

### Формат чисел

Значение меры можно форматировать. К одному и тому же значению можно применить разные параметры форматирования, к примеру, «Денежный», «Дата», «Длительность». Диаграмма обновляется в соответствии с выбранным форматом чисел.

Выполните следующие действия.

1. Щелкните Данные &gt; Меры на панели свойств и щелкните выбранную меру.
2. Выберите соответствующий формат чисел в меню Формат чисел.
3. Введите сведения в поля панели. Для отображения этих полей в ходе настройки диаграммы следует выбрать параметр, отличный от «Авто».

## Использование панели стиля для дополнительной настройки внешнего вида

В области Вид на панели свойств доступен ряд параметров для настройки стилей.

Щелкните the Стиль icon в области Вид &gt; Представление для дополнительной настройки стиля диаграммы. Чтобы сбросить стили, щелкните ![Сброс](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) рядом с каждым разделом. Щелкните ![Сброс](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Icons/reset.svg) Сбросить все, чтобы сбросить стили для всех доступных вкладок на панели стиля.

Для получения общих сведений о настройке стиля отдельной визуализации см. раздел [Применение пользовательского стиля к визуализации](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Visualizations/style-visualization.htm).

### Настройка текста

Можно настроить текст для заголовка, подзаголовка и сноски на вкладке Вид &gt; Общие. Чтобы скрыть эти элементы, выключите параметр Показать заголовки.

Видимость различных меток на диаграмме зависит от настроек конкретной диаграммы и от параметров отображения меток. Их можно задать на панели свойств.

Можно настроить стиль текста, который отображается на диаграмме.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon.

3. На вкладке Общие настройте шрифт, стиль начертания, размер шрифта и цвет для следующих элементов:

   * Заголовок

   * Подзаголовок

   * Сноска

### Настройка фона

Можно настроить фон диаграммы. В качестве фона можно использовать цвет или изображение.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon .

3. На вкладке Общие панели стиля выберите цвет фона (основной цвет или выражение). Также можно выбрать фоновое изображение из библиотеки медиафайлов или указать URL-адрес изображения.

   Примечание к информации

   Чтобы добавить фоновое изображение из URL-адреса, источник необходимо добавить в список разрешенных в политике безопасности содержимого клиента. Добавьте источник с помощью директивы img-src. Это делает администратор в центре активности Администрирование.

   Для получения дополнительной информации см. раздел [Создание записи CSP](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Admin/mc-administer-content-security-policy.htm#AddEntry).

   При использовании цвета фона настройте непрозрачность фона с помощью ползунка.

   При использовании фонового изображения можно настроить размер и расположение изображения.

### Пользовательская настройка границы и тени

Можно настроить границу и тень диаграммы.

Выполните следующие действия.

1. На панели свойств разверните раздел Вид.

2. Выберите Вид &gt; Представление и щелкните the Стиль icon.

3. На вкладке Общие панели стилей в области Граница настройте значение параметра Контур, чтобы сделать линию вокруг диаграммы более широкой или узкой.

4. Выберите цвет границы.

5. Настройте параметр Радиус закругления, чтобы управлять скруглением рамки.

6. В области Тень на вкладке Общие выберите размер и цвет тени. Выберите Нет, чтобы убрать тень.

Связанные учебные материалы:

* [Настройка сетевой диаграммы в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Network_chart)

## Подробнее

* [Настройка сетевой диаграммы в Visualization Bundle](https://help.qlik.com/lnk/How_configure_Visualization_Bundle_Network_chart)