# Третий лист: Customer Details

На третьем листе вы добавите точечный график и сводную таблицу, с данными о клиентах. Затем вы добавите фильтры, чтобы фильтровать данные по дате и менеджеру.

[The third sheet: Customer details](https://play.vidyard.com/oVnN7oTMJuWPqNBxHDuafQ)

К настоящему времени у вас уже так много опыта в создании измерений, мер и визуализаций, что вам больше не нужны подробные процедуры. Если вам нужно вспомнить пройденный материал, вы можете вернуться к предыдущим темам.

Готовый лист Customer Details

Готовый лист Customer Details

Готовый лист Customer DetailsCustomer Details ![Лист Customer Details после завершения настройки](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/ui_gen_CustomerDetailsSheetFinal.png)

Вы начнете работу в режиме редактирования.

## Добавление точечной диаграммы

Следующая визуализация — это точечная диаграмма, показывающая Продажи и Количество Клиентов.

Точечная диаграмма используется для визуализации связей между двумя или тремя мерами.

Для получения дополнительной информации см. раздел [Точечная диаграмма](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Visualizations/ScatterPlot/scatter-plot.htm).

В этом случае сравниваются меры Sales и Quantity. Каждый пузырек представляет значение измерения Customer.

Выполните следующие действия.

1. На панели ресурсов нажмите Поля, затем правой кнопкой мыши нажмите на Sales Qty и выберите Создать меру.

2. В диалоговом окне Создать новую меру, в поле Имя введите Quantity.

3. Под Выражение, введите Sum(Sales Qty).

4. Нажмите Создать.

   Мера будет добавлена как основной элемент.

5. Перейдите в Диаграммы, и в разделе Визуализации перетащите точечную диаграмму на лист.

6. Перейдите в Поля и перетащите Customer поле на точечную диаграмму и добавьте его в качестве измерения.

7. Перейдите в Элементы-шаблоны и добавьте Sales и Quantity в качестве мер.

8. На панели свойств, перейдите в Вид &gt; Представление. Как по ось X, так и по ось Y:

   1. Установите Диапазон на Пользовательский.

   2. Установите Мин на 0.

   Отрицательные значения будут удалены.

9. Присвойте точечной диаграмме название: Продажи и объем продаж по клиентам.

## Добавление сводной таблицы Customer KPIs

В сводной таблице измерения и меры представлены в виде строк и столбцов в таблице. В сводной таблице можно анализировать данные при помощи нескольких мер и в нескольких измерениях одновременно.

Для изменения режима представления данных можно изменить порядок мер и измерений. Перемещение мер и измерений поочередно между строками и столбцами называется «сведение».

Одним из преимуществ сводной таблицы является взаимозаменяемость, то есть возможность перемещать элементы строк в столбцы, а элементы столбцов в строки. Такая гибкость очень полезна. Она позволяет менять порядок данных и отображать один набор данных в нескольких разных представлениях.

В зависимости от того, на чем необходимо сконцентрировать внимание, можно перемещать измерения и меры, чтобы выдвинуть вперед интересующие данные, а также скрыть данные, которые слишком детализированы либо не имеют отношения к анализу.

Для получения дополнительной информации см. раздел [Сводная таблица](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Visualizations/PivotTable/pivot-table.htm).

Выполните следующие действия.

1. На панели ресурсов перейдите в раздел Диаграммы.

2. В разделе Визуализации перетащите сводную таблицу в область под предыдущей диаграммой.

3. Перейдите в Поля и добавьте Customer в качестве измерения.

4. В разделе Основные элементы добавьте Sales и Quantity в качестве мер, перетащив их оба в сводную таблицу.

5. Присвойте сводной таблице заголовок: Customer KPIs.

Теперь у вас есть очень простая сводная таблица.

### Настройка форматирования мер

Далее вы отформатируете номера мер.

Выполните следующие действия.

1. Выберите Данные &gt; Меры.

2. Нажмите Sum (Sales) и отключите Форматирование главной меры. Установите следующее:

   * параметру Формат чисел значение Денежный;

   * параметру Метка значение Продажи.

3. Нажмите Quantity и отключите Форматирование главной меры. Установите следующее:

   * задайте параметру Формат чисел значение Числовой (1,000).

   * параметру Метка значение Количество.

### Добавление мер с выражениями в сводную таблицу

Далее вы добавите несколько более сложных мер в виде выражений. Вы создадите следующие меры:

* Margin Percent

* # of Invoices

* Average Sales per Invoice

Выполните следующие действия.

1. Выберите сводную таблицу.

2. Выберите Данные &gt; Меры.

3. Чтобы создать Margin Percent меру:

   1. Нажмите Добавить и нажмите the Выражение icon. Вставьте это выражение:

      ```
      (Sum(Sales) - Sum(Cost)) / Sum(Sales)
      ```

   2. Щелкните Применить.

   3. В разделе Метка введите: Margin Percent.

   4. Задайте параметру Формат чисел значение Числовой (12.3%).

4. Чтобы создать # of Invoices меру:

   1. Нажмите Добавить и нажмите the Выражение icon. Вставьте это выражение:

      ```
      Count (Distinct [Invoice Number])
      ```

   2. Щелкните Применить.

   3. В разделе Метка введите: # of Invoices.

5. Чтобы создать Average Sales per Invoice меру:

   1. Нажмите Добавить и нажмите the Выражение icon. Вставьте это выражение:

      ```
      Sum(Sales)/Count(Distinct [Invoice Number])
      ```

   2. Щелкните Применить.

   3. В разделе Метка введите: Average Sales per Invoice.

   4. Задайте параметру Формат чисел значение Денежный.

Примечание к подсказке

Классификатор Distinct используется в двух выражениях. С помощью классификатора Distinct номер накладной учитывается только один раз, даже если он встречается в источнике данных несколько раз. Классификатор Distinct отсортировывает уникальные числа. Обратите внимание, после классификатора Distinct перед именем поля должен стоять пробел.

### Добавление дополнительных измерений в виде строк

Выполните следующие действия.

1. Выберите Данные &gt; Измерения. В разделе Строка щелкните Добавить.
2. В списке выберите элемент Product Group.
3. Еще раз выберите Добавить и добавьте строку Product Type.

Теперь можно просматривать продажи отдельных клиентов по группе продукта и типу. Щелкните Клиент, Группа товаров или Тип продукта либо выберите отдельные элементы в таблице, отфильтруйте выборки, отображаемые в таблице. Для отображения данных в разных представлениях переместите элемент Группа продукта или Тип продукта в поле Меры и примените фильтрацию.

## Добавление фильтров

Теперь вы добавите фильтры, чтобы фильтровать данные по периоду и менеджеру.

Выполните следующие действия.

1. Добавьте фильтр Period.
2. Добавьте новый фильтр с измерением Manager.

Этот лист готов. На панели ресурсов щелкните Листы и выберите Customer Location, чтобы перейти к этому листу.

Связанные учебные материалы:

* [Использование вида редактирования листа по умолчанию в облаке](https://help.qlik.com/lnk/Using_default_sheet_editing_Cloud)

## Подробнее

* [Использование вида редактирования листа по умолчанию в облаке](https://help.qlik.com/lnk/Using_default_sheet_editing_Cloud)