# Пример: построение листа

В этом примере показано, как быстро построить лист. Если требуется воспроизвести пример, базовое приложение и используемые данные доступны в руководстве по бизнес-логике. Руководство по бизнес-логике см. в [Учебное пособие — настройка интерпретации данных в Инструмент «Наблюдения»](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/BusinessLogic/Tutorial/tutorial-customizing-insight-advisor.htm).

Режим редактирования листа позволяет быстро разрабатывать полезные визуализации. Создавая лист, нужно иметь представление о том, какая информация должна отображаться. В этом случае из приложения Учебное пособие — Бизнес-логика мы хотим создать лист, который позволит нам исследовать продажи в разные моменты времени. На этом листе должны отображаться следующие данные:

* Географическое представление продаж по странам и городам.

* Валовая прибыль отдела продаж.

* Данные о продажах сотрудников.

* Разбивка конкретных продуктов и категорий.

* Фильтр, с помощью которого пользователи могут фильтровать данные по годам, кварталам, месяцам и неделям.

Пример листа

Пример листа

Пример листа ![Изображение готового листа, верхний ряд которого содержит линейчатую диаграмму, карту и фильтр, а нижний ряд — таблицу и карту дерева.](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Sheets/ui_sheet-example-rev.png)

## Создание первой визуализации

Для первой визуализации мы построим линейчатую диаграмму.

Выполните следующие действия.

1. В приложении Учебное пособие — Бизнес-логика создайте новый лист.

   Примечание к информации

   Средство выбора шаблонов листов может открыться при создании нового листа. Шаблоны листов не используются в этом примере, поэтому вы можете закрыть окно или нажать Создать без шаблона.

   Чтобы узнать больше о том, как использовать шаблоны листов, см. [Создание листов с использованием шаблонов](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Sense_Hub/Sheets/sheet-templates.htm).

2. В Ресурсах откройте Диаграммы.

3. В разделе Визуализации перетащите линейчатую диаграмму на лист.

4. В разделе Ресурсы вкладки Поля перетащите элемент SalesOffice на линейчатую диаграмму и выберите Добавить SalesOffice.

5. Из раздела Ресурсы вкладки Поля перетащите элемент Валовая прибыль на линейчатую диаграмму и выберите Добавить меру &gt; Sum([Gross Profit]).

6. На панели свойств нажмите Сортировка.

7. Перетащите элемент Sum([Gross Profit]) в верхнюю часть списка сортировки.

8. Нажмите Вид &gt; Представление.

9. Выберите Горизонтальное.

10. На панели свойств нажмите раздел Вид &gt; Цвета и легенда.

11. В разделе Цвета выберите пункт Пользовательский.

12. Выберите По измерению.

    Первая визуализация

    Первая визуализация

    Первая визуализация ![Завершенная линейчатая диаграмма](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Sheets/ui_sheet-example1rev.png)

## Добавление карты

Создав гистограмму, мы можем затем создать карту, на которой отображаются как страны, так и города.

Выполните следующие действия.

1. В Ресурсах откройте Диаграммы.

2. В разделе Визуализации перетащите карту на лист.

3. На панели свойств нажмите Слои &gt; Добавить слой.

4. Выберите Слой области.

5. В разделе Измерения щелкните Добавить и выберите Страна.

6. В разделе Цвета выберите Пользовательский, щелкните По мере и раскрасьте по Avg(Sales).

7. Щелкните the Назад icon, чтобы вернуться в раздел Слои.

8. Щелкните Добавить слой и выберите Слой точек.

9. В разделе Измерения щелкните Добавить и выберите Город.

10. В разделе Цвета выберите Пользовательский, щелкните По мере и раскрасьте по Sum(Sales).

11. В разделе Цветовая схема выберите Расходящиеся классы.

    Лист с картой

    Лист с картой

    Лист с картой ![](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Sheets/ui_sheet-example3rev2.png)

## Добавление фильтра и изменение организации строки

Далее мы добавим фильтр, чтобы иметь возможность исследовать данные в визуализациях за определенные периоды времени. Мы также изменим организацию строки визуализаций.

Выполните следующие действия.

1. В Ресурсах откройте Диаграммы.

2. В разделе Визуализации перетащите фильтр справа от карты.

3. Нажмите Добавить измерение &gt; OrderDate &gt; Year.

4. Нажмите OrderDate.autoCalendar.Year и в поле Заголовок введите Year.

5. На панели свойств нажмите Добавить поле &gt; OrderDate &gt; Quarter.

6. Нажмите OrderDate.autoCalendar.Quarter и в поле Заголовок введите Quarter.

7. Нажмите Добавить поле &gt; OrderDate &gt; Month.

8. Нажмите OrderDate.autoCalendar.Month и в поле Заголовок введите Month.

9. Нажмите Добавить поле &gt; OrderDate &gt; Week.

10. Нажмите OrderDate.autoCalendar.Week и в поле Заголовок введите Week.

11. Нажмите и перетащите границы карты и панель фильтров, чтобы изменить их размер.

    Добавление фильтра

    Добавление фильтра

    Добавление фильтра ![Лист с картой и фильтром с измененным размером.](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Sheets/ui_sheet-example3rev3.png)

## Добавление новой строки с таблицей

Мы добавим новую строку визуализаций под текущей строкой, начиная с таблицы.

Отфильтрованная таблица

Отфильтрованная таблица

Отфильтрованная таблица ![Лист с заполненной таблицей.](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Sheets/ui_sheet-example4rev2.png)

Выполните следующие действия.

1. В Ресурсах откройте Диаграммы.

2. В разделе Визуализации перетащите Прямую таблицу на лист.

3. Нажмите Добавить столбцы &gt; Поля и основные элементы.

4. В разделе Измерения выберите EmployeeName.

5. В разделе Ресурсы перетащите элемент SalesOffice в таблицу и выберите Добавить "SalesOffice".

6. В разделе Ресурсы перетащите элемент Продажи в таблицу и выберите Добавить измерение &gt; Avg(Sales).

7. Выберите Avg(Sales) и в поле Формат чисел выберите Денежный.

8. В разделе Образец формата введите $ #,##0.00;-$ #,##0.00.

9. В разделе Ресурсы перетащите элемент Продажи в таблицу и выберите Добавить измерение &gt; Sum(Sales).

10. Выберите Sum(Sales) и в поле Формат чисел выберите Денежный.

11. В поле Формат чисел выберите Денежный.

12. В разделе Образец формата введите $ #,##0.00;-$ #,##0.00.

13. На панели свойств в разделе Данные вкладки Фильтрынажмите the Открыть меню "Добавить ресурс данных" icon &gt; Поля.

14. На панели свойств в разделе Данные вкладки Фильтрынажмите the Открыть меню "Добавить ресурс данных" icon &gt; Поля.

15. Выберите Sales и нажмите Добавить.

16. Нажмите на новый фильтр, чтобы вывести его свойства.

17. Выберите тип фильтра Условие.

18. Выберите Сравнить.

19. Под условием щелкните &gt; и выберите Фиксированное значение.

20. В поле Больше введите 0.

## Добавление карты дерева

Теперь мы добавим карту дерева, чтобы иметь возможность исследовать как категории продуктов, так и продукты в этих категориях.

Создать карту дерева

Создать карту дерева

Создать карту дерева ![Заполненный лист с картой дерева](https://help.qlik.com/ru-RU/cloud-services/Subsystems/Hub/Content/Resources/Images/Sheets/ui_sheet-example5rev.png)

Выполните следующие действия.

1. В Ресурсы откройте Диаграммы.

2. В разделе Визуализации перетащите древовидную карту на лист.

3. На панели свойств в разделе Данные вкладки Измерения нажмите Добавить &gt; CategoryName.

4. Нажмите Добавить &gt; ProductName

5. В разделе Меры нажмите Добавить меру &gt; Sum([Gross Profit]).

6. Нажмите и перетащите на границы таблицы и карты дерева.