Gráfico de mapa de calor

Um gráfico de mapa de calor (Gráfico de mapa de calor) exibe dados comparativos em que os valores são representados como padrões de cores em um gráfico. A criação de um mapa de calor ajuda a transmitir informações instantaneamente, combinando elementos de várias fontes em uma. Isso está incluído no pacote de Visualização.

Um mapa de calor pode exibir grandes quantidades de dados em sua totalidade, porque os valores são substituídos por cores. Esse formato condensado codificado por cores fornece uma visão geral de dados fácil de entender.

Gráficos de calor requerem duas dimensões e uma medida. Uma segunda medida é opcional. O gráfico é exibido em um formato tabular com blocos codificados por cores. Os valores mais altos e mais baixos são exibidos em cada coluna de dimensão. Os valores intermediários são mostrados em um gradiente de cores, centralizado na média.

Quando usar

Um gráfico de mapa de calor exibe um resumo visual de grandes quantidades de dados comparativos. As informações são apresentadas em padrões de cores e são comunicadas quase instantaneamente em um único gráfico. Um mapa de calor também é útil ao:

  • Comparar o desempenho entre empresas, mercados ou investimentos.
  • Identificar o nível de desempenho entre os departamentos de uma empresa.
  • Definir prioridades de investimento e destacar áreas de preocupação.
  • Apresentar amplos dados estatísticos e conjuntos de dados.
  • Medir a interação do usuário com sites.
  • Classificar e categorizar lugares, pessoas, desempenhos ou empregos.

Criando um gráfico de mapa de calor

Você pode criar um gráfico de mapa de calor na pasta que estiver editando.

Faça o seguinte:

  1. No painel de ativos, em Objetos personalizados > Visualization bundle, arraste um objeto do Heatmap chart até a pasta.
  2. Clique no botão superior Adicionar dimensão e selecione a dimensão.
  3. Clique no botão inferior Adicionar dimensão e selecione uma segunda variável de dimensão.
  4. Clique no botão Adicionar medida para selecionar a medida do gráfico.

Depois que dimensões e uma medida forem selecionadas, o gráfico de mapa de calor será exibido.

Examples:

A heatmap displaying results using colors only.

Um mapa de calor exibindo resultados usando somente cores.

A heatmap with grid layout, data, and labels.

O mesmo mapa de calor acima, com layout com grade, dados e rótulos.

Alterando a aparência do gráfico

Usando a ferramenta de seleção de laço

A ferramenta de seleção de laço permite fazer uma seleção bidimensional de uma área específica que você deseja examinar mais de perto, traçando uma borda em torno dela.

Esse esboço desaparece, e você pode traçar outro laço na área desejada.

Faça o seguinte:

  1. Abra seu mapa de calor no campo de exibição principal. Se você estiver trabalhando no modo de edição, clique em Concluído.
  2. Clique no cursor em um bloco e, enquanto pressiona o botão do mouse para baixo, contorne a área do gráfico que você deseja examinar mais de perto.
  3. Finalize seu esboço onde começou. O gráfico aumentará automaticamente o zoom e exibirá apenas a área contornada.

Examples:

Heatmap with border traced out with the lasso tool.

Uma borda é traçada ao redor de uma área usando a ferramenta de laço, colorindo-a de verde.

Heatmap showing a selection picked using lasso tool.

Quando a seleção estiver concluída, somente a área destacada com zoom será exibida no gráfico.

Usando a opção de seleção de dimensão

Você pode selecionar uma coluna ou linha de blocos para qualquer dimensão, clicando no rótulo de dimensão, ou em uma seleção de duas dimensões, clicando em um bloco. Após a seleção, apenas a linha, coluna ou bloco escolhido é exibido no gráfico.

Alterando o esquema de cores

Você pode alterar o esquema de cores do gráfico escolhendo entre quatro opções predefinidas.

Faça o seguinte:

  1. Clique em Aparência > Design no painel de propriedades.
  2. Selecione um esquema de cores em Esquema de cores.

    The different colour gradients that can be used in heatmaps.
Os diferentes gradientes de cor que podem ser usados em mapas de calor.

Alterando as cores dos rótulos

Rótulos são elementos de texto ou imagem que podem ser colocados em qualquer lugar em qualquer gráfico. Você pode definir sua própria cor de rótulo em Aparência > Cor do rótulo no painel de propriedades. Clique na caixa de cores do rótulo e selecione uma cor no círculo de cores do gradiente. Você também pode clicar no símbolo de cavalete no círculo colorido e selecionar a cor ou inserir uma cadeia de código de cores no campo ao lado do símbolo de cavalete. As cores devem ser cores CSS válidas.

Alternando a legenda

A legenda fornece uma linha gradiente fina de descrição de cores na parte superior do gráfico. Para ocultar a legenda, mova o botão deslizante em Aparência > Design > Legenda no painel de propriedades para a esquerda para desativar a opção.

Ajustando a opacidade de bloco

Você pode ajustar a opacidade de bloco movendo o botão deslizante do controle deslizante de opacidade de bloco em Aparência > Design > Opacidade de bloco no painel de propriedades. Definir a opacidade como 1 permite que a configuração mostre as cores claramente, dando aos blocos uma aparência individualmente mais distinta.

Usando uma média na escala

Em um mapa de calor, você pode calcular e exibir a média do conjunto de dados. Ela é usada como valor médio em uma escala de cores. Você pode ativar ou desativar esse recurso em Aparência > Opções > Usar média na escala no painel de propriedades.

Digite um valor de escala por expressão para o valor médio. Isso permite que o sistema escolha o intervalo de cores que define uma escala de cores mediana. Você também pode inserir uma cadeia de escala na expressão no Editor de expressões (Expression) em Aparência > Opções > Valor de escala média no painel de propriedades. Quando nenhuma média é usada, o valor de escala média deve ser definido como 0.

Definindo uma escala fixa

Você pode configurar valores mínimos, máximos e médios para definir uma escala de cores fixa independente de um conjunto de dados. Para fazer isso, mova o botão deslizante Escalas fixas para a direita em Aparência > Opções > Escala fixa no painel de propriedades. Em seguida, insira um valor mínimo em Valor mínimo de escala e um valor máximo em Valor máximo de escala e um valor médio em Valor médio de escala. Você também pode inserir uma cadeia de escala na expressão no Editor de expressões (Expression).

Alternando títulos

Esta opção oculta o nome do gráfico de mapa de calor. Clique em Aparência > Geral no painel de propriedades e alterne o botão deslizante Mostrar títulos.

Alterando os tamanhos dos rótulos nos eixos do gráfico

Você também pode personalizar o tamanho dos rótulos no eixo y e no eixo x do gráfico. Clique em Aparência no painel de propriedades e insira o tamanho do rotulo que você deseja em Tamanho do rótulo do eixo y e em Tamanho do rótulo do eixo x.

Limitando os valores de dimensão

Você pode limitar seus valores de dimensão. Acesse Dados > Dimensões no painel de propriedades. Clique em dimensão e, em Limitação, escolha uma limitação no menu.

Definindo o tamanho horizontal mínimo

Em um mapa de calor, você insere um tamanho mínimo de como o gráfico é exibido horizontalmente. Insira o tamanho desejado em Aparência > Opções > Tamanho horizontal mínimo no painel de propriedades. Você também pode inserir uma cadeia na expressão no Editor de expressões (Expression).

Formato numérico

É possível formatar o valor da medida. Formatação diferente pode ser aplicada ao mesmo valor, por exemplo, dinheiro, data, duração. O gráfico é atualizado para refletir o tipo de número alterado.

Faça o seguinte:

  1. Clique em Dados > Medidas no painel de propriedades e clique em uma medida.
  2. Selecione a formatação de número aplicável no menu Formato numérico.
  3. Insira detalhes nos campos do painel. Eles são exibidos ao escolher uma opção diferente de Automático ao configurar o gráfico.

Limitações

Para obter informações sobre limitações gerais, consulte Limitações dos pacotes de objetos fornecidos pela Qlik.