# Personalizando seus KPIs

Com o gráfico de KPI múltiplo (KPI múltiplo), os valores e medidas podem ser personalizados usando uma ou mais configurações condicionais. Você pode adicionar vários KPIs juntos, agrupá-los e vinculá-los a diferentes pastas. Os valores de KPI também podem ser personalizados independentemente, diferenciando-os com uma ou mais propriedades CSS, como cor de texto, fontes, tamanhos, ícones, rótulos e gráficos.

Nota informativa

O KPI múltiplo não estará mais disponível no painel de ativos para a criação de novos gráficos a partir de 5 de abril de 2025 no Qlik Cloud e na versão May 2025 do Qlik Sense Client-Managed. Ele ainda funcionará nos painéis em que foi adicionado anteriormente, mas será totalmente removido em maio de 2026 para o Qlik Cloud e na versão May 2026 do Qlik Sense Client-Managed.

Para obter recomendações sobre a substituição da funcionalidade, consulte [Gráfico de KPI múltiplo](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/multi-KPI.htm).

Os valores de KPI também podem ser personalizados independentemente, diferenciando-os com uma ou mais propriedades CSS, como cor de texto, cor de fundo, fontes, tamanhos, ícones, rótulos e gráficos.

Valores de KPI usando ícones, diferentes cores, fontes, visualizações mestre

Valores de KPI usando ícones, diferentes cores, fontes, visualizações mestre

Valores de KPI usando ícones, diferentes cores, fontes, visualizações mestre ![Valores de KPI usando ícones, diferentes cores, fontes, visualizações mestre](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/info1_701x117.png)

## Colorindo um KPI múltiplo

A opção de cor permite que todos os valores de KPI (medidas e rótulos) sejam diferenciados por cores. Você pode alterar as cores do texto, os ícones e a cor de fundo. As cores devem ser cores CSS válidas.

Você pode escolher entre as seguintes opções:

* A paleta de cores com um conjunto de cores predefinidas.
* O círculo de cores (clique no símbolo de cavalete na paleta de cores e escolha individualmente).
* Insira uma cadeia de código de cores no campo ao lado do símbolo de cavalete.

### Alterar uma cor de medida/rótulo

Faça o seguinte:

1. Clique em Data &gt; Measures no painel de propriedades.

2. Clique na medida aplicável e selecione para colorir o valor (Cor de valor) ou o rótulo (Cor de rótulo).

3. Selecione a cor na paleta de cores que se abre.

   ![Painel de seleção de cores de KPI](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/color50_680x243.png)

### Alterar a cor de fundo

Faça o seguinte:

1. Você também pode definir sua própria cor clicando no símbolo de cavalete na paleta de cores e selecionar a cor ou inserir uma cadeia de código de cores no campo ao lado do símbolo de cavalete. As cores devem ser cores CSS válidas.

2. Clique em Appearance &gt; Styles no painel de propriedades.

3. Clique na caixa Cor de fundo.

4. Selecione a cor na paleta de cores que se abre, e o gráfico é atualizado.

## Alterando os tamanhos de um KPI múltiplo

O tamanho das dimensões, medidas, rótulos e ícones pode ser configurado usando tamanhos predefinidos disponíveis em um menu suspenso:

* Rótulos de dimensão: selecione o tamanho dos rótulos no menu suspenso em Aparência &gt; Dimensões &gt; Tamanho no painel de propriedades.
* Rótulos de medida: todas as medidas podem ter tamanhos individuais.

Faça o seguinte:

1. Selecione o tamanho das medidas no painel de propriedades em Data &gt; Measures.
2. Selecione a medida e clique na caixa Substituir parâmetros.
3. Insira o tipo de rótulo como uma cadeia ou na expressão em Rótulo e selecione o tamanho entre as opções no menu suspenso em Tamanho.

Ícones: todos os ícones podem ser diferenciados aplicando cores diferentes.

Faça o seguinte:

1. Acesse Dados &gt; Medidas no painel de propriedades.
2. Selecione a medida e escolha o ícone na opção de ícone.
3. Em seguida, escolha o tamanho do ícone no menu suspenso em Ícone.

## Alterando as fontes de um KPI múltiplo

Você pode alterar a família de fontes de todos os rótulos se acessar Data &gt; Measures no painel de propriedades e selecionar a medida aplicável. Em Estilo de fonte, insira uma cadeia de rótulo e pressione Enter.

Você também pode alterar a fonte usando uma expressão no Editor de expressões (the Expressão icon) ou pode aplicar propriedades CSS de fontes individuais inseridas por meio de Aparência &gt; Estilos &gt; Estilos (CSS) no painel de propriedades.

## Alterando ícones

Você pode definir um ícone predefinido para representar um valor e/ou rótulo selecionando no conjunto de ícones. Os ícones podem ser mais personalizados diferenciando-os com as opções de cores, fontes, rótulos e tamanhos.

Faça o seguinte:

1. Clique em Data &gt; Measures no painel de propriedades.

2. Marque a caixa Selecionar ícone e clique no ícone aplicável do conjunto de ícones que se abre.

   ![Painel de conjunto de ícones](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/icon3_665x258.png)

3. Clique em OK. O pop-up será fechado, e seu gráfico será atualizado.

4. Escolha se deseja configurar seu rótulo ou valor, selecionando Rótulo ou Valor em Posição do ícone.

Você também pode alterar um valor/rótulo para um ícone inserindo uma cadeia de ícones em Ícone (Data &gt; Measures &gt; medida aplicável no painel de propriedades) e pressionar Enter. Em seguida, clique em Rótulo ou Valor em Posição do ícone, dependendo do que você deseja configurar. Também é possível alterar um ícone usando uma expressão no editor de expressões (the Expressão icon). Os ícones devem ser ícones CSS válidos.

## Usando o modo infográfico

O modo infográfico permite que você mostre cada medida graficamente como um número apropriado de ícones.

Faça o seguinte:

1. Clique na medida aplicável em Data &gt; Measures no painel de propriedades e clique no botão Ícone .

2. Selecione um ícone para representar uma medida do conjunto de ícones predefinido (Ícones) que é aberto.

3. Clique no botão Modo infográfico. O gráfico de KPI resultante é atualizado e mostra graficamente as medidas com o número de ícones aplicável (máximo de 100 ícones por medida).

   Você também pode selecionar um ícone usando uma expressão no editor de expressões (the Expressão icon).

   ![gráficos usando diferentes tipos de ilustração de infográfica.](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/info2_715x163.png)

## Inserindo uma visualização mestre

Para ilustrar graficamente o objeto de KPI, você pode inserir uma visualização mestre.

Faça o seguinte:

1. No painel de propriedasdes, acesse Data &gt; Measures e clique em Add.
2. Clique no botão Editor de expressões (the Expressão icon).
3. Insira a cadeia ='Drag and Drop here' no Editor de expressões e clique em Aplicar.
4. Arraste e solte um objeto de visualização mestre na região de valor de cada marcador de posição de medida.

Você também pode alterar a inserção da string de ID do objeto na expressão no editor de expressões (the Visualização icon) em para cada medida (Dados &gt; Medidas &gt; medida aplicável no painel de propriedades).

![O KPI mede onde cada KPI é mostrado com a visualização mestre correspondente.](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/info_684x157.png)

## Usando propriedades de estilos (CSS)

Você pode configurar mais suas medidas usando a propriedade de estilos não predefinidos (CSS) para cada medida. Esses estilos podem ser ícones, alteração da cor do texto/ícones, rótulo, fonte, cor de fundo, tamanho etc. Copie e cole os estilos no campo Styles (CSS) (em Appearance &gt; Styles no painel de propriedades).

Para ícones, insira classes apropriadas no campo Ícone da medida escolhida em Data &gt; Measures no painel de propriedades. Você também pode inserir a string de ícone usando uma expressão no editor de expressões (the Expressão icon).

![Caixa de estilo CSS no painel de propriedades.](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/css502_639x203.png)

## Formatar seus KPIs

Você pode formatar o layout do gráfico para ser apresentado de diferentes maneiras.

### Alinhamento

Você pode configurar o alinhamento do texto do gráfico principal selecionando a caixa aplicável em Alinhamento da medida escolhida em Dados &gt; Medidas no painel de propriedades.

Todos os KPIs também podem ser alinhados verticalmente. Esse alinhamento pode ser ajustado para alinhar a parte superior, inferior e central ou como esticado. Selecione o alinhamento aplicável no menu Vertical alignment em Appearance &gt; Styles no painel de propriedades. Também é possível alinhar no centro os rótulos, marcando a opção Center align labels no painel de propriedades em Appearance &gt; Dimensions.

### Formato numérico

Você também pode personalizar o formato dos valores numéricos de KPIs. Uma formatação diferente pode ser aplicada aos mesmos valores. O gráfico é atualizado para refletir o tipo de número alterado.

Faça o seguinte:

1. Clique em Data &gt; Measures no painel de propriedades e selecione a medida aplicável.

2. Selecione a formatação de número aplicável no menu Formato numérico.

   ![O mesmo objeto de KPI usando dois tipos diferentes de formatação de números (automático, dinheiro).](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/number3_600x347.png)

### Padrão de formato

O texto de uma medida específica pode ser alterado ou removido.

Faça o seguinte:

1. Clique em Data &gt; Measures no painel de propriedades.
2. Clique na medida aplicável e insira/remova a cadeia de formato aplicável em Padrão de formato e pressione Enter.

### Segmento/cartão

Também é possível configurar o layout do gráfico de KPI em que as dimensões e os valores são exibidos em um layout de segmento ou cartão.

Faça o seguinte:

1. Clique em Appearance &gt; Dimensions no painel de propriedades.

2. Escolha o layout de Segmento ou Cartão no menu Mostrar como. O gráfico será atualizado.

   ![O mesmo objeto de KPI exibido no layout de segmento (superior) e no layout de cartão (inferior).](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/seg3_641x413.png)

O layout de segmento pode ser configurado horizontal ou verticalmente em Appearance &gt; Dimensions &gt; Orientation no painel de propriedades. Clique nos botões Horizontal ou Vertical.

### Itens por linha

Também é possível decidir o número de itens (KPIs) por linha em um gráfico no painel de propriedades em Appearance &gt; Measures. Use o padrão Automático ou selecione o número aplicável no menu Itens por linha (entre 1 e 8).

### Bordas

Você pode ocultar as bordas externas e internas do gráfico. Por padrão, todas as bordas são visíveis. Para configurar as bordas, acesse Aparência &gt; Dimensões no painel de propriedades e marque, conforme aplicável, Ocultar bordas externas ou Ocultar bordas internas.

### Layout e formatação de valor/rótulo

A posição e a ordem dos rótulos para os valores de dimensão e medida podem ser alteradas e exibidas de maneiras diferentes. Os rótulos podem ser ocultos ou exibidos vertical ou horizontalmente. Por padrão, Horizontal é selecionado.

#### Layout de rótulo de dimensão

Faça o seguinte:

1. Clique em Appearance &gt; Measures no painel de propriedades.
2. Clique em Horizontal ou em Vertical em Orientação dos rótulos para selecionar como os rótulos devem ser exibidos.

#### Layout de valor de medida

O layout de valor de medida pode ser definido de duas maneiras diferentes.

Faça o seguinte:

1. Parâmetros existentes:
   1. Clique em Appearance &gt; Measures no painel de propriedades.
   2. Clique em Horizontal ou em Vertical em Orientação dos rótulos para selecionar como os rótulos devem ser exibidos.
2. Novos parâmetros:
   1. Clique em Data &gt; Measures no painel de propriedades.
   2. Clique na medida aplicável e marque a caixa Substituir parâmetros.
   3. Insira a cadeia de rótulo em Rótulo e pressione Enter.

#### Ordem dos rótulos

Você também pode ajustar a ordem em que os rótulos de valor de medida são exibidos.

Faça o seguinte:

1. Clique em Appearance &gt; Measures no painel de propriedades.
2. Clique em Rótulo, Valor ou em Valor, Rótulo em Orientação dos rótulos para selecionar como os rótulos devem ser exibidos.

#### Ordem dos ícones

Você pode decidir onde mostrar os ícones - antes ou depois de um valor. No painel de propriedades, sob Appearance &gt; Measures, acesse Icon order e clique nos botões Icon, Value ou em Value, Icon para selecionar qual exibir primeiro no gráfico.

#### Ocultar rótulos

* Rótulos de medida: essa opção oculta o rótulo de medida de cada KPI. Para ocultar os rótulos, clique em Data &gt; Measures no painel de propriedades e selecione a medida aplicável. Em seguida, marque a caixa Ocultar rótulos.
* Rótulos de dimensão: essa opção oculta o rótulo de dimensão de cada KPI. Para ocultar os rótulos, clique em Appearance &gt; Dimensions no painel de propriedades. Em seguida, marque a caixa Ocultar rótulos.

#### Ocultar valores

Essa opção oculta o valor de cada KPI. Para ocultar o valor, clique em Data &gt; Measures no painel de propriedades. Em seguida, marque a caixa Ocultar valores.

#### Agrupar valores de KPI

Todos os valores de KPI podem ser agrupados ou exibidos individualmente por medida. Acesse Data &gt; Measures no painel de propriedades. Escolha a medida aplicável e marque a caixa Agrupar por dimensão.

Outra opção é inserir uma cadeia de valor de dimensão em Valor da dimensão e pressionar Enter. O gráfico será atualizado. Você também pode inserir o valor da dimensão usando uma expressão no editor de expressões (the Expressão icon). Os valores devem ser valores CSS válidos.

#### Link para uma pasta separada

Cada pasta pode ser vinculada a outra pasta.

Faça o seguinte:

1. Clique em Data &gt; Measures no painel de propriedades e selecione a medida aplicável.

2. Mova o controle deslizante Link para pasta para a direita para ativar a opção.

3. Clique no botão Selecionar pasta e, no pop-up Selecionar pasta, clique na página com a qual você deseja estabelecer link. A pasta será fechada e suas páginas serão vinculadas.

   ![Vinculação a uma pasta separada no painel de propriedades.](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Resources/Images/sheet2_662x302.png)

## Limitações

Para obter informações sobre limitações gerais, consulte [Limitações](https://help.qlik.com/pt-BR/sense/May2025/Subsystems/Hub/Content/Sense_Hub/Visualizations/VisualizationBundle/visualization-bundle.htm#Limitati).

APRENDIZADO RELACIONADO:

* [Como configuro um gráfico de KPI múltiplo do pacote Visualização?](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)

## Saiba mais

* [Como configuro um gráfico de KPI múltiplo do pacote Visualização?](https://help.qlik.com/lnk/How_configure_Visualization%20Bundle_Multi_KPI_chart)