# Diálogo Editar expressão

O diálogo Editar Expressão é aberto selecionando o botão Adicionar abaixo da lista de expressões em Propriedades de Gráfico: Expressões ou clicando com o botão direito em uma expressão existente e selecionando Adicionar Expressão ou Editar Expressão.

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Define_Expression.htm)Embora seja usada principalmente para expressões de gráfico, essa caixa de diálogo também é usada para criar e editar outras expressões sempre que necessário. Para acessá-la, basta clicar no botão que contém três pontos, localizado ao lado das caixas de edição de texto em todo o programa.

As partes principais da caixa de diálogo são compostas pela área de edição Expressão que pode ser redimensionada para acomodar expressões grandes e pela área de abas que consiste em Campos, Funções, Variáveis e Imagens.

## Expressões de escrita

Você pode digitar toda a expressão na área de edição da expressão selecionada, mas geralmente é conveniente fazer a maior parte da construção da expressão na área da guia descrita abaixo. A expressão precisa começar com =.

O rótulo Expressão OK será mostrado apenas enquanto a sintaxe da expressão for aceita pelo programa, isto é, enquanto a expressão for válida. Caso contrário, o rótulo exibirá uma das várias mensagens de erro (Nome(s) de campo errado(s), Erro na expressão, Lixo depois da expressão). Não feche a caixa de diálogo clicando no botão OK, a não ser que a expressão seja válida.

## Opções da guia Expressão

As guias do diálogo Editar Expressão contêm as seguintes opções para a construção de expressões.

### Campos

A aba Campospossui controles usados para criar funções de agregação estatísticas com base nos dados do campo.

Opções de campos

| Opção | Descrição |
| --- | --- |
| Agregação | O primeiro dropdown contém uma lista de funções de agregação estatísticas disponíveis. (As funções Primeiro Caractere e Último Caractere podem ser usadas, por exemplo, para exibir um texto em uma tabela dinâmica.) |
| Tabela | Essa lista suspensa permite limitar os campos exibidos na lista Campo abaixo da tabela interna específica. |
| Campo | Este dropdown contém uma lista de nomes de campo disponíveis.<br><br>Os campos MEASURE só podem ser usados com as funções de agregação básicas Sum, Avg, Count, Min e Max. |
| Mostrar Campos do Sistema | Marque esta alternativa para incluir os campos do sistema na lista Campo. |
| Distinto | As funções estatísticas são, por padrão, calculadas com base no número de ocorrências. Ao marcar a opção Distinto, a expressão será calculada sem valores duplicados. |
| Colar | Clique neste botão para inserir suas seleções como um componente da expressão. |

### Funções

A aba Funções contém controles usados para inserir funções gerais do QlikView na expressão.

Opções de funções

| Opção | Descrição |
| --- | --- |
| Categoria da Função | Essa lista suspensa permite limitar as funções exibidas na lista Nome da função abaixo a uma única categoria de cada vez. |
| Nome da Função | Essa lista suspensa contém uma lista de todas as funções disponíveis do QlikView (exceto um número limitado de funções de script dedicadas).<br>O painel localizado na parte inferior da guia de funções exibe a sintaxe do argumento da função selecionada. |
| Colar | Clique neste botão para inserir suas seleções como um componente da expressão. |

### Variáveis

A aba Variáveis contém controles usados para inserir variáveis do QlikView na expressão.

Opções de variáveis

| Opção | Descrição |
| --- | --- |
| Variáveis | Este dropdown contém uma lista de todas as variáveis definidas atualmente para o documento. |
| Mostrar Variáveis de Sistema | Marque esta alternativa para incluir as variáveis do sistema na lista Variáveis. |
| Colar | Clique neste botão para inserir suas seleções como um componente da expressão. |

Na parte inferior da aba Variáveis, há um painel que mostra o valor atual de qualquer variável selecionada na lista suspensa Variáveis.

### Imagens

A aba Imagens contém controles usados para acessar os arquivos internos disponíveis no QlikView. Também é possível acessar outros arquivos de imagem associados. Observe que essa funcionalidade está limitada a algumas partes do layout. No lado direito da aba Imagens, existe um painel que mostra a imagem selecionada atualmente.

Opções de imagens

| Opção | Descrição |
| --- | --- |
| Pasta de Imagens | Este menu suspenso contém uma lista de pastas de imagens disponíveis. |
| Imagem | Este dropdown contém uma lista de imagens disponíveis na pasta selecionada. |
| Avançado... | Clique neste botão para selecionar diretamente as imagens na caixa de diálogo Seletor de Imagens. |
| Colar | Clique neste botão para inserir suas seleções como um componente da expressão. |

## Opções do menu Editar Expressão

Além disso, a caixa de diálogo Editar Expressão contém os seguintes comandos de menu e botões.

### Menu Arquivo

Opções do menu arquivo

| Opção | Descrição |
| --- | --- |
| Exportar para Arquivo de Expressão... | É possível salvar o conteúdo da caixa de edição Expressão como um arquivo de tabela por meio do comando Exportar para Arquivo de Expressões. O arquivo é salvo com a extensão .qve. |
| Inserir Arquivo... | Um arquivo de expressão criado anteriormente pode ser inserido no script usando o comando Inserir Arquivo.... |
| Assistente de Gradiente de cores... | Uma expressão de cor mista pode ser criada com o uso do Assistente de Cor Mista. |
| Imprimir | Abre a caixa de diálogo Imprimir padrão do Windows para imprimir as expressões. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+P. |

### Menu Editar

Opções do menu Editar

| Opção | Descrição |
| --- | --- |
| Desfazer | Desfaz a última alteração. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+Z. |
| Refazer | Reverte a última ação Desfazer. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+Y. |
| Recortar | Exporta o texto realçado para a área de transferência. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+X. |
| Copiar | Copia o texto realçado na área de transferência. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+C. |
| Colar | Cola o conteúdo da área de transferência na caixa de diálogo, na posição do cursor. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+V. |
| Limpar | Limpa toda a expressão. |
| Selecionar Tudo | Seleciona toda a expressão. |
| Localizar/Substituir... | Abre uma caixa de diálogo onde é possível localizar e substituir números ou caracteres na expressão. Esse comando também pode ser chamado pelo seguinte atalho de teclado: Ctrl+F. |

### Menu Configurações

Opções do menu Configurações

| Opção | Descrição |
| --- | --- |
| Configurar... | Abre Preferências do Usuário: Editor |

## Saiba mais

* [Expressões de gráficos](https://help.qlik.com/pt-BR/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/chart-expressions.htm)
* [Sintaxe da expressão para fórmulas calculadas](https://help.qlik.com/pt-BR/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)